P. 1
Algoritmos

Algoritmos

|Views: 221|Likes:
Publicado porRomulo Reis

More info:

Published by: Romulo Reis on Dec 16, 2012
Direitos Autorais:Attribution Non-commercial

Availability:

Read on Scribd mobile: iPhone, iPad and Android.
download as DOCX, PDF, TXT or read online from Scribd
See more
See less

12/16/2012

pdf

text

original

http://www.scribd.

com/doc/10166445/4289Logica-de-Programacao

LISTA DE EXERC�CIOS IV ----------------------MAT�RIA: Algoritmos & Programa��o PROGRAMA: Dev C++ FALCULDADE: UniFacs - Salvador, BA CURSO: Engenharia de Produ��o ----COMANDOS ----# include <stdio.h> ----- usa os codigos de dev c++. # include <math.h> ------ usa opera��es matematicas. main () ----------------- fun��o principal, identifica o programa. {} ---------------------- abre/fecha estruturas de comando (main (),if, else, for, while, switch). () ---------------------- abre/fecha comandos espec�ficos para as estruturas. ; ----------------------- fecha uma linha de comando. int --------------------- variaveis inteiras. float ------------------- variaveis flutuantes (numeros com virgula). char -------------------- caracteres. printf (" ") ------------ escreve o que voc� quiser entre os " ". printf (" \n") ---------- \n serve para quebrar uma linha. printf (" %x ", y) ------ imprime valor da variavel y. scanf ("%x", &y) -------- %x pode ser variaveis do int (%d), float (%f) ou char (%c) e y corresponde a variavel escolhida pelo usu�rio. && ---------------------- e || ---------------------- ou == ---------------------- igual != ---------------------- diferente > ----------------------- maior < ----------------------- menor <= ---------------------- menor ou igual >= ---------------------- maior ou igual * ----------------------- multiplica��o / ----------------------- divis�o % ----------------------- resto da divis�o (n�o � porcentagem) if () ------------------- se for () ------------------ para while () ---------------- enquanto switch () --------------- se system ("pause") -------- impede a janela do programa de fechar ap�s executar o programa. 1) Ler 3 numeros e verificar se eles podem ou n�o ser lados de um tri�ngiulo #include <stdio.h> //S� ir� existir um tri�ngulo se, somente se, os seus lados obedeceram � seguinte regra: um de seus lados deve ser maior que o valor absoluto (m�dulo) da diferen�a dos outros dois lados e menor que a soma dos outros dois lados:

printf ("Qual a altura em metros?"\n).b. printf ("Digite o valor dos lados"). // Cilindro V = pi*r*r*H e A = 2pi*r*H // Esfera V = 4/(3*pi*r*r*r) e A = 4*pi*r*r #include <stdio. &h). &h).h> #include <math.8)(2h/9. cilindro ou esfera?\n") scanf ("%c". &c). } system ("pause").8). } } 3) Calcular e imprimir o volume e a �rea de superf�cie de um cone reto. R. if (h<0){ printf ("escreva a altura sem sinal"). } 2) Determinar quanto tempo um corpo em repouso leva para atingir o solo a a partir de uma certa altura informada pelo usu�rio.h> main (){ float vol. um cilindro ou uma esfera. switch (op){ case char == cone: . &b. h.c. // Cone reto V = pi*r*r*(H/3) e A = pi*r*sgrt(r*r+H*H). printf ("o corpo leva %. Considere g = -9. if (a>|b-c| && a< b+c && b>|a-c| && a< a+c && c>|b-a| && c< b+a){ printf ("O triangulo existe"). scanf ("%f%f%f". } if (h>0){ t = (2/9. A. O programa dever� ler a op��o da figura desejada.h> main (){ // Em queda livre Vo = 0 e H = 0. &a. &op).|b-c|<a<b+c |a-c|<b<a+c |a-b|<c<a+b main (){ float a. H. } if(a<|b-c| || a>b+c || b<|a-c| || b< a+c || c<|b-a| || c> b+a){ printf ("o triangulo nao existe"). char op printf ("cone. ent�o T = (2h/g)^2 float t. scanf ("%f%".2f segundos para atingir o solo". scanf ("%f%".t).8 m/s^2 e que a queda livre � determinada pela f�rmula: H = Ho + VoT + (gT^2)/2 #include <stdio.

} if(c==b && a!=c){ printf ("triangulo isosceles"). #include <stdio. &op"). A).14*r*r*r) A = 4*3.14*r*r*H. if (a>|b-c| && a< b+c && b>|a-c| && a< a+c && c>|b-a| && c< b+a){ printf ("O triangulo existe"). vol. Qual a figura?").c.b. &H). &b.14*r*r printf ("volume = %f e area = %f".} if(a==b || a==c && c!=b){ printf ("triangulo isosceles"). &r. printf ("Digite o valor dos lados"). A = 3. printf ("volume = %f e area = %f". &a. break. case char == cilindro: printf ("o raio e a altura?").printf ("o raio e a altura?"). A). &c).h> main(){ float a. case char == esfera: printf ("o raio e a altura?").} } if(a<|b-c| || a>b+c || b<|a-c| || a< a+c || c<|b-a| || c> b+a){ printf ("o triangulo nao existe"). vol.} if(a==b && a==c && c==b){ printf ("triangulo equil�tero"). &r. scanf ("%c". scanf ("%f%f". } . default: printf ("op��o invalida. scanf ("%f%f". break. vol.14*r*sgrt((r*r)+(H*H)). vol = 3.14*r*H. } } 4)Construa um algoritmo pedindo os lados de um triangulo e depois dando sua classifica��o.14*r*r*(H/3). &H). break. vol = 3. vol = 4/(3*3. if(a!=b && a!=c && c!=b){ printf ("triangulo escaleno"). scanf ("%f%f". scanf ("%f%f%f". printf ("volume = %f e area = %f". break. } system ("pause"). &r. A = 2*3. A). &H).

#inclide <stdio. f4. for (i=0. maior. scanf ("%d".a porcentagem de cada faixa etaria. f3. printf ("%d sao maiores". i++){ printf ("proximo numero?"\n). &num). &num). i++){ if (idade>=18){ contador = contador + 1 } } maiores = contador. } 6) Ler 10 numeros e informar o menor e o maior #include <stdio. i<10.a quantidade de pessoas em cada faixa etaria e 2. maior = num. system ("pause"). printf ("digite a idade"). f4p. menor). #include <stdio. if (num > maior){ maior = num. scanf ("%f".h> main (){ int idade. scanf ("%f". maiores).h> main (){ int contador=0. printf ("numero?"\n). maiores. f2. f5. menor = num.5) Ler a idade de 10 pessoas e imprimir quantas s�o maiores de idade. } if (num < menor){ menor = num. } } printf ("o maior numero � %f e o menor � %f". idade. f5p. i<10.h> main (){ float num. f1p. maior. system ("pause"). for (i=0. . f2p. f3p. &idade). } 7) Ler a data de nascimento de 5 pessoas e informar 1. float f1. menor.

f3*100 = f3p. f5*100 = f5p. f4. &n). printf ("%f % sao menores de 15 anos. system ("pause"). scanf ("%d". %f pessoas entre 31-45 e %f pessoas entre 46-60 e %f pessoas maiores de 60 ". f1. f5\n). &idade).for (i=0. %f % sao entre 31-45. f2*100 = f2p. for (i=0. f3p. float n . if (idade <= 15){ contA++ } if (idade > 15) && idade <=30){ contB++ } if (idade > 30) && idade <=45){ contC++ } if (idade > 45) && idade <=60){ contD++ } if (idade >= 60)){ contE++ } } f1 = 5/contA. f4p. i<5. %f pessoas entre 16-30. f4*100 = f4p. %f % sao entre 46-60 e %f % sao maiores de 60 ". i++){ . f5p\n).h> main (){ int N=0 . scanf ("%f". } 8) Ler 5 numeros e informar quantos desses eram �mpares. f5 = 5/contE. f2. i<5.i++){ printf ("diga ai"). #include <stdio. f2 = 5/contB. printf ("numero?"\n). f1p. f3. printf ("Existem %f menores de 15 anos. f1*100 = f1p. f4 = 5/contD. f3 = 5/contC. %f % sao entre 16-30. f2p.

if (n%2!=0){ N = N + 1.} . ahMenor = a. i++){ printf ("numero?"\n). cont = cont + 1. char sexo. switch(sexo){ case char == M: printf ("informe altura\n"). if (a > ahMaior){ a = ahMaior. &sexo). ahMaior = a. float a.h> main (){ int cont=0. } 10) Ler a altura e o sexo de 15 pessoas (M para homem e F para mulher) e informe 1-a menor e a maior altura. } 9) Ler 130 numeros e informar quantos desses eram �mpares. } } printf ("%d numeros impares\n". printf ("informe M para homem ou F para mulher\n"). system ("pause"). scanf ("%c". &a). scanf ("%f". #include <stdio.} if (a < ahMenor){ a = ahMenor. for (i=0. scanf ("%f". amMenor. 2media da altura dos homens. ahMedia=0. float n . i<130. system ("pause"). &n).ahMenor. } } printf ("%d numeros impares\n". ahMaior. N). 3-a altura da mulher mais alta 4-quantos eram os homens. N). #include <stdio. ahMedia = (ahMedia + a)/cont. amMaior.if (n%2!=0){ N = N + 1.h> main (){ int N=0 .

system ("pause"). printf ("a media da altura dos homens � %f\n". break. } system ("pause").} if (ahMenor < amMenor){ printf ("a menor altura � %f\n". amMenor). i++){ c = (i-32)*9/5. cont). amMaior). &sexo). &a). printf ("informe M para homem ou F para mulher\n).32 /5. i. scanf ("%f". ahMedia).} break. . ahMenor).break. amMenor = a. } if (ahMaior > amMaior){ printf ("a maior altura � %f\n". amMaior).} if (amMenor > amMenor){ printf ("a menor altura � %f\n".} if (a < amMenor){ a = amMenor. printf ("%d em farenheit e %f em celcius". case char == F: printf ("informe altura\n"). ahMaior). amMaior = a. float c. } 11) Convers�o de graus farenheit em celcius atrav�s da formula c/9 = f . i<65. scanf ("%c". Escrever uma tabela de convers�o de F pra C. default: printf ("sexo errado\n"). printf ("%f homens participaram\n". #include <stdio.h> main (){ int i. c). com F variando de 50 a 65.} printf ("a mulher mais alta tem %f metros\n". if (a > amMaior){ a = amMaior.} if (amMaior < amMaior){ printf ("a maior altura � %f\n". for (i=50.

MpesoC = pesoC/contC. } MpesoA = pesoA/contA. %f. MpesoB = pesoB/contB.} 12) Ler a idade e o peso de 15 pessoas.M�dia de pesos por faixa etaria ----". scanf ("%f%f". MpesoB. pesoC. } if (id >21 && id <=30){ contC++ pesoC = pesoC + p. MpesoB. float n1. %f. MpesoD = pesoD/contD. %f ---. pesoB. n3. As faixas de 1 a 10 anos. i++){ if (id <=10){ contA++ pesoA = pesoA + p. switch (op){ case char == +: printf ("3 numeros?\n"). &id. MpesoC.h> main (){ int id. MpesoC. MpesoA. Calcular e imprimir as m�dias de peso das pessoas da mesma faixa etaria e quantas sao de cada faixa etaria. } system ("pause"). %f. MpesoD. . printf ("idade? peso?"). printf ("%f. MpesoA. i<15. for (i=0. r. contA. n4. scanf ("%c". %f ---. float p. contD\n). &p). pesoD. de 21-30 e maiores de 30. contC. } if (id >30){ contD++ pesoD = pesoD + p. n2. &op). } if (id >11 && id <=20){ contB++ pesoB = pesoB + p. de 11-20. pesoA.Pessoas por faixa etaria ----".h> main(){ char op. prinf ("qual a opera��o?\n").h> #include <math. printf ("%f. %f. MpesoD\n). #include <stdio. } Ex) Fazer uma calculadora simples #include <stdio. contB.

. case char == /: printf ("2 numeros?\n").&n2). else{ r = sqrt(n1).2f".r). scanf ("%f%f%f". if (n2 == 0){ printf ("erro").2f". break. case char == raiz: printf ("numero?\n"). if (n2 == 0){ printf ("erro").r). printf ("%. printf ("%.2f". r = n1 . Qual opera��o?\n").} break.scanf ("%f%f%f".n2 . int i.&n2).2f". &n1. printf ("%.} if (n1 == 0 && n2 ==0){ printf ("indetermina��o").} else { r = n1/n2. &op). printf ("%.&n3).n3.2f". break. break. printf ("%. scanf ("%f".&n2. fat=1.} else { r = n1/n2.&n3). printf ("%.r).} break.} break. scanf ("%c". scanf ("%f%f". default: printf ("opera��o inv�lida. &n1. } } Ex) Fatorar um numero main (){ float num.2f". r = n1 + n2 + n3.} if (n1 == 0 && n2 ==0){ printf ("indetermina��o"). case char == -: printf ("3 numeros?\n"). if (n1 < 0){ printf ("n�o existe"). scanf ("%f".r). case char == %: printf ("2 numeros?\n"). case char == *: printf ("2 numeros?\n"). r = n1*n2.r). &n1).&n2). scanf ("%f%f". &num). scanf ("%f%f".&n2.r). &n1. printf ("numero?"). &n1. &n1. break.

} } printf ("matricula?"). if (r >= 7){ printf ("aprovado"). printf ("%f � a media da turma". r. main (){ int mat.(r*7). } if (r < 4){ printf ("reprovado").for (i=1. main (){ int n=0. Tmedia = Tsoma / cont. Tsoma=0. scanf ("%d". &n2. Por exemplo: 6. system ("pause"). fat). i<num. } if (r<7 && r>=4){ printf ("final"). scanf ("%f%f%f%f". Um programa teve ter um loop infinito ate que digite '0' na matricula. Al�m disso tire a media da turma. while (mat!=0){ cont = cont + 1 printf ("as quatro notas?"). cont=0. } } Ex) Use c�digos para que um programa leia 4 notas de um aluno (a 1o tem peso 3. printf ("matricula?"). Tmedia). &mat). acumulador=0. //um numero perfeito � quando a some de seus divisores com exce��o dele mesmo resultam nesse numero. final). n�o passou ou vai para a recupera��o (precisando de tantos pontos). r = ((n1*3) + (n2*2) + n3 + n4) /4. // Ao executar o programa a maquina fica lenta porque s�o muitos calculos. p=0. n3.. Tmedia. Calcule a m�dia e diga se ele passou. final = 50 . printf ("%f". i++){ fat = num*i. . Tsoma = Tsoma + r. float n1. // Detalhe que o programa n�o vai interagir com o usu�rio. final. a 2o 2 e a 3o e 4o peso 1). n2. i. printf ("precisa de %d pontos na final". &n1. &n4). &mat). n4.. scanf ("%d". Para ter id�ia pit�goras s� chegou at� o quarto numero perfeito. } Ex) Encontrar os cinco primeiros numeros perfeitos. onde 1 + 2 + 3 = 6. &n3.

} } Ex) Ler n numeros e contar quantos s�o pares. while (n%11!=0){ printf ("qual o numero?"). } . &n). main (){ int n=1.while (p!=5){ for (i=1. scanf ("%d". n). } } if (acumulador == n){ p = p + 1. acumulador = 0.n). if (n%2==0){ cont = cont + 1. 1<n. } } printf ("%d numeros foram pares". } n = n + 1. i++){ if (n%i == 0){ acumulador = acumulador + i. O pragrama deve parar quando ler um multiplo de 11. system ("pause"). printf ("%d � perfeito". cont=0.

n3. var n1.n1 + n2 + n3 + n4 escreva (soma) // Seção de Comandos fimalgoritmo 2) Faça um algoritmo que receba três notas. mas a sintaxe é um pouco diferente. Se essa é a vida do programador. var n1. n4. Algoritmos são as principais dificuldades que o programador encontra no início dos seus estudos.. utilizando a sintaxe do Visualg. tipo. calcule e mostre a média aritmética entre elas. soma: inteiro inicio escreva ("Digite o primeiro número: ") leia (n1) escreva ("Digite o segundo número: ") leia (n2) escreva ("Digite o terceiro número: ") leia (n3) escreva ("Digite o quarto número: ") leia (n4) soma <.Alguns algoritmos resolvidos O post de hoje é um post especial: é sobre algoritmos. é possível usar o Portugol. n2. n3. A principal tarefa do programador é resolver problemas para conseguir criar o software desejado pela empresa onde trabalha. media: real inicio escreva ("Digite a primeira nota: ") leia (n1) escreva ("Digite a segunda nota: ") . fazer códigos. Abaixo estão listados 18 algoritmos resolvidos.. Vale lembrar que a principal tarefa do programador não é programar em si. nada como resolver alguns algoritmos para treinar desde já a resolução de problemas. Se preferir. calcule e mostre a soma desses números. 1) Faça um algoritmo que receba quatro números inteiros. n2.

leia (n2) escreva ("Digite a terceira nota: ") leia (n3) media <. n2. aumento. novoSal: real inicio escreva ("Digite o salário: ") leia (sal) novoSal< .sal * 1. media) // Seção de Comandos fimalgoritmo 3) Faça um algoritmo que receba três notas e seus respectivos pesos. novoSal) // Seção de Comandos fimalgoritmo 5) Faça algoritmo que receba o salário de um funcionário e o percentual de aumento e calcule e mostre o valor do aumento e o novo salário.(n1 + n2 + n3) / 3) escreva ("A média das notas é: ". var sal. var sal. p2. p1. novoSal: real inicio . calcule e mostre a média ponderada dessas notas. n3.((n1 * p1) + (n2 * p2) + (n3 * p3)) / (p1 + p2 + p3) escreva ("A média ponderada das três notas é: ". mediaPon) // Seção de Comandos fimalgoritmo 4) Faça um algoritmo que receba o salário de um funcionário.25 escreva ("O salário com aumento é: ". mediaPon: real inicio escreva ("Digite a primeira nota: ") leia (n1) escreva ("Digite a segunda nota: ") leia (n2) escreva ("Digite a terceira nota: ") leia (n3) escreva ("Digite o peso da primeira nota: ") leia (p1) escreva ("Digite o peso da segunda nota: ") leia (p2) escreva ("Digite o peso da terceira nota: ") leia (p3) mediaPon< . var n1. sabendo-se que este sofreu um aumento de 25%. p3. calcule e mostre o novo salário.

Sabe-se que: Area=ΠR2. rend. novoSal: real inicio escreva ("Digite o salário-base do funcionário: ") leia (sal) imp< . desc.sal * 0.imp) + 50 escreva ("O salário que o funcionário tem a receber é: ".sal * 0. novoSal: real inicio escreva ("Digite o sálário base do funcionário: ") leia (sal) grat< . var area: real inicio area< . calcule e mostre o salário a receber.deposito + rend escreval ("O valor do rendimento é: ". Sabendo-se que esse funcionário tem gratificação de R$ 50. calcule e mostre o valor do rendimento e o valor total depois do rendimento.07 desc< .sal . var sal. area) // Seção de Comandos fimalgoritmo . taxa.10 novoSal< . total: real inicio escreva ("Digite o valor do depósito: ") leia (deposito) escreva ("Digite o valor da taxa de juros: ") leia (taxa) rend< . novoSal) // Seção de Comandos fimalgoritmo 6) Faça um algoritmo que receba o salário-base de um funcionário. var deposito.00 e paga imposto de 10% sobre o salário-base. var sal.sal * (aumento / 100) novoSal< .sal * 0.deposito * (taxa / 100) total <. rend) escreva ("O valor total após o rendimento é: ". grat. imp. imp. total) // Seção de Comandos fimalgoritmo 9) Faça um algoritmo que calcule e mostre a área de um círculo. novoSal) // Seção de Comandos fimalgoritmo 7) Faça um algoritmo que receba o salário-base de um funcionário.14 * 10) ^ 2 escreva ("A área do círculo é: ". calcule e mostre seu salário a receber. aumento) escreva ("O valor do novo salário é: ".(sal . novoSal) // Seção de Comandos fimalgoritmo 8) Faça um algoritmo que receba o valor de um depósito e o valor da taxa de juros.(3.aumento + sal escreval ("O valor do aumento é: ".05 imp< .escreva ("Digite o valor do salário: ") leia (sal) escreva ("Digite o valor do aumento em porcentagem: ") leia (aumento) aumento <.desc + grat escreva ("O salário do funcionário a receber é: ". sabendo-se que esse funcionário tem gratificação de 5% sobre o salário base e paga imposto de 7% sobre o salário base.imp novoSal< .

num2. idFut) // Seção de Comandos fimalgoritmo .10) Faça um algoritmo que receba um número positivo e maior que zero. quadrado) escreval ("O número ao cubo é: ". num2. cubo) escreval ("A raiz quadrada do número é: ". " elevado a ". var num. rCubica: real inicio escreva ("Digite um número positivo e maior do que zero: ") leia (num) quadrado <.exp(num. rQuadrada. d)A raiz cúbica do número digitado. calcule e mostre um elevado ao outro.exp(num.exp(num. quadrado. c)A raiz quadrada do número digitado. idFut: inteiro inicio escreva ("Digite o ano de nascimento da pessoa: ") leia (aNasc) escreva ("Digite o ano atual: ") leia (aAtual) idPres< . rQuadrada) escreva ("A raiz cúbica do número é: ". result: real inicio escreva ("Digite um número maior do que zero: ") leia (num) escreva ("Digite outro número maior do que zero: ") leia (num2) result< . result) // Seção de Comandos fimalgoritmo 12) Faça um algoritmo que receba o ano de nascimento de uma pessoa e o ano atual.(aAtual . aAtual. num2) escreva ("O número ". idPres. " é: ". Calcule e mostre: a)A idade dessa pessoa.exp(num. 1/3) escreval ("O número ao quadrado é: ". 3) rQuadrada< . idPres) escreva ("A idade que a pessoa terá em 2017 será: ".aNasc) escreval ("A idade da pessoa é: ". var num.exp(num. b)Quantos anos essa pessoa terá em 2017. num. var aNasc. 2) cubo <.(2017 . b)O número digitado ao cubo. 1/2) rCubica< . calcule e mostre: a)O número digitado ao quadrado.aNasc) idFut< . rCubica) // Seção de Comandos fimalgoritmo 11) Faça um algoritmo que receba dois números maiores que zero. cubo.

vImp. Calcule e mostre: a)O valor correspondente ao lucro do distribuidor b)O valor correspondente aos impostos.03 sARec< .imp escreva ("O salário a receber será: ". pFinal: real inicio escreva ("Digite o preço de fábrica: ") leia (pFabr) escreva ("Digite o percentual de lucro: ") leia (pLucro) escreva ("Digite o percentual de impostos: ") leia (vImp) pLucro< .pFabr * (pLucro / 100) vImp< .(pFabr + pLucro + vImp) escreval ("O valor do lucro do distribuidor é: ". o percentual de lucro do distribuidor e o percentual de impostos. mSalMin. hTrabalhada.nHorasTrab * hTrabalhada imp< . imp. vImp) escreva ("O preço final do veículo é: ". pLucro. pLucro) escreval ("O valor correspondente aos impostos é: ". Calcule e mostre o salário a receber seguindo as regras abaixo: a)A hora trabalhada vale a metade do salário mínimo. var nHorasTrab. c)O imposto equivale a 3% do salário bruto. b)O salário bruto equivale ao número de horas trabalhadas multiplicado pelo valor da hora trabalhada. pFinal) // Seção de Comandos fimalgoritmo 14) Faça um algoritmo que receba o número de horas trabalhadas e o valor do salário mínimo. var pFabr. d)O salário a receber equivale ao salário bruto menos o imposto. salBruto. c)O preço final do veículo.salBruto .13) O custo ao consumidor de um carro novo é a soma do preço de fábrica com o percentual de lucro do distribuidor e dos impostos aplicados ao preço de fábrica. sARec) . sARec: real inicio escreva ("Digite o número de horas trabalhadas: ") leia (nHorasTrab) escreva ("Digite o valor do salário mínimo: ") leia (mSalMin) hTrabalhada< .salBruto * 0. Faça um algoritmo que receba o preço de fábrica de um veículo.pFabr * (vImp / 100) pFinal< .mSalMin / 2 salBruto< .

0038 parcial <. Esse trabalhador emitiu dois cheques e agora deseja saber seu saldo atual. d)A quantia a receber pelas horas extras equivale ao número de horas extras trabalhadas multiplicado pelo valor da hora extra. c)O salário bruto equivale ao número de horas trabalhadas multiplicado pelo valor da hora trabalhada. c)A idade dessa pessoa em dias. Sabe-se que cada operação bancária de retirada paga CPMF de 0.") escreva ("Ela possui. dias. cpmf.ano meses <. parcial2: real inicio // Seção de Comandos escreval ("Digite o valor do salário do trabalhador: ") leia (salMinimo) cpmf< . hETrab. b)A hora extra vale ¼ do salário mínimo.salMinimo . var hTrab. idade.38% e o saldo inicial da conta está zerado.") escreval ("E exatamente ". portanto. Calcule e mostre o salário a receber seguindo as regras a seguir: a)A hora trabalhada vale 1/8 do salário mínino. semanas.") fimalgoritmo 17) Faça um algoritmo que receba o número de horas trabalhadas.salMinimo * cpmf salMinimo< .2012 . meses.salMinimo . " meses. var ano.idade * 52 escreval ("A pessoa tem ". " dias de vida. sFinal: real inicio // Seção de Comandos escreva ("Digite o número de horas trabalhadas: ") leia (hTrab) escreva ("Digite o valor do salário mínimo: ") leia (salMin) escreva ("Digite o número de horas extras trabalhadas: ") . d)A idade dessa pessoa em semanas. HExtraARec. idade.parcial parcial2 <.idade * 365 semanas <. o valor do salário mínimo e o número de horas extras trabalhadas.parcial2 escreva ("O salário do trabalhador após as retiradas é: ". salMinimo) fimalgoritmo 16) Faça um algoritmo que receba o ano de nascimento de uma pessoa e o ano atual calcule e mostre: a)A idade dessa pessoa em anos. e)O salário a receber equivale ao salário bruto mais a quantia a receber pelas horas extras. vHT. b)A idade dessa pessoa em meses. " anos. dias.") escreval ("Podemos concluir que ela tem ". vHET.salMinimo * cpmf salMinimo< . var salMinimo.// Seção de Comandos fimalgoritmo 15) Um trabalhador recebeu seu salário e depositou em sua contra corrente bancária. " semanas. salBruto. parcial. semanas: inteiro inicio // Seção de Comandos escreva ("Digite o ano de nascimento da pessoa: ") leia (ano) idade <. ".idade * 12 dias <.0. salMin. meses.

" libras.00 e da libra esterlina é de R$ 1.leia (hETrab) vHT< .") fimalgoritmo .salMin / 8 vHET< . Sabe-se que a cotação do dólar é de R$ 1.") escreval (marco. marco alemão e libra esterlina. marco. var reais.hETrab * vHET sFinal< .57.salMin / 4 salBruto< . " dólares. dolar. O algoritmo deve fazer as conversões e mostrá-las.00 libra <.hTrab * vHT HExtraARec< .57 escreval ("O dinheiro da pessoa equivale a ".salBruto + HExtraARec escreva ("O salário a receber é de: ". sFinal) fimalgoritmo 18) Faça um algoritmo que receba a quantidade de dinheiro em reais que uma pessoa que vai viajar possui.reais / 1.80.reais / 1. libra: real inicio // Seção de Comandos escreva ("Digite a quantidade de dinheiro em reais que a pessoa possui: ") leia (reais) dolar< . do marco alemão é de R$ 2.80 marco <. dolar.reais / 2. Essa pessoa vai passar por vários países e precisa converter seu dinheiro em dólares. " marcos ou") escreva (libra.

You're Reading a Free Preview

Descarregar
scribd
/*********** DO NOT ALTER ANYTHING BELOW THIS LINE ! ************/ var s_code=s.t();if(s_code)document.write(s_code)//-->