P. 1
Algoritmos Resolvidos Lista 1

Algoritmos Resolvidos Lista 1

|Views: 2|Likes:
Publicado porKeny Keane

More info:

Published by: Keny Keane on Jul 09, 2013
Direitos Autorais:Attribution Non-commercial

Availability:

Read on Scribd mobile: iPhone, iPad and Android.
download as PDF, TXT or read online from Scribd
See more
See less

03/03/2015

pdf

text

original

Algoritmos Resolvidos – Lista 1

Algoritmo “Ex1"
Faça um algoritmo que receba dois números e exiba o resultado da sua soma.
// Seção de Declarações var x, y: inteiro inicio // Seção de Comandos escreval("Digite o primeiro número: ") leia(x) escreval("Digite o segundo número: ") leia(y) escreva("A soma dos números é: ",x+y) fimalgoritmo

1 Carlão – Carlos Eduardo Martins contato@desenvolvefacil.com.br www.desenvolvefacil.com.br

com.br www.desenvolvefacil. multiplicação e a divisão dos números lidos. // Seção de Declarações var x. subtração.Algoritmos Resolvidos – Lista 1 Algoritmo “Ex2" Faça um algoritmo que receba dois números e ao final mostre a soma.com.x-y) escreval("A multiplicação é: ".x/y) fimalgoritmo 2 Carlão – Carlos Eduardo Martins contato@desenvolvefacil.x+y) escreval("A subtração é: ".br . y: real inicio // Seção de Comandos escreva("Digite o primeiro número: ") leia(x) escreva("Digite o segundo número: ") leia(y) escreval("A soma é: ".x*y) escreval("A divisão é: ".

desenvolvefacil.com.br . combustivel: real inicio // Seção de Comandos escreval("========== Cálculo de consumo médio de combustível =========") escreva("Digite a distância pecorrida: ") leia(distancia) escreva("Digite o combustível gasto: ") leia(combustivel) escreval("O consumo médio de combustível do seu veículo é: ".br www.Algoritmos Resolvidos – Lista 1 Algoritmo “Ex3" Escrever um algoritmo para determinar o consumo médio de um automóvel sendo fornecida a distância total percorrida pelo automóvel e o total de combustível gasto.distancia/combustivel) fimalgoritmo 3 Carlão – Carlos Eduardo Martins contato@desenvolvefacil.com. // Seção de Declarações var distancia.

o seu salário fixo e o total de vendas efetuadas por ele no mês (em dinheiro).salario + comissao limpatela escreval(">>>>>>>>>> RESUMO <<<<<<<<<<") 4 Carlão – Carlos Eduardo Martins contato@desenvolvefacil.com. o salário fixo e salário no final do mês.com. informar o seu nome.0.desenvolvefacil.Algoritmos Resolvidos – Lista 1 Algoritmo “Ex4" Escrever um algoritmo que leia o nome de um vendedor.br www. // Seção de Declarações var nome: caractere salario: real vendas: real comissao: real salarioFinal: real inicio // Seção de Comandos escreval("<><><><><> Sistema de gestão de vendedores <><><><><>") escreva(">>> Digite o nome do vendedor: ") leia(nome) escreva(">>> Digite o salário: ") leia(salario) escreva(">>> Informe a quantidade de vendas deste no mês: ") leia(vendas) // Cálculo da comissão e salário final comissao <.br .15 * vendas salarioFinal <. Sabendo que este vendedor ganha 15% de comissão sobre suas vendas efetuadas.

nome) escreval("-.desenvolvefacil.br www.com.salarioFinal) escreval(">>>>>>>>>><><><><><<<<<<<<<<") fimalgoritmo 5 Carlão – Carlos Eduardo Martins contato@desenvolvefacil.salario) escreval("-.Salário Final (salário + comissão): ".Algoritmos Resolvidos – Lista 1 escreval("-.Nome: ".br .Salário: ".com.

" ==============") escreval(">>> Média: ".Algoritmos Resolvidos – Lista 1 Algoritmo “Ex5" Escrever um algoritmo que leia o nome de um aluno e as notas das três provas que ele obteve no semestre.br www.desenvolvefacil.com. // Seção de Declarações var aluno: caractere notas: vetor[1.."º nota ") leia(notas[x]) fimpara media <.3] de real x: inteiro media: real inicio // Seção de Comandos escreval("============== Média de alunos ==============") escreva("Digite o nome do aluno: ") leia(aluno) para x de 1 ate 3 faca escreva("Digite a ". No final informar o nome do aluno e a sua média (aritmética).media) escreval("=======================================") fimalgoritmo 6 Carlão – Carlos Eduardo Martins contato@desenvolvefacil.x.com. aluno.(notas[1] + notas[2] + notas[3]) / 3 limpatela escreval("==============".br .

desenvolvefacil.com.br .com.Algoritmos Resolvidos – Lista 1 7 Carlão – Carlos Eduardo Martins contato@desenvolvefacil.br www.

b b <.desenvolvefacil.com. troca: inteiro inicio // Seção de Comandos escreva("Digite o valor(numérico) da variável A: ") leia(a) escreva("Digite o valor(numérico) da variável B: ") leia(b) troca <.b) escreval("===========================") fimalgoritmo 8 Carlão – Carlos Eduardo Martins contato@desenvolvefacil. Apresentar os valores trocados. // Seção de Declarações var a. b. e efetuar as trocas dos valores de forma que a variável A passe a possuir o valor da variável B e a variável B passe a possuir o valor da variável A.a) escreval("O novo valor de B é: ".br .a a <.Algoritmos Resolvidos – Lista 1 Algoritmo “Ex6" Ler dois valores para as variáveis A e B.br www.com.troca limpatela escreval("===========================") escreval("O novo valor de A é: ".

sendo F a temperatura em Fahrenheit e C a temperatura em Celsius."ºF") fimalgoritmo 9 Carlão – Carlos Eduardo Martins contato@desenvolvefacil.far.desenvolvefacil. far: real inicio // Seção de Comandos escreval("=-=-=-=-=.com. A fórmula de conversão é: F= (9*C+160) / 5. // Seção de Declarações var cel.br www.Algoritmos Resolvidos – Lista 1 Algoritmo “Ex7" Ler uma temperatura em graus Celsius e apresentá-la convertida em graus Fahrenheit.br .(9*cel+160)/5 escreval("A nova temperatura é: ".Tabela de conversão: Celcius -> Fahrenheit -=-=-=-=-=") escreva("Digite a temperatura em Celcius: ") leia(cel) far <.com.

O algoritmo deverá solicitar o valor da cotação do dólar e também a quantidade de dólares disponíveis com o usuário.desenvolvefacil.br .com. us.us/cotacao limpatela escreval(us. cotacao.com." R$") fimalgoritmo 10 Carlão – Carlos Eduardo Martins contato@desenvolvefacil.Algoritmos Resolvidos – Lista 1 Algoritmo “Ex8" Elaborar um algoritmo que efetue a apresentação do valor da conversão em real (R$) de um valor lido em dólar (US$). dolaDisponivel: real inicio // Seção de Comandos escreval("========= Cotação do Dólar ==========") escreva("Qual a cotação atual do dólar? ") leia(cotacao) escreva("Quantos dólares você possui? ") leia(us) rs <.br www." Dólares equivalem á: ". // Seção de Declarações var rs.rs.

Algoritmos Resolvidos – Lista 1 Algoritmo “Ex9" Faça um algoritmo que receba um valor que foi depositado e exiba o valor com rendimento após um mês.desenvolvefacil. Considere fixo o juro da poupança em 0.br .br www.70% a. // Seção de Declarações var correcao. deposito: real inicio // Seção de Comandos escreval("Sistema de depósito do Banco do Oeste") escreva("Digite o valor depositado: ") leia(deposito) correcao <.deposito+correcao) fimalgoritmo 11 Carlão – Carlos Eduardo Martins contato@desenvolvefacil.com.com.0.7 * deposito escreva("O rendimento do depósito após um mês é de: ". m.

com.br . prestacao: real inicio // Seção de Comandos escreval("========== Loja Mamão com Açúcar ==========") escreva("Digite o valor da compra: ") leia(compra) prestacao <.br www.prestacao.com. // Seção de Declarações var compra.desenvolvefacil. Faça um algoritmo que receba um valor de uma compra e mostre o valor das prestações." cada") fimalgoritmo 12 Carlão – Carlos Eduardo Martins contato@desenvolvefacil.compra/5 escreval("O cliente deverá pagar 5 prestações de R$".Algoritmos Resolvidos – Lista 1 Algoritmo “Ex10" A Loja Mamão com Açúcar está vendendo seus produtos em 5 (cinco) prestações sem juros.

desenvolvefacil.(percent/100) * custo venda <. Sabe-se que o preço de custo receberá um acréscimo de acordo com um percentual informado pelo usuário.br . venda.Algoritmos Resolvidos – Lista 1 Algoritmo “Ex11" Faça um algoritmo que receba o preço de custo de um produto e mostre o valor de venda.venda) fimalgoritmo 13 Carlão – Carlos Eduardo Martins contato@desenvolvefacil.com.custo + percent escreval("O valor de venda é: ". percent: real inicio // Seção de Comandos escreva("Digite o custo do produto: ") leia(custo) escreva("Digite o percentual para venda: ") leia(percent) percent <.com.br www. // Seção de Declarações var custo.

primeiro os impostos sobre o custo de fábrica.45) * 1.com. Supondo que a percentagem do distribuidor seja de 28% e os impostos 45%. e depois a percentagem do distribuidor sobre o resultado). // Seção de Declarações var custoFabrica.custoFinal) fimalgoritmo 14 Carlão – Carlos Eduardo Martins contato@desenvolvefacil.desenvolvefacil. Escrever um algoritmo que leia o custo de fábrica de um carro e informe o custo ao consumidor do mesmo. custoFinal: real inicio // Seção de Comandos escreva("Informe o custo de fábrica do veículo: ") leia(custoFabrica) custoFinal <.com.br .28 escreval("O custo para o consumidor final é de: ".br www.Algoritmos Resolvidos – Lista 1 Algoritmo “Ex12" O custo ao consumidor de um carro novo é a soma do custo de fábrica com a percentagem do distribuidor e dos impostos (aplicados.(custoDeFabrica * 1.

// Seção de Declarações var numero: inteiro inicio // Seção de Comandos escreva("Digite um número: ") leia(numero) se numero > 10 entao escreval("O número é maior que 10") fimse fimalgoritmo 15 Carlão – Carlos Eduardo Martins contato@desenvolvefacil.com.com.br www.br .desenvolvefacil.Algoritmos Resolvidos – Lista 1 Algoritmo “Ex13" Faça um algoritmo que receba um número e mostre uma mensagem caso este número seja maior que 10.

You're Reading a Free Preview

Descarregar
scribd
/*********** DO NOT ALTER ANYTHING BELOW THIS LINE ! ************/ var s_code=s.t();if(s_code)document.write(s_code)//-->