Você está na página 1de 5

Comando Varivel tipo inteiro i: inteiro

Portugol (Visualg) sbyte i; short i; int i; long i; byte i; ushort i; uint i; ulong i; float d; double d; decimal d; bool b; char s; string s; tipo[] v = new tipo[linhas]; tipo[,] m = new tipo[linhas, colunas]; 3 // int 3L // long 3U // unsigned int 3UL // unsigned long 3.14F // float 3.14 // double 3.14M // decimal false true 'C' // char "texto entre aspas" // string

C#

Varivel tipo real

d: real

Varivel tipo lgico Varivel tipo texto Varivel tipo vetor Varivel tipo matriz Exemplos de literais (valores) do tipo inteiro

b: logico s: caractere v: vetor[linha1..linhaN] de tipo m: vetor[linha1..linhaN, coluna1..colunaN] de tipo 3

Exemplos de literais (valores) do tipo real

3.14

Exemplos de literais (valores) do tipo lgico Exemplos de literais (valores) do tipo texto

FALSO VERDADEIRO "texto entre aspas"

Comando Ler valor tipo inteiro leia(i)

Portugol (Visualg) i i i i i i i i = = = = = = = =

C# Convert.ToSByte(Console.ReadLine()); // sbyte Convert.ToInt16(Console.ReadLine()); // short Convert.ToInt32(Console.ReadLine()); // int Convert.ToInt64(Console.ReadLine()); // long Convert.ToByte(Console.ReadLine()); // byte Convert.ToUInt16(Console.ReadLine()); // unsigned short Convert.ToUInt32(Console.ReadLine()); // unsigned int Convert.ToUInt64(Console.ReadLine()); // unsigned long

Ler valor tipo real

leia(d)

d = Convert.ToSingle(Console.ReadLine()); // float d = Convert.ToDouble(Console.ReadLine()); // double d = Convert.ToDecimal(Console.ReadLine()); // decimal b = Convert.ToBoolean(Console.ReadLine()); s = Convert.ToChar(Console.ReadLine()); // char s = Console.ReadLine(); // string Console.Write(...); Console.WriteLine(...); Console.Write("...{0}...{1}...", a, b, ); Console.WriteLine("...{0}...{1}...", a, b, ...); Console.Clear(); a = b; a+b a-b a/b a / b (sendo a e b inteiros) a%b Math.Pow(a, b) Math.Sqrt(a) "texto" + "texto" "texto" + a a + "texto" v[linha] (ndice comea em 0 e termina em tamanho-1) m[linha, coluna] (ndices comeam em 0 e terminam em tamanho-1)

Ler valor tipo lgico Ler valor tipo texto Escrever Escrever, pulando linha Escrever com parmetros Escrever com parmetros, pulando linha Limpar tela Operao recebe Operao soma Operao subtrao Operao diviso Operao diviso inteira Operao resto da diviso Operao potenciao Operao raiz quadrada Operao concatenao

leia(b) leia(s) escreva(...) escreval(...) escreva(..., a, ..., b, ...) escreval(..., a, ..., b, ...) limpatela a <- b a+b a-b a/b a\b a%b a mod b a ^b RaizQ(a) "texto" + "texto" "texto" + a a + "texto" v[linha] m[linha, coluna]

Operao acessar valor do vetor Operao acessar valor da matriz

Comando Operao menor Operao menor ou igual Operao maior Operao maior ou igual Operao igual Operao diferente Operao e Operao ou Operao ou-exclusivo Operao negao Operao bit-a-bit e Operao bit-a-bit ou Operao bit-a-bit ou-exclusivo Operao bit-a-bit negao Operao de incremento Operao de decremento Operao com atribuio a<b a <= b a>b a >= b a=b a <> b aeb a ou b a xou b no a (no existe) (no existe) (no existe) (no existe)

Portugol (Visualg) a<b a <= b a>b a >= b a == b a != b a && b a || b (no existe) !a a&b a|b a^b ~a a++ ++a a---a a op= b ( o mesmo que a = a op b)

C#

(no existe operador especfico, mas pode ser feita com a <- a + 1) (no existe operador especfico, mas pode ser feita com a <- a - 1) (no existe)

Comando Comando se-ento se condio entao ... fimse se condio entao ... senao ... fimse

Portugol (Visualg) if (condio) { ... } if (condio) { ... } else { ... } if (condio1) { ... } else { if (condio2) { ... } else { ... } } switch (varivel) { case valor1: ... break; case valor2: case valor3: ... break; default: ... break; } while (condio) { ... } ou

C#

Comando se-ento-seno

Comando se-ento-seno encadeados

se condio1 entao ... senao se condio2 entao ... senao ... fimse fimse escolha varivel caso valor1 ... caso valor2, valor3 ... outrocaso ... fimescolha

if (condio1) { ... } else if (condio2) { ... } else { ... }

Comando escolha-caso

Comando enquanto-faa

enquanto condio entao ... fimenquanto para varivel de valor1 ate valorN passo P faca ... fimpara repita ... ate condio (no existe)

Comando para

for (varivel = valor1; varivel <= valorN; varivel += P) { ... } (no existe)

Comando repita-at

Comando faa-enquanto

do { ... } while (condio); break; continue;

Comando de interrupo Comando de prxima iterao

interrompa (no existe)

Comando Criar procedimento

Portugol (Visualg) procedimento nome(parmetro: tipo; ...) var ... inicio ... fimprocedimento funcao nome(parmetro: tipo; ...): tipo var ... inicio ... retorne valor fimfuncao nome(valor, ...) a <- nome(valor, ...)

C# static void nome(tipo parmetro, ...) {

... } static tipo nome(tipo parmetro, ...) {

Criar funo

... return valor; } nome(valor, ...); a = nome(valor, ...);

Chamar procedimento Chamar funo