Você está na página 1de 2

Una institucin educativa estableci un programa para estimular a los alumnos con buen rendimiento acadmico y que consiste

en lo siguiente: Si el promedio es de 9.5 o ms y el alumno es de preparatoria, entonces este podr cursar 55 unidades y se le har un 5! de descuento. Si el promedio es mayor o igual a 9 pero menor que 9.5 y el alumno es de preparatoria, entonces este podr cursar 5" unidades y se le har un #"! de descuento. Si el promedio es mayor que $ y menor que 9 y el alumno es de preparatoria, este podr cursar 5" unidades y no tendr ning%n descuento. Si el promedio es de $ o menor, el n%mero de materias reprobadas es de " a & y el alumno es de preparatoria, entonces podr cursar '5 unidades y no tendr descuento. Si el promedio es de $ o menor, el n%mero de materias reprobadas es de ' o ms y el alumno es de preparatoria, entonces podr cursar '" unidades y no tendr ning%n descuento. Si el promedio es mayor o igual a 9.5 y el alumno es de pro(esional, entonces podr cursar 55 unidades y se la har un " ! de descuento. Si el promedio es menor de 9.5 y el alumno es de pro(esional, entonces podr cursar 55 unidades y no tendr descuento. )btener el total que tendr que pagar n alumno si la colegiatura para alumnos de pro(esional es de *&"" por cada cinco unidades y para alumnos de preparatoria es de *#+" por cada cinco unidades pagar n alumno si la colegiatura para alumnos de pro(esional es de *&"" por cada cinco unidades y para alumnos de preparatoria es de *#+" por cada cinco unidades.

double promedio,total,descuento string tipo escribir "ingrese el promedio" leer promedio escribir "escribir tipo de persona profesional o prepa" leer tipo si promedio>=9.5 entonces si tipo="prepa" entonces unidad=55 descuento=25 caso_contrario unidad=55 descuento=20 fin _si fin_si numero_unidades=unidad/5 si tipo="prepa" entonces total=((180*numero_unidades) *descuento)/100 caso contrario

total=((300*numero_unidades) *descuento)/100 fin_si escribir "El total a pagar es: " total FIN