P. 1
Kerkythea Tutorial

Kerkythea Tutorial

|Views: 22.105|Likes:
Publicado porlealtudo
TUTORIAL ABOUT 3D RENDERING OF SKETCHUP MODELS.TUTORIAL SOBRE RENDERIZAÇÃO DE MODELOS 3D DO SKETCHUP.
TUTORIAL ABOUT 3D RENDERING OF SKETCHUP MODELS.TUTORIAL SOBRE RENDERIZAÇÃO DE MODELOS 3D DO SKETCHUP.

More info:

Published by: lealtudo on Oct 06, 2009
Direitos Autorais:Attribution Non-commercial

Availability:

Read on Scribd mobile: iPhone, iPad and Android.
download as PDF, TXT or read online from Scribd
See more
See less

01/02/2014

pdf

text

original

Primeiros Passos

Prefácio:
Com a introdução do novo plugin de exportação SU2KT, agora está mais fácil você exportar o seu modelo do Google SketchUp e renderizá-lo em imagens fotos-realísticas usando o Kerkythea 2007. Apenas seis passos são necessários para você facilmente poder utilizar o SketchUp (SU) e o Kerkythea (KT), e então após estes passos, você estará mais familiarizado com o programa. 1. 2. 3. 4. 5. 6. Abra o seu modelo no SU. Aplique os materiais, componentes, sol e sombras, e crie as cenas (“pages” no SU5). Exporte o seu modelo utilizando a última versão do plugin SU2KT (Ruby Script). Abra o arquivo XML exportado no KT. Ajuste os materiais como desejar (refração, especular, clip, mascara, múltiplos layers, etc.). Escolha a posição da câmera, a resolução da imagem de saída, o padrão de render e pressione o botão render.

Isto é realmente muito simples. Mas, é claro, que você pode melhorar e testar muito mais as configurações, e criar imagens fotosrealísticas do seu modelo 3D com o Kerkythea 2007. Como foi dito acima, este é um tutorial inicial “passo a passo” e foi escrito para você utilizar o Kerkythea 2007. É claro que alguma experiência com programas de renderização será uma vantagem, mas o fato é que mesmo que você não tenha nenhuma experiência com estes programas, isto não será necessário para utilizar o KT. Nós acreditamos que você se adaptará rapidamente. Este guia abordará aquilo que acreditamos como o início básico, o qual é o essencial para a compreensão inicial do programa. Para configurações mais avançadas, o convidamos a visitar o nosso sítio na internet em http://www.kerkythea.net e procurar por algum outro tutorial disponível. Também o convidamos a visitar o Fórum KT, onde você pode encontrar muitas informações e poderosas dicas e truques postadas pelos usuários do KT.

Observação importante! Se esta é a primeira vez que você renderiza um modelo, recomendamos que comece por um modelo muito simples. Como foi dito antes, você deve aprender a engatinhar antes de você aprender a andar.

Kerkythea 2007 - Getting started Written by: The KT Team February 5th, 2007

Kerkythea 2007 – Primeiros Passos Traduzido por: Ezequiel M Rezende 12 de Julho de 2007

2

Primeiros Passos
Índice:
Prefácio ................................................................................................................................................2 Primeira Parte: Exportando do Google SketchUp para o Kerkythea...................................................4 1. Superfícies normais e invertidas: .............................................................................................4 2. Verifique se você tem tudo configurado corretamente: ...........................................................5 3. Removendo todos os materiais e componentes não utilizados: ...............................................5 4. Aplicando os materiais de vidro: .............................................................................................5 5. Criando um espelho: ................................................................................................................6 6. Aplicando sol e sombra:...........................................................................................................7 7. Aplicando as luzes: ..................................................................................................................8 8. Aplicando posições da câmera:..............................................................................................11 9. Exportando para o KT:...........................................................................................................12 Segunda Parte: Aplicando os ajustes no Kerkythea...........................................................................13 10. Abrindo o arquivo XML e fazendo o primeiro render de teste:.........................................13 11. Importando bibliotecas materiais padrão: ..........................................................................14 12. Aplicando e corrigindo materiais em seu modelo:.............................................................15 13. Encontrando materiais em seu modelo/cena:.....................................................................17 14. Criando o seu próprio material: .........................................................................................18 15. Aplicando e modificando os ajustes do Sol e sombras no KT:..........................................19 16. Como aplicar imagens esféricas para o céu: ......................................................................20 17. Ajustando Luz Pontual e Luz Spot no KT: ........................................................................21 18. Ajuste de materiais com Luz Própria no KT: ....................................................................22 19. Alternando entre posições de câmeras:..............................................................................23 20. Escolhendo a pré-configuração de render:.........................................................................23 21. Renderizando o seu modelo: ..............................................................................................24

Kerkythea 2007 - Getting started Written by: The KT Team February 5th, 2007

Kerkythea 2007 – Primeiros Passos Traduzido por: Ezequiel M Rezende 12 de Julho de 2007

3

Primeiros Passos
Primeira Parte: Exportando do Google SketchUp para o Kerkythea
1. Superfícies normais e invertidas:
Dentro do SketchUp (SU) tenha certeza de que todas as superfícies sejam mostradas com o lado normal. Quando modelar no SU, o programa apresentará superfícies normais e invertidas. As superfícies normais são apresentadas na cor marrom claro e a as superfícies invertidas são apresentadas na cor roxa. Se a face ficar roxa após você utilizar alguma ferramenta como o “Push/Pull” ou o “Follow me”, você deve simplesmente clicar com o botão direito do mouse sobre a superfície e escolher “Reverse face”. Isto é muito importante, porque se você desejar renderizar uma imagem, todas as superfícies do modelo deverão estar com as faces do lado normal. Se isto não for considerado, na imagem rederizada não serão apresentadas as faces invertida e as cores ou texturas não aparecerão. Além disto, é uma boa prática quando se está modelando, que se tenha apenas as superfícies com faces normais. Não se preocupe com as faces invertidas! Todas as árvores, arbustos, etc, apresentarão faces invertidas. Uma coisa importante, é que se você colocar uma textura em uma face invertida, ela se apresentará correta no SketchUp, mas ela desaparecerá quando renderizada no Kerkythea (KT). Se você aplica uma cor ou uma textura em uma face normal, ela será reconhecida e também será mostrada na face invertida. Para verificar no SketchUp se as superfícies estão orientadas corretamente, selecione no menu View > Face Style > Monochrome (no SU v5 – View > Rendering > Monochrome), ou click no ícone “Monochrome” na barra de ferramentas “Face Style”.

Você pôde pensar de que este modelo não renderá corretamente por causa das faces invertidas na árvore.

Você não pode ver no SU quando as texturas estiverem ligadas.

Mas renderizará corretamente porque as cores e as texturas foram aplicadas no lado normal das faces das folhas.

Kerkythea 2007 - Getting started Written by: The KT Team February 5th, 2007

Kerkythea 2007 – Primeiros Passos Traduzido por: Ezequiel M Rezende 12 de Julho de 2007

4

Primeiros Passos
2. Verifique se você tem tudo configurado corretamente:
Para ter um melhor resultado, certifique-se de que você tem a última versão do plugin Ruby SU2KT (versão atual 2.2) 1 instalado em seu computador e na pasta correta (C:\ Arquivos de programas\ Google\ Google SketchUp 6\ Plugins) 1. Abra o Google SketchUp 6. 2. Click em Plugins > Kerkythea Exporter > About SU2KT. 3. Verifique se a versão instalada é superior à versão 2.11.

Observação importante! Se você tiver uma versão anterior do plugin Ruby SU2KT, ou se verificar que o seu modelo não é exportado, é porque você não tem o plugin Ruby apropriado corretamente instalado. Faça uma busca e localize em seu computador o arquivo o arquivo “su2kt.rb” e apague todos os arquivos encontrados. Faça um novo download do plugin Ruby mais atualizado em http://www.kerkythea.net e o instale-o.

3. Removendo todos os materiais e componentes não utilizados:
É necessário garantir que todos os materiais e componentes não utilizados sejam removidos do seu modelo. Isto evitará a exportação de materiais e componentes não utilizados que porventura ainda existem em seu modelo. 1. Click no menu “Window > Model Info” 2. Escolha “Statistics” e click em “Purge Unused” 3. Feche o quadro “Model Info”

4. Aplicando os materiais de vidro:
1. Abra o quadro “Materials” e click no ícone “In Model”. 2. Mude o nome de todos os materiais transparentes no SU de modo que tenham o prefixo “TG_” antes do nome do material. Isto permitirá ao KT interpretar o material como vidros finos. Para isto, dê dois clicks no nome do material que você deseja editar e então acrescente o prefixo “TG_”.
1

N.T.: No dia 06/10/2007 foi lançada a versão 3.0 do plugin SU2KT.
Kerkythea 2007 - Getting started Written by: The KT Team February 5th, 2007 Kerkythea 2007 – Primeiros Passos Traduzido por: Ezequiel M Rezende 12 de Julho de 2007

5

Primeiros Passos
Click em na aba “Select” e repita o procedimento para todos os materiais transparentes que existirem no modelo e que você deseje que sejam apresentados como vidros finos no KT. Note que, se você utiliza materiais translúcidos coloridos no SU, este também será colorido no KT. Para um melhor efeito, as janelas deverão ser de cor branca (White) e a opacidade deve ser ajustada para 80. Se você não estiver satisfeito com o material renderizado, você ainda poderá ajustá-lo no KT.

5. Criando um espelho:
Todos sabem que não é possível criar um efeito de reflexo de espelhos no SU. Mas poderá fazê-lo no KT. Então você deve criar um material no SU que crie este efeito de espelho no KT. 1. No SU, crie dentro do seu modelo um espelho como uma superfície ou componente. 2. Em princípio, pode-se escolher qualquer cor que quiser. Mas iremos escolher a cor “Color_001” (light gray), já que esta cor se mostra muito agradável no modelo do SU, apesar de faltar o efeito reflexivo no espelho. 3. Aplique esta cor à superfície do espelho. 4. Dê dois clicks no ícone “In Model”, localize e renomeie o material utilizado para o espelho. Isto permitirá localiza-lo mais facilmente no editor de materiais do KT. Aqui nós o renomeamos como “Mirror”.

No exemplo aplicamos a cor “Mirror” ao retângulo da parede, que se transformará no nosso espelho no KT. Mais tarde você verá como isto será feito bem como a imagem renderizada que se apresentará com um espelho.

Kerkythea 2007 - Getting started Written by: The KT Team February 5th, 2007

Kerkythea 2007 – Primeiros Passos Traduzido por: Ezequiel M Rezende 12 de Julho de 2007

6

Primeiros Passos
6. Aplicando sol e sombra:
A localização geográfica será exportada do SU para o KT, então é bom você verificar se a localização está correta dentro do SU. Você também pode modificar a localização dentro do KT. 1. 2. 3. 4. Vá ao menu “Window > Model Info”. Click em “Location”. Escolha o País e a Localização. Se for necessário, corrija a posição do norte em “North angle”. 5. Feche o quadro “Model Info” Escolha a hora, o dia e o mês para os ajustes da sombra, de acordo com a sua preferência. Note que todas as configurações feitas no SU serão exportadas para o KT. Isto inclui a localização (país e cidade) e a orientação solar. A aparência da projeção da sombra apresentada no SU será idêntica no KT.

Se você desejar que o sol seja visto quando for renderizar o modelo, simplesmente click no botão “Display shadows” antes de exportar o seu modelo. Você poderá ligar ou desligar a luz do sol no KT se você esqueceu de ligá-la ou desliga-la no SU.

Observação importante! Evitar usar os céu-abóbadas (sky-domes) ou ou céu-imagens (sky-images) nos modelos a serem renderizados. Mais adiante, neste guia, você aprenderá como aplicar imagens esféricas para o céu utilizando o KT. Se o seu modelo contiver um céu-abóboda, nós recomendamos que o coloque em uma camada (Layer) separada e a desligue antes de exportar o modelo.

Kerkythea 2007 - Getting started Written by: The KT Team February 5th, 2007

Kerkythea 2007 – Primeiros Passos Traduzido por: Ezequiel M Rezende 12 de Julho de 2007

7

Primeiros Passos
7. Aplicando as luzes:
Em relação a luz do sol ou luz do céu (Céu Físico, Céu de Imagem de Esfera - normal ou HDRI), o Kerkythea é capaz de manipular diversos tipos de luz. Este guia lhe apresentará algum conhecimento básico sobre a luz no KT. Um novo guia que aborda as luzes e mais documentos técnicos logo estará disponível no sitio do Kerkythea. Nesta seção focalizaremos na Luz Omni Direcional / Luz Pontual e Luz Spot, que você poderá aplicar diretamente ao seu modelo no SU, mas também mostraremos como fazer Luz Emissiva e material com Luz Própria. Na seção KT deste tutorial, abordaremos o Céu Físico e o Céu de Imagem de Esfera. Luz Pontual e Luz Spot: Se você fez o download do arquivo compactado SU2KT, encontrará um tutorial SKP que contém vários componentes de Luz Pontual e Luz Spot. Verifique estes arquivos e os salve como componentes do SU: 1. Para isto, feche o SU. 2. Em sua pasta componentes (C:\ Arquivos de programas\ Google\ Google SketchUp 6\ Components) você deve criar uma pasta chamada KT-Lights, SU2KT, Kerkythea ou qualquer outro nome que desejar. 3. Abra o tutorial SPK do arquivo compactado. 4. Dentro do SU, abra o quadro Componentes (Windows > Components) e click no ícone “In Model”. 5. Dê um click com o botão direito no arquivo “su2kt_pointlight.skp” e escolha “Salvar como” e salve-o na pasta que você criou. 6. Repita o procedimento anterior para o arquivo “su2kt_spotlight.skp”. Se você abaixou o programa instalador do SU2KT, você terá uma biblioteca de componentes com vários tipos de luz, incluindo os componentes de Luz Pontual e Luz Spot. 1. No SU, abra o quadro de Componentes e escolha a biblioteca KT-Ligths. 2. Selecione o componente de luz e o coloque no local desejado do seu modelo.

Kerkythea 2007 - Getting started Written by: The KT Team February 5th, 2007

Kerkythea 2007 – Primeiros Passos Traduzido por: Ezequiel M Rezende 12 de Julho de 2007

8

Primeiros Passos
1. Para configurar a intensidade da luz, click com o botão direito sobre o componente de Luz Pontual ou Luz Spot. 2. No menu de contexto selecione: a. SU2KT: Edit Pointlight. Entre com o nome para a luz escolhida (isto o permitirá o KT a reconhecer o nome de luz especificado). E entre com um valor para a intensidade da luz (Light Power) (utilize um valor entre 3 e 5. Você poderá ajusta-la no KT).

b. SU2KT: Edit Spotlight. Entre com o nome para a luz escolhida (isto o permitirá o KT a reconhecer o nome de luz especificado). E entre com um valor para a intensidade da luz (Light Power) (utilize um valor entre 3 e 5. Você poderá ajusta-la no KT). Entre um valor para o campo “Hot Spot” (a área totalmente iluminada pelo spot). Utilize um valor entre 15 e 20. Você poderá modificá-lo no KT. E finalmente preencha o campo “Falloff” (a área da penumbra do spot). Utilize um valor de 90. Você poderá modificá-lo no KT.

Você também poderá facilmente criar os seus componentes de Luz Pontual e Luz Spot no SU. Se estiver utilizando o plugin Ruby SU2KT versão 2.1 então poderá criar um componente e nomeá-lo de su2pov_spotlight” ou “su2pov_pointlight”, mas lembre-se que se pode ter apenas um componente com este propósito. Click com o botão direito sobre o novo componente de Luz criado e escolha no menu de contexto a opção “Make Component” e escolha um dos nomes indicado acima. Se você criou um objeto e o transformou em componente com o comando “Make Component” utilizando o nome “su2pov_pointlight”, então, se clicar sobre ele com o botão direito do mouse,
Kerkythea 2007 - Getting started Written by: The KT Team February 5th, 2007 Kerkythea 2007 – Primeiros Passos Traduzido por: Ezequiel M Rezende 12 de Julho de 2007

9

Primeiros Passos
aparecerá no menu de contexto a opção “SU2KT: Edit Point Light” que permitira editar o nome e a intensidade da luz. Se você tentar fazer dois componentes diferentes com o mesmo nome, o SU nomeará automaticamente um deles, como por exemplo, “su2pov_pointlight#1” e então não será mais capaz de ver a opção “SU2KT: Edit Point Light” no menu de contexto quando clicar com o botão direito do mouse sobre o componente. Se estiver utilizando o plugin Ruby SU2KT versão 2.20, este reconhecerá todos os componentes que começam com o nome o “su2xxx_pointlight_yyy” ou “su2xxx_spotlight_yyy”, onde o “xxx” representa o “kt” ou o “pov” e poderá entrar com o nome que preferir para os campos “yyy”. Isto é, “su2kt_pointlight_no1”, etc. Pode ser um pouco difícil determinar exatamente o valor da intensidade da luz (Light Power) a se aplicar no SU, mas após um período de prática modificando algumas configurações, você ficará mais familiarizado com os ajustes. Além disto, não precisa se preocupar, já que no KT, você poderá ajustar novamente a intensidade da luz. Luz Emissiva e material com Luz Própria: 1. Crie uma forma (por exemplo, quadrado no teto). 2. Abra o quadro “Materials” e escolha uma cor (Neste exemplo criamos uma luz com a cor amarelada “Color E05”). 3. Aplique a cor à forma que você criou. 4. Clicks no ícone “In Model” e dê dois clicks na cor utilizada para renomeá-la. Você deve incluir o nome como “ xxxxEmit [#]” onde o “xxxx” representam o nome da luz e o “#” a intensidade da luz.

Observação importante! Ao utilizar os componentes de Luz Pontual e Luz Spot no SU, este componente será visível no SU, mas invisível no KT. Ao utilizar um material com Luz Própria ou Emissiva, ele iluminará o modelo, mas será invisível. Sabemos que uma luz de bulbo tem uma forma esférica no mundo real, mas devemos evitar o uso de formas esféricas. O uso de esferas como emissores de luz aumentarão consideravelmente o tempo de render, já que para construir uma forma esférica será necessária a utilização de uma malha com um grande número de faces triangulares.

Além disso, você não verá este objeto após o render.

Kerkythea 2007 - Getting started Written by: The KT Team February 5th, 2007

Kerkythea 2007 – Primeiros Passos Traduzido por: Ezequiel M Rezende 12 de Julho de 2007

10

Primeiros Passos
No exemplo à direita, inicialmente criamos um círculo e aplicamos a ferramenta “Push/pull” para adicionar a extrusão. No fundo deste objeto cilíndrico, criamos um retângulo, que posteriormente o transformamos em um grupo (click no botão direito do mouse sobre a seleção e escolha “Make Group”). Finalmente aplicamos a cor criada anteriormente. Em seqüência, copiamos o objeto cilíndrico que contém a nossa luz, e a colocamos no teto como mostrado abaixo.

8. Aplicando posições da câmera:
É muito fácil criar as posições de câmeras no SU As cenas (scenes) criadas no SU (ou “pages” no SU v5) serão as posições de câmeras no KT. Além destas posições de câmeras importadas do SU, você também poderá criar novas câmeras no KT ou então modificar uma posição de uma câmera escolhida: 1. Gire o seu modelo na tela e escolha uma posição e ângulo de visualização desejado para então criar uma nova posição de câmera no KT. 2. Click em “View > Animation > Add Scene” (no SU v5, click em “Tourguide > Add Page”) 3. Repita os passos 1 e 2 para criar quantas posições de câmeras desejar.

Estas 10 cenas serão posições de câmeras no KT. Lembre-se que no SU você pode renomear ou mudar a ordem das seqüências das posições de câmeras (vá ao menu “Window > Scenes”) (no SU v5 vá ao menu “Window > Pages”).

Observação importante! Note que os planos de corte (Section Planes) não são suportados no KT. Se você criou um plano de corte no SU, por exemplo, através do telhado de uma casa, ele não será reconhecido no KT. Se você deseja uma vista em planta de uma casa sem o telhado, então deverá colocar o telhado em uma camada (Layer) em separado. Desligue esta camada e exporte o seu modelo para o KT.
Kerkythea 2007 - Getting started Written by: The KT Team February 5th, 2007 Kerkythea 2007 – Primeiros Passos Traduzido por: Ezequiel M Rezende 12 de Julho de 2007

11

Primeiros Passos
9. Exportando para o KT:
Como foi mencionado anteriormente, verifique se você tem a última versão do plugin Ruby SU2KT e este está instalado corretamente dentro da pasta “Plugin”do SU. 1. Click em Plugins > Kerkythea Exporter > Export Model. 2. Click em OK.

3. Se você selecionou uma superfície do seu modelo acidentalmente ou por alguma finalidade, o quadro de exportação terá um campo extra. Se a escolha foi acidental, escolha NÃO na opção “Export Selection ONLY”.

4. Após clicar no botão “OK”, o programa solicitará uma pasta e um nome para salvar o arquivo XML do seu modelo.

Observação importante! Atenção, o KT não suporta Unicode, portanto ele não reconhecerá letra com caracteres especiais e acentuados em seu nome de arquivo (por exemplo, ç, Ç, ã, Ã, õ, Õ, ö, Ö, etc.). Para um procedimento seguro, recomendamos utilizar somente o alfabeto inglês quando nomear os seus arquivos. Note que isto também se aplica para o nome das texturas usadas.

Você poderá acompanhar o progresso da exportação observando o canto inferior esquerdo do SU. Quando a exportação estiver finalizada, o programa apresentará a seguinte janela: Click no botão “OK” e saia do SU.

Kerkythea 2007 - Getting started Written by: The KT Team February 5th, 2007

Kerkythea 2007 – Primeiros Passos Traduzido por: Ezequiel M Rezende 12 de Julho de 2007

12

Primeiros Passos
Segunda Parte: Aplicando os ajustes no Kerkythea
10. Abrindo o arquivo XML e fazendo o primeiro render de teste:
1. Abra o KT 2007 e abra o arquivo XML que foi exportado.

Você pode alternar o modo de apresentação da imagem entre “Wireframe Rendering” ou “Solid Rendering”, apenas clicando em “V” do seu teclado. Ou selecione View > Adjust > “Wireframe Rendering” ou “Solid Rendering”.

2. Click no ícone “Start Render” . 3. Escolha uma posição de câmera (em “Câmera”). 4. Selecione uma resolução para a imagem de saída do render (em “Resolution”). (Já que este será apenas o primeiro teste, recomendamos que escolha uma imagem de baixa resolução, como 800x600 pixels). 5. Selecione as configurações do render (em “Settings”). Nas etapas iniciais, utilize apenas uma configuração baixa, como o “03. PhotonMap - Quick”.

Kerkythea 2007 - Getting started Written by: The KT Team February 5th, 2007

Kerkythea 2007 – Primeiros Passos Traduzido por: Ezequiel M Rezende 12 de Julho de 2007

13

Primeiros Passos
6. A opção “Threads” refere-se ao número de processadores que existem em seu computador. Para este momento, selecione “## Custom Settings ##”. 7. Click no botão “OK” para iniciar o primeiro render do seu modelo. (Você poderá ver o progresso do render na barra superior e ainda poderá visualizar uma vista prévia no canto inferior direito). 8. Click no ícone “Image” para visualizar a imagem renderizada na resolução que você selecionou. (Neste quadro também tem o botão “Save” para salvar a imagem renderizada). Você pode interromper o processo de render a qualquer momento. Em uma fase inicial de testes, não é necessário esperar o KT finalizar o render. Além desta parte inicial do render, também será necessário alguns ajuste no KT. Então, poderá ser necessário modificar alguns dos materiais utilizados ou fazer ajustes na intensidade da luzes.

11.

Importando bibliotecas materiais padrão:

Na seção de download do sitio http://www.kerkythea.net, você poderá encontrar vários tipos de materiais padrão que serão muito úteis. Inicialmente faça o download destas bibliotecas e então abra o KT: 1. Click em “File > Install Library”

2. Selecione a biblioteca de material desejada a ser instalada e click em “OK”.

Um procedimento alternativo segue abaixo: Click em “Settings > Materials…”

1. No campo “Current Library” click no botão “Open”

2. Selecione a biblioteca de material a ser instalada e click no botão “Import”. 3. Click em “OK” para finalizar.

Kerkythea 2007 - Getting started Written by: The KT Team February 5th, 2007

Kerkythea 2007 – Primeiros Passos Traduzido por: Ezequiel M Rezende 12 de Julho de 2007

14

Primeiros Passos
12. Aplicando e corrigindo materiais em seu modelo:

1. Click em “Settings > Materials…” 2. Na lista de materiais é apresentado todos os materiais que você aplicou no SU. Click com o botão direito do mouse e escolha “Select All”

3. Em seguida, click em “Rebuild Selected” para mostrar a miniatura de cada material da cena. Após recarregar todos os materiais, o quadro de materiais da cena aparentará como a imagem abaixo. Selecione um material (por exemplo, o cromo Chrome) e dê dois click sobre ele.

4. Click no botão “Get”.

Kerkythea 2007 - Getting started Written by: The KT Team February 5th, 2007

Kerkythea 2007 – Primeiros Passos Traduzido por: Ezequiel M Rezende 12 de Julho de 2007

15

Primeiros Passos
1. Selecione um material a ser aplicado a partir de uma biblioteca instalada:

Um modo alternativo de aplicar o material é clicando no menu “Settings > Materials…” Na biblioteca ativa, click no botão “Open” e selecione um dos materiais disponíveis e click em “OK” 1. No quadro “Material Workshop”, do lado esquerdo, selecione o material que você deseja substituir:

2. Do lado direito, na relação de materiais da biblioteca ativa (Current Library), com um click, selecione o material que será utilizado como substituto. 3. E com o botão direito do mouse, substitua o material do painel esquerdo com a opção “Apply to Left Pane”.

Kerkythea 2007 - Getting started Written by: The KT Team February 5th, 2007

Kerkythea 2007 – Primeiros Passos Traduzido por: Ezequiel M Rezende 12 de Julho de 2007

16

Primeiros Passos
13. Encontrando materiais em seu modelo/cena:
Mostramos como modificar os nomes dos materiais e aplicá-los no SU, entretanto, também reconhecemos que ao importar os componentes, os nomes dos materiais serão mantidos como os aplicado originalmente. Estes materiais poderão às vezes ter nomes difíceis de reconhecer quando forem exportados para o KT. no KT, click em um objeto em seu modelo, e o material Usando a ferramenta “Select” correspondente será destacado na lista de material.

Você também pode dar dois clicks sobre o nome na lista de material e o objeto correspondente em seu modelo será destacado. Uma vez conhecido o nome do material, você poderá aplicar um novo material como foi explicado na seção anterior. Para remover a seleção do material, basta dar um click em uma outra área do modelo ou então dois clicks no nome do material destacado na lista.

Kerkythea 2007 - Getting started Written by: The KT Team February 5th, 2007

Kerkythea 2007 – Primeiros Passos Traduzido por: Ezequiel M Rezende 12 de Julho de 2007

17

Primeiros Passos
14. Criando o seu próprio material:
Você também pode criar os seus próprios materiais, e a seguir mostraremos como criar um material “espelho”. 1. Click em “Settings > Materials…” 2. No quadro “Material Workshop” selecione com dois clicks o “material espelho” que você criou no SU. Abrirá o quadro “material Workshop”:

3. Com o botão direito do mouse em “Shader” e selecione [Matte / Phong] e dê um click em [Set Dielectric / Glass]. 4. Mude a cor da reflexão para um branco de 100%: 5. Desmarque a opção “Fresnel” 6. Click em “Apply Changes” e em “Close Editor”. Você acabou de criar um material espelho 100% reflexivo.

Observação importante! Você descobrirá que não será necessário modificar todos os materiais. Neste guia não abordaremos a criação de materiais em detalhes, e o convidamos ir à seção de download do sítio http://www.kerkythea.net, onde encontrará tutoriais abordando este assunto.

Kerkythea 2007 - Getting started Written by: The KT Team February 5th, 2007

Kerkythea 2007 – Primeiros Passos Traduzido por: Ezequiel M Rezende 12 de Julho de 2007

18

Primeiros Passos
15. Aplicando e modificando os ajustes do Sol e sombras no KT:
Se você ligar as sombras no SU antes de exportar o seu modelo, o Céu Físico também estará ligado no KT. Mas também é possível ligar e desligar a luz do Sol no KT. No lado esquerdo já janela do KT, você encontrará uma lista com todos os materiais, luzes e câmeras disponíveis no seu modelo. Se por exemplo, existir uma luz bulbo com uma cruz vermelha, significa que a luz está desligada. Você poderá ligá-la selecionando-a com o botão direito do mouse e escolhendo “Enable”. Para desligar uma luz, simplesmente escolha “Disable”. Como pode-se notar, é possível visualizar, esconder, selecionar, remover a seleção, habilitar, desabilitar, apagar e renomear. Escolha “Enable” para ligar a luz do Sol:

1. Click em “Settings > Sun and Sky…”

A posição geográfica, a data e a hora devem ser idênticas à que foram aplicadas no SU. Se você não estiver satisfeito com os ajustes, poderá mudá-los a qualquer momento.

Se no SU as sombras estavam desligadas, o Céu Físico também estará desligado no KT. Se for necessário, pode-se modificar a intensidade e a densidade, e então click no botão “Finish”.

Kerkythea 2007 - Getting started Written by: The KT Team February 5th, 2007

Kerkythea 2007 – Primeiros Passos Traduzido por: Ezequiel M Rezende 12 de Julho de 2007

19

Primeiros Passos
16. Como aplicar imagens esféricas para o céu:
Você pode fazer o download de alguns bitmaps esféricos grátis e realmente agradáveis nos sítios BlenderArtists.org, Evermotion ou Continuum Skies. Os links à estes sítios estão disponíveis no sítio http://www.kerkythea.net.

1. Click em “Settings > Sun and Sky…”

2. Escolha a localização para o seu modelo e click em “Next”. 3. Em “Sky Type” escolha “Spherical Sky”. 4. Click em “Map/Color”. 5. Click no botão “Browse” e selecione a imagem do Céu Esférico (Imagens JPG ou arquivos HDRI são suportados). 6. Selecione o Céu e click em “OK”. 7. Click no botão “Finish” para finalizar o quadro “Sun & Sky Wizard”. Este é um bom momento para fazer um teste do render, apenas para se ter uma noção de como se apresentará o Céu finalizado. 8. Se a imagem do Céu aparentar muito clara ou muito escura, você poderá ajustar em “Settings > Scene...”. 9. Ajuste o valor do multiplicador (Multiplier) para cima ou para baixo, dependendo da sua necessidade. 10. Inicie um novo teste de render e repita os passos 8 e 9 se for necessário.

Kerkythea 2007 - Getting started Written by: The KT Team February 5th, 2007

Kerkythea 2007 – Primeiros Passos Traduzido por: Ezequiel M Rezende 12 de Julho de 2007

20

Primeiros Passos
17. Ajustando Luz Pontual e Luz Spot no KT:
Você provavelmente inseriu os componentes de Luz Pontual e Luz Spot no SU e configurou a intensidade da luz para estes. Mesmos para usuários experientes é difícil determinar o valor correto para esta luz. Na maioria dos casos, você aplicou muito ou então pouca luz. Mas você pode modificar os ajuste ou mesmo desabilitar uma Luz Pontual ou Luz Spot. No lado esquerdo da janela do KT você tem uma lista com materiais, luzes e câmeras do seu modelo. Dê dois clicks em um dos seus componentes para torná-lo visível. 1. No canto superior direito da janela do KT, pode-se ver dois controles deslizantes que permitem ajustar as configurações de “Hotspot” e “Falloff” para a Luz Spot escolhida.

Para ajustar a intensidade da luz, click em “Settings > Scene…”

1. Ajuste o valor multiplicativo (Multiplier) dependendo da sua necessidade. 2. Ajuste o valor do “Falloff” se necessário. 3. Ajuste o valor do “Hotspot” se necessário. Repita as etapas de 1 à 3 se for necessário.

Kerkythea 2007 - Getting started Written by: The KT Team February 5th, 2007

Kerkythea 2007 – Primeiros Passos Traduzido por: Ezequiel M Rezende 12 de Julho de 2007

21

Primeiros Passos
18. Ajuste de materiais com Luz Própria no KT:
Na seção 7 deste guia, mostramos como aplicar um material que pudesse ser utilizado no KT como um material com Luz Própria. Agora que você importou o seu modelo para o KT, mostraremos como fazer este material funcionar como uma luz. 1. No quadro “material Editor”, dê dois clicks no material que você deseja que comporte como uma luz. 2. Selecione a aba “Advanced”. 3. Ajuste o valor da cor para 5. (Não utilize os controles deslizantes para isto, modifique os valores no campo) 4. Click no botão “Apply Changes”. 5. Click em “Close” para fechar o editor. Observe que ao fazer um material com Luz Própria, um ícone de uma lâmpada aparecerá na frente do nome do material, na lista de material.

Faça um teste rápido de render e verifique se é necessário aumentar ou diminuir este valor.

Observação importante! Ao utilizar um material com Luz Própria o tempo de render aumentará. Às vezes, este tempo poderá aumentar consideravelmente. O uso de Luz Pontual ou Luz Spot é um modo muito mais rápido de iluminar um modelo.

Kerkythea 2007 - Getting started Written by: The KT Team February 5th, 2007

Kerkythea 2007 – Primeiros Passos Traduzido por: Ezequiel M Rezende 12 de Julho de 2007

22

Primeiros Passos
19. Alternando entre posições de câmeras:
Para alternar entre as câmeras que foram aplicadas no SU, você simplesmente utiliza a ferramenta “Cycle”. Para escolher uma posição de câmera que foi aplicada, utilize a seguinte ferramenta:

1. Click em na ferramenta “Cycle” e escolha a posição de câmera que você deseja renderizar. 2. Click no ícone “Start Render” . O KT escolherá automaticamente a câmera que você selecionou. Existe alguns números de pré-configurações de resolução que você pode escolher a partir da lista do menu “pull down”, mas perceba que também é possível entrar com qualquer valor desejado no campo “Resolution”. Para isto, apenas modifique os valores dentro do campo para os valores de resolução desejados.

20.

Escolhendo a pré-configuração de render:

É grande a lista de pré-definições de render disponíveis, e contém renderes dos tipos Path, Ray, PhontonMap (GI), Bidirectional Path Tracing (BiPT), Metropolis Light Transport (MLT), Clay, Mask e muitos outros. Para iniciar, sugerimos que você teste várias configurações de render. Utilize o render “No. 03 PhontonMap - Quick” para fazer os seus teste, e quando estiver satisfeito com a aplicação dos materiais e luzes, tente outros ajustes mais complexos.

Kerkythea 2007 - Getting started Written by: The KT Team February 5th, 2007

Kerkythea 2007 – Primeiros Passos Traduzido por: Ezequiel M Rezende 12 de Julho de 2007

23

Primeiros Passos
21. Renderizando o seu modelo:
O KT é capaz de utilizar processadores de dois núcleos (Dual Core). Se o seu computador for do tipo Dual Core, você o visualizará na lista do menu “pull down” chamada de “Threads”. Especificamente, se for renderizar imagens usando BiPT ou MLT, você pode tira vantagens ao utilizar a opção “Dual Core”. Recorda da cena do banheiro, onde foi aplicado o material de espelho? Bem, aqui está o resultado.

Para perguntas adicionais, recomendamos que você visite o sítio e o fórum do KT.

(emr – 2007/10/18)
Kerkythea 2007 - Getting started Written by: The KT Team February 5th, 2007 Kerkythea 2007 – Primeiros Passos Traduzido por: Ezequiel M Rezende 12 de Julho de 2007

24

You're Reading a Free Preview

Descarregar
scribd
/*********** DO NOT ALTER ANYTHING BELOW THIS LINE ! ************/ var s_code=s.t();if(s_code)document.write(s_code)//-->