Você está na página 1de 7

Lista de Exerccios de Estrutura Condicional 1 - Escrever um algoritmo que leia o nome e as trs notas obtidas por um aluno durante

o semestre. Calcular a sua mdia (aritmtica), informar o nome e sua meno aprovado (media >= 7), Reprovado (media <= 5) e Recuperao (media entre 5.1 a 6.9). INICIO LITERAL:NOME REAL:N1, N2, N3, MEDIA ESCREVAL("SISTEMA DE MDIAS") ESCREVA("DIGITE A PRIMEIRA NOTA: ") LEIA(N1) ESCREVA("DIGITE A SEGUNDA NOTA: ") LEIA(N2) ESCREVA("DIGITE A TERCERIA NOTA: ") LEIA(N3) MEDIA <- (N1 + N2 + N3) / 3 SE MEDIA >= 7 ENTAO ESCREVAL("ALUNO APROVADO!") SENAO SE MEDIA <= 5 ENTAO ESCREVAL("ALUNO REPROVADO!") SENAO ESCREVAL("ALUNO EM RECUPERAO...") FIMSE FIMSE FIM 2 - Escrever um algoritmo que leia dois valores inteiros distintos e informe qual o maior. INICIO INTEIRO:NUM1, NUM2 ESCREVA("DIGITE O PRIMEIRO NMERO: ") LEIA(NUM1) ESCREVA("DIGITE O SEGUNDO NMERO: ") LEIA(NUM2) SE NUM1 > NUM2 ENTAO ESCREVA("O PRIMEIRO NMERO ",NUM1," MAIOR QUE O SEGUNDO",NUM2) SENAO ESCREVA("O SEGUNDO NMERO",NUM2," MAIOR QUE O PRIMEIRO",NUM1) FIMSE FIM 3 - Elabore um algoritmo que leia do teclado o sexo de uma pessoa. Se o sexo digitado for M ou F, escrever na tela Sexo vlido!. Caso contrrio, informar Sexo invlido!; INCIO LITERAL: SEXO ESCREVA DIGITE A LETRA CORRESPONDENTE AO SEXO: ; LEIA SEXO; SE ((SEXO = M) OU (SEXO = F)) ENTO ESCREVA SEXO VLIDO!; SENO ESCREVA SEXO INVLIDO!; FIM SE FIM

4 - Elabore um algoritmo que leia dois nmeros inteiros e mostre o resultado da diferena do maior valor pelo menor;

INCIO INTEIRO:VAL1, VAL2 ESCREVA DIGITE O PRIMEIRO VALOR: ; LEIA VAL1; ESCREVA DIGITE O SEGUNDO VALOR: ; LEIA VAL2; SE (VAL1 > VAL2) ENTO ESCREVA O RESULTADO DA DIFERENA : , VAL1 VAL2; SENO ESCREVA O RESULTADO DA DIFERENA : , VAL2 VAL1; FIM SE FIM 5 - Elabore um algoritmo a ler 4 notas de um aluno (de 1 a 10). Aps calcular a mdia das notas, apresentar a mensagem Aprovada se o aluno tiver obtido mdia maior ou igual a 6, caso contrrio, apresentar Reprovado. INCIO REAL:N1, N2, N3, N4, MEDIA ESCREVA DIGITE O VALOR DA PRIMEIRA NOTA DE 1 A 10: ; LEIA N1; ESCREVA DIGITE O VALOR DA SEGUNDA NOTA DE 1 A 10: ; LEIA N2; ESCREVA DIGITE O VALOR DA TERCEIRA NOTA DE 1 A 10: ; LEIA N3; ESCREVA DIGITE O VALOR DA QUARTA NOTA DE 1 A 10: ; LEIA N4; MEDIA (N1 + N2 + N3 + N4) / 4; SE (MEDIA >= 6) ENTO ESCREVA O ALUNO FOI APROVADO!; SENO ESCREVA O ALUNO FOI REPROVADO!; FIM SE FIM 6 - Altere o algoritmo anterior para que seja lido do teclado, alm das notas, o sexo do aluno (M ou F). Se for masculino, o resultado dever ser precedido de Caro aluno, seu resultado : . Se for feminino, o resultado dever ser precedido de Cara aluna, seu resultado : . INCIO REAL:N1, N2, N3, N4, MEDIA LITERAL:SEXO ESCREVA DIGITE O VALOR DA PRIMEIRA NOTA DE 1 A 10: ; LEIA N1; ESCREVA DIGITE O VALOR DA SEGUNDA NOTA DE 1 A 10: ; LEIA N2; ESCREVA DIGITE O VALOR DA TERCEIRA NOTA DE 1 A 10: ; LEIA N3; ESCREVA DIGITE O VALOR DA QUARTA NOTA DE 1 A 10: ; LEIA N4; ESCREVA DIGITE O SEXO DO ALUNO: ; LEIA SEXO; MEDIA (N1 + N2 + N3 + N4) / 4; SE (MEDIA >= 6) ENTO SE (SEXO = M) ENTO ESCREVA CARO ALUNO, SEU RESULTADO APROVADO!; SENO ESCREVA CARA ALUNA, SEU RESULTADO APROVADA!; FIM SE SENO SE (SEXO = M) ENTO ESCREVA CARO ALUNO, SEU RESULTADO REPROVADO!; SENO ESCREVA CARA ALUNA, SEU RESULTADO REPROVADA!; FIM SE FIM SE FIM

7 - A escola APRENDER faz o pagamento de seus professores por hora/aula. Faa um algoritmo que calcule e exiba o salrio de um professor. Sabe-se que o valor da hora/aula segue a tabela abaixo: Professor Nvel 1 R$12,00 por hora/aula Professor Nvel 2 R$17,00 por hora/aula Professor Nvel 3 R$25,00 por hora/aula INICIO INTEIRO:NIVEL, HORAS ESCREVA("DIGITE O NVEL DO PROFESSOR (1/2/3): ") LEIA(NIVEL) ESCREVA("DIGITE O NMERO DE HORAS TRABALHADAS: ") LEIA(HORAS) SE NIVEL = 1 ENTAO ESCREVAL("O PROFESSOR GANHA",HORAS*12) SENAO SE NIVEL = 2 ENTAO ESCREVAL("O PROFESSOR GANHA",HORAS*17) SENAO ESCREVA("O PROFESSOR GANHA",HORAS*25) FIMSE FIMSE FIM 8 - Elabore um algoritmo que leia 5 valores inteiros e apresente na tela o maior e o menor deles. INCIO INTEIRO: V1, V2, V3, V4, V5, MAIOR, MENOR ESCREVA DIGITE O 1. VALOR: ; LEIA V1; MAIOR V1; MENOR V1; ESCREVA DIGITE O 2. VALOR: ; LEIA V2; SE (V2 < MENOR) ENTO MENOR V2; FIM SE SE (V2 > MAIOR) ENTO MAIOR V2; FIM SE ESCREVA DIGITE O 3. VALOR: ; LEIA V3; SE (V3 < MENOR) ENTO MENOR V3; FIM SE SE (V3 > MAIOR) ENTO MAIOR V3; FIM SE ESCREVA DIGITE O 4. VALOR: ; LEIA V4; SE (V4 < MENOR) ENTO MENOR V4; FIM SE SE (V4 > MAIOR) ENTO MAIOR V4; FIM SE ESCREVA DIGITE O 5. VALOR: ; LEIA V5; SE (V5 < MENOR) ENTO MENOR V5; FIM SE SE (V5 > MAIOR) ENTO MAIOR V5; FIM SE ESCREVA O MAIOR VALOR DIGITADO FOI: , MAIOR; ESCREVA O MENOR VALOR DIGITADO FOI: , MENOR; FIM

9 - Faa um algoritmo que leia um nmero e mostre uma mensagem indicando se este nmero par ou mpar e se positivo ou negativo. INCIO INTEIRO:N ESCREVA ("DIGITE UM NMERO") ; LEIA N ; SE N >= 0 ENTO ESCREVA (,N " POSITIVO"); SENO ESCREVA (,N " NEGATIVO"); FIM SE SE N(MOD2) = 0 ENTO ESCREVA (,N " PAR"); SENO ESCREVA (,N " MPAR"); FIM SE FIM 10 - Dados trs valores X, Y e Z, verificar se eles podem ser os comprimentos dos lados de um tringulo e, se forem verificar se um tringulo equiltero, issceles ou escalenos. Se eles no formarem um tringulo, escrever a mensagem. Considere as seguintes propriedades: O comprimento de cada lado em um tringulo menor que a soma dos outros dois lados; Equilteros: tem os comprimentos dos trs lados iguais; Issceles: tem os comprimentos de dois lados iguais; escaleno: tem os comprimentos dos trs lados diferentes. INCIO INTEIRO:X, Y, Z ESCREVA ('DIGITE UM LADO DO TRINGULO') LEIA X ESCREVA ('DIGITE OUTRO LADO DO TRINGULO') LEIA Y ESCREVA ('DIGITE OUTRO LADO DO TRINGULO') LEIA Z SE (X>=(Y+Z)) || (Y>=(X+Z)) || (Z>=(X+Y)) ENTO ESCREVA ('ESTES NMEROS NO PODEM SER LADOS DE UM TRINGULO') SENO SE (X=Y) E (X=Z) ENTO ESCREVA ('O TRINGULO EQUILTERO') SENO SE (X=Y) OU (Y=Z) ENTO ESCREVA ('O TRINGULO ISSCELES') SENO ESCREVA ('O TRINGULO ESCALENO') FIM SE FIM SE FIM SE FIM 11 - Construa um algoritmo que calcule o peso ideal de uma pessoa. Dados de entrada: altura e sexo. Frmulas para clculo do peso: peso ideal de homem = (72,7 x altura) - 58 peso ideal da mulher = (62,1 x altura) - 44,7

INCIO INTEIRO: SEXO; REAL: PESO, ALTURA; ESCREVA("SEXO (1. HOMEM 2. MULHER) :"); LEIA(SEXO); SE((SEXO<1) OU (SEXO>2)) /* ANALISA SE ESCOLHA DE SEXO VLIDA */ ESCREVA("OPO DE SEXO INVLIDA !!!"); SENO ESCREVA("QUAL SUA ALTURA ?"); LEIA(ALTURA); SE (SEXO = 1) /* USURIO HOMEM */ PESO <== (72,7 * ALTURA) -58; SENO /* USURIO MULHER */ PESO <== (62,1 * ALTURA) - 44,7; FIM SE; ESCREVA("SEU PESO IDEAL ", PESO); FIMSE; FIM 12 - Escrever um algoritmo que l um valor em reais e calcule qual o menor nmero possvel de notas de 100, 50, 10, 5 e 1 em que o valor lido pode ser decomposto. Escrever o valor lido e a relao de notas necessrias. INICIO INTEIRO: DINHEIRO, CEM, CINQUENTA, DEZ, CINCO, UM; LEIA (DINHEIRO); AUX DINHEIRO; SE (DINHEIRO>99) ENTO CEM DIV ( DINHEIRO, 100); DINHEIRO MOD( DINHEIRO, 100); FIM SE SE (DINHEIRO > 49)ENTO CINQUENTA DIV (DINHEIRO, 50); DINHEIRO MOD( DINHEIRO, 50); FIM SE SE (DINHEIRO >9)ENTO DEZ DIV (DINHEIRO, 10); DINHEIRO MOD( DINHEIRO, 10); FIM SE SE (DINHEIRO >4)ENTO CINCO DIV (DINHEIRO, 5) DINHEIRO MOD( DINHEIRO, 5); FIM SE SE (DINHEIRO >0)ENTO UM DINHEIRO FIM SE ESCREVA (AUX, CEM, CINQUENTA, DEZ, CINCO, UM); FIM

13 - Num determinado Estado, para transferncias de veculos, o DETRAN cobra uma taxa de 1% para carros fabricados antes de 1990 e uma taxa de 1.5% para os fabricados de 1990 em diante, taxa esta incidindo sobre o valor de tabela do carro. O algoritmo abaixo l o ano e o preo do carro e a seguir calcula e imprime imposto a ser pago. INICIO INTEIRO: ANO_CARRO; REAL: PREO_CARRO, TAXA; LEIA (ANO_CARO, PREO_CARRO); SE (ANO_CARRO < 1990) ENTO TAXA PREO_CARRO * 0,01; SENO TAXA PREO_CARRO * 0,015; FIM SE ESCREVA (TAXA); FIM

14 - Uma empresa conceder um aumento de salrio aos seus funcionrios, varivel de acordo com o cargo, conforme a tabela abaixo. Faa um algoritmo que leia o salrio e o cargo de um funcionrio e calcule o novo salrio. Se o cargo do funcionrio no estiver na tabela, ele dever, ento, receber 40% de aumento. Mostre o salrio antigo, o novo salrio e a diferena. Cdigo Cargo Percentual 101 Gerente 10% 102 Engenheiro 20% 103 Tcnico 30% INICIO INTEIRO: CODIGO; REAL: SAL_ATUAL, NOVO_SAL, DIFERENA; LEIA (CODIGO, SAL_ATUAL); SE (CODIGO = 101) ENTO NOVO_SAL SAL_ATUAL * 1,1; SENO SE (OP = 102) ENTO NOVO_SAL SAL_ATUAL * 1,2; SENO SE (OP = 103) ENTO NOVO_SAL SAL_ATUAL * 1,3; SENO NOVO_SAL SAL_ATUAL * 1,4; FIM SE FIM SE FIM SE DIFERENA NOVO_SAL SAL_ATUAL; ESCREVA (SAL_ATUAL, NOVO_SAL, DIFERENA); FIM 15 - Um banco conceder um crdito especial aos seus clientes, varivel com o saldo mdio no ltimo ano. Faa um algoritmo que leia o saldo mdio de um cliente e calcule o valor do crdito de acordo com a tabela abaixo. Mostre uma mensagem informando o saldo mdio e o valor do crdito. Saldo mdio Percentual de 0 a 200 nenhum crdito de 201 a 400 20% do valor do saldo mdio de 401 a 600 30% do valor do saldo mdio acima de 601 40% do valor do saldo mdio INICIO REAL:CREDITO, SALDO; LEIA (SALDO); SE (SALDO >= 0 E SALDO < 201 ) ENTO ESCREVA (SALDO ,NENHUM CRDITO); SENO SE (SALDO >= 201 E SALDO < 401 ) ENTO CREDITO SALDO * 0,2; ESCREVA (SALDO , CREDITO); SENO SE (SALDO >= 401 E SALDO < 601 ) ENTO CREDITO SALDO * 0,3; ESCREVA (SALDO , CREDITO); SENO SE (SALDO >=601) ENTO // ** CREDITO SALDO * 0,4; ESCREVA (SALDO , CREDITO); FIM SE FIM SE FIM SE FIM //** NESSE CASO NECESSARIO UM ULTIMO SE POIS O SALDO PODE SER NEGATIVO.

16 - O cardpio de uma lanchonete o seguinte: Especificao Preo unitrio 100 Cachorro quente 1,10 101 Bauru simples 1,30 102 Bauru c/ovo 1,50 103 Hamburger 1,10 104 Cheeseburger 1,30 105 Refrigerante 1,00 Escrever um algoritmo que leia o cdigo do item pedido, a quantidade e calcule o valor a ser pago por aquele lanche. Considere que a cada execuo somente ser calculado um item. INICIO INTEIRO: CODIGO, UNIDADE; REAL: PREO; LEIA (CODIGO, UNIDADE); SE (CODIGO = 100) ENTO PREO UNIDADE * 1,10; SENO SE (CODIGO = 101) ENTO PREO UNIDADE * 1,30; SENO SE (CODIGO = 102) ENTO PREO UNIDADE * 1,50; SENO SE (CODIGO = 103) ENTO PREO UNIDADE * 1,10; SENO SE (CODIGO = 104) ENTO PREO UNIDADE * 1,30; SENO SE (CODIGO = 105) ENTO PREO UNIDADE * 1,00; SENO ESCREVA (CDIGO INVALIDO); FIM SE FIM SE FIM SE FIM SE FIM SE FIM SE FIM SE ESCREVA (PREO); FIM