Você está na página 1de 29

TUTORIAL PROTEUS

ISIS
Para a seleo dos componentes, deve-se selecionar a opo Component Mode, destacado
em vermelho no menu esquerda e apertar a tecla P, ou clicar no boto P destacado em
azul. A janela Pick Devices ser aberta como mostrado abaixo:

A escolha dos componentes poder ser feita atravs do menu esquerda da janela Pick
Devices atravs do menu Category ou poder ser feita diretamente escrevendo-se o nome
do componente atravs do campo de busca Keywords:

O primeiro componente a ser escolhido, normalmente o microcontrolador, pois as ligaes
sero feitas, em sua maioria, a partir deste.

Localizado o componente, basta clicar no boto OK ou dar um clique duplo no nome do
componente que o mesmo ir automaticamente para a lista DEVICES direita do menu
lateral esquerdo. Para levar o componente para o campo de construo do circuito, basta
clicar uma vez no nome do componente e clicar no campo de construo, onde pode-se
escolher a posio do componente.

Para fixar o componente no local escolhido, basta clicar no local desejado com o boto
esquerdo. Atravs do scrolI do mouse, pode-se ajustar o zoom de visualizao de acordo com a
necessidade do usurio.

Aps o microcontrolador, deve-se adicionar o circuito do cristal, constitudo por 2 capacitores
e o cristal, ligados ao microcontrolador com aterramento. Para colocar os capacitores e o
cristal no campo de construo do circuito, deve-se proceder da mesma forma com que foi
colocado o microcontrolador (atravs da tecla P):

Clicando com o boto direito sobre qualquer componente, o programa oferece um menu com
uma srie de opes, dentre as quais possibilita fazer alteraes com o componente, dentre as
quais destaca-se rotacionar, espelhar, movimentar, excluir, etc:


Colocado os componentes, h a necessidade de efetuar a ligao entre eles e o
microcontrolador. O modo de ligao das trilhas bem simples: basta clicar uma vez num
terminal do componente e levar a linha com o mouse at o terminal do outro componente,
terminando a ligao com outro clique.



O boto direito do mouse funciona como um boto de atalho de excluso. Clicando com esse
boto sobre qualquer componente ou trilha duas vezes, o componente automaticamente
excludo do campo de construo do circuito, porm continua permanecendo no menu
DEVICES para facilitar o seu reuso.
Com um clique duplo sobre qualquer componente, um menu Edit Component ir aparecer
oferecendo as opes de propriedades do componente, como o seu valor e denominao:

Terminals Mode
No menu lateral esquerda, encontra-se a opo Terminals Mode, onde esto localizados os
componentes de aterramento, energia, etc:

Selecionando a opo, GROUND, colocamos um ponto de aterramento, finalizando o circuito
de cristal, como mostrado abaixo:

Outra maneira de se efetuar a ligao entre os circuitos diversos e o microcontrolador
atravs do terminal OUTPUT. Atravs desse terminal, simplifica-se a visualizao das
ligaes, organizando o layout do circuito:

Para que as ligaes sejam devidamente efetuadas, deve-se nomear cada terminal OUTPUT
com seu correspondente no microcontrolador, atrves do clique duplo no componente onde
surgir a seguinte tela:

No campo String, escolhe-se uma denominao para a ligao, que dever ser a mesma para
o terminal do microcontrolador:

O circuito abaixo equivalente ligao mostrada anteriormente:

Com um clique duplo sobre o microcontrolador, um menu Edit Component ir aparecer com
opes de edio das propriedades do microcontrolador, dentre as quais se destaca o
Processor Clock Frequency, a qual dever ser ajustada de acordo com a frequncia do cristal:

No campo Program File, onde se seleciona o arquivo .hex no qual se encontra o cdigo
de programao do circuito. Deve-se clicar no boto circulado em vermelho e buscar o arquivo
.hex no diretrio onde o mesmo se encontra.

O software Proteus possui uma interface com o arquivo de programao. Devido a essa
interface, possvel realizar uma simulao do projeto a ser construdo a partir do ISIS, como
acender LEDs, acionar motores, etc:
Adicionado o arquivo com o cdigo de programao, basta apertar o boto Play circulado em
vermelho para iniciar a simulao. Abaixo segue um exemplo de simulao do acionamento de
2 motores atravs de 2 botes (circulados em azul), onde o status dos motores aparecem
numa tela de LCD (circulada em amarelo).



ARES
Depois de finalizada a construo e simulao do circuito, passamos para a parte fsica do
projeto da placa de circuito impresso. agora que a placa comea a tomar forma e passamos a
posicionar os componentes e as trilhas da maneira em que ficaro na placa.
Dado o exemplo de projeto abaixo, clicamos no cone do ARES circulado em vermelho:

O software ARES ir abrir automaticamente com a seguinte tela:

Selecionamos a opo DEFAUT para o nosso projeto.
Automaticamente, uma lista com todos os componentes utilizados no projeto do software
ISIS ir aparecer no menu COMPONENTS:

Primeiramente, iremos ao menu View e selecionaremos o grid mais adequado ao trabalho
selecionando as opes Snap. A princpio, a janela de edio estar configurada para
milsimos de polegada (th), mas podemos alterar a unidade para milmetros clicando no boto
circulado em vermelho. O grid representa o espaamento real de cada quadrado no compo de
edio do projeto. Ou seja, no caso da figura abaixo, onde est selecionado Snap 25th,
representa que o lado de cada quadrado representado na superfcie de edio corresponde a
25 milsimos de polegada [(25x2,54) / 1000].
A vantagem de se utilizar milsimos de polegada a preciso do espaamento.


Selecionado o grid, devemos demarcar os limites da placa de circuito impresso selecionando o
2D Graphics Box Mode no menu esquerda circulado em vermelho e por seguinte
selecionando o layer Board Edge no canto inferior esquerdo da tela:



Selecionando essa opo, traamos os limites da placa (quadrado amarelo):



O layer Board Edge utlizado para demarcar os limites da placa. Porm, podemos configurar
os layers de maneiras diferentes para outras funes selecionando o item no menu
esquerda, selecionando o layer escolha posteriormente.

Realizados esses procedimentos, podemos comear a posicionar os componentes no campo de
edio selecionando a opo Component Mode no menu esquerda, aparecendo a listagem
dos componentes.



O software ARES permite o posicionamento automtico dos componentes nos limites da placa
atravs da opo Auto Placer... disponvel no menu Tools:



Como se pode ver na figura abaixo, os componentes so posicionados automaticamente no
campo de edio. Porm, a posio imposta pelo software no a mais adequada para a
configurao da placa, mas pode ser um ponto de partida para quem est comeando a
trabalhar com o ARES.



Outra opo de posicionamento dos componentes o posicionamento manual, onde, um a
um, os componentes so posicionados dentro do limite da placa. Nesse caso, aconselha-se
sempre comear colocando o microcontrolador, seguido do circuito de cristal. O procedimento
para posicionar os componentes o mesmo do ISIS, selecionando o componente na lista
COMPONENTS e o alocando no campo de construo.



A linha amarela com a seta representa uma dica do ARES, mostrando o lugar mais adequado
para se posicionar o componente e as linhas verdes representam as ligaes que devem ser
feitas. Pela figura acima, percebemos que as linhas verdes esto cruzadas. Uma maneira de se
resolver esse incoveniente, nesse caso, clicando no componente com o boto direito do
mouse e rotacion-lo.



Nesse caso e em vrios casos de cruzamento de linhas, a rotao do componente faz com que
as linhas fiquem dispostas de uma maneira em que no fiquem cruzadas:



Feito isso, basta arrastar o componente para o lugar mais adequado para ser afetuada a
ligao:



Seguindo essas dicas, podemos posicionar todo o circuito de cristal para o lugar mais
adequado para se efetuar a ligao:


A inteno no posicionamento dos componentes ter o mnimo de conflitos de trilhas
possvel. Isso se consegue atravs do remanejamento dos componentes at que atinjam a
melhor posio segundo suas demandas de ligao. A dica para essa tarefa ser bem sucedida
comear pelos componentes que possuem mais terminais, pois esses geralmente possuem
mais ligaes e consequentemente apresentam maior propenso a trazer conflitos de trilhas
de ligao.

Normalmente o software tem quase todos os invlucros necessrios para a elaborao do
layout, mas s vezes, nos deparamos com componentes que foram lanados aps a aquisio
do software, como o caso do boto liga/desliga. Podemos ento criar este invlucro.
Clicando no boto P, vemos o componente e o desenho do encapsulamento da lista, que
vem com as medidas, segundo a figura abaixo:



Mas se o encapsulamento que se necessita no se encontra nestas bibliotecas, podemos criar
um novo, e para isto utilizamos duas barras de ferramentas, a 2D Graphics e Pad
Placement:



Como exemplo til, veremos como criar o Push Button:

Segundo as especificaes de medida dos botes vendidos, traaremos suas medidas para
depois ir posicionando seus terminais. Primeiramente, selecionamos a ferramenta Dimension
Mode, circulada em vermelho abaixo:



Depois, determinamos as menidas do boto a ser construdo:


Ento, utilizaremos as seguintes ferramentas circuladas em vermelho para sua construo:




Feita a estrutura do Push Button, devemos efetuar suas ligaes atravs da ferramenta Track
Mode circulada em vermelho:





Terminada a parte estrutural do boto, podemos remover as rguas de medio e
selecionamos toda a estrutura criada, clicando com o boto direito no conjunto selecionado:



No menu que ir aparecer, selecionamos a opo Make Package, como demonstrado acima.




Na tela que ir aparecer, configuramos o boto a ser criado:


Retornando ao ISIS, atravs da tecla P, procuramos pelo boto (button) e o colocaremos no
campo de construo. Repare que ao selecionar o Device button, no h invlucro encontrado
(Package Not Found).


Ento, colocaremos o componente button no campo de construo e abriremos seu menu
de opes clicando com o boto direito sobre ele, selecionando a opo Packaging Tool:



A seguinte janela ir se abrir e clicaremos em Add para adicionar o invlucro construdo:




Na janela Pick Packages que se abrir, procuraremos pelo nome ao qual configuramos o
invlucro criado (no caso o nome dado ao invlucro foi push button1):



Clicando duas vezes no device encontrado, abrir a seguinte janela:



Clicamos primeiramente no quadrado em vermelho e posteriormente no crculo vermelho
para identificar os pinos do invlucro criado. Da mesma maneira procedemos com o quadrado
e o crculo azul. Feito isso, basta apenas criar em Assign Package(s) e posteriormente em
Save Package(s) na janela que ir se abrir. Feito isso, temos o invlucro do Push Button
criado, podendo posicion-lo no ARES na posio que acharmos conveniente.




Aps posicionar e reposicionar os componentes, chegamos a um posicionamento que pode ou
no ser o ideal para se traar as trilhas de ligao. A linha que limita a placa pode ser
reajustada aps a alocao dos componentes:



Chega ento momento de traar as trilhas de ligao dos componentes. Essa ligao pode ser
feita de modo manual ou por roteamento automtico das trilhas.
Para circuitos mais simples, podem-se traar as trilhas manualmente. Mas para circuitos mais
complexos, que possuem maior nmero de componentes, fica mais fcil fazer o roteamento
automtico das trilhas para posteriores ajustes manuais.

Para se efetuar o roteamento automtico, selecionamos a opo Auto-router, circulada em
vermelho:



A janela abaixo ir aparecer, onde configuramos as opes de roteamento. Configuradas as
preferncias, basta clicar em Begin Routing que o software traa trilhas eltricas calculando
as melhores ligaes com o mnimo de conflitos entre as trilhas possvel.



Trilhas sendo calculadas:



Aps realizado o reteamento automtico, provavelmente ser encontrado algum conflito
entre as ligaes. Raramente conseguimos uma ligao perfeita na primeira tentativa. Ento,
realizado o roteamento, clicamos no boto Conectivity Rules Checker, ao lado do boto
Auto-router:



Esse boto nos mostra onde esto os erros no circuito:

Nesse caso, no foi efetuada uma ligao entre o pino 2 do BUTTON_ 1 e o pino 4 do BUTTON_
3. Em alguns casos conseguimos resolver esse conflito remanejando as trilhas ou remanejando
os componentes e roteando as trilhas novamente. Mas aproveitaremos esse caso para ver a
soluo desse conflito com a implantao de jumpers no circuito:
Primeiramente, selecionamos a ferramenta Round Through-hole Pad Mode circulada em
vermelho e colocamos uma ilha (destacadas em amarelo) prxima a cada terminal que no foi
afetuada a ligao.


Ligamos cada terminal em conflito a ilha colocada prxima. Ento, mudamos o layer para Top
Copper e efetuamos a ligao entre as ilhas colocadas:


Nos casos em que o jumper colocado, a trilha criada em vermelho no impressa na placa
no momento de sua confeco. Solda-se um fio de uma ilha outra para efetuar sua ligao.
Finalizadas as ligaes e livres de conflitos, deve-se por ltimo configurar o aterramento de
toda a placa. Basta ir no menu Tools e selecionar Power Plane Generator...:

Seleciona-se a opo marcada abaixo, escolhe-se o layer e s clicar em OK.

Se estiver livre de conflitos, o circuito est pronto para sair do projeto e ser impressa na placa
de fenoltio.
Para isso, vamos ao menu Output e selecionamos Print...

Na janela Print Layout, selecionamos apenas os layers Bottom para impresso das trilhas,
selecionando a opo Normal em Reflection:

Na mesma janela, selecionamos apenas os layers Top para impresso dos componentes,
selecionando a opo Mirrorl em Reflection:

Você também pode gostar