Você está na página 1de 1

algoritmo "semnome

"
// Função : Calcular e apresentar os n primeiros primos
// Data : 1/11/2011
// Seção de Declarações
var
n, num, cont, d, r: inteiro
inicio
escreva("Qtde de primos:")
leia(n)
cont <- 0
num <- 2
enquanto cont < n faca
d <- 2
enquanto d < num/2 faca
r <- num MOD d
se r = 0 entao
interrompa
fimse
d <- d + 1
fimenquanto
se d > num/2 entao
escreva(num)
cont <- cont + 1
fimse
num<- num + 1
fimenquanto
fimalgoritmo