Você está na página 1de 2

ATIVIDADE AVALIATIVA 3

FOLHA DE QUESTES

Disciplina: Algoritmo e Linguagem de Programao


Nome: Josiel Gomes dos Santos
Resoluo e Respostas

1. Analise os algoritmos abaixo e diga o que ser impresso na tela ao serem executados:
a) inteiro A, B;
Ser impresso:
40
20,15
b) inteiro X, Y, Z;
Ser impresso:
1
10, 11, 1

c) inteiro A, B;
Ser impresso:
120
140,130

2. Dado o algoritmo abaixo, faa um teste de mesa e complete o quadro a seguir para os
valores especificados:
Quadro para o teste de mesa:
VARIAVEIS
A

RESPOSTAS

16

150

460

-1

-3

-5

50

160

3. Na feira, uma banca est vendendo frutas com a seguinte tabela de preos:

var
Preco_Maca,Preco_Morango,Peso_Maca,Peso_Morango,Total_Morango,Total_Maca,Final:r
1

eal
inicio
Preco_Maca <- 2.5
Preco_Morango <- 8.9
escreval("Quantos Kilos de Morangos: ")
leia(Peso_Morango)
escreval("Quantos Kilos de Maca : ")
leia(Peso_Maca)
se (Peso_Morango > 5)entao
Total_Morango <- (Preco_Morango - 0.5) * Peso_Morango
senao
Total_Morango <- Preco_Morango * Peso_Morango
fimse
se (Peso_Maca > 5) entao
Total_Maca <- (Preco_Maca - 0.5) * Peso_Maca
senao
Total_Maca <- Preco_Maca * Peso_Maca
fimse
se((Total_Morango + Total_Maca > 25) ou (Peso_Morango + Peso_Maca > 8))entao
Final <- (Total_Morango + Total_Maca) * 0.9
seno
Final <- Total_Morango + Total_Maca
fimse
escreval("Preco Final da Compra : R$ ",Final)