Você está na página 1de 15

Pseudocdigo

1. Leer por pantalla 2 nmeros enteros y calcular la suma, resta y multiplicacin de los mismos.
Mostrar por pantalla los resultados.
Algoritmo Suma Resta y Multiplicacin
Entero: N1, N2, Sum, Res, Mult
Inicio
Escribir Digite dos nmeros
Leer N1, N2
Sum = N1+N2
Res = N1-N2
Mult = N1*N2

Escribir La suma es:, Sum


Escribir La resta es:, Res
Escribir La multiplicacin es:, Mult
Fin
2. Realice un algoritmo que lea por pantalla un nmero entero y calcule el cuadrado y el cubo de
mismo. Mostrar los resultados.
Algoritmo Cuadrado y cubo
Entero: N, Cua, Cub
Inicio
Escribir Digite nmero
Leer N
Cua = N*N
Cub = Cua*2
Escribir El cuadrado es:, Cua
Escribir El cubo es:, Cub
Fin
3. Realice un algoritmo que lea en pantalla la edad de un estudiante y se indique si es mayor o
menor de edad.
Algoritmo Mayor de edad
Entero: E
Inicio
Escribir Digite edad
Leer E
Si (E>=18) entonces
Escribir Es mayor de edad
Sino
Escribir Es menor de edad
Fin_si
Fin

4. Realice un algoritmo que calcule el precio total de un tiquete areo. El precio del tiquete es
igual a la distancia recorrida por 2.5. El cliente obtiene un descuento del 35% del valor del
tiquete siempre y cuando la distancia recorrida sea mayor a 800. Debe leer por pantalla la
distancia recorrida y mostrar el precio total del tiquete.
Algoritmo Precio de tiquete
Entero: D
Real: Pt
Inicio
Escribir Digite distancia
Leer D
Pt = D*2.5
Si (D>800) entonces

Pt = Pt*0.65
Fin_si
Escribir El precio a pagar es:, Pt
Fin
5. Leer por pantalla dos nmeros enteros e indicar cul es el mayor o si son iguales.
Algoritmo Mayor o iguales
Entero: N1, N2
Inicio
Escribir Digite dos nmeros
Leer N1, N2
Si (N1=N2) entonces
Escribir Son iguales
Sino
Si (N1>N2)
Escribir El mayor es:, N1
Sino
Escribir El mayor es, N2
Fin_si
Fin_si
Fin

6. Realice un algoritmo que lea por pantalla 3 nmeros enteros, diga si son iguales o cual es
mayor.
Algoritmo Mayor o iguales 2
Entero: N1, N2, N3
Inicio
Escribir Digite tres nmeros
Leer N1, N2, N3
Si (N1=N2) ^ (N2=N3) entonces
Escribir Son iguales
Sino
Si (N1>N2) ^ (N2>N3) entonces
Escribir El mayor es:, N1

Sino
Si (N2>N1) ^ (N2>N3) entonces
Escribir El mayor es:, N2
Sino
Escribir El mayor es:, N3
Fin_si
Fin_si
Fin_si
Fin

7. Leer por pantalla edad, genero (F o M) y semanas cotizadas para determinar si un empleado
tiene derecho a pensin.

Algoritmo Pensin
Entero: E, S
Cadena: G: M, F
Inicio

Genero

Edad

Semanas

65

1000

62

1000

Escribir Digite Edad


Leer E
Escribir Digite Genero
Leer G
Escribir Digite semanas cotizadas
Leer S
Si (G = M) entonces
Si (S>=1000) ^ (E>=65) entonces
Escribir Tiene derecho
Sino
Escribir No tiene derecho
Fin_si
Sino
Si (S>=1000) ^ (E>=62) entonces
Escribir Tiene derecho
Sino
Escribir No tiene derecho
Fin_si
Fin_si
Fin

8. Una empresa tiene 3 tipos de empleados. Realice un algoritmo que calcule su salario deacuerdo
al nmero de horas trabajadas durante el mes, teniendo en cuenta la siguiente informacin:

Algoritmo
Entero: S, H, Op
Inicio

Tipo de empleado

Valor Hora

Ingeniero

25000

Administrador

20000

Secretario

15000

Escribir Digite 1: Ingeniero, 2: Administrador, 3: Secretario


Leer Op
Escribir Digite Horas
Leer H
Segn_sea (Op) haga
Caso 1:
S = H*25000
Interrumpir
Caso 2:
S = H*20000
Interrumpir
Caso 3:
S = H*15000
Interrumpir
Caso default
Escribir Opcin errada
Fin_segun_sea
Escribir El salario a pagar es:, S
Fin
9. Realice un algoritmo que calcule la edad promedio de 500 estudiantes de una institucin.
Algoritmo Edades
Entero: E, Cont=0, Acum=0
Real=P
Inicio
Mientras_que (Cont<500) haga
Escribir Digite edad
Leer E
Acum=Acum+E
Cont++
Fin_MQ
P=Acum/500
Escribir El promedio es:, P
Fin
10. Realice un algoritmo que calcule el nmero de estudiantes que aprobaron y reprobaron el curso
de programacin. Debe leer por pantalla la nota de cada estudiante. El curso tiene 30
estudiantes.
Algoritmo Perdidos programacin
Entero: N, Cont=0, ContA=0, ContR=0
Inicio
Mientras_que (Cont<30) haga
Escribir Digite nota
Leer N
Si (N>=300) entonces
ContA++
Sino

ContR++
Fin_si
Escribir Aprobaron:, ContA
Escribir Reprobaron, ContR
Fin

11. En una Industria se fabrican planchas rectangulares que se venden en lotes de 10 planchas. Una
plancha se considera defectuosa si su superficie (ancho x largo) es inferior a 4mm, y se
considera buena si es igual o superior. Un lote se considera defectuoso si tiene una o ms
planchas defectuosas, y bueno si todas sus planchas son buenas. Se dispone de los datos sobre el
ancho y el largo de 500 planchas correspondientes a 500 lotes. Escribir un programa que lea
dichos datos /(ancho y largo de las planchas) y escriba el nmero de lotes buenos, y la
superficie media de todas las planchas de las buenas. Ntese que no se pide superficie media de
todas las planchas buenas. El programa debe disearse de modo que cuando se detecte que una
plancha de un lote es defectuosa, no siga pidiendo los datos de las restantes planchas del mismo
lote.
Algoritmo Planchas
Entero: Cont1=0 Cont2=0, AS=0, AT=0, ContL=0 ContPB=0, P, A, L, S

Real: Prom
Inicio
Mientras_que (ConL<50) haga
Mientras_que (Con2<10) haga
Leer A, L
S = A*L
Si (S>=4) entonces
AS = AS+S
ContPB++
Cont2++
Sino
Cont2=10
Fin_si
Fin_MQ
Si (ContPB=10) entonces
AT =AT+AS
ContL++
Fin_si
Cont2=0, AS=0, ContPB=0
Cont1++
Fin_MQ
P = ContL*10
Prom = AT/P
Escribir La cantidad de lotes nuenos es:, ContL
Escribir El promedio de superficie es:, Prom
Fin

12. Se desea realizar una estadstica de los pesos de los estudiantes de una institucin educativa, la
cual cuenta con 500 estudiantes. Debe leer por pantalla el peso del estudiante y calcular la
cantidad de estudiantes y el promedio de los pesos segn su clasificacin.
Clasificacin:
A: Menos de 40kg
B: Entre 40 y 50kg
C: Entre 51 y 70kg
D: Mayor a 70kg
Algoritmo Peso
Entero: P, A, B, C, D, E, ContE=0, ContA=0, ContB=0, ContC=0, ContD=0
Real: PromA=0, PromB=0, PromC=0, PromD=0
Inicio

Mientras_que (ContE<500) haga


Escribir Digite peso
Leer P
Si (P<40) entonces
A = A+P
ContA++
Sino
Si (P>=40) ^ (P<=50) entonces
B = B+P
ContB++
Sino
Si (P>=51) ^ (P<=70) entonces
C = C+P
ContC++
Sino
Si (P>70) Entonces
D = D+P
ContD++
Fin_si
Fin_si
Fin_si
Fin_si
Fin_MQ
PromA = A/500
PromB = B/500
PromC = C/500
PromD = D/500
Escribir Estudiantes del grupo A:, A
Escribir El promedio de peso del grupo A:, PromA
Escribir Estudiantes del grupo B:, B
Escribir El promedio de peso del grupo B:, PromB
Escribir Estudiantes del grupo C:, C
Escribir El promedio de peso del grupo C:, PromC
Escribir Estudiantes del grupo D:, D
Escribir El promedio de peso del grupo D:, PromD
Fin

Vectores
1. Realice un algoritmo que almacene en un vector 500 edades y calcule el promedio.
Algoritmo Edades
Entero: E, V[500], i, Acum=0
Real: P
Inicio
Para (i=0; i<500; i++) haga
Leer E
V[ i ]=E
Fin_para
Para (i=0; i<500; i++) haga

Acum = Acum+ V[ i ]
Fin_para
P = Acum/500
Escribir El promedio es:, P
Fin
2. Realice un algoritmo que almacene 500 edades en dos vectores. Un vector de pares y un vector
de impares y calcular el promedio de edad de cada uno.
Algoritmo Edades 2
Entero: E, i, i1=0, i2=0, AcumI=0, AcumP=0, VP[500], VI[500], TP=i1+1, TI=i2+2
Real: P1, P2
Inicio
Para (i=0; i<500; i++) haga
Leer E
Si (E mod 2=0) entonces
VP[i1]=E
i1++
Sino
VI[i2]=E
i2++
Fin_si
Fin_para
Para (i=0; i<500; i++) haga
AcumP = AcumP+ VP[i]
Fin_para
Para (i=0; i<500; i++) haga
AcumI = AcumI+ VI[i]
Fin_para
P1 = AcumP/TP
P2 = AcumI/TI
Fin

3. Almacenar en un vector las edades de 500 estudiantes. Calcular cuntos son mayores y menores
de edad.
Algoritmo Edades 3
Entero: E, V[500], ContM=0, Contm=0
Inicio
Para (i=0; i<500; i++) haga
Leer E
V[ i ]=E
Fin_para
Para (i=0; i<500; i++) haga
Si (V[ i ]>=18) entonces
ContM++

Sino
Contm++
Fin_si
Fin_para
Escribir Mayores:, ContM
Escribir Menores:, Contm
Fin
4. Almacenar en un vector las notas de los estudiantes de programacin del segundo seguimiento y
calcular el nmero de estudiantes que aprobaron y reprobaron. (30 estudiantes).
Algoritmo Notas
Entero: N, V[30], Conta=0, ContR=0
Inicio
Para (i=0; i<30; i++) haga
Leer N
V[ i ]=N
Fin_para
Para (i=0; i<30; i++) haga
Si (V[ i ]>=90) entonces
ContA++
Sino
ContR++
Fin_si
Fin_para
Escribir Aprobaron:, ContA
Escribir Reprobaron:, ContR
Fin

5. Almacenar en un vector 100 nmeros donde los pares se almacenen en las


posiciones pares y los impares en las posiciones impares.
Algoritmo Nmeros pares e impares
Entero: N, V[200], i1=0, i2=0
Inicio
Para (i=0; i<100; i++) haga
Leer N
Si (N mod 2=0) entonces
V[i1]=N
i1 = i1+2
Sino
V[i1]=N

i2 = i2+2
Fin_si
Fin_para
Fin
6. Almacenar en dos vectores A y B 45 nmeros enteros en cada uno. Almacenar
en un tercer vector C el resultado de sumar el primer elemento del vector A
con el primer elemento del vector B y as sucesivamente hasta terminar los 45
elementos.
Algoritmo Nmeros enteros
Entero: N1, N2, A[45], B[45], C[45]
Inicio
Para (i=0; i<45; i++) haga
Leer N
A[ i ]=N1
B[ i ]=N2
Fin_para
Para (i=0; i<45; i++) haga
C[ i ]= A[ i ]+B[ i ]
Fin_para
Para (i=0; i<45; i++) haga
Escribir C[ i ]
Fin

7. Almacenar 300 nmeros en un vector, y calcular cuntos son: ceros, negativos,


y positivos. Calcular la suma de los negativos y la suma de los positivos.
Algoritmo
Entero:
Inicio
Para

8. Almacenar 100 nmeros en un vector de forma invertida.


Algoritmo Inverso
Entero: V[100], N
Inicio
Para (i=99; i>=0; i- -) haga
Leer N
V[ i ]=N
Fin_para
Fin
9. Almacenar 150 nmeros en un vector A, luego deber almacenarlos en un
vector B en orden inverso al vector A.

Algoritmo Vector inverso


Entero: A[150], B[150], C[150], N, i, j
Inicio
Para (i=0; i<150; i++) haga
Leer N
A[ i ]=N
Fin_para
i=0
Para (j=149; j>=0; j- -) haga
B[ j ]=A[ i ]
i++
Fin_para
Fin
10.
Almacenar 100 nmeros en un vector y determinar cul es el mayor
elemento.
Algoritmo Mayor elemento
Entero: N, V[100]
Inicio
Para (i=0; i<150; i++) haga
Leer N
V[ i ]=N
Fin_para
May= V[ 0 ]
Para (i=0; i<150; i++) haga
Si (V[ i ]>May) entonces
May= V[ i ]
Fin_si
Fin_para
Escribir El mayor es:, May
Fin

11.
Almacenar en un vector las notas de los estudiantes del curso de
programacin y Calcular el nmero de estudiantes de aprobaron y reprobaron.
El curso tiene 30 estudiantes.
Algoritmo Notas
Entero: N, i, V[30], ContA=0, ContR=0
Inicio
Para (i=0; i<30; i++) haga
Leer N
V[ i ]=N
Fin_para
Para (i=0; i<30; i++) haga

Si (V[ i ]>=300) entonces


ContA++
Sino
ContR++
Fin_para
Escribir Aprobaron:, ContA
Escribir Reprobaron:, ContR
Fin
12.
Almacenar las ventas de una empresa en un vector durante sus primeros
5 aos y Calcular las ventas totales de cada ao. Nota: Las ventas se
almacenan mensualmente en el vector.

Algoritmo Ventas
Entero: A=0, Cont=1
Inicio
Para (i=0; i<60; i++) haga
A=A+ V[ i ]
Si (Cont=12) entonces
Escribir A
A=0
Cont=0
Fin_si
Fin_para
Fin