Você está na página 1de 124

Acknowledgements

Special thanks to:

Dean, School of Mechanical and Aerospace Engineering, USM


Assoc. Prof. Dr. Zaidi Mohd Ripin.

USAINS Holding Sdn. Bhd.

Unit Latihan, USM

Secretariat committee;
Mr. Mohamad Ikhwan Zaini Ridzwan,
Dr. Mohd Salman Abu Mansor,
Mr. Wan Amri Wan Mamat Ali,
Mr. Norijas Abd Aziz,
Mr. Hishammudin Endan
Ms. Rosmawati Mohamath
Ms. Siti Farah Aida Zolhani

Staffs, School of Mechanical and Aerospace Engineering, USM


Prof. Ahmad Yusoff Hassan
Mr. Ahmad Khaizi Mahidin
Ms. Sharmila Azlin Ramly
Ms. Nor Zainah Bahari
Ms. Juhana Ahmad Ariff
Mr. Jamari Sadli
Mr. Hasrie Mohd Hashim

Coordinator,
Mr. Mohamad Ikhwan Zaini Ridzwan

i
Contents
Day One – 29 April 2008
Module 1: Introduction to SolidWorks and Basic Sketching..................................... 1
Introduction to SolidWorks........................................................................................1
SolidWorks user interface & Toolbar menus .......................................................2
FeatureManager Design Tree ...............................................................................4
Keyboard shortcuts and mouse buttons..............................................................5
Tools-Options .........................................................................................................6
Basic 2D sketching....................................................................................................9
Sketch Entities/Geometry.................................................................................. 10
Status of a sketch............................................................................................... 11
Sketch Relations................................................................................................. 12
Tutorial 1.1: Sketch a Simple Nut with Circle and Polygon ............................. 20
Tutorial 1.2: Using 3D sketch ............................................................................ 21
Tutorial 1.3: Apply Add Relations between Sketch Entities ………………………. 22
Exercise 1.1: Sketching Horizontal and Vertical Lines..................................... 23
Exercise 1.2: Sketching Lines............................................................................ 23
Exercise 1.3: Sketching using Rectangle and Circle........................................ 24
Exercise 1.4: Sketching a Chair Frame using 3D sketch................................. 24

Module 2: Additional Sketching ............................................................................... 25


Tutorial 2.1: Creating a Flat Bar ............................................................................ 26
Tutorial 2.2.............................................................................................................. 31
Tutorial 2.3.............................................................................................................. 33
Exercise 2.1 ........................................................................................................ 35
Exercise 2.2 ........................................................................................................ 36

Module 3: Basic Part Modeling ................................................................................ 37


Sketching and Creating Bosses............................................................................. 38
Creating a Counterbore Hole ............................................................................. 41
Cut Feature ......................................................................................................... 43
Filleting................................................................................................................ 46
Chamfering.......................................................................................................... 47
Define Material and Mass Properties ............................................................... 48
Editing features .................................................................................................. 49
Exercise 3.1: Glass Plate ....................................................................................... 51
Exercise 3.2: Bracket ............................................................................................. 51
Exercise 3.3 ............................................................................................................ 52
Exercise 3.4: Gland ................................................................................................ 52
Exercise 3.5: PVC Tee Pipe .................................................................................... 54

Day Two – 30 April 2008


Module 4: Additional Part Modeling......................................................................... 55
Revolved features................................................................................................... 56
Tutorial 4.1.......................................................................................................... 57
Patterning................................................................................................................ 62

ii
Tutorial 4.2: Vary Sketch option ........................................................................ 63
Exercises 4.1: Curve Driven Pattern.................................................................. 64
Swept....................................................................................................................... 65
Tutorial 4.3: Creating a Worm Gear .................................................................. 66
Tutorial 4.4: Creating a Spring........................................................................... 67
Tutorial 4.5: Creating a Bottle (with a guide curve).......................................... 68
Lofted ...................................................................................................................... 69
Tutorial 4.6: Create lofted part with Centerline Parameters ........................... 70
Exercises 4.2: Chisel .......................................................................................... 72
Rib and Shell........................................................................................................... 76
Tutorial 4.7: Using Shell to create wall thickness inside the Bottle................ 77

Module 5: Assembly Modeling ................................................................................. 78


Assembly toolbars .................................................................................................. 81
Basic assembly mates ........................................................................................... 81
Sliding Brace Assembly .......................................................................................... 82
Exploding and collapsing the assembly ................................................................ 93
Creating an explode line sketch ............................................................................ 94

Module 6: Drawing.................................................................................................... 96
Drawing toolbars..................................................................................................... 97
Insert standard drawing views - Angle of projections........................................... 97
Insert Component into Drawing............................................................................. 98
Adding dimensions to drawing and modifying dimensions ............................... 100
Create Section View.............................................................................................. 101
Insert a Note ......................................................................................................... 105
Edit Sheet Format................................................................................................. 106
Assembly Drawing ................................................................................................ 112
Elements of an Assembly Drawing ...................................................................... 112
Example of Assembly Drawing............................................................................. 112
Opening drawing template and edit Sheet Format ............................................ 113
Adding the Exploded View.................................................................................... 114
Creating Bill of Materials (BOMs) ........................................................................ 115
Customizing BOMs ............................................................................................... 116
AutoBalloons......................................................................................................... 116
Producing an e-drawing file ................................................................................. 118
Exercises 6.1:.................................................................................................... 119

References ..............................................................................................................120

iii
SolidWorks Training (Basic)

Module 1: Introduction to SolidWorks and Basic


Sketching (1 hour 50 minutes)
Introduction to SolidWorks (20 minutes)
SolidWorks is a mechanical design software package to build parts, assemblies,
and drawings, which take advantage of the Microsoft Windows graphical user
interface.

In SolidWorks, a part, an assembly, and a drawing are all fully associated. Changes
to the model are automatically reflected in the associated drawings and
assemblies. Likewise, when you make change to the drawing and assembly, those
changes will be reflected back to the model.

Starting a SolidWorks

1
SolidWorks Training (Basic)

SolidWorks user interface & Toolbar menus

The interface is native Windows interface, and such behaves in the same manner
as other Windows applications.

Main Menu Standard Views


Standard Toolbar
Toolbar
View Toolbar

CommandManager

FeatureManager Status Toolbar


Design Tree

Menus

• It provides access to all commands that the SolidWorks offers.


• When a menu item has a right pointing arrow, it means there is a sub-menu
associated with the choice,

• When a menu item is followed by a series of dots, it means that option opens a
dialog box with additional choices or information.

2
SolidWorks Training (Basic)

Toolbars menus

• Provide shortcuts enabling to quickly access the most frequently used


commands.
• They are organized according to function and can be customized, removed and
rearranged according to your preferences.

Example of a Toolbar

Standard toolbar as shown below contains commonly used function as opening


new or existing documents, saving documents, printing, copying and pasting
objects, undo, redo, and help.

You can turn toolbars on and off using one of three methods.

1. Click Tools – Customize. On the


Toolbars page, click the check boxes
to select each toolbar you want to
display. Clear the check boxes of the
toolbars you want to hide.

2. Right click on toolbar area of the SolidWorks


window. Check marks indicate which toolbars are
currently visible. Clear the check marks of the
toolbar you want to hide.

3. Clicking View – Toolbars displays the same list of toolbars.

3
SolidWorks Training (Basic)

FeatureManager Design Tree

• It is located on the left side of the SolidWorks Graphic window.


• It displays the details chronological sequence on how all the parts, assembly
and drawing are created.
• It allows access to do editing of the models.
• It consists of three default tabs:
o FeatureManager design tree
o PropertyManager
o ConfigurationManager

The FeatureManager design tree makes it easy to:

• Select items in the model by name.


• Identify and change the order in which features are created. You can drag
items in the FeatureManager design tree list to reorder them. This changes the
order in which features are regenerated when the model is rebuilt.
• Display the dimensions of a feature by double-clicking the feature’s name.
• Rename items by slowly clicking two times on a name to select it and then
entering a new name.
• Suppress and Unsuppress part features and assembly components.

The PropertyManager appears on the PropertyManager tab in the panel to the left
of the graphics area. It opens when you select entities or commands defined in the
PropertyManager.

OK. Accept the selections, Title bar


execute the command, and Help. Open the
close the PropertyManager. corresponding help topic.

Cancel. Ignore any


Preview. Display a
selections and close the
preview of the feature.
PropertyManager.

The ConfigurationManager on the left side of the SolidWorks window is a means to


create, select, and view multiple configurations of parts and assemblies in a
document. The icons in the ConfigurationManager denote how the configuration
was created:

Manually
With a design table
Manually, and has an explode state
With a design table, and has explode state
4
SolidWorks Training (Basic)

Keyboard shortcuts and mouse buttons

Keyboard shortcuts

Some menu items indicate a


keyboard shortcut such as:

Ctrl+O for File, Open


Ctrl+S for File, Save
Ctrl+Z for Undo
And many more

You can customize SolidWorks by


creating your own shortcuts.
Click Tools – Customize.
Find Keyboard tab as in figure
shown.

Three mouse buttons

• Left – to select objects as geometry, menus buttons, and objects in the


FeatureManager design tree. To select multiple items, you must hold down
the Control (Ctrl) key. To deselect object, simply click anywhere in a blank
(empty) portion of the work area.

• Right – activates a context sensitive shortcut menu. The contents of the


menu is differ depending on what object the cursor is over.

• Middle – use for dynamically rotating, panning, zooming a part or assembly.

o Rotate part or assembly – Holding down the middle button and drag
the mouse
o Zoom all document types – Hold down the Shift key while
depressing the middle button and moving the mouse.
(Simply rotates the wheel of the middle mouse button for zooming in
or out if your middle mouse button is a wheel.)
o Pan all document types – Hold down the Ctrl key while depressing
the middle button and drag the mouse.

5
SolidWorks Training (Basic)

Tools-Options

The Options dialog box able you to customize the SolidWorks software based on
your preferences.

Level of customization:

• System Options

Every option under System Options will affect every document you open in
SolidWorks session. For example, the viewport background, if you set the color to
Black, it will remain as black every time you open the SolidWorks window until you
change to another color.

Example: Set Viewport Background to White

6
SolidWorks Training (Basic)

• Document Properties

This setting only applied to individual documents. For example, units, drafting
standard, material properties, image quality etc. They are saved with the
document and do not change.

Example: Setting Units

Tools Æ Options Æ Document Properties Æ Units Æ MMGS (millimeter, gram,


second)

Example: To increase the quality of image

7
SolidWorks Training (Basic)

Example: Set Dimensioning Standard

8
SolidWorks Training (Basic)

Basic 2D sketching (1 hour 30 minutes)


Sketching is the act of creating 2-dimensional profile comprised of wireframe
geometry. Sketches are used for all sketched feature in SolidWorks including:
• Extrusions • Revolves
• Sweeps • Lofts

Process of completing the sketches

Starting a New part


(It can be created in inch, millimeter or other units)

Sketches
(Collections of 2D geometry that are used to create solid features)

Sketch Entities/Geometry
(Types of 2D geometry such as lines, circles and rectangles that make up the
sketch)

Sketch Relations
(Geometric relationships such as horizontal and vertical are applied to the sketch
entities. The relations restrict the movement of the entities)

State of the sketch


(Each sketch has a status that determines whether it is ready to be used or not.
The state can fully-, under- or over defined)

Sketch tools
(Tools can be used to modify the sketch geometry that has been created/ this
often involves the trimming or extension of the entities)

Extruding the sketch


(Extruding uses the 2D sketch to create a 3D solid feature)

9
SolidWorks Training (Basic)

Sketch Entities/Geometry

SolidWorks offers a rich variety of sketch tools for creating profile geometry.

Sketch entity Toolbar button Geometry example

Line

Circle

Centerpoint Arc

3 Point Arc

Tangent Arc

Ellipse

Partial Ellipse

Parabola

Spline

Polygon

Rectangle

Parallelogram

Point

Centerline

10
SolidWorks Training (Basic)

Status of a sketch

The most common color codes are:

No. Color Diagnostic Case

Under constrained

1. Blue (this is usually


appears when first
drawn)

Fully constrained

(when more
constraints and
2. Black dimensions are
added to the sketch
– the sketch
become completely
defined)

Over constrained

(adding any
3. Red dimension to fully
defined would
serve to overdefine
the sketch)

Only case 1 and 2 are allowable. For case 3, you must fix the error as soon as
possible before quitting the sketch mode otherwise a warning message will pop-
out and it will create more problems for yourself.

11
SolidWorks Training (Basic)

Sketch Relations

The following table describes the entities that you can select for a relation and the
characteristics of the resulting relation.

Relation Entities to select Resulting relations


Horizontal or One or more lines or The lines become horizontal or
Vertical two or more points. vertical (as defined by the current
sketch space). Points are aligned
horizontally or vertically.
Collinear Two or more lines. The items lie on the same infinite
line.
Coradial Two or more arcs. The items share the same centerpoint
and radius.
Perpendicular Two lines. The two items are perpendicular to
each other.
Parallel Two or more lines. The items are parallel to each other.

A line and a plane (or The line is parallel to the selected


a planar face) in a 3D plane.
sketch.
Tangent An arc, ellipse, or The two items remain tangent.
spline, and a line or
arc.
Concentric Two or more arcs, or a The arcs share the same centerpoint.
point and an arc.
Midpoint Two lines or a point The point remains at the midpoint of
and a line. the line.
Intersection Two lines and one The point remains at the intersection
point. of the lines.
Coincident A point and a line, arc, The point lies on the line, arc, or
or ellipse. ellipse.
Equal Two or more lines or The line lengths or radii remain equal.
two or more arcs.
Symmetric A centerline and two The items remain equidistant from
points, lines, arcs, or the centerline, on a line perpendicular
ellipses. to the centerline.
Fix Any entity. The entity’s size and location are
fixed. However, the end points of a
fixed line are free to move along the
infinite line that underlies it. Also, the
endpoints of an arc or elliptical
segment are free to move along the
underlying full circle or ellipse.
Merge Points Two sketch points or The two points are merged into a
endpoints. single point.

12
SolidWorks Training (Basic)

A line may be constrained vertically or horizontally. Once the line is drawn


horizontally, it will remain horizontal unless the relation is removed. The line can be
repositioned and resized but must remain horizontal.

For an instance:

The line is in Horizontal The line is in vertical


The lines are in horizontal
and have equal length
Where to find it

• Select the sketch entity or entities, and select


the appropriate relation from the Add Relations
section of the PropertyManager

• Or, right click the entity or entities, and select Add Relation from the short-cut
menu
• Or, click Tools, Relations, Add…
• Or, on the Sketch toolbar click Add Relation

You can view all relations in your sketches by select View – Sketch Relations

13
SolidWorks Training (Basic)

What are we going to sketch? How to start?

1. Open SolidWorks 2007.


2. Select New from the File menu, or click on the New
icon on the Standard toolbar.
3. Select the type of new file (Part, Assembly, or
Drawing) from the New SolidWorks Document
window.

4. Click OK.

5. Open a new Sketch.

Open the sketch by either clicking

or choosing Sketch from the Insert


menu.

This will show all three default planes for


selection in a trimetric orientation.

From the screen, choose the Front Plane.


The plane will highlight and rotate.

6. Sketch active.

The selected Front Plane


rotates so it is parallel to the Plane can be resized by
screen. dragging these handles

The Origin Point

14
SolidWorks Training (Basic)

7. Sketch lines

Click the Line tool

1 2

3 4

5 6

8. Saving your Work.

It is a good habit to save your work right way. Always


bear in mind to save regularly and often.
Select Save from the File menu, or click Save icon
on the Standard toolbar.

15
SolidWorks Training (Basic)

9. Linear dimensions.

Add additional linear dimensions to the sketch as shown.

Where to find it?

• Tools menu, select Dimensions,


Smart
• Or Right click, select Smart
Dimension
• Or Dimensions/Relations toolbar,
pick Smart Dimension tool,

10. Angular dimension.

Using the dimension tool, create the angular dimension shown and set the value to
125°.

16
SolidWorks Training (Basic)

11. Fillets.

Click Sketch Fillet

and set the Radius to 10 mm. Select all of the


endpoints in the sketch.

Click OK.

Sketch Fillets are used to


round off sharp corners in a
sketch.

Where to find it?


• Tools menu, select
Sketch Tools, Fillet.
• Or Sketch toolbar, click
Sketch Fillet

12. Extrude menu.

Click Insert, Boss/Base, Extrude or the tool on the Features toolbar


to access the command

The depth is 10 mm.

17
SolidWorks Training (Basic)

13. Edit the sketch

Right click on Extrude, and select Edit Sketch

a. Change the value of angular dimension

Double click on 125° and modify to 110°. You’ll see that other dimensions remain
unchanged.

18
SolidWorks Training (Basic)

b. Length of the base

Double click on 100 mm and modify to 90 mm

Click here to Exit Sketch and update your part.

Modified part

19
SolidWorks Training (Basic)

Tutorial 1.1: Sketch a Simple Nut with Circle and Polygon

1. Create a New part in SolidWorks.


2. Right click Top Plane from the FeatureManager design tree. This will be a
Sketch plane.
3. Click Sketch from the toolbar.

4. Click Circle from the Sketch toolbar. Sketch a circle centered at the
origin. Give dimension as illustrated.

5. Click Tools – Sketch Entities – Polygon from the Menu bar. Sketch a Polygon
centered to the origin larger than the circle.

6. Extrude to 8 mm depth.

We can create equilateral


polygons with any number of
sides from 3 to 40.

Parameters
This box allows you to define the
number of sides. Other
parameters will automatically
update when this parameter is
modified.

Circumscribed circle Inscribed circle

20
SolidWorks Training (Basic)

Tutorial 1.2: Using 3D sketch

1 Select 3D sketch and start 2 You can change the plane


sketching sketch by pressing the Tab key

3
4

5 6

Sweep function. You will learn this


Apply Fillet with the radius is 10 mm through Module 4

21
SolidWorks Training (Basic)

Tutorial 1.3: Sketch part using Lines, 3 Point Arc, Tangent Arc and apply Add Relations between Sketch Entities

1 2 3 4

Select these two arcs to


make tangent

5 6 7 8

Select Tangent as Symbol of tangent as Add dimensions as Extrude to 80 mm depth


relations relations between these illustrated
two arcs
22
SolidWorks Training (Basic)

Exercise 1.1: Sketching Horizontal and Vertical Lines (15 minutes)


Create this sketch on the Front Plane
using lines, automatic relations and
dimensions. Fully define the sketch.

Extrude the sketch 30 mm in depth.

Save and close the part.

Exercise 1.2: Sketching Lines (5 minutes)


Create this sketch on the Front
Plane using lines, automatic
relations and dimensions.

Extrude the sketch 30 mm in


depth.

Save and close the part.

23
SolidWorks Training (Basic)

Exercise 1.3: Sketching using Rectangle and Circle (5 minutes)


Create this sketch on the Front Plane using rectangle and circle, automatic relations
and dimensions.

Exercise 1.4: Sketching a Chair Frame using 3D sketch (5 minutes)

Create this sketch using 3D sketch (free dimension)

The completed figure used Swept feature


that you will learn in Module 4

24
SolidWorks Training (Basic)

Module 2: Additional Sketching (2 hours)


This module is an extension of the previous module. Here, you will learn more
about Sketch toolbar, Sketch Relations, Dimensions and edit the sketch.

On the completion of this module, you will be able to:

• Apply other Sketch Entities:


o Rectangle
o Centerline
o Ellipse

• Understand and utilize the available tools from the Sketch toolbar to create
and modify the sketch:
o Trim – able to trim the selected entities,
o Linear Pattern – able to create a linear pattern along one or both
axes,
o Mirror – able to mirror existing sketch entities,
o Offset – able to offset one or more sketch entities, and selected
model edges by a specified distance,
o Circular Pattern – able to create a circular pattern along one or both
axes

• Apply Sketch Relations between sketch entities


o Midpoint
o Horizontal
o Coincident
o Tangent

• Edit the sketch


o Edit Linear Pattern
o Change the sketch plane

25
SolidWorks Training (Basic)

Tutorial 2.1: Creating a Flat Bar (20 minutes)


1. Open a New sketch and Save As Flat Bar
2. Click Sketch from the toolbar.
3. Select the Front Plane.

4. Click Rectangle from the Sketch toolbar.

5. Click Centerline from the Sketch


toolbar.

6. Select both Centerline and Origin Point (press Ctrl key while selecting) and
choose Midpoint as their relations.

26
SolidWorks Training (Basic)

7. Click Trim Entities from the Sketch toolbar

8. Select Trim to closest from the Trim Options

9. Select the right and left vertical lines to remove.

10. Click Tangent Arc from the Sketch toolbar.

11. Give dimension to the bar.

27
SolidWorks Training (Basic)

12. Click Circle from the Sketch toolbar with the diameter is 20 mm at the

left end of the bar.

13. Click Linear Pattern from Tools – Sketch Tools drop down
menus.

14. Extrude the bar to 10 mm depth.

28
SolidWorks Training (Basic)

15. Save the part.

16. Editing

a. Reduce the number of holes to 5

i. Right click on Extrude and


select Edit Sketch
ii. Select one of the Circle and
right click and choose Edit
Linear Pattern

iii. Change the number of holes from 9


to 5 and the distance between
each holes to 50 mm

iv. Select OK and Exit Sketch.

29
SolidWorks Training (Basic)

b. Change the Sketch Plane

i. Expand the Extrude. Right click on


Sketch and select Edit Sketch
Plane.

ii. You will see shows the Front


Plane, which denotes your
previous sketch plane.

iii. Expand this button

iv. Select Top Plane.

v. Click OK and you will see that the sketch plane is now changed to Top Plane.

30
SolidWorks Training (Basic)

Tutorial 2.2: (20 minutes)


1. Open a new sketch.
2. Click Sketch from the toolbar.
3. Select the Front Plane.
4. Sketch horizontal and vertical Centerlines.
5. Sketch two Circles with different diameters as shown in figure below.
Connect these circles with 3 Point Arc.

6. We can see all relations between the sketch entities.

Tangent between arc and circle

Coincident
Horizontal

31
SolidWorks Training (Basic)

7. Trim the sketch as shown in figure below.

8. Select Mirror from the sketch toolbar and mirror the entity with respect to the
vertical Centerline.

9. Next, Mirror with the horizontal Centerline.


10. Select Ellipse from the sketch toolbar and complete all dimensions as shown
in figure below.

32
SolidWorks Training (Basic)

11. Extrude to 10 mm depth and save the part.

Tutorial 2.3: (15 minutes)


1. Open a new sketch.
2. Click Sketch from the toolbar.
3. Select the Front Plane.
4. Create a Circle with 50 mm in diameter.

5. Create another Circle by using Offset

6. Type 7 mm as distance parameter outside


the first Circle.

33
SolidWorks Training (Basic)

7. Sketch one Line which 6.15 mm from the vertical Centerline and Mirror
about the Centerline. Then Trim the lines carefully until you get as similar as
in figure below. If you pick a wrong line, you may Undo the step.

Trimming

8. Select Tools – Sketch Tools – Circular Pattern .


9. Select the lines and insert 8 as your number of pattern instances.

10. Trim the lines

11. Extrude to 10 mm and save your part.

34
SolidWorks Training (Basic)

Exercise 2.1: (20 minutes)

(a)

(b) Special cam (Unit is in inch)

35
SolidWorks Training (Basic)

(c) Shift Lever

Exercise 2.2: Create a solid model of this 2 mm thick steel bicycle disk rotor.
(25 minutes)

36
SolidWorks Training (Basic)

Module 3: Basic Part Modeling (2 hours)


This module provides an understanding of creating Extruded, Fillet, Chamfer,
Simple Hole and Hole Wizard features.

These are the samples of Features toolbar:

Boss/Base and Cut

Features

Pattern/mirror

Some of the icons (which are not circled) will be seen during Module 4 – Additional
Part Modeling.

On the completion of this module, you will be able to:

1. Sketch at any planes,


2. Utilize extruded boss and extruded cut,
3. Create fillet and chamfer at the selected edges,
4. Create standard holes by applying the Hole Wizard,
5. Find the mass of your part and
6. Edit or manipulate features geometry to reduce or increase the mass
properties of the component.

37
SolidWorks Training (Basic)

Sketching and Creating Bosses (45 minutes)

1. Open a new sketch.


2. Click Sketch from the toolbar.
3. Select the Top Plane.

4. Sketch as shown in figure below. Add dimensions to the sketch.


Equal length

Coincident with the origin


5. Extrude 10 mm upwards.

38
SolidWorks Training (Basic)

6. lnsert new sketch.

Create a new sketch using Insert, Sketch or by clicking the Sketch tool.

Select this side/plane

7. Sketch as shown in figure below.

Coincident with the origin

39
SolidWorks Training (Basic)

8. Add dimensions.

9. Extrude to 10 mm depth and in reverse direction.

40
SolidWorks Training (Basic)

Creating a Counterbore Hole

10. Hole position.

Select the face indicated and Insert – Features – Hole – Wizard…

Select this face

41
SolidWorks Training (Basic)

11. Choose Counterbore.

Set the properties of the hole as follows:

Standard: Ansi Metric


Screw Type: Hex Bolt – ANSI B18.2.3.5
Size: M8
Fit: Normal
End Condition: Through All

12. Turn to Hole Position.

13. Drop the point onto the center point.

42
SolidWorks Training (Basic)

14. Completed Hole.

Click Finish to complete the hole feature.

Cut Feature

15. Press the spacebar and double-click *Front.

Start a sketch on this large face and add a rectangle Coincident


with the bottom model edge.

16. Select the left vertical sketch line and


the vertical model edge.

Add a Colinear relation between them.


(Hold down the Ctrl key and then select
the objects)

Repeat the process on the opposite side.

43
SolidWorks Training (Basic)

17. Add a dimension.

18. Through All Cut.

Click Insert, Cut, Extrude,

Or pick Extruded Cut on the Features toolbar.

Choose Through All and click OK

44
SolidWorks Training (Basic)

Holes

19. Change the view orientation. Press the spacebar and double-click *Top.

20. Hole.

Click the Hole tab and set the properties of the hole as follows:

Standard: Ansi Metric


Screw Type: Drill sizes
Size: ∅12.5
End Condition: Through All

21. Turn to Hole Position and locate the holes.

22. Set Dimensions add relation so that these points are


aligned horizontally.

45
SolidWorks Training (Basic)

23. Return to Isometric.

Filleting

24. lnsert Fillet.

Set a radius = 10 mm

46
SolidWorks Training (Basic)

25. Add fillets at selected edges and face, radius 2.5 mm, and using Full preview.

Selected edges and face

Chamfering

26. Add chamfer to the holes.

47
SolidWorks Training (Basic)

27. Save the part.

Define Material and Mass Properties

28. How to define material and check its mass properties

Right click on Material


and select Edit Material

29. Choose Copper and its Alloys and select Brass.

48
SolidWorks Training (Basic)

30. Drop down menus, Tools – Mass Properties…

Mass of the part


(474.04 g)

Editing features

31. Mass of the part can be reduced by modified the thickness of the features.
32. Right click on Extrude and select Edit Feature.

49
SolidWorks Training (Basic)

33. Change the depth from 10 mm to 5 mm.

34. Click OK.


35. Check the current mass of the part. Now, the mass is 326.09 g which means more
than 30 % of mass has been reduced.

36. The Cut Feature is still maintaining the dimension to be 2.50 mm from the bottom
face.

50
SolidWorks Training (Basic)

Exercise 3.1: Glass Plate (15 minutes)


Create this part using the information and dimensions provided. Sketch and extrude
profiles to create the part.

4 x M20 Drilled Hole

10

R20 fillet

Exercise 3.2: Bracket (15 minutes)


Create this part using the information and dimensions provided. Sketch and extrude
profiles to create the part.
CBore M14 Hex Head
Bolt

51
SolidWorks Training (Basic)

Exercise 3.3: Create this part using the information and dimensions provided.
Sketch and extrude profiles to create the part. (10 minutes)

Exercise 3.4: Gland (15 minutes)


Create this part using the information and dimensions provided. Sketch and extrude
profiles to create the part.

52
SolidWorks Training (Basic)

Give dimensions Mirror the sketch with


Start sketching vertical axis

Trimming

Mirror

Extrude 10 Sketch small


mm circle and mirror
for another circle

Complete part

Sketch circle with 70 mm Sketch another circle with 48 mm 53


diameter and extrude 10 mm diameter and extrude cut 15 mm
SolidWorks Training (Basic)

Exercise 3.5: PVC Tee Pipe (30 minutes)


Create a solid model of this plastic pipe tee. A tee is used to connect pipes
together. The type of tee shown here is used to join pipes with solvent welding. A
chemical is applied to the inside of the socket, and the pipe is then forced into the
socket. The solvent softens the plastic, and when the solvent dries, a strong,
permanent joint is created. The sockets are tapered slightly to allow for a tight fit
with the pipe.

Sockets are to be tapered 0.50 degrees

Set the material to PVC Rigid (density=1300kg/m3) and find the mass of the tee.

(Answer: Weight =70.63 g)

54
SolidWorks Training (Basic)

Module 4: Additional Part Modeling


This module provides a comprehensive understanding on additional modeling
techniques such as:

Revolved, Patterning, Swept, Lofted, Rib and Shell features in SolidWorks.

Below are examples of products that applied these types of features.

55
SolidWorks Training (Basic)

Revolved features

Revolved Boss/Base – material added by rotating the profiles about a centerline


Revolved Cut – material removed by rotating the sketch

The Revolve parameters box provides the ability to select:

Axis of Revolution
Revolve Type
• One-Direction
• Mid-Plane Angle
• Two-Direction
It controls the revolve
thickness

Allow a small gap between rectangle and the Centerline


centerline to create a hollow cylinder

One of the lines is collinear with the centerline to


make a solid cylinder

56
SolidWorks Training (Basic)

Tutorial 4.1:

1. Draw a Centerline across the Origin

2. Using Line, sketch as follows (free dimension)

3. Exit the sketch and select Revolve from Features toolbar. Select the Centerline
as the Axis of Revolution.

It rotates clockwise

57
SolidWorks Training (Basic)

4. The direction of rotation and its angle can be changed, i.e. 180°.

Click here to change the rotation


to counter clockwise

5. Click OK.

6. To edit the feature. Right click Revolve and select Edit Feature.

58
SolidWorks Training (Basic)

7. Change the angle of revolution to 360°.

8. We will make holes on the selected face.

9. Sketch a Circle and tick For construction box. The line will turn to construction
line.

59
SolidWorks Training (Basic)

10. Sketch a small Circle and coincident with the construction line.

11. Extrude Cut, Through All.

12. The hole will be copied around the face by using Circular Pattern. Click View –
Temporary Axes. The axis will be used as axis of rotation.

60
SolidWorks Training (Basic)

13. Select Circular Pattern from Features toolbar. Number of holes are 6.

14. The completed part.

61
SolidWorks Training (Basic)

Patterning
In Module 2, you have learnt the sketch pattern such as linear and circular
pattern. There are other pattern tools that are available in SolidWorks. You may
find them at Insert – Pattern/Mirror.

Pattern repeats the selected features in an array based on a seed feature. You
can create a linear pattern, a circular pattern, a curve driven pattern, a fill pattern,
or use sketch points or table coordinates to create the pattern.

Linear pattern Select the features, then


specify the direction, the
linear spacing, and the total
number of instances.
Circular pattern Select the features and an
edge or axis as the center of
rotation, and then specify the
total number of instances
and the angular spacing
between instances.
Curve driven Select the features and an
pattern edge or sketch segment on
which to pattern the feature.
Then you can specify the
type of curve, the curve
method, and the alignment
method.
Fill pattern Fill a defined region with a
pattern of features or a
predefined cut shape.
Typical uses include:
• Weight reduction
• Ventilation holes
Sketch points Select where to populate a
seed feature by sketching
or points on model face, or
Add or retrieve previously
Table created X-Y coordinates to
coordinates to populate a seed feature on
create the the face of the model.
pattern

But remember, the commands are only enable when you have multi body parts.

62
SolidWorks Training (Basic)

Tutorial 4.2: Vary Sketch option

1 2 3 4

Sketch as illustrated Extrude the sketch


(some of the entities Sketch a slot on top of 3D Extrude cut the slot
part and give dimensions
are free dimension)
Hint: 8 mm at both sides
will control the distance
5 6 between the arcs and the 7
plate edges.

Apply Linear Pattern and


enable Vary Sketch
option Apply Circular Pattern
Complete component 63
SolidWorks Training (Basic)

Exercises 4.1: Curve Driven Pattern

1 4
2 3

Offset 5 mm

Sketch as illustrated using Extrude to 10 mm


Spline (free dimension) Sketch a Circle with diameter 3
mm on top of spline face

5 6 7 8

Select the Circle and add


relations with the Offset line to
be coincident

Select the Extruded Cut feature and go to


Extrude Cut the Circle 64
Insert-Pattern/Mirror-Curve Driven Pattern
Select the Offset Spline as the direction
Spacing and Instances: 20
SolidWorks Training (Basic)

Swept

Swept Boss/Base – material added by sweeping a profile along the path


Cut Sweep – material removed by sweeping a profile along the path

Follow path – the section Keep Normal Constant – the


remains at the same angle with section remains parallel to the
respect to the path at all times. beginning section at all times.

Sample of applications:

Power cord Spiral coil

65
SolidWorks Training (Basic)

Tutorial 4.3: Creating a Worm Gear

Sketch the profile (or the sketch can be


taken from Tutorial 2.3, but you have to Create the path
modified a bit)

Completed part

66
SolidWorks Training (Basic)

Tutorial 4.4: Creating a Spring


Click Insert: Curve: Helix/Spiral

Sketch a Circle

Create a Plane Normal to


Curve

Sketch a Circle with 3.50


Completed spring Select Swept. The Circle will be
mm diameter
the Profile and Helix/Spiral is
the Path. 67
SolidWorks Training (Basic)

Tutorial 4.5: Creating a Bottle (with a guide curve)


Create a Profile
1 2 3 4

5 6 7

68
SolidWorks Training (Basic)

Lofted

Loft creates a feature by making transitions between profiles. A loft can be a base,
boss, cut, or surface. You create a loft using two or more profiles. Only the first, last,
or first and last profiles can be points. All sketch entities, including guide curves and
profiles, can be contained in a single 3D sketch.

You can drag to modify/change the


location of these blue points
(closing point)

Sample of application: Chisel

69
SolidWorks Training (Basic)

Tutorial 4.6: Create lofted part with Centerline Parameters

1. Create Rectangle on Front Plane.

2. Select and sketch 3 Point Arc at other Top Plane. One of its end points must
coincident with the Origin.

3. View in Isometric.

4. Create a Plane Normal to Curve. You have to select the Arc and Point.

70
SolidWorks Training (Basic)

5. Sketch another Rectangle on this Plane

6. Select Loft from Feature toolbar. Select Sketch 1 and Sketch 3 (both
Rectangles) as the profiles.

7. Expand the Centerline Parameters and pick the Arc (Sketch 2).

71
SolidWorks Training (Basic)

Exercises 4.2: Chisel

1. Select Front Plane

2. To create another Plane, Hold Ctrl key and drag Front plane to the left.

3. Set the Distance to 30 mm and Instances: 2

4. Create one more plane (Plane3) which 40 mm from Plane2 using the same
method.

72
SolidWorks Training (Basic)

5. Select Front Plane and sketch a square.

6. Exit sketch.
7. Select Plane1 and sketch a Circle.

8. Exit sketch.
9. Select Plane2 and sketch another Circle, which its radius is coincident with the
vertex of the square. Exit the sketch.

10. Select and Copy larger Circle and Paste on


Plane3.

73
SolidWorks Training (Basic)

11. Click Features – Lofted Boss/Base

12. Select sketches. You have to make sure that all the selected points are at the
same corner.

13. Create one plane 200 mm at the back of Front Plane.

74
SolidWorks Training (Basic)

14. Select Plane4 that you have just created and sketch a Rectangle as illustrated
below.

15. Click Features – Lofted Boss/Base. Select the profile. Pick the point at the right
bottom of square and rectangle.

16. Complete the model. Save the part.

75
SolidWorks Training (Basic)

Rib and Shell

Rib is a special type of extruded feature created from open or closed sketched
contours. It adds material of a specified thickness in a specified direction between
the contour and an existing part. You can create a rib using single or multiple
sketches.

Rib

Rib

1. Sketch L shape and extrude the sketch.

2. Sketch a Line to use as the rib feature on a plane.

3. Click Rib on the Features toolbar, or click Insert, Features, Rib.

4. Click OK

Shell tool hollows out a part, leaves open the faces you select, and creates thin-
walled features on the remaining faces. If you do not select any face on the model,
you can shell a solid part, creating a closed, hollow model. You can also shell a
model using multiple thicknesses.

76
SolidWorks Training (Basic)

Tutorial 4.7: Using Shell to create wall thickness inside the Bottle

1 2 3

4 5 6

77
SolidWorks Training (Basic)

Module 5: Assembly Modeling


Stages in the process;

1. Creating a new assembly


• New assemblies are created using the same method as new parts

2. Adding the first component


• Components can be added in several ways. They can be dragged and dropped from an
open part window or opened from standard browser.

3. Position of the first component


• The initial component added to the assembly is automatically fixed as it is added.
Others components can be positioned after they are added.

4. Mating components to each other


• Mates are used to position and orient components with reference to each other. Mates
remove degrees of freedom from the components.

78
SolidWorks Training (Basic)

Concentric mate between two cylindrical faces

5. Sub assemblies
• Assemblies can be created and inserted into the current assembly. They are
considered sub-assembly components.

79
SolidWorks Training (Basic)

From assemblies, you can:

1. Perform mass properties calculations on entire assemblies and also interference


(clashes) detection between parts in assembly,

2. Create an exploded view of an assembly,

3. Bill of Materials (BOM) table can be generated from the assembly. Associated
balloons can be added to identify the items.

80
SolidWorks Training (Basic)

Assembly toolbars

• Insert components • Smart fasteners


• Hide/show components • Exploded view
• Change suppression state • Explode line sketch
• Edit component • Interference detection
• No external references • Simulation
• Mate
• Move component

Basic assembly mates

• Coincident – place two flat surfaces in the same


plane

• Parallel – define two flat surfaces as parallel

• Perpendicular – define two lines or planes as


perpendicular to one another

• Tangent – define a cylindrical feature as tangent


to a line or plane

• Concentric – align the centerlines of two


cylindrical features

• Distance – make two surfaces parallel, with a


specified distance between them

• Angle – two lines or planes at a preset angle to one another

81
SolidWorks Training (Basic)

Sliding Brace Assembly

1. Create a new assembly


2. Insert components (Browse the components from Desktop/SolidWorks Basic
Training/Module5/Bracket)
By default, the first component inserted into an
assembly is fixed (locked) in position.

Fixed

3. Float and Fix components

Right click and select Float. Now, the


component is ‘floating’, and can be moved or
rotated

82
SolidWorks Training (Basic)

4. Mate the faces of these two components (Bracket – C Link) and select Coincident

Select top Face of C Link

1
Coincident

Select bottom Face of Bracket

83
SolidWorks Training (Basic)

Select these two faces

Select these two faces

84
SolidWorks Training (Basic)

5. Moving and rotating the component – U Bolt

Select this component to rotate

1
2

3 Rotate the bolt so that its legs are


parallel with the holes

85
SolidWorks Training (Basic)

6. Mating components (select U Bolt’s right leg and Bracket’s hole) – choose Concentric

2
1

Concentric

86
SolidWorks Training (Basic)

7. Mate another side

Mate another side

87
SolidWorks Training (Basic)

8. Select bottom faces of U-Bolt and C Link and constraint their Distance to maintain at 40 mm.

1 2

Distance

88
SolidWorks Training (Basic)

9. Continue with the other side. You have to insert other U-Bolt and C Link and
apply mates on respective parts as before.

10. You will utilize the Design Library and take a standard nut from the library.

11. Save as the nut to Desktop/SolidWorks Basic


Training/Module5/nut.

Double click the nut


89
SolidWorks Training (Basic)

12. You will be asked to Select a Configuration of the nut size. Select M20-2.5.
M – Metric, 20 – nut diameter (in mm)

13. Insert/copy four nuts.

14. Mating the nuts

90
SolidWorks Training (Basic)

15. A complete assembly.

91
SolidWorks Training (Basic)

16. Generate an assembly statistics - Generate a report of the components and


mates in an assembly.

9 components

20 mates

92
SolidWorks Training (Basic)

Exploding and collapsing the assembly

Exploded View - It is a view of an assembly where the components have been


separated.

17. Select the component to be exploded – a triad will appear – place the cursor
over the arrow on the triad that represents the direction in which component
should be exploded – then drag to the desired distance.

18. Select the nuts (it will be highlighted in cyan color at the design tree). Then drag
the triad downward.

Exploded step

Drag the triad


downward

19. Continue to select other parts and follow the sequence.

93
SolidWorks Training (Basic)

20. Expand the entries in the ConfigurationManager so that defined Explode Steps
will appear

1
2

Exploding

Collapsing

Creating an explode line sketch

21. Make sure the assembly in its exploded view (not collapsed).

94
SolidWorks Training (Basic)

22. Select edges or faces on components that the explode line will connect
between.

Select
edges

23. Repeat for other components. Save the assembly.

95
SolidWorks Training (Basic)

Module 6: Drawing
After completion of this module, you will be able to: -
• make 2-D drawing from a SolidWorks part file.
• create a custom drawing sheet format, and
• use eDrawings to create a drawing file that allows easy file sharing

1. To open a new drawing file, open SolidWorks 2007, click New icon on the
Standard toolbar.
2. Select Drawing icon and then OK.

3. You will be asked about the format and size of your drawing layout. Click
Standard sheet size and select A-Landscape. Do not turn on the Display sheet
format yet.

4. Click on the X to close the box, we will set a few options


before browsing the part file.

96
SolidWorks Training (Basic)

Drawing toolbars

In the drawing mode, the CommandManager has THREE groups of command:

Drawing

Sketch

Annotation

You will use some of the icons along the way.

Insert standard drawing views - Angle of projections

5. In the drawing space, right-click and select Properties from the menu.

97
SolidWorks Training (Basic)

6. Select Third angle projection. Do not worry about the scale, it can be changed
later,

Select Third
angle projection

Insert Component into Drawing

7. In Drawings CommandManager, select Standard 3 View

8. Then Browse…

98
SolidWorks Training (Basic)

9. Search the Bracket that you have created during Exercise 3.2 or go to
Desktop/Module3/Exercise 3.2. Enable the Preview to view the part before you
open.

10. Selected part in third angle projection.

Top view

Front view Right view

11. All other views are aligned with the Front view. When you move/drag the front
view up-down or left-right will move the other views.

99
SolidWorks Training (Basic)

12. Enlarge the views by change the scale to 1:2

Make the Hidden Lines Visible

Adding dimensions to drawing and modifying dimensions

13. Select Annotation – Model Items, and in Dimensions tab, click Marked for
Drawing

Source: Entire model

Marked for
Drawing

100
SolidWorks Training (Basic)

14. To change the arrow direction, click this point.

Create Section View

15. Select the Section View Tool from the Drawing group.

1 2

Move the cursor over the edge

Move the cursor to the downside of


the bracket

101
SolidWorks Training (Basic)

16. A Section View is created. To reverse the arrow direction – double click on the
section line

17. To break alignment between section view and top view, right click the section
view; go to Alignment-Break Alignment.

18. Delete the Right view.

102
SolidWorks Training (Basic)

19. The location of Right view will be replaced by the Section view, but you need to
rotate this view first. Right click the view; choose Zoom/Pan/Rotate – Rotate
View.

20. Rotate the view to -90°.

21. Select the section view, and click Centerline Tool from Annotations group then
centerlines will be added to the holes

103
SolidWorks Training (Basic)

22. Press and hold the Shift key and drag the dimension of 45 mm diameter hole
from the top view into the Section View

Press Shift key and select the Dimension

Bring the Dimension to a new location

23. You can also hide the dimension. Just select the dimension you want to hide,
right click and find Hide. To show the dimension, go to View – Hide/Show
Annotations, then click any hidden dimension

104
SolidWorks Training (Basic)

Insert a Note

24. Select Note Tool from the Annotation group

25. Begin typing the text as shown in the box that appears.

105
SolidWorks Training (Basic)

Edit Sheet Format

26. Right click in the drawing space and select Properties

27. Turn on/enable the box Display sheet format.

106
SolidWorks Training (Basic)

28. Right click in the drawing area and select Edit Sheet Format.

29. The drawing Sheet Format. After this, you will learn how to do some modification
to the sheet.

107
SolidWorks Training (Basic)

30. Drag your mouse from left to the right to select all the lines and information that
you may not needed. Press Delete key and then use Trim Entities to trim the
lines.

31. Trim until you get the drawing table like this.

32. Select Note Tool and type inside the Comments. Symbol plus/minus is inserted
by clicking on the Add Symbol Tool under Text Format tab.

108
SolidWorks Training (Basic)

33. Fill up the form as shown; type your department and drawing title.

The Scale 1:5 is not corrected.

34. To modify the scale, you have to go to Sheet Properties and change the Scale
1:2.

109
SolidWorks Training (Basic)

35. Right click and select Edit Sheet.

36. You will get back to the other side of drawing. It includes your drawing part and
sheet.

110
SolidWorks Training (Basic)

37. A trimetric view can often be helpful in interpreting a 2D drawing. To bring the
view into the drawing layout, click Model View from Drawings.

38. Click arrow Next.

39. Select the Trimetric View, and arrange the view as


figure below.

111
SolidWorks Training (Basic)

Assembly Drawing

ƒ Assembly drawings show all the parts and how they go together
ƒ Dimensioning is not usually required
ƒ Hidden lines usually omitted
ƒ 3D CAD packages can generate assembly drawings directly from assembly
models

Elements of an Assembly Drawing

¾ All parts are shown in one drawing


• assembled view
• sectioned assembly
• exploded assembly
¾ Parts list or bill of materials (BOMs)
• Part ID, quantity, description, catalogue number, etc.
¾ Balloons
• each part is identified by a numbered balloon, and referenced to the
parts list
¾ Machining and assembly instructions

Example of Assembly Drawing

Balloons

Parts list
(BOM)

112
SolidWorks Training (Basic)

Opening drawing template and edit Sheet Format

1. Open the assembly file Desktop/SolidWorks


Basic Training/Module5/Sliding brace
assembly.sldasm”. Make sure that the
assembly is in the ‘collapsed’ configuration

2. OK to accept the Drawing Template

3. Click Standard sheet size and select A-Landscape. Do not


turn on the Display sheet format yet.

Uncheck the
box

4. In the new drawing window, select the Standard 3 View, and make
sure it is in Third angle projection

113
SolidWorks Training (Basic)

5. Select the Model View Tool from Drawings group

Select Trimetric
from the list Trimetric view

Adding the Exploded View

6. Next, we will make an exploded view to the drawing.

1
Right click the
Trimetric View
and select
Properties 2 Enable the box to show in
exploded state

114
SolidWorks Training (Basic)

7. Showing the assembly and exploded drawing.

Creating Bill of Materials (BOMs)

8. Select any of the drawing views


9. From the main menu, select Insert: Tables: Bill of Materials

10. Accept the default selections

115
SolidWorks Training (Basic)

Customizing BOMs

11. Edit the title box

1 2
Click on the
Part Number Edit the title box
cell, and to read PART
select NAME
Column
Properties

12. The drawing is almost complete, but the item numbers in the Bill of Materials
are not linked with the components in the drawing. We will add “balloons” with
part numbers to the drawing.

AutoBalloons

13. Select the exploded Trimetric Views. Select


the AutoBalloons Tool from the Annotations
group of the CommandManager.

14. Balloons will be added to the view.

15. Click and drag the part numbers to relocate the


balloons.

116
SolidWorks Training (Basic)

16. Balloon styles

Circular –

Triangular –

Hexagon –

Item number
Circular split line –
Quantity

17. Completed assembly drawing.

117
SolidWorks Training (Basic)

Producing an e-drawing file

1. Right click at the Main Menu and select eDrawings 2007.

2. Click Publish eDrawings 2007 File

3. A pop up window will come out. Click Retry button.

4. e-drawing file.

118
SolidWorks Training (Basic)

5. To save the file, go to File-Save As. The type of file is *.edrw.

Exercises 6.1:
In the PropertyManager, click Browse, and then open Desktop\ SolidWorks Basic
Training/Module6/motor casing.sldasm. Do the assembly drawing as shown.

119
SolidWorks Training (Basic)

References
1. William E. Howard and Joseph C. Musto, (2006). Introduction to Solid Modeling
using SolidWorks. McGraw-Hill International Edition. ISBN 007-124956-7.

2. David Murray, (2006). Inside SolidWorks 4th Edition. Thompson Delmar


Learning. ISBN 1-4180-2085-0.

3. David C. Planchard and Marie P. Planchard, (2008). A Commands Guide for


SolidWorks 2008 – The reference edition including more than 200 integrated
stand-alone tutorials. Thompson Delmar Learning. ISBN-10: 1-42835301-1,
ISBN-13: 9781-4283-5301-5.

4. Frederick E. Giesecke, Alva Mitchell, Henry Cecil Spencer, Ivan Leroy Hill, John
Thomas Dygdon and James E. Novak, (2003). Technical Drawing 12th Edition.
Prentice Hall. ISBN 0-13-178446-3.

5. Albert William Boundy, (2002). Engineering Drawing 6th Edition. McGraw-Hill


International Edition. ISBN 007-471043-5.

6. James H. Earle (2004). Engineering Design Graphics AutoCAD 2004 11th


Edition. Pearson Prentice-Hall. ISBN 0-13-142573-0.

7. SolidWorks 2003 Training Manual.

8. http://www.solidworks.com/

9. SolidWorks 2007 Online User’s Guide

120