Você está na página 1de 12

Exercicio-Variveis e expresses

Autor :Emerson Souza - 1 Periodo


Lista de exerccios, prof: Pedriana - Diciplina PACC

algoritmo "Exercicio 01-Variveis e expresses"


// Funo :Leia um numero e o imprima
// Autor :Emerson Souza
// Data : 01/09/2015
// Lista de exerccios, prof: Pedriana
var numero:inteiro
inicio
escreval("Sistema: Leia um numero e o imprima")
escreva("Digite um numero: ")
Leia(numero)
escreval("O numero : ",numero)
fimalgoritmo
_____//_____
// algoritmo "Exercicio 01-Variveis e expresses"
// Funo :Leia um numero e o imprima
// Autor :Emerson Souza
// Data : 01/09/2015
// Lista de exerccios, prof: Pedriana
#include <stdio.h>
#include <stdlib.h>
#include <locale.h>
int main()
{
int numero;
setlocale(LC_ALL, "Portuguese");
printf("Sistema: Leia um nmero e o imprima\n\n");
printf("Digite um nmero: ");
scanf("%d",&numero);
printf("\n\nO nmero : %d",numero);
getch();
return 0;
}
_____//_____
algoritmo "Exercicio 02-Variveis e expresses"
// Funo :leia um numero real e o imprima
// Autor :Emerson Souza
// Data : 01/09/2015
// Lista de exerccios, prof: Pedriana
var numero:real
inicio
escreval("Sistema: leia um numero real e o imprima")

escreva("Digite um numero: ")


Leia(numero)
escreval("O numero : ",numero)
fimalgoritmo
_____//_____
// algoritmo "Exercicio 02-Variveis e expresses"
// Funo :leia um numero real e o imprima
// Autor :Emerson Souza
// Data : 01/09/2015
// Lista de exerccios, prof: Pedriana
#include <stdio.h>
#include <stdlib.h>
#include <locale.h>
main()
{
float numero;
setlocale(LC_ALL, "Portuguese");
printf("Sistema: leia um numero real e o imprima\n\n");
printf("Digite um nmero: ");
scanf("%f",&numero);
printf("\n\nO nmero : %f",numero);
getch();
return 0;
}
_____//_____
algoritmo "Exercicio 03-Variveis e expresses"
// Funo :digitar tres valores inteiros e imprima a soma deles
// Autor :Emerson Souza
// Data : 01/09/2015
// Lista de exerccios, prof: Pedriana
var a, b, c:inteiro
inicio
escreval("Sistema: digitar trs valores inteiros e imprima a soma deles")
escreva("Digite o primeiro valor: ")
Leia(a)
escreva("Digite o segundo valor: ")
Leia(b)
escreva("Digite o terceiro valor: ")
Leia(c)
escreval("O a soma dos igual : ",a+b+c)
fimalgoritmo
_____//_____
// algoritmo "Exercicio 03-Variveis e expresses"
// Funo :digitar tres valores inteiros e imprima a soma deles
// Autor :Emerson Souza
// Data : 01/09/2015
// Lista de exerccios, prof: Pedriana

#include <stdio.h>
#include <stdlib.h>
#include <locale.h>
main()
{
int a,b,c;
setlocale(LC_ALL, "Portuguese");
printf("Sistema: digitar trs valores inteiros e imprima a soma deles\n\n");
printf("Digite o primerio valor: ");
scanf("%d",&a);
printf("Digite o segundo valor: ");
scanf("%d",&b);
printf("Digite o terceiro valor: ");
scanf("%d",&c);
printf("\n\nA soma dos valores e igual : %d",a+b+c);
getch();
return 0;
}
_____//_____
algoritmo "Exercicio 04-Variveis e expresses"
// Funo :Leia um numero real e imprima o resultado do quadrado desse numero
// Autor :Emerson Souza
// Data : 01/09/2015
// Lista de exerccios, prof: Pedriana
var numero:real
inicio
escreval("Sistema: Leia um numero real e imprima o resultado do quadrado desse numero")
escreva("Digite um nmero: ")
Leia(numero)
escreval("O quadrado deste nuemro : ",numero*numero)
fimalgoritmo
_____//____
// algoritmo "Exercicio 04-Variveis e expresses"
// Funo :Leia um numero real e imprima o resultado do quadrado desse numero
// Autor :Emerson Souza
// Data : 01/09/2015
// Lista de exerccios, prof: Pedriana
#include <stdio.h>
#include <stdlib.h>
#include <locale.h>
main()
{
float numero;
setlocale(LC_ALL, "Portuguese");
printf("Sistema: Leia um numero real e imprima o resultado do quadrado desse numero\n\n");
printf("Digite um nmero: ");

scanf("%f",&numero);
printf("\n\nO quadrado deste nuemro : %f",numero*numero);
getch();
return 0;
}
_____//_____
algoritmo "Exercicio 05-Variveis e expresses"
// Funo :Leia um numero real e imprima a quinta parte deste numero.
// Autor :Emerson Souza
// Data : 01/09/2015
// Lista de exerccios, prof: Pedriana
var numero:real
inicio
escreval("Sistema: Leia um numero real e imprima a quinta parte deste numero")
escreva("Digite um nmero: ")
Leia(numero)
escreval("A quinta parte deste numero : ",numero*1/5)
fimalgoritmo
_____//_____
// algoritmo "Exercicio 05-Variveis e expresses"
// Funo :Leia um numero real e imprima a quinta parte deste numero.
// Autor :Emerson Souza
// Data : 01/09/2015
// Lista de exerccios, prof: Pedriana
#include <stdio.h>
#include <stdlib.h>
#include <locale.h>
main()
{
float numero;
setlocale(LC_ALL, "Portuguese");
printf("Sistema: Leia um numero real e imprima a quinta parte deste numero.\n\n");
printf("Digite um nmero: ");
scanf("%f",&numero);
printf("\n\nA quinta parte deste numero : %f",numero*1/5);
getch();
return 0;
}
_____//_____
algoritmo "Exercicio 06-Variveis e expresses"
// Funo :Leia uma temperatura em graus Celsius e apresente-a convertida em graus Fahrenheit
// Autor :Emerson Souza
// Data : 01/09/2015
// Lista de exerccios, prof: Pedriana
var c:real
inicio
escreval("Sistema: Leia uma temperatura em graus Celsius e apresente-a convertida em graus Fahrenheit")

escreva("Digite a temperatura em celsius: ")


Leia(c)
escreval("A temperatura em fahrenheit : ",c*(9.0/5.0)+32.0)
fimalgoritmo
_____//_____
// algoritmo "Exercicio 06-Variveis e expresses"
// Funo :Leia uma temperatura em graus Celsius e apresente-a convertida em graus Fahrenheit
// Autor :Emerson Souza
// Data : 01/09/2015
// Lista de exerccios, prof: Pedriana
#include <stdio.h>
#include <stdlib.h>
#include <locale.h>
main()
{
float c;
setlocale(LC_ALL, "Portuguese");
printf("Sistema: Leia uma temperatura em graus Celsius e apresente-a convertida em graus Fahrenheit\n\n");
printf("Digite a temperatura em celsius: ");
scanf("%f",&c);
printf("\n\nA temperatura em fahrenheit : %f",c*(9.0/5.0)+32.0);
getch();
return 0;
}
_____//_____
algoritmo "Exercicio 07-Variveis e expresses"
// Funo :Leia uma temperatura em graus Fahrenheit e apresente-a convertida em graus Celsius
// Autor :Emerson Souza
// Data : 01/09/2015
// Lista de exerccios, prof: Pedriana
var f:real
inicio
escreval("Sistema: Leia uma temperatura em graus Fahrenheit e apresente-a convertida em graus Celsius")
escreva("Digite a temperatura em fahrenheit: ")
Leia(f)
escreval("A temperatura em celsius : ",5.0*(f-32.0)/9.0)
fimalgoritmo
_____//_____
//algoritmo "Exercicio 07-Variveis e expresses"
// Funo :Leia uma temperatura em graus Fahrenheit e apresente-a convertida em graus Celsius
// Autor :Emerson Souza
// Data : 01/09/2015
// Lista de exerccios, prof: Pedriana
#include <stdio.h>
#include <stdlib.h>
#include <locale.h>

main()
{
float f;
setlocale(LC_ALL, "Portuguese");
printf("Sistema: Leia uma temperatura em graus Fahrenheit e apresente-a convertida em graus Celsius\n\n");
printf("Digite a temperatura em fahrenheit: ");
scanf("%f",&f);
printf("\n\nA temperatura em celsius : %f",5.0*(f-32.0)/9.0);
getch();
return 0;
}
_____//_____
algoritmo "Exercicio 08-Variveis e expresses"
// Funo :Leia uma temperatura em graus Kelvin e apresente-a convertida em graus Celsius
// Autor :Emerson Souza
// Data : 01/09/2015
// Lista de exerccios, prof: Pedriana
var k:real
inicio
escreval("Sistema: Leia uma temperatura em graus Kelvin e apresente-a convertida em graus Celsius")
escreva("Digite a temperatura em Kelvin: ")
Leia(k)
escreval("A temperatura em celsius : ",k-273.15)
fimalgoritmo
_____//_____
//algoritmo "Exercicio 08-Variveis e expresses"
// Funo :Leia uma temperatura em graus Kelvin e apresente-a convertida em graus Celsius
// Autor :Emerson Souza
// Data : 01/09/2015
// Lista de exerccios, prof: Pedriana
#include <stdio.h>
#include <stdlib.h>
#include <locale.h>
main()
{
float k;
setlocale(LC_ALL, "Portuguese");
printf("Sistema: Leia uma temperatura em graus Kelvin e apresente-a convertida em graus Celsius\n\n");
printf("Digite a temperatura em Kelvin: ");
scanf("%f",&k);
printf("\n\nA temperatura em celsius : %f",k-273.15);
getch();
return 0;
}

_____//_____

algoritmo "Exercicio 09-Variveis e expresses"


// Funo :. Leia uma temperatura em graus Celsius e apresente-a convertida em graus Kelvin
// Autor :Emerson Souza
// Data : 01/09/2015
// Lista de exerccios, prof: Pedriana
var c:real
inicio
escreval("Sistema: . Leia uma temperatura em graus Celsius e apresente-a convertida em graus Kelvin")
escreva("Digite a temperatura em Celsiu: ")
Leia(c)
escreval("A temperatura em Kelvin : ",c+273.15)
fimalgoritmo
_____//_____
//algoritmo "Exercicio 09-Variveis e expresses"
// Funo :Leia uma temperatura em graus Celsius e apresente-a convertida em graus Kelvin
// Autor :Emerson Souza
// Data : 01/09/2015
// Lista de exerccios, prof: Pedriana
#include <stdio.h>
#include <stdlib.h>
#include <locale.h>
main()
{
float c;
setlocale(LC_ALL, "Portuguese");
printf("Sistema: Leia uma temperatura em graus Celsius e apresente-a convertida em graus Kelvin\n\n");
printf("Digite a temperatura em Celsius: ");
scanf("%f",&c);
printf("\n\nA temperatura em Kelvin : %f",c+273.15);
getch();
return 0;
}

_____//_____
algoritmo "Exercicio 10-Variveis e expresses"
// Funo : Leia uma velocidade em km/h (quilometros por hora) e apresente-a convertida em m/s(metros por
segundo).
// Autor :Emerson Souza
// Data : 01/09/2015
// Lista de exerccios, prof: Pedriana
var k:real
inicio
escreval("Sistema: Leia uma velocidade em km/h (quilometros por hora) e apresente-a convertida em
m/s(metros por segundo).")
escreva("Digite a velocidade em km/h: ")
Leia(k)
escreval("A a velocidade em m/s : ",k/3.6)

fimalgoritmo
_____//_____
//algoritmo "Exercicio 10-Variveis e expresses"
// Funo : Leia uma velocidade em km/h (quilometros por hora) e apresente-a convertida em m/s(metros por
segundo).
// Autor :Emerson Souza
// Data : 01/09/2015
// Lista de exerccios, prof: Pedriana
#include <stdio.h>
#include <stdlib.h>
#include <locale.h>
main()
{
float k;
setlocale(LC_ALL, "Portuguese");
printf("Sistema: Leia uma velocidade em km/h (quilometros por hora) e apresente-a convertida em m/s(metros
por segundo).\n\n");
printf("Digite a velocidade em km/h: ");
scanf("%f",&k);
printf("\n\nA velocidade em m/s : %f",k/3.6);
getch();
return 0;
}

_____//_____
algoritmo "Exercicio 11-Variveis e expresses"
// Funo : Leia uma velocidade em m/s (metros por segundo) e apresente-a convertida em km/h(quilometros por
hora)
// Autor :Emerson Souza
// Data : 01/09/2015
// Lista de exerccios, prof: Pedriana
var m:real
inicio
escreval("Sistema: Leia uma velocidade em m/s (metros por segundo) e apresente-a convertida em
km/h(quilometros por hora)")
escreva("Digite a velocidade em m/s: ")
Leia(m)
escreval("A a velocidade em km/h : ",m*3.6)
fimalgoritmo
_____//_____
//algoritmo "Exercicio 11-Variveis e expresses"
// Funo : Leia uma velocidade em m/s (metros por segundo) e apresente-a convertida em km/h(quilometros por
hora)
// Autor :Emerson Souza
// Data : 01/09/2015
// Lista de exerccios, prof: Pedriana

#include <stdio.h>
#include <stdlib.h>
#include <locale.h>
main()
{
float k;
setlocale(LC_ALL, "Portuguese");
printf("Sistema: Leia uma velocidade em m/s (metros por segundo) e apresente-a convertida em
km/h(quilometros por hora)\n\n");
printf("Digite a velocidade em m/s: ");
scanf("%f",&k);
printf("\n\nA velocidade eem km/h : %f",k*3.6);
getch();
return 0;
}

_____//_____
algoritmo "Exercicio 12-Variveis e expresses"
// Funo : Leia uma distancia em milhas e apresente-a convertida em quilometros
// Autor :Emerson Souza
// Data : 01/09/2015
// Lista de exerccios, prof: Pedriana
var m:real
inicio
escreval("Sistema: Leia uma distancia em milhas e apresente-a convertida em quilometros")
escreva("Digite a velocidade em milhas: ")
Leia(m)
escreval("A a velocidade em quilometros : ",m*1.61)
fimalgoritmo
_____//_____
//algoritmo "Exercicio 12-Variveis e expresses"
// Funo : Leia uma distancia em milhas e apresente-a convertida em quilometros
// Autor :Emerson Souza
// Data : 01/09/2015
// Lista de exerccios, prof: Pedriana
#include <stdio.h>
#include <stdlib.h>
#include <locale.h>
main()
{
float m;
setlocale(LC_ALL, "Portuguese");
printf("Sistema: Leia uma distancia em milhas e apresente-a convertida em quilometros\n\n");
printf("Digite a velocidade em milhas: ");
scanf("%f",&m);
printf("\n\nA velocidade em quilometros : %f",m*1.61);

getch();
return 0;
}

_____//_____
algoritmo "Exercicio 13-Variveis e expresses"
// Funo :Leia uma distancia em quilometros e apresente-a convertida em milhas
// Autor :Emerson Souza
// Data : 01/09/2015
// Lista de exerccios, prof: Pedriana
var k:real
inicio
escreval("Sistema: . Leia uma distancia em quilometros e apresente-a convertida em milhas")
escreva("Digite a velocidade em quilometros: ")
Leia(k)
escreval("A a velocidade em milhas : ",k/1.61)
fimalgoritmo
_____//_____
//algoritmo "Exercicio 13 -Variveis e expresses"
// Funo : Leia uma distancia em quilometros e apresente-a convertida em milhas
// Autor :Emerson Souza
// Data : 01/09/2015
// Lista de exerccios, prof: Pedriana
#include <stdio.h>
#include <stdlib.h>
#include <locale.h>
main()
{
float k;
setlocale(LC_ALL, "Portuguese");
printf("Sistema: Leia uma distancia em quilometros e apresente-a convertida em milhas\n\n");
printf("Digite a velocidade em quilometro: ");
scanf("%f",&k);
printf("\n\nA velocidade em milhas : %f",k/1.61);
getch();
return 0;
}

_____//_____
algoritmo "Exercicio 14-Variveis e expresses"
// Funo :Leia um angulo em graus e apresente-o convertido em radianos
// Autor :Emerson Souza
// Data : 01/09/2015
// Lista de exerccios, prof: Pedriana
var g:real

inicio
escreval("Sistema: Leia um angulo em graus e apresente-o convertido em radianos")
escreva("Digite um angulo em graus: ")
Leia(g)
escreval("O valor convertido em radianos : ",(g*3.14)/180)
fimalgoritmo
_____//_____
//algoritmo "Exercicio 14 -Variveis e expresses"
// Funo : Leia um angulo em graus e apresente-o convertido em radianos
// Autor :Emerson Souza
// Data : 01/09/2015
// Lista de exerccios, prof: Pedriana
#include <stdio.h>
#include <stdlib.h>
#include <locale.h>
main()
{
float g;
setlocale(LC_ALL, "Portuguese");
printf("Sistema: Leia um angulo em graus e apresente-o convertido em radianos\n\n");
printf("Digite um angulo em graus: ");
scanf("%f",&g);
printf("O valor convertido em radianos : %f",(g*3.14)/180);
getch();
return 0;
}

_____//_____
algoritmo "Exercicio 15-Variveis e expresses"
// Funo :Leia um angulo em radianos e apresente-o convertido em graus
// Autor :Emerson Souza
// Data : 01/09/2015
// Lista de exerccios, prof: Pedriana
var r:real
inicio
escreval("Sistema: Leia um angulo em radianos e apresente-o convertido em graus")
escreva("Digite um angulo em radianos: ")
Leia(r)
escreval("O valor convertido em graus : ",(r*180)/3.14)
fimalgoritmo
_____//_____
//algoritmo "Exercicio 15 -Variveis e expresses"
// Funo : Leia um angulo em radianos e apresente-o convertido em graus
// Autor :Emerson Souza

// Data : 01/09/2015
// Lista de exerccios, prof: Pedriana
#include <stdio.h>
#include <stdlib.h>
#include <locale.h>
main()
{
float r;
setlocale(LC_ALL, "Portuguese");
printf("Sistema: Leia um angulo em radianos e apresente-o convertido em graus\n\n");
printf("Digite um angulo em radianos: ");
scanf("%f",&r);
printf("O valor convertido em graus : %f",(r*180)/3.14);
getch();
return 0;
}

Fim dos exercicios!