Você está na página 1de 41

Animao 3D

Configuraes,
pargrafos, janelas,
comandos e menus

- Manual de Formao -

Projeto financiado por:

Ttulo:
MANUAL DE FORMAO
Animao 3D configuraes, pargrafos,
janelas, comandos e menus.

rea:
Multimdia

Edio:
REGIBIO FORMAO E CONSULTADORIA,
SOC. UNIP. LDA

Organizao de Contedos:
Mrio Renato Pereira Calhau

Coordenador da edio:
Alexandra Alves

Verso: 3/2013

QUEM SOMOS

FICHA TCNICA

A Regibio uma empresa de consultoria e formao profissional,


acreditada pela Direco Geral do Emprego e das Relaes do
Trabalho, processo n 3377, possui ainda certificao e
homologao por parte do Instituto de Emprego e Formao
Profissional, Ministrio da Agricultura Direco Regional de
Agricultura e do Instituto da Mobilidade e dos Transportes
Terrestres. A sua equipa de profissionais conta com mais de uma
dcada de experincia no desenvolvimento, organizao e gesto
de sistemas de formao. Em 2006, a convite do Instituto para a
Qualidade da Formao (IQF), fez parte do grupo de empresas
piloto, que testou, o ento, novo modelo de acreditao (que em
parte ainda vigora, at concluso da transio para a
certificao). membro da Associao Nacional das Entidades
Formadoras, ocupando um lugar de Direo.
Apoiando-se num crescimento sustentado, desenvolve as suas
atividades em todo o espao nacional, com maior incidncia na
Regio Norte, Centro e LVT, tendo atualmente delegaes em
Bragana, Chaves, Porto, Oliveira do Hospital e na Amadora.
misso da Regibio cumprir com rigor os contratos assumidos,
excedendo as expectativas dos seus clientes, valorizando os seus
colaboradores e contribuindo para a aquisio e consolidao de
competncias dos seus formandos, atravs da apresentao de
projectos de formao, nas suas vertentes de formao cofinanciada e no financiada, intervindo em todos os momentos do
processo formativo.
Na sua atuao, a Regibio disponibiliza recursos humanos e
fsicos que sustentam a organizao, execuo e gesto de aes
de formao profissional, numa ptica de prestao de servios
tcnicos, logsticos e administrativos. Promove ainda a adoo de
solues de racionalizao dos processos de trabalho, suportados
em sistemas e tecnologias de informao e comunicao.

NDICE

ndice
NDICE..................................................................................................3
Objetivos..............................................................................................4
Configurao do computador...............................................................5
Software de modelao e animao 3D...............................................6
Barra de Comandos..............................................................................7
Menus.................................................................................................10
Criao de Cenas, luzes e cmaras e Animaes...............................11
Equadramento de modelos em fundos reais......................................13
Cortes e objectos AEC. rvores, vedaes, escadas, portas, paredes e
janelas................................................................................................14
Modelao de telhados e interiores....................................................17
Modos de visualizao........................................................................21
Abrir e guardar documentos...............................................................23
Importar e exportas elementos..........................................................24
Seleo de objetos.............................................................................26
Sistemas de coordenao...................................................................27
Unidades, localizao e Template....................................................27
Webgrafia...........................................................................................30

4
Colocar aqui os smbolos relativos a apoios das tipologias
financiadas

Colocar aqui o nome da UFCD/Curso

Objetivos

Identificar programas, janelas, comandos e menus para


animao 3D;

Saber configurar o computador;

Reconhecer principais programas de animao;

Compreender funcionamento da animao 3D;

Utilizar Google Sketchup na construo de aplicaes 3D.

6
Colocar aqui os smbolos relativos a apoios das tipologias
financiadas

Colocar aqui o nome da UFCD/Curso

Configurao do computador
CPU 600MHz, 128MB de memria RAM, 80MB de espao
em disco, Placa de vdeo 3D com suporte OpenGL, Internet
Explorer 6.0 ou superior e Windows Media Player ou Quicktime
5.0 ou superior para a visualizao de tutoriais multimdia.
Tamanho: 32 MB
Sistema operacional: Windows 98/2000/XP
Servidor: Link direto | Fabricante

8
Colocar aqui os smbolos relativos a apoios das tipologias
financiadas

Colocar aqui o nome da UFCD/Curso

Software de modelao e animao 3D


O software Autodesk 3ds Max proporciona uma soluo
abrangente de modelao, animao, rendering e composio 3D
para quem desenvolve jogos, filmes e grficos em movimento.

SketchUp
outro

Software

para a criao de modelos em 3D no computador. Foi


originalmente

desenvolvido

pela At Last Software(@last


software). Posteriormente foi
adquirido pelo Google, a 14
de Maro de 2006. Em 2012,
a Trimble Navigation adquiriu
o programa. O SketchUp est
disponvel em duas verses: a verso profissional - Pro, e a
verso gratuita - Make, (para uso pessoal, no comercial). No
site e do SketchUp encontra-se para download a verso 2013
em ingls do software.

10
Colocar aqui os smbolos relativos a apoios das tipologias
financiadas

Colocar aqui o nome da UFCD/Curso

Barra de Comandos

Seleccionar
Seleciona objetos. Pressionando Shift para amplia a
seleo. Arraste o rato para fazer vrias selees.
Linha
Arraste as arestas de ponto em ponto. Arraste o
rato e clique quando achar que a linha esta
concluida.
Retngulo
Desenha faces retangulares de canto a canto. S
clicar, arrastar e clicar. Tem tambm a opo de
inserir valores para as dimenses do seu retngulo,
situado no canto esquerdo. Depois do valor digitado pressione a
tecla Enter, que a figura assumir as dimenses inseridas.
Crculo
Permite desenhar crculos de um ponto central at
o raio. S clicar, arrastar e clicar. Tem tambm a
opo de inserir valores para as dimenses do seu
cirsculo, situado no canto esquerdo. Depois do valor digitado
pressione a tecla Enter, que a figura assumir as dimenses
inseridas.
Arco
Desenha arcos de ponto em ponto com curvatura.
Para desenhar o mesmo processo do crculo e do
tringulo.

12
Colocar aqui o nome da UFCD/Curso

Colocar aqui os smbolos relativos a apoios das tipologias


financiadas

Criar componente
Criar
componente

partir

de

entidades

selecionadas.
Borracha
Apaga, ou

remove partes de um modelo.

Fita

mtrica
Mede distncias, cria linhas ou pontos guia
ou ajusta a escala de um modelo inteiro. Para
utiliz-la, selecione um ponto at o qual ir medir,

ou digite um valor. A tecla CTRL igual a ativar ou desativar a


criao de guias.
Pintura
Aplica cor e material a partes de um modelo. Ao
clicar nesse cone, o software apresentar outro
quadro com diferentes cores e texturas para
escolher e aplicar ao seu modelo. Como mostra o quadro
abaixo.

Empurra

Empurrar/puxar
puxa parte da face de um

dado modelo. Utilizado para


esculpir modelos 3D.
Mover
Move, prolonga e copia partes selecionadas.
Rodar

Gira,

prolonga,

copia

serializa

entidades

selecionadas sobre um eixo. SIFHT pressionado o


mesmo que alinhar com a face.
Equidistncia
Calcula a distncia de arestas selecionadas num
plano.
Orbitra
Orbita a viso da cmera sobre o modelo.
O boto orbit faz a movimentao em 360.
Panormica
Desloca

vista

da

cmera

vertical

ou

horizontalmente. Clicar e arrastar.

ZOOM
Amplia ou reduz a viso da cmera. Arraste o cursor para
ampliar ou reduzir o zoom: para cima, aproxima; para
baixo, distancia. Caso queira mudar o campo de viso, s necessita
de clicar em Shift.
Modelo centralizado
Amplia ou reduz a viso da cmera para mostrar o
modelo inteiro
Adicionar localizao
Adiciona geolocalizao ao modelo e obtm informaes
online.

14
Colocar aqui o nome da UFCD/Curso

Colocar aqui os smbolos relativos a apoios das tipologias


financiadas

Adicionar novo edifcio


Adiciona

um

novo

modelo

de

edifcio

utilizando

modelador de edifcios do Google.


Texturas de fotos
Adiciona texturas de fotografias a faces selecionadas.

Menus
Muitas das funcionalidades do Sketchup encontram-se agrupadas em
menus. Os seguintes menus oferecem diversas funcionalidades:

16
Colocar aqui o nome da UFCD/Curso

Colocar aqui os smbolos relativos a apoios das tipologias


financiadas

Criao

de

Cenas,

luzes

cmaras

Animaes.
O principal objetivo do SketchUp no criar animaes 3d, mas
grande parte dos utilizadores escolherem esta ferramenta gratuita
para modelar e apresentar os seus projetos. possvel realizar
algumas animaes simples usando cenas para adaptar a funo que
seria dos keyframes. Na animao atravs de cenas, o utilizador pode
apresentar diferentes ngulos do seu modelo de maneira simples,
sem a sofisticao de um software como o Blender 3D, 3ds Max ou
outro para controlar e determinar com exatido as trajetrias das
cmaras. Mas, ainda assim, para apresentaes simples necessrio
apenas mostrar diferentes pontos.

O ideal comear a trabalhar com os ajustes da animao, quando o


modelo 3d estiver totalmente concludo. A configurao da animao
funciona assim, primeiro necessrio posicionar a visualizao do
seu modelo 3d num ponto chave. Esse ponto ser usado como
marcao para a animao. Quando o ponto estiver definido,
podemos abrir o menu de gesto de cenas que acessvel em
Window->Scenes como mostra imagem acima.

No painel ao lado possvel adicionar novas cenas usando o


sinal de +. Quando uma nova cena for adicionada, altera-se a posio
da cmara e determina-se o enquadramento para o modelo 3d na
segunda cena. O mesmo procedimento pode ser realizado para outras
posies das cmaras. Com vrias cenas adicionadas, basta clicar nos

18
Colocar aqui o nome da UFCD/Curso

Colocar aqui os smbolos relativos a apoios das tipologias


financiadas

separadores com o respetivo nome da cena para que a cmara do


SketchUp deslize e se ajuste na posio em que a cena foi criada.
Ao criar uma nova cena importante manter a opo Include in
animation marcada, esta opo est disponvel no menu de cenas.
Ao clicar na sequncia nos nomes das cenas, teremos uma animao
simplificada.

Equadramento de modelos em fundos reais


Como colocar uma imagem definida num cu ou ambiente de
fundo dentro de um modelo do SketchUp?
Como muitos sabem, a adio de um fundo no SketchUp
permite inserir arquivos de imagem para o seu modelo e posicionar
estas imagens de tal forma que eles funcionem como um fundo.
Devemos
SketchUp,
selecione

guardar

opo

imagem

no

nosso

Windowns/Janela>

"edit/editar".

Selecione

computador.
Styles/Estilos,
opo

No
e

"Marca

d'gua/Watermark". Clique no sinal "+" para adicionar uma


foto como Marca d'gua/Watermark/Background/Fundo. Existe
um assistente que permite a escolha de diferentes configuraes.

Um aspeto importante no design de interiores a relao com o meio


ambiente e os pontos de vista de um espao
interior.
Para aplicar a imagem de ambiente,
criamos

uma

forma

cilndrica

que

envolva o modelo, de forma a cobrir


pontos
tivermos

de

vista
apenas

do

interior.

uma

janela

os

Se
a

curvatura ser muito menor de modo a


que o espao interior possua uma vista

como

exemplo abaixo.
Para isso, criamos uma textura e aplica-se na face plana, ajustando a
textura sobre a face plana. Podemos visualizar ainda algumas das
cenas captadas com a aplicao do fundo ambiente.

20
Colocar aqui o nome da UFCD/Curso

Colocar aqui os smbolos relativos a apoios das tipologias


financiadas

Cortes e objectos AEC. rvores, vedaes,


escadas, portas, paredes e janelas.
Desde que a Google adquiriu
os

direitos

muitas

sobre

SketchUp,

ferramentas

inclusive

opo

programa.

Sendo

importante

para

surgiram,
gratuita

uma
quem

do

opo
est

iniciar a modelagem em trs dimenses principalmente se levarmos


em conta que o software um dos mais famosos do mercado
oferecendo ferramentas eficazes e intuitivas.
Todos os recursos oferecidos pela Google encontram-se num enorme
depsito online que conta com vrios componentes e modelos em 3D,

para download.
Com o Google SketchUp Free instalado possvel aceder
pgina
Google
armazm
3D.
Ou
ento
aceder
Window/Components.

Ao entrar na pgina principal, j


existe uma grande quantidade de
opes entre colees, modelos
populares, modelos recentes e vrios
outros
tipos
diferentes
para
download.
No Google SketchUp Free,
clique no menu File e v at a
opo 3D warehouse. Em seguida,
selecione
a
ferramenta
get
models . Aparece ento, uma nova
janela dentro do software, mostrando
uma espcie de pgina principal de
acesso aos servios do Armazm 3D.

Na separao por categorias, h


tambm um campo de pesquisa. Poder realizar pesquisas de objetos
que precisa, como um avio, por exemplo:

Uma dica importante realizar a procura utilizando termos em


ingls, desta forma, a possibilidade de encontrar os resultados
pretendidos bem maior. Durante a pesquisa pode encontrar no s
modelos isolados, como tambm colees.

22
Colocar aqui os smbolos relativos a apoios das tipologias

Colocar aqui o nome da UFCD/Curso

financiadas

Existem, inclusive, pacotes com


exerccios feitos, alguns criados
pelo
prprio
Google. Aps
escolher o item desejado, clique
sobre o modelo para v-lo em
detalhes.

Clique no boto para fazer o


download
do
modelo.
Automaticamente surge a opo
para que o objeto j seja includo
no programa.

Basta clicar na opo Sim para poder ter acesso ao contedo


selecionado. Se preferir, escolha a alternativa No e ter o acesso
noutro momento, uma vez que o item ser descarregado e ficar
disponvel para quando for necessrio.

Modelao de telhados e interiores

Iremos construir as divises de uma casa com o apoio de uma


planta. Para isso abrimos o SketchUp

Comece por desenhar um retngulo, para defenir a plata


na sua textura.

24
Colocar aqui os smbolos relativos a apoios das tipologias

Colocar aqui o nome da UFCD/Curso

financiadas

Depois de criado o retngulo, clique com o boto direito do rato


e inverta a sua face.

Agora iremos importar a imagem da planta, apenas clique em


"File" "Import"

Assim que tivermos a nossa plata definida no rectngulo


desenhado podemos atravs da ferramenta lapis contornar o
desenho da planta.

Quanto toda a planta possuir


as
divises devidamente desenhadas, podemos ento fazer uma
extruso de todos os elementos. O resultado ficar semelhante
ao da imagem a baixo.

O resultado final poder ficar algo do gnero.

26
Colocar aqui os smbolos relativos a apoios das tipologias

Colocar aqui o nome da UFCD/Curso

financiadas

Modos de visualizao
Os comandos mais importantes de visualizao podem ser
feitos diretamente com o rato. Entretanto, existem algumas
movimentaes mais complexas que s podem ser feitas atravs dos
menus e paletas.

Para aproximar e afastar:


1. Na paleta Camara, clique na Ferramenta Zoom;
2. Coloque o cursor do rato no centro do
cone, clique e arraste para cima
(Aproximar) e para baixo (afastar).

Para visualizar um projeto:


1. Na
paleta
Camara,
Ferramenta Orbit;

Clique

na

2. Coloque o cursor do rato no centro


tela, clique e arraste para navegar.
pretende
manter
a
tecla
Shift
pressionada enquanto clica e arraste o
o SketchUp faz o movimento conhecido
como Pan.

da
Se
rato,

Para ampliar determinada rea:


1. Na paleta Camara, clique na Ferramenta Zoom Window;
2. Clique uma vez para indicar o comeo da rea a ser
ampliada. Arraste o rato e solte onde voc quer definir o fim
da janela de ampliao.

28
Colocar aqui os smbolos relativos a apoios das tipologias

Colocar aqui o nome da UFCD/Curso

financiadas

Para fazer um deslocamento lateral do observador:


1. Na paleta Camera, clique na Ferramenta Pan;
2. Coloque o cursor do rato no centro da tela, clique e arraste para
qualquer lado para deslocar o observador.

Como colocar o observador dentro do projeto


1. V ao menu Camara/Standard Views/Top;
2. Na paleta Walk, clique na Ferramenta Position Camera;
3. Clique onde pretende posicionar o observador e segure o boto
do rato. Solte o boto na direo em que o observador est a
olhar.

4. No VCB (Value Control Box), digite a altura do observador;


5. Em seguida, o SketchUP ativa automaticamente a ferramenta
Look Around. Clique e arraste para movimentar a a cabea do
observador sem mud-lo de lugar.

30
Colocar aqui os smbolos relativos a apoios das tipologias

Colocar aqui o nome da UFCD/Curso

financiadas

Abrir e guardar documentos


O Sketchup, ao ser iniciado pela primeira vez, apresenta uma
janela para ajustes no programa. Escolha entre Perspective View ou
Top View para definir a vista padro do programa (em perspetiva ou
em vista de topo); em Units, escolha as unidades que deseja utilizar.
Todos estes ajustes podem ser alterados posteriormente. Clique em
Continue para sair da janela.
Uma nova janela, chamada Learning Center, contm dicas sobre
o uso do programa. Se pretende que esta janela aparea sempre ao
iniciar o programa, clique em Show tips on start up.
Ao fechar esta janela, o Sketchup apresenta automaticamente a
janela de desenho, e podemos comear a desenhar imediatamente,
ou ento realizar algumas das seguintes tarefas:
Para criar um novo documento:
1. V ao menu File/New..;
2. O SketchUp abre uma nova janela de desenho. As suas
configuraes (unidades, localizao, cores, padro, etc)
esto baseadas no arquivo Template, que pode ser escolhido
em Window/Preferences/Template.
Para abrir um documento:
1. V ao menu File/open.., indicando na sequncia o nome do
arquivo a ser aberto.

Para salvar um documento:


1. Use o menu File/Save;
2. 2. Se for a primeira vez que o arquivo ser guardado, o
Sketchup pode o nome do arquivo e a sua localizao no
computador:
3. Se no for a primeira vez, o arquivo gravado com o
mesmo nome com que foi criado e no mesmo lugar;
4. Para salvar o documento com outro nome e/ou coloc-lo
noutro local do computador usamos o comando File/Save
As.

32
Colocar aqui os smbolos relativos a apoios das tipologias
financiadas

Colocar aqui o nome da UFCD/Curso

Importar e exportas elementos


Importe 3DS: Economize tempo em sua modelagem
Voc pode importar arquivos 3DS diretamente para seus modelos do
SketchUp.

Importe imagens: Pinte paredes com fotos


Com o SketchUp, voc pode importar arquivos de imagem em
formatos como JPG, TIFF, PNG e PDF. Voc pode us-los tal como so
(como se fossem psteres), mas tambm pode col-los em superfcies
para criar modelos foto realsticos de construes, desenhos de
embalagens e outros itens.

34
Colocar aqui o nome da UFCD/Curso

Colocar aqui os smbolos relativos a apoios das tipologias


financiadas

Exportar

nos

formatos

TIFF,

JPEG e PNG
O SketchUp permite
exportar

imagens

raster de at 10 mil
pixels

quadrados.
Portanto,

gerar

uma
imagem
para
envi-la
por

e-

mail,
public-la

em

um

documento ou projet-la sobre uma parede to fcil quanto escolher


umas poucas opes e clicar em Exportar.

36
Colocar aqui o nome da UFCD/Curso

Colocar aqui os smbolos relativos a apoios das tipologias


financiadas

Seleo de objetos
Todos os objetos do Sketchup so construdos com linhas e
faces. Uma face s existe
quando estiver envolvida completamente por linhas que esto
num mesmo plano. Pode ainda selecionar uma srie de linhas e
faces, podendo transformar este conjunto num Grupo ou
Componente.
Como selecionar uma linha:
1. Na paleta Principal, clique
Ferramenta Select;
2.
Clique
uma
vez
diretamente sobre a linha que
deseja.

Como selecionar uma


face:
1. Na paleta Principal, clique
na Ferramenta Select;
2.
Clique
uma
vez
face que deseja
Como
selecionar
um
objeto:
1. Na paleta Principal, clique na
Select;
2. Clique trs vezes sobre
do projeto, que o sketchup
selecionar todas as linhas e
faces conectadas a ele.

na

diretamente

sobre

Ferramenta
qualquer

Para selecionar mais de


um objeto:
1. Na paleta Principal, clique na Ferramenta Select;

elemento

2. Clique trs vezes sobre o primeiro objeto a ser selecionado;


3. Prima e mantenha a tecla Shift pressionada, e clique trs
vezes sobre pos outros
objetos para Selecion-los;
4. Se voc clicar trs vezes sobre um objeto j selecionado, o
SketchUp ir tir-lo da seleo.
Outras opes interessantes:
1. Se clicar duas vezes sobre uma linha, o SketchUp far a
seleo da linha e todas as faces conectadas a ela.
2. Se clicar duas vezes numa face, o SketchUp far a seleo da
face e de todas as linhas conectadas a ela.
3. Algumas opes de ediao de objetos s aparecem quando
selecionamos apertando o boto direito do rato. Nesse caso o
SketchUp mostra o menu contextual. as informaes deste
menu (que variam de acordo com o objeto selecionado) sero
comentadas ao londe deste livro.

38
Colocar aqui o nome da UFCD/Curso

Colocar aqui os smbolos relativos a apoios das tipologias


financiadas

Sistemas

de

coordenao
Unidades, localizao e
Template
Os items citados acima so os
principais
a
serem
configurados,
dentre vrios que existem no SketchUp. Como todo software
americano, vem com as suas unidades padro em polegadas, e para
efeitos de clculo de luz solar, localizado inicialmente nos EUA. A
ideia deste tpico mostrar como alterar esses parmetros e criar
um novo template (Gabarito) que seja o ponto de partida do
SketchUp.
Para alterar a Unidade:
1. Ir ao menu Window/Model Info, e escolhera opo Units;
2. No campo Format, escolha Decimal. No campo ao lado (que estava
travado e passa a ser habilitado), escolha Meters. Se quiser, altere o
campo Precision para 0,00m (duas casas decimais).
Para Mudar a Localizao

1. V ao menu Window/Model info, e escolha a


opo Location;
2. Em country, escolha Portugal. Em
seguida, escolha a cidade entre as
que vem pr-configuradas no
programa;
3. Se quiser criar um novo local,
clique
no
boto
Custom
Location
e
coloque
as
informaes necessrias (pas,
localidade, latitude, longitude e
zona horria);
4. Indique a quantos graus est o
Norte do projeto em relao ao eixo vertical do programa, digitando o
valor no campo ou clicando com Select, para em seguida apontar a
direco no prprio desenho;
5. A indicao Show in model faz com que o Norte seja apresentado no
desenho como um eixo alaranjado.

Para criar um template:


1. Configure o arquivo(unidades, localizao e qualquer outro tipo de
informao, inlcuindo desenhos, se for caso ) e salve-o, usando
File/Save na pasta que desejar;
2. No menu Window/Preferences, escolha Template;
3. Clique no boto Browse.., e indique o arquivo criado no item 1 acima;
4. Clique em Abrir... o Sketchup volta para a janela anterior;

40
Colocar aqui os smbolos relativos a apoios das tipologias

Colocar aqui o nome da UFCD/Curso

financiadas

5. Confirme o arquivo, que agora aparece entre os da lista ao lado


esquerdo do boto Browse Da prxima vez que o SketchUp for
iniciado, esse ser o template usado para mostrar a janela de
desenho.

Webgrafia
SketchUp. Disponvel em:
https://www.sketchup.com/intl/pt-BR/training/videos.html
Como criar ambientes no SketchUp 8. Disponvel em:
http://cad.cursosguru.com.br/cursos/sketchup/cursosketchup-8-projeto-interiores/criando-ambientes-no-sketchup8/
Manual SketchUp em portugus. Disponvel em:
http://pt.scribd.com/doc/23975291/Manual-Sketchup-emPortugues
Alan Britto, Cursos online. Disponvel em:
http://www.allanbrito.com/2009/02/18/tutorial-sketchupanimacao-de-camera/
http://sketchup-interiordesign.blogspot.co.uk/2012/07/backgrounds-and-landscapeviews-in_19.html
Google SketchUp: como adquirir componentes no armazm 3D do
Google. Disponvel em:

http://www.tecmundo.com.br/tutorial/23487-googlesketchup-como-adquirir-componentes-no-armazem-3d-dogoogle.htm#ixzz2hvaW1UWi
Sketchup: Wikipdia. Disponvel em:
http://pt.wikipedia.org/wiki/SketchUp