Você está na página 1de 34

Tutorial FreeCad

Draft Module
(Redirecionado de Draft Workbench)

The Draft workbench allows to quickly draw


simple 2D objects in the current document,
and offers several tools to modify them
afterwards. Some of these tools also work
on all other FreeCAD objects, not only
those created with the Draft workbench. It
also provides a complete snapping system,
and several utilities to manage objects and
settings.

Drawing objects
These are tools for creating objects.

Mdulo de projecto
(Redirecionado de Bancada de trabalho de
projecto )

A bancada de trabalho de projecto permite


desenhar rapidamente objetos 2D simples
no documento atual e oferece vrias
ferramentas para modific-los depois.
Algumas dessas ferramentas tambm
funcionam em todos os outros objetos
FreeCAD, no apenas aqueles criados com
a bancada de trabalho de projecto. Ele
tambm fornece um completo sistema de
encaixe e vrios utilitrios para gerenciar
objetos e configuraes.

Objetos de desenho
Estas so ferramentas para a criao de
objetos.

Line: Draws a line segment

Linha: desenha um

between 2 points

Wire: Draws a line made of

segmento de reta entre 2 pontos


Fio: desenha uma linha feita

de vrios segmentos de linha (polilinha)


Crculo: desenha um crculo

de centro e raio
Arc: desenha um segmento

de arco do centro, raio, ngulo de incio


e ngulo final
Elipse: desenha uma elipse

a partir de dois pontos de canto


Polgono: desenha um

polgono regular de um centro e um


raio
Retngulo: desenha um

multiple line segments (polyline)

Circle: Draws a circle from


center and radius

Arc: Draws an arc segment


from center, radius, start angle and end
angle

Ellipse: Draws an ellipse from


two corner points

Polygon: Draws a regular


polygon from a center and a radius

Rectangle: Draws a rectangle


from 2 opposite points

retngulo de 2 pontos opostos

Text: Draws a multi-line text


annotation

Dimension: Draws a

Texto: desenha uma


anotao de texto de vrias linhas
Dimenso: desenha uma
anotao de dimenso

dimension annotation

BSpline: Draws a B-Spline

from a series of points

BSpline: desenha uma BSpline de uma srie de pontos


Ponto: insere um objeto de

Point: Inserts a point object


ponto

ShapeString: The

ShapeString: O ShapeString

ShapeString tool inserts a compound

ferramenta insere uma forma


composta, que representa uma
seqncia de caracteres de texto em
um determinado ponto no documento
atual
Facebinder: cria um novo

objeto de faces selecionadas em


objetos existentes
Curva de Bzier: desenha

shape representing a text string at a


given point in the current document

Facebinder: Creates a new


object from selected faces on existing
objects

Bezier Curve: Draws a Bezier


curve from a series of points

uma curva de Bzier de uma srie de


pontos

Modifying objects
These are tools for modifying existing
objects. They work on selected objects, but
if no object is selected, you will be invited to
select one.

Move: Moves object(s) from


one location to another

Modificando objetos
Estas so ferramentas para modificar
objetos existentes. Eles trabalham em
objetos selecionados, mas se nenhum
objeto estiver selecionado, voc ser
convidado para selecionar um.

Rotate: Rotates object(s) from


a start angle to an end angle

Mover: move o objeto (s) de


um local para outro
Rotate: Rotaciona o objeto

Offset: Moves segments of an

(s) de um ngulo de incio para um


ngulo de fim
Deslocamento: segmentos

de um objeto move-se sobre uma certa


distncia
Trim/Extend (Trimex): apara

ou estende-se um objeto
Atualizar: junta-se a objetos

em um objeto de nvel superior


Downgrade: explode objetos

em objetos de nvel inferior


Escala: escalas selecionado

object about a certain distance

Trim/Extend (Trimex): Trims or


extends an object

Upgrade: Joins objects into a


higher-level object

Downgrade: Explodes objects


into lower-level objects

Scale: Scales selected


object(s) around a base point

Drawing: Writes selected

objeto (s) em torno de um ponto base

Desenho: grava os objetos

objects to a Drawing sheet

Edit: Edits a selected object

Wire to BSpline: Converts a


wire to a BSpline and vice-versa

Add point: Adds a point to a


wire or BSpline

Delete point: Deletes a point

selecionados para uma folha de


desenho
Editar: edita um objeto

selecionado
Fio para BSpline: converte

um fio para um BSpline e vice-versa


Ponto de Add: Adiciona um

ponto de um fio ou BSpline


Ponto de excluir: exclui um

ponto de um fio ou BSpline


Vista 2D de forma: cria um

from a wire or BSpline

Shape 2D View: Creates a 2D


object which is a flattened 2D view of
another 3D object

objeto 2D que uma vista 2D plana de


outro objeto 3D

Draft to Sketch: Converts a

converte um objeto de projecto para o


desenho e vice-versa
Array: cria uma matriz

retangular ou polar de objetos


selecionados
Path Array: cria uma matriz

de objetos, colocando as cpias ao


longo de um caminho
Clone: Clones de objetos

Draft object to Sketch and vice-versa

Projecto de desenho:

Array: Creates a polar or


rectangular array from selected objects

Path Array: Creates an array


of objects by placing the copies along a
path

Clone: Clones the selected


selecionados

objects

Utility tools
Additional tools available via right-click
context menu, depending on the selected
objects.

Set working plane: Sets a


working plane from a standard view or
a selected face

Utilitrio de ferramentas
Ferramentas adicionais disponveis atravs
do menu de contexto do boto direito do
mouse, dependendo dos objetos
selecionados.

Finish line: Ends the drawing

avio: define um plano de trabalho de


um modo de exibio padro ou uma
face selecionada
Linha de chegada: termina o

desenho do fio atual ou bspline, sem


fech-lo
Linha estreita: termina o

desenho do fio atual ou bspline e


fecha-lo
Linha de desfazer: desfaz o

of the current wire or bspline, without


closing it

Conjunto de trabalhando

Close line: Ends the drawing


of the current wire or bspline, and
closes it

Undo line: Undoes the last


segment of a line

Toggle construction mode:


Toggles the Draft construction mode
on/off

ltimo segmento de uma linha

Alternar modo de

construo: alterna o modo de


construo do projecto de ligar/desligar
Alternar modo de continuar:

alterna o projecto continua modo de


ligar/desligar
Aplicar estilo: aplica-se o

atual estilo e a cor de objetos


selecionados
Alternar o modo de

visualizao: alterna o modo de


exibio de objetos selecionados entre
"linhas planas" e "wireframe"
Adicionar a grupo:

rapidamente adiciona objetos


selecionados a um grupo existente
Selecione o contedo do

grupo: seleciona o contedo de um


grupo selecionado
Ativar/desativar snap:

alterna snap ao objeto ligado/desligado


Grade de alternncia:

alterna a grade de ligar/desligar


Mostrar barra de presso:

Mostra/oculta a barra de ferramentas


do encaixe
Heal: cura problemticos

objetos de rascunho encontrados em


arquivos muito antigos
Dimenso de inverter:

Toggle continue mode:


Toggles the Draft continue mode on/off

Apply style: Applies the


current style and color to selected
objects

Toggle display mode:


Switches the display mode of selected
objects between "flat lines" and
"wireframe"

Add to group: Quickly adds


selected objects to an existing group

Select group contents:


Selects the contents of a selected
group

Toggle snap: Toggles object


snapping on/off

Toggle grid: Toggles the grid


on/off

Show snap bar: Shows/hides


the snapping toolbar

Heal: Heals problematic Draft


objects found in very old files

Flip Dimension: Flips the


orientation of the text of a dimension

VisGroup: Creates a VisGroup

inverte a orientao do texto de uma


dimenso
VisGroup: cria uma

in the current document


VisGroup no documento atual

File formats
The Draft module provides FreeCAD with
importers and exporters for the following file
formats:

Autodesk .DXF: Imports and


exports Drawing Exchange Format files

Formatos de arquivo
O mdulo de projecto fornece FreeCAD
com importadores e exportadores para os
seguintes formatos de arquivo:

created with 2D CAD applications

SVG (as geometry): Imports and

exports Scalable Vector Graphics files


created with vector drawing
applications

Open Cad format .OCA: Imports


and exports OCA/GCAD files, a
potentially new open CAD file format

Airfoil Data Format .DAT: Imports

DAT files describing Airfoil profiles

Autodesk .DWG: Import and exports


DWG files via the DXF importer, when

the Teigha Converter utility is installed.

FreeCAD and DWG Import: Import


and exports DWG files

Caractersticas adicionais

Additional features

Snapping: Allows to place new

points on special places on existing


objects

Constraining: Allows to place new


points horizontally or vertically in

Autodesk. DXF: importaes e


exportaes arquivos de formato de
intercmbio de desenho criados com
aplicativos de CAD 2D
SVG (como geometria): importaes e
exportaes Scalable Vector Graphics
arquivos criaram com aplicativos de
desenho vetorial
Formato Cad aberto. OCA:
importaes e exportaes de arquivos
OCA/GCAD, um novo potencialmente
abrir formato de arquivo CAD
Dados do aeroflio de formato. DAT:
importaes DAT arquivos descrevendo
perfis de aeroflio
Autodesk. DWG: importao e
exportao de arquivos DWG atravs
do importador DXF, quando a utilidade
do Conversor Teigha est instalada.
FreeCAD e DWG importao:
importao e exportao de arquivos
DWG

Aligator: permite colocar novos pontos


em lugares especiais em objetos
existentes
Constraining: permite colocar novos
pontos horizontalmente ou
verticalmente em relao aos pontos
anteriores
Trabalhando com coordenadas
manuais: permite para inserir
coordenadas manuais em vez de clicar
na tela

Avio a trabalhar: permite que voc


defina um avio no espao 3D, onde
vo ser o prximo operaes

relation to previous points

Configuraes de preferncias

Working with manual coordinates:


Allows to enter manual coordinates

O mdulo de projecto tem sua tela de


preferncias

instead of clicking on screen

Working plane: Allows you to define

O mdulo de projecto dispe de uma


completa API de projecto assim que voc
pode usar as suas funes em scripts e
macros

a plane in the 3D space, where next


operations will take place

Preference settings

Criao de scripts

The Draft module has


its preferences screen

Scripting
The Draft module features a complete Draft
API so you can use its functions in scripts
and macros

Iniciando um projeto
Draft tutorial
Este tutorial vai ensinar voc como usar do FreeCAD mdulo de desenho 2D
(tambm chamado de mdulo de projecto) para criar um desenho de arquitetura
simples. Para essa finalidade, podemos estar atraindo uma cabine de alvenaria
simples. Vamos supor que ns recebemos um CAD desenho mostrando a
localizao da cabine, e vou us-lo para desenhar nosso projeto em cima dela.
Vamos desenhar um plano, uma seo e duas elevaes.
ndice
[ocultar]
1 Before you begin

ndice
[ocultar]

1 antes de comear

2 criao de seu espao de


trabalho do FreeCAD

3 desenhos CAD importando

4 desenho da vista de planta


o 4.1 usando as
ferramentas de
desenho
o 4.2 uma nota sobre
upgrade e downgrade
o 4.3 outra nota sobre
encaixe
o 4.4 importando e
construindo objetos
compostos
o 4.5 dimenses e
anotaes
o 4.6 a organizao

5 as elevaes de desenho
o 5.1 rotacionar a vista e
criao de macros
o 5.2 as girado vistas de
desenho

2 Setting up your FreeCAD workspace


3 Importing CAD drawings
4 Drawing the plan view

4.1 Using the drawing tools

4.2 A note about upgrade &

downgrade
o

4.3 Another note about

4.4 Importing and building

snapping
o

compound objects
o

4.5 Dimensions and

annotations
o

4.6 Organizing

5 Drawing the elevations


o

5.1 Rotating the view, and

creating macros
o

5.2 Drawing the rotated views

Antes de comear
Tenha em mente que FreeCAD ainda em fase inicial de desenvolvimento, portanto voc
pode no ser to produtivo quanto com CAD outro aplicativo e voc vai certamente
encontrar bugs, ou experimentar falhas. FreeCAD agora tem a capacidade de salvar
arquivos de backup. O nmero daqueles arquivos de backup pode ser especificado na
caixa de dilogo Preferncias. No hesite em permitir que os arquivos de backup de 2 ou 3
at que voc sabe bem como lidar com FreeCAD.

Guarde o seu trabalho, muitas vezes, de vez em quando salvar seu trabalho com um nome
diferente, ento voc tem uma cpia de "segura" para cair para trs e estar preparado para
a possibilidade de que alguns comandos no podem lhe dar os resultados esperados.

Setting up your FreeCAD workspace


FreeCAD is a 3D modeler, but in this tutorial we will use it only for working in 2D. So, we
will be drawing on the ground plane, and everything we do will have a Z coordinate of zero.

So first, let's put ourselves in top view by pressing the 2 and be sure we are in orthographic
projection (key O) otherwise we might get fooled by some perspective effects.
Another very important thing to do, is to give custom hotkeys to your Draft commands. So
you can do all the commands from the keyboard, which will drastically improve your speed.
Basically you can do about everything from the keyboard, and will need the mouse only to
draw points and select objects. Go to menu Customize -> Keyboard -> Category Python
and select shortcuts as you like, a good idea is to make them easy to remember. For
example, I use L for Line, W for Polyline (also called Wire in FreeCAD), A for Arc, C for
Circle, M for Move, R for Rotate, F for Offset (O is already taken by Orthographic), D for
Dimension, T for Text, etc...
Now we are set up, we can begin to draw.

Importing CAD drawings


If you are going to import a 2D cad drawing, chances are high that they will be in a
proprietary format such as .dwg (from AutoCAD) or .mcd (from VectorWorks). The
specification of those file formats are being kept secret by their vendors, so it is extremely
difficult or totally impossible for FreeCAD to support them. However, One file format that is
fairly well documented is the DXF format, and the Draft module supports it partially.
Almost all CAD applications can export to the DXF format, and you also have several free
converters such as openDWG's "Teigha file Converter" utility, that will allow you to convert
your file to the DXF format. For example, Doublecad is a free, fully functional CAD program
that allows you to export DXF files:

Open your DXF file simply with the File -> Open dialog. Several import settings can be
configured in the Draft Preferences screen. For example, you can configure if you want the
DXF file to be imported with original colors and linewidths, or converted to current Draft
color, that you see at the right side of the Draft command bar. But in FreeCAD you won't
need to attribute ugly colors to your objects to determine their linewidth. Objects all have
independent color and linewidth attributes. So, you can very well forget about DXF colors,
or convert everything to the colors of your choice.
After importing your drawing in FreeCAD, it will look like this:

Let's begin with doing some cleaning.

In FreeCAD, there are no layers like in AutoCAD. We work with groups instead. Groups are
another more flexible way to organize your drawing. You can create new groups with a
right-click on the tree view, rearrange them, move them into other groups, or move objects

to/from groups simply by dragging and dropping things in the tree view. You can also assign
current line width and colors to all objects in a group, or turn them on or off by
pressing SPACE.
Let's put all our objects into one new group, and turn off everything we won't use, like
vegetation and dimensions, to speed up our work.

Drawing the plan view


Using the drawing tools
The only thing we'll need at the moment is the area that is assigned to our cabin. It lies in a
separate group named "projection". So we can basically turn off everything else with
the SPACE key, and start drawing on top of it. We will draw a small cabin with a guard
room and a WC, in very simple structural masonry, so there won't be any need for special
concretework in the plan itself. But we'll put a layer of plaster inside, and a layer of
ceramics outside.
So, let's begin with doing the general shape of our walls:

Our DXF drawing was drawn in meters, so unless we have any reason to change that, we'll
continue with the same units. FreeCAD currently does not have a friendly system to work
with real-world units, so we simply assume that "one" means "one meter".
Another good thing to remember is to construct temporary geometry whenever you need.
You want a point that lies 2 meters away horizontally? Draw a vertical line, move it 2m
away, pass a horizontal line through it, there is your point.

Create a rectangle: Snap its cornerpoints with CTRL to the corners of the assigned
area

Offset the rectangle: With the rectangle selected, press Offset, press C to turn on
copy mode, move your mouse inside the first rectangle so offset knows in which
direction to go, and type 0.20, Enter

Turn them into a face: Upgrade the first rectangle, upgrade the second rectangle,
then select the outer rectangle, CTRL-select the inner rectangle and press Downgrade

Create the door opening: Make a 1.00 x 0.50 rectangle, move it to the upper corner
of our main wall (press C to turn copy mode off).

Move the door opening to the right position: Move it 0.10 to the left. We won't put
our opening directly on the corner, because it would make the door difficult to open.

Subtract the door opening: Select the wall, CTRL-select the door opening, and
press downgrade.

A note about upgrade & downgrade


Now, you must be aware that the openCasCade kernel that FreeCAD is built upon, is a 3D
kernel. It is made primarily for 3D operations. When it has to cut or unite planar faces, like
we are doing now with upgrade/downgrade operations, it sometimes does strange things,
and subsequent operations (like other upgrades/downgrades) sometimes don't give the
expected results. Of course with time those behaviours will end up being corrected by the
FreeCAD developers, but it is wise to know alternative ways to solve immediate problems.
The best way to solve a face that isn't upgrading/downgrading/offsetting correctly, is simply
to downgrade it until it is all exploded to single edges, then upgrade those edges together
again up to a new face. In case that doesn't work either, simply redraw a new wire
(polyline) on top of the problematic face, snapping to its endpoints, then delete the old face
and upgrade the new wire. Usually a face that you draw yourself is in much better shape
than a face that you obtained by upgrade/downgrade.
Another thing to keep in mind is that when you subtract a shape from another, you can find
yourself with one object containing several faces. This might difficult your further work (they
don't offset correctly, etc), so a good thing in that case is always to separate them with the
downgrade tool.

Another note about snapping


There are two forms of snapping in the Draft module: passive snap, which occurs when you
simply pass your mouse cursor over an object (an open circle symbol appears), and active
snap, which is when you press CTRL. Active snapping allows you to snap to specific points
on an object, like its endpoints, midpoints, centers, or intersections with other objects. If you
press SHIFT, which is the key for constraining horizontally and vertically, you gain even
more snapping points. But this has a cost, because FreeCAD must do many calculations in
real time. If you have many objects, you'll begin to feel the difference. So a good trick to
speedup your work is to take the habit of working as much as possible with SHIFT and
passive snapping only. You will see quickly that you'll obtain accurate results and work
much faster.
So let's go back to work:

Create a 10cm-wide wall between the main room and the WC. Upgrade it, then
upgrade it together with the main wall to unite them

Create other rectangles for your other openings. I put a 60cm-wide window in what
will become the WC, a 80cm door between the main room and the WC, and for the big
window in the main room I simply left 40cm wall at the left and right side.

Offset all the walls of 1cm, to make a cement/plaster layer, then downgrade the
offsetted copies to turn them into simple wires

Create a layer of ceramics on the exterior side, by offsetting our plaster line 2cm,
then drawing a 2cm-thick shape between the two lines

Delete the 2cm offset. that we don't need anymore, as well as all construction
geometry. If you feel you might need them later, simply put them in a separate group
and turn that group off with SPACE.

This is where we are now (I kept construction geometry there, in blue, for you to see):

Importing and building compound objects


In FreeCAD, compound objects are objects made with the geometry of several other
objects. In other softwares, it is called blocks, symbols or components. It is a very handy
way to group geometry under one single object. Any of the objects created with the draft
module can be grouped into a compound. The command to create a compound is
the Upgrade command. The use is simple, select everything you want to turn into a
compound, and press Upgrade. If no other more intelligent shape can be created, they will
be turned into a compound.
Using compound geometry is specially useful to build a symbol library on your disk, so you
can reuse them later. One cool use of this, coupled to the DXF import function, is that you
can very easily use symbol libraries in DXF format (if your symbols are in dwg format, the
free "Teigha file Converter" application can batch-convert all your library at once).

Once you have a library of DXF symbols, just drag one of them and drop it on top of your
open FreeCAD window and it will be imported in the current document. It won't be imported
as a compound, but all of the symbol geometry will be placed in a separate group, so it is
easy to select it all and simply press "Upgrade". Beware that AutoCAD users have the bad
habit of drawing things very far from the origin point (0,0,0), your inserted symbol can then
lie very far from your drawing zone.
So, back to our drawing:

Import a sanitary block if you have one, or pick one on the Cad Exchange site, and
convert it to DXF with the "Teigha file Converter"

Create the geometry for a door, upgrade it to a compound, copy it to the other door
location, downgrade it, adjust the elements to the new size, and upgrade it again

Do the same for the windows

Dimensions and annotations


Now that our plan is more or less ready, we can add dimensions and texts. This is usually
pretty straightforward, so there is probably no need to explain much. Just try to dimension
everything, and as a convention, always start the dimension lines from the main wall line,
not the finishing layer. One thing is good to know, sometimes you draw a text or a
dimension over a filled area, and the filled area will cover your dimension. There is a simple
way to fix that, it is by downgrading and upgrading again the filled area. It will then be
displayed under the other elements.

The dimension and text will by default have the same text height, which can be changed in
the Draft Preferences page. You can then edit individually each text height.
Unfortunately certain non-geometry objects like texts and dimension are still not selectable
in the FreeCAD 3D view, you must therefore select them in the tree, and you won't be able
to snap to them, but this will probably be solved in a near future. It is also not possible at
the moment to choose a font style. To align dimensions, at the moment, you need to draw a
line first, then snap your dimensions to that line.

Organizing

Finally, we can add a few things to finish our plan, like putting vegetation around the cabin.
We can simply copy a few trees from our imported DXF drawing and scale them down with
the scale tool, to for example (0.5,0.5). We can also change the line thickness of a couple
of objects, for example make the walls thicker, and change the color of some things. And
we can organize all our elements in groups.
The ability to organize your work in nested groups is surely one of the big advantages of
groups over traditional work with layers. In this tutorial, I grouped my objects by type, inside
the Plan group. For example, instead of having one big layer with all dimensions of your
drawing, each part of the drawing will contain their own dimensions group, making it
extremely easy to organize your drawing.
You might feel a loss at first if you come from a traditional drawing program like AutoCAD,
but you'll quickly see the power that this method brings.
For example, all our construction geometry can go in a separate group, that we'll turn off.
Maybe later we'll need to make some changes, and it will be handy to have that geometry
available.
So, now we are ready to draw other parts...

Drawing the elevations

Since in this exercise we are going to stay in pure 2D, we will draw our elevations and
sections directly. In more advanced architecture environments (what FreeCAD will
hopefully become in some future), we wouldn't need to draw the elevations. We would
model the building in 3D and then generate the different views automatically. But for the
sake of this exercise (and also because all the needed tools are still not implemented in
FreeCAD), we'll do it by hand, like in the old times.
We'll begin with the rear wall elevation, because the way our plan is oriented, it can be
drawn directly below it, without the need to rotate the view. We will simply draw
construction lines from the plan, set horizontal lines to the desired heights, I set the 0.00
level, the +0.15 level of the slab, then heights for the windows, and the roof slab at +2.50.
We can then draw our geometry very quickly on top of it.
We can then place a couple of annotations, dimensions, and upgrade some of the objects
so they appear filled with a color. Finally, we can make a bit of cleaning by creating a
"South Elevation" group, then subgroups for our construction geometry and annotations,
and place all of our new objects in them.

Rotating the view, and creating macros


Now, we need to draw other elevations of our little building. The simplest way would be to
draw them directly under the plan view, as we did with the south elevation. For this, it would
be handy to be able to rotate the view by 90, so we can continue drawing our elevations
"on foot". Unfortunately, FreeCAD has at the moment no "Rotate View" tool. But,
fortunately, it has tools for us to easily create our own tools, called Macros. So, this is a
good opportunity for us to try something easy.
Macros, as well as all scripting in FreeCAD, is done in a very simple programming
language called python. You can write very complex programs in FreeCAD in python, but
you can also use it to perform very simple operations where there still isn't a proper
FreeCAD toolbar icon, such as our Rotate The View tool. So, first thing to do, open the
Report view, if you closed it, and select the python tab. In there, type (or copy/paste) the
following code:
import math
from pivy import coin
cam = Gui.ActiveDocument.ActiveView.getCameraNode()
rot = coin.SbRotation()
rot.setValue(coin.SbVec3f(0,0,1),math.pi/2)
cam.orientation = rot
This small script will simply rotate the view by 90 (left). For rotating by -90 (right), you
would simply change math.pi/2 by -math.pi/2. If you would like to learn more about python
scripting in FreeCAD, there is an extensive Scripting section on this wiki.
Now, we need to do one more step, which is save our piece of code in a macro, so we can
reuse it later. So, instead of pasting our code in the python interpreter, let's open the macro
manager (Tools -> Macros), create a new macro, press the "Edit" button and paste our
code in it. Close the macro editor tab, and the macro will be saved.
The macros can behave like any other FreeCAD tool. With the Tools -> Customize menu,
we can add an icon to our macro, a keyboard shortcut, and add it to a toolbar.

Drawing the rotated views

Now that we can rotate the view at will, we can draw our other elevations. The easiest way
is to draw your elevation at the right place under the plan view, and use a "mirror" (a 45oriented line) to push the height lines from another elevation. This way, drawing goes pretty
fast.
Finally, we draw 2 others elevations, and since the fourth one is the same as the second
one (but mirrored), we will skip it. We can then draw a cross section, and our drawing is
complete:

Antes de comear
Tenha em mente que FreeCAD ainda em fase inicial de desenvolvimento,
portanto voc pode no ser to produtivo quanto com CAD outro aplicativo e
voc vai certamente encontrar bugs, ou experimentar falhas. FreeCAD agora
tem a capacidade de salvar arquivos de backup. O nmero daqueles arquivos
de backup pode ser especificado na caixa de dilogo Preferncias. No hesite
em permitir que os arquivos de backup de 2 ou 3 at que voc sabe bem como
lidar com FreeCAD.
Guarde o seu trabalho, muitas vezes, de vez em quando salvar seu trabalho
com um nome diferente, ento voc tem uma cpia de "segura" para cair para
trs e estar preparado para a possibilidade de que alguns comandos no podem
lhe dar os resultados esperados.

Criao de seu espao de trabalho do FreeCAD


FreeCAD um modelador 3D, mas neste tutorial vamos us-lo apenas para
trabalhar em 2D. Ento, ns de desenho sobre o plano de cho, e tudo o que
fazemos ter uma coordenada Z de zero. Ento, primeiro, vamos colocar nos
top Visualizar pressionando o 2 e certifique-se de que estamos em projeo
ortogonal (tecla O) caso contrrio que ns pode ser enganados por alguns
efeitos de perspectiva.
Outra coisa muito importante a fazer, dar Personalizar teclas de atalho para
seus comandos de projecto. Ento voc pode fazer todos os comandos do
teclado, que ir melhorar drasticamente a sua velocidade. Basicamente, voc
pode fazer sobre tudo do teclado e vai precisar do mouse somente para
desenhar pontos e selecionar objetos. Ir para menu Personalizar -> teclado ->
Python de categoria e selecionados atalhos como voc gostam, uma boa idia
faz-los fcil de lembrar. Por exemplo, eu uso L para linha, W para polilinha
(tambm chamado de fio em FreeCAD), um arco, C para o crculo, M para
mover, R para rotacionar, F para deslocamento (O j tomado por ortogonal),
D para a dimenso, T para texto, etc...
Agora ns so configurados, podemos comear a desenhar.

Importao de desenhos CAD


Se voc estiver indo para importar um desenho do cad 2D, as chances so
altas que eles estaro em um formato proprietrio como. DWG (do AutoCAD)
ou .mcd (do VectorWorks). A especificao desses formatos de arquivo so
sendo mantido em segredo por seus fornecedores, por isso extremamente
difcil ou impossvel para FreeCAD para apoi-los. No entanto, um formato

de arquivo que est bastante bem documentado o formato DXF, e o mdulo


de projecto apoia-lo parcialmente.
Quase todas as aplicaes do CAD podem exportar para o formato DXF, e
voc tambm tem vrios conversores grtis como utilitrio de "Conversor de
arquivo de Teigha" do openDWG, que permitir que voc converter o arquivo
para o formato DXF. Por exemplo, o Doublecad um programa de CAD
grtis, totalmente funcional que permite exportar arquivos DXF:

Abra o seu arquivo DXF simplesmente com o arquivo -> caixa de dilogo
abrir. Vrias configuraes de importao podem ser configuradas na tela
de Preferncias do projecto . Por exemplo, voc pode configurar se quer o
arquivo DXF a ser importado com cores e linewidths originais, ou convertido
para a cor atual do projecto, que voc v no lado direito da barra de comandos
do projecto. Mas na FreeCAD voc no precisar de cores feias atributo seus
objetos para determinar sua linewidth. Todos os objetos tm atributos de cor e
linewidth independentes. Ento, voc pode muito bem esquecer cores DXF ou
converter tudo para as cores de sua escolha.
Depois de importar o seu desenho em FreeCAD, olhar como este:

Vamos comear fazendo uma faxina.

Em FreeCAD, no h nenhum camadas como no AutoCAD. Em vez disso,


trabalhamos com grupos. Grupos so uma outra maneira mais flexvel de
organizar o seu desenho. Voc pode criar novos grupos com direito do mouse
na exibio de rvore, reorganiz-los, mov-las para outros grupos ou mover
objetos de/para grupos simplesmente arrastando e soltando as coisas na
exibio de rvore. Voc tambm pode atribuir a largura da linha atual e cores
para todos os objetos em um grupo, ou transform-los ou desligar
pressionando espao.

Vamos colocar todos os nossos objetos em um novo grupo e desligar tudo que
no vamos usar, como a vegetao e dimenses, para acelerar nosso trabalho.

Desenho da vista de planta


Usando as ferramentas de desenho
A nica coisa que vamos precisar no momento a rea que atribuda a nossa
cabine. Encontra-se em um grupo separado, denominado de "projeo". Ento
podemos basicamente desligar tudo o resto com a tecla de espao e comear a
desenhar por cima. Sortearemos uma pequena cabana com uma sala de guarda
e um WC, em alvenaria estrutural muito simples, para no haver qualquer
necessidade de concretework especial no plano em si. Mas vamos colocar uma
camada de gesso dentro e uma camada de cermica do lado de fora.
Ento, vamos comear com a forma geral de nossas paredes a fazer:

Nosso desenho DXF foi desenhado em metros, ento a menos que tenhamos
qualquer razo para mudar isso, vamos continuar com as mesmas
unidades. FreeCAD atualmente no tem um sistema amigvel para trabalhar
com as unidades do mundo real, ento simplesmente assumir que "um"
significa "um metro".
Outra boa coisa a lembrar construir a geometria temporria sempre que voc
precisar. Voc quer um ponto que se encontra a 2 metros de distncia na
horizontal? Desenhar uma linha vertical, mov-lo 2m de distncia, passar uma
linha horizontal atravs dele, seu ponto de vista.
Crie um retngulo: Snap sua cornerpoints com CTRL para os cantos da
rea atribudo

Deslocamento do retngulo: com o retngulo selecionado, pressione


o deslocamento, pressione C para ativar o modo de cpia, mova o
mouse dentro do retngulo primeiro deslocamento sabe em que direo
deve ir e digite 0.20, digite
Transform-los em um rosto: Atualizar o primeiro retngulo, atualizar o
segundo retngulo, em seguida selecione o retngulo externo, CTRLselecione o retngulo interno e pressione Downgrade
Criar a abertura da porta: fazer um 1.00 x 0.50 retngulo, mova -o para
o canto superior da parede da nossa principal (pressione C para
desativar o modo de cpia).
Mover a abertura para a posio correta da porta: mova-0,10 para a
esquerda. Ns no colocamos nossa abertura diretamente na esquina,
porque seria difcil abrir a porta.
Subtrair a abertura da porta: selecione a parede, CTRL-selecione a
porta abrir e clique em downgrade.
Uma nota sobre upgrade e downgrade
Agora, voc deve estar ciente de que o kernel openCasCade que FreeCAD
construdo em cima, um kernel 3D. feito principalmente para operaes de
3D. Quando tem que cortar ou unir faces planas, como estamos fazendo agora
com as operaes de atualizao/downgrade, ele s vezes faz coisas estranhas
e as operaes subseqentes (como outros upgrades/downgrades) s vezes no
do os resultados esperados. Claro com o tempo esses comportamentos vo
acabar sendo corrigidos pelos desenvolvedores FreeCAD, mas sbio saber
formas alternativas para resolver problemas imediatos.
A melhor maneira de resolver um rosto que no
upgrade/downgrade/compensao corretamente, simplesmente para degradlo at que esteja tudo explodiu a single bordas e, em seguida, atualizar essas
bordas juntos novamente at um novo rosto. Caso isso no funcione ou,
simplesmente redesenhar um novo fio (polilinha) em cima do cara
problemtica, encaixe para seus pontos de extremidade, em seguida, excluir a
cara velha e atualizar o novo fio. Geralmente, um rosto que voc desenhar a
mesmo em muito melhor forma do que um cara que voc obteve por
upgrade/downgrade.
Outra coisa a ter em mente que quando voc subtrair uma forma de outra,
pode encontrar-se com um objeto que contm vrios rostos. Isto talvez difcil
seu mais trabalho (eles no compensar corretamente, etc), ento uma coisa
boa, nesse caso, sempre para separ-los com a ferramenta de downgrade.

Outra nota sobre encaixe


Existem duas formas de rotura no mdulo de projecto: snap passiva, que
ocorre quando voc simplesmente passar o cursor do mouse sobre um objeto
(aparece um smbolo de crculo aberto) e snap ativo, que quando voc
pressionar CTRL. Ativo encaixe permite que voc ajustar a pontos especficos
em um objeto, como seus pontos de extremidade, pontos mdios, centros ou
intersees com outros objetos. Se voc pressionar SHIFT, que a chave para
restringir horizontalmente e verticalmente, voc ganha ainda mais pontos de
snap. Mas isso tem um custo, porque FreeCAD deve fazer muitos clculos em
tempo real. Se voc tiver muitos objetos, voc comear a sentir a
diferena. Ento um bom truque para speedup seu trabalho tomar o hbito de
trabalhar tanto quanto possvel com SHIFT e passiva de encaixe s. Voc vai
ver rapidamente que voc vai obter resultados precisos e trabalhar muito mais
rpido.
Ento vamos voltar ao trabalho:
Crie uma parede de 10cm de largura entre a sala principal e o
WC. Atualiz-lo e, em seguida, atualiz-lo junto com a parede principal
de uni-los
Crie outros retngulos para suas outras aberturas. Eu coloquei uma
janela de 60cm de largura em que se tornar o WC, uma porta de 80cm
entre a sala principal e o WC, e para a grande janela na sala principal,
eu simplesmente deixei parede 40cm no lado esquerdo e direito.
Compensar todas as paredes de 1cm, tornar-se uma camada de
cimento/gesso, em seguida, degradar as offsetted cpias para
transform-los em fios simples
Criar uma camada de cermica no lado exterior, por nossa linha de
gesso 2cm, ento desenhar uma forma de 2cm de espessura entre as
duas linhas de compensao
Exclua o deslocamento de 2cm. que no precisamos mais, geometria de
construo, bem como todas. Se voc sentir que voc precisar deles
mais tarde, basta coloc-los em um grupo separado e desligar esse
grupo com espao.
Isto onde ns estamos agora (mantive a geometria de construo, em azul,
para voc ver):

Importao e construo de objetos compostos


Em FreeCAD, objetos compostos so objetos feitos com a geometria de vrios
outros objetos. Em outros softwares, chama-se componentes, smbolos ou
blocos. uma maneira muito til de geometria de grupo sob um nico
objeto. Qualquer um dos objetos criados com o mdulo de projecto podem ser
agrupadas em um composto. O comando para criar um composto o comando
de atualizao . O uso simples, selecione tudo o que voc deseja transformar
em um composto e clique em Upgrade. Se no h outra forma mais inteligente
pode ser criada, eles sero transformados em um composto.
Usar geometria composta especialmente til para construir uma biblioteca
de smbolos em seu disco, ento voc pode reutiliz-los mais tarde. Um cool
usar isto, juntamente com a funo de importao DXF, que voc pode
facilmente usar bibliotecas de smbolos em formato DXF (se os smbolos
esto em formato dwg, o aplicativo gratuito de "Conversor de arquivos de
Teigha" pode lote-converter toda a sua biblioteca de uma s vez).
Depois de ter uma biblioteca de smbolos DXF, apenas arraste um dos-los e
solt-lo em cima de sua janela aberta do FreeCAD e ele ser importado no
documento atual. Ele no vai ser importado como um composto, mas toda a

geometria de smbolo ser colocada em um grupo separado, por isso fcil


selecionar tudo e simplesmente pressione "Atualizar". Cuidado com o que os
usurios do AutoCAD tm o mau hbito de desenhar coisas muito longe de ser
o ponto de origem (0, 0,0), seu smbolo inserido pode mentir ento muito
longe de sua zona de desenho.
Ento, de volta ao nosso desenho:
Importar um bloco sanitrio, se voc tiver um, ou escolhe um no site
do Exchange de Cad e convert-lo em DXF com o "Conversor de
arquivo de Teigha"
Crie a geometria para uma porta, atualize -o para um
composto, cpia para a outra porta local, downgrade , ajustar os
elementos para o novo tamanho e atualiz-lo novamente
Faa o mesmo para o windows

Dimenses e anotaes

Agora que nosso plano mais ou menos pronto, podemos


adicionar dimenses e textos. Isto geralmente bastante simples, ento no h
provavelmente nenhuma necessidade de explicar muito. Tente tudo da
dimenso, e como uma conveno, sempre comeam as linhas de dimenso da
linha parede principal, no a camada de acabamento. Uma coisa bom saber
que, s vezes voc desenhar um texto ou uma dimenso mais uma rea
preenchida e a rea preenchida cobrir a sua dimenso. H uma maneira
simples de resolver isso, desclassificao e atualizando novamente a rea
preenchida. Ele ento ser exibido sob os outros elementos.
A dimenso e o texto por padro ter a mesma altura do texto, que pode ser
alterada na pgina de Preferncias do projecto . Voc pode editar
individualmente cada altura do texto.
Infelizmente certos no-geometria objetos como textos e dimenso so ainda
no selecionveis na vista 3D FreeCAD, voc deve, portanto, selecione-os na
rvore e voc no ser capaz de encaixe para eles, mas isso provavelmente
ser resolvido em um futuro prximo. Isso tambm no possvel no
momento de escolher um estilo de fonte. Para alinhar as dimenses, no
momento, voc precisa traar uma linha primeiro e, em seguida, encaixar suas
dimenses para essa linha.

Organizando

Finalmente, podemos acrescentar algumas coisas para terminar nosso plano,


como colocar a vegetao ao redor da cabine. Podemos simplesmente copiar
algumas rvores de nosso desenho DXF importado e dimension-los para
baixo com a ferramenta ' escala ', para por exemplo (0.5,0.5). Podemos
tambm alterar a espessura de linha de um par de objetos, por exemplo fazem
as paredes mais grossas e alterar a cor de algumas coisas. E podemos
organizar todos os nossos elementos em grupos.
A capacidade de organizar seu trabalho em grupos aninhados certamente
uma das grandes vantagens dos grupos ao longo do trabalho tradicional com
camadas. Neste tutorial, agrupei meus objetos por tipo, dentro do grupo de
plano. Por exemplo, em vez de ter uma camada grande com todas as
dimenses do desenho, cada parte do desenho ir conter o seu prprio grupo
de dimenses, tornando-se extremamente fcil de organizar seu desenho.
Voc pode sentir uma perda no comeo se voc vem de um tradicional
programa de desenho como AutoCAD, mas rapidamente, voc ver o poder
que este mtodo traz.
Por exemplo, toda a geometria de nossa construo pode ir em um grupo
separado, que vou desligar. Talvez mais tarde ns vamos precisar fazer
algumas alteraes, e ser til ter essa geometria disponvel.
Ento, agora estamos prontos para desenhar outras partes...

As elevaes de desenho

Desde que, neste exerccio, ns vamos ficar em 2D puro, traaremos nossas


sees e elevaes diretamente. Em ambientes de arquitetura mais avanadas
(o que FreeCAD esperanosamente ser em um futuro), no precisaramos
desenhar as elevaes. Ns modelo do edifcio em 3D e em seguida, gerar
automaticamente os pontos de vista diferentes. Mas por causa deste exerccio
(e tambm porque todas as ferramentas necessrias ainda no so
implementadas em FreeCAD), vamos faz-lo pela mo, como nos velhos
tempos.
Vamos comear com a elevao da parede traseira, porque do jeito que nosso
plano orientado, pode ser sacado diretamente abaixo dela, sem a necessidade
de rodar a vista. Vamos simplesmente desenhar linhas de construo do plano,
definidos linhas horizontais para a altura desejada, definir o nvel de 0,00, o
+0.15 nvel da laje, e alturas para as janelas e a laje de cobertura em
+2.50. Podemos ento traar nossa geometria muito rapidamente em cima
dela.
Podemos ento colocar um par de anotaes, dimenses e atualizar alguns dos
objetos para que eles aparecem preenchidos com uma cor. Finalmente,
podemos fazer um pouco de limpeza atravs da criao de um grupo de
"Elevao do Sul" e, em seguida, subgrupos para nossa geometria de
construo e anotaes e colocar todos os nossos novos objetos neles.

Rotacionar a vista e criao de macros


Agora, precisamos desenhar outras elevaes de nosso pequeno edifcio. A
maneira mais simples seria para desenh-las diretamente sob a vista de planta,
como fizemos com a elevao do Sul. Para isso, seria til para ser capaz de
girar a visualizao de 90, para que possamos continuar nossas elevaes de
desenho "a p". Infelizmente, o FreeCAD no possui no momento nenhuma
ferramenta "Girar visualizao". Mas, felizmente, possui ferramentas para
facilmente criar nossas prprias ferramentas, chamadas Macros. Ento, esta
uma boa oportunidade para tentar algo fcil.
As macros, bem como todos os scripts em FreeCAD, feito em uma
linguagem de programao muito simples chamada python. Voc pode
escrever programas muito complexos em FreeCAD em python, mas voc
tambm pode us-lo para executar operaes muito simples onde no h ainda
um cone de barra de ferramentas de FreeCAD adequado, tais como nossa
ferramenta girar a visualizao. Ento, a primeira coisa a fazer, abra a vista de
relatrio, se fechou e selecione a guia de python. Em l, digite (ou copie/cole)
o cdigo a seguir:
import math

from pivy import coin


cam = Gui.ActiveDocument.ActiveView.getCameraNode()
rot = coin.SbRotation()
rot.setValue(coin.SbVec3f(0,0,1),math.pi/2)
cam.orientation = rot

Este pequeno script simplesmente ir girar a visualizao de 90 (


esquerda). Para rotao de-90 ( direita), voc simplesmente mudaria
math.pi/2 por - math.pi/2. Se voc gostaria de aprender mais sobre python
scripting em FreeCAD, h uma extensa seo de scripts deste wiki.
Agora, precisamos fazer mais um passo, que salvar nosso pedao de cdigo
em uma macro, ento podemos reutiliz-lo mais tarde. Ento, em vez de colar
o cdigo no interpretador python, vamos abrir o Gerenciador de macro
(Ferramentas -> Macros), criar uma nova macro, pressione o boto "Editar" e
cole o nosso cdigo nele. Feche a aba do editor de macro e a macro ser salva.
As macros podem se comportar como qualquer outra ferramenta de
FreeCAD. Com as ferramentas -> menu Personalizar, podemos adicionar um
cone para nossa macro, um atalho de teclado e adicion-lo para uma barra de
ferramentas.
As girado vistas de desenho

Agora que ns pode rodar a vista vontade, podemos tirar nossas outras
elevaes. A maneira mais fcil para desenhar sua elevao no lugar certo
sob a vista de planta e use um "espelho" (uma linha orientada a 45) para
empurrar as linhas de altura de uma outra elevao. Desta forma, o desenho
vai muito rpido.
Finalmente, chamamos a outros 2 elevaes, e desde que o quarto o mesmo
que o outro (mas espelhada), podemos ignor-lo. Podemos ento desenhar
uma seo transversal, e nosso desenho est completo: