Você está na página 1de 3

Tutorial Função PROCV (VLOOKUP)

Procedimento do PROCV(Excel 2003 &


Excel 2007)
Referências
 Você deve selecionar as referências em sua planilha. Neste exemplo, a sua
referência é $A$2:$D$10. Depois de selecionar, clicar em Inserir - Nome -
Definir (Para este exemplo, dei o nome de CAMPOS).

Excel 2007: A definição do nome é feita através do menu Fórmulas.

Local onde os dados encontrados aparecerão


 Neste exemplo:
o H1= Termo a ser procurado
o H4= Descrição encontrada (coluna2 da nossa planilha)
o H6= Quantidade encontrada (coluna 3 da nossa planilha)
o H8= Preço encontrado (coluna 4 da nossa planilha)

Fórmulas

A sintaxe de base da função PROCV é:


=PROCV(valor_pesquisa;tabela_matriz;no_index_lig;valor_aproximado)
(=VLOOKUP(lookup_value,table_array,row_index_num,range_lookup)

 H4
o =PROCV($H$1;CAMPOS;2;FALSO)
o Para ser mais claro, partindo do conteúdo da célula H1, procuramos na
primeira linha da tabela CAMPOS, a coluna começando com esse
conteúdo, e extraímos o valor colocado na segunda linha; FALSO, indica
que estamos procurando uma correspondência exata.
o Para evitar a mensagem #N/A, se nada foi encontrado, utilizamos a
fórmula seguinte e "Desconhecido" aparecerá na célula do resultado.
o =SE(FORNA(PROCV($H$1;CAMPOS;2;FALSO));"Desconhecido";PR
OCV($H$1;CAMPOS;2;FALSO))
o Com o Excel 2007 existe uma fórmula mais curta:
=SEERRO(PROCV($H$1;CAMPOS;2;FALSO);"Desconhecido")
 H6
o =PROCV($H$1;CAMPOS;3;FALSO)
o Simplificando, partindo do conteúdo da célula H1, procuramos na
primeira linha da tabela CAMPOS, a coluna começando com esse
conteúdo, e extraímos o valor colocado na terceira linha; FALSO, indica
que estamos procurando uma correspondência exata.
o Para evitar a mensagem #N/A, se nada foi encontrado, utilizamos a
fórmula seguinte e "Desconhecido" aparecerá na célula do resultado.
o =SE(FORNA(PROCV($H$1;CAMPOS;3;FALSO));"Desconhecido";PR
OCV($H$1;CAMPOS;3;FALSO))
o Com o Excel 2007 existe uma fórmula mais curta:
=SEERRO(PROCV($H$1;CAMPOS;3;FALSO);"Desconhecido")
 H8
o =PROCV($H$1;CAMPOS;4;FALSO)
o Simplificando, partindo do conteúdo da célula H1, procuramos na
primeira linha da tabela CAMPOS, a coluna começando com esse
conteúdo, e extraímos o valor colocado na quarta linha; FALSO, indica
que estamos procurando uma correspondência exata.
o Para evitar a mensagem #N/A, se nada foi encontrado, utilizamos a
fórmula seguinte e "Desconhecido" aparecerá na célula do resultado.
o =SE(FORNA(PROCV($H$1;CAMPOS;4;FALSO));"Desconhecido";PR
OCV($H$1;CAMPOS;4;FALSO))
o Com o Excel 2007 existe uma fórmula mais curta:
=SEERRO(PROCV($H$1;CAMPOS;4;FALSO);"Desconhecido")
Nota: Na fórmula, colocamos o parâmetro em FALSO se você quiser procurar o valor
exato (# N/A se não for encontrado) e, em VERDADEIRO se o valor for igual ou
inferior mais próximo; neste caso, a lista de valores deve estar organizada.
Se este parâmetro for omitido, seu valor padrão é VERDADEIRO.

Você também pode gostar