Você está na página 1de 3

Tutorial - Instalando Opencv no Linux

Alessandro Diogo Brückheimer


alebruck@gmail.com

Esta tutorial contém um "passo-a-passo" para a obtenção e instalação do OpenCV em sistemas


Linux Ubuntu, Mint ou derivados.

1- Abra uma janela do terminal.

2- Primeiro é necessários instalar alguns aplicativos básicos ( gcc, g++, ld, make, cmake), para isso
digite no terminal:

sudo apt­get install build­essential cmake cmake­qt­gui

3- Agora instale alguns outros pacotes necessários, para isso digite no terminal:

sudo apt­get install libgtk2.0­dev libavcodec­dev libavformat­dev 
libjpeg62­dev libtiff4­dev

sudo apt­get install libdc1394­22­dev libjasper­dev 
libgstreamer0.10­dev libgstreamermm­0.10­dev

sudo apt­get install libswscale­dev libv4l­dev libxine­dev 
libunicap­dev

4- Agora realize o download do Opencv do sourceforge , para extrair utilize o comando:

~/OpenCV­2.1.0 
5- Para gerar o make execute o cmake, digitando no terminal:

cmake­gui

Na janela do Cmake informe o local onde a pasta do OpenCV foi extraida e o destino do make.
Também selecione as seguintes opções (caso já não estejam selecionadas):

• BUILD_EXAMPLES
• BUILD_NEW_PYTHON_SUPPORT
• BUILD_PACKAGE
• BUILD_SHARED_LIBS
• BUILD_SWIG_PYTHON_SUPPORT
• BUILD_TESTS
• EXECUTABLE_OUTPUT_PATH
• INSTALL_C_EXAMPLES
• INSTALL_PYTHON_EXAMPLES
• OPENCV_BUILD_3RDPARTY_LIBS
• WITH_FFMPEG

Clique em Configure e em seguida em Generate.

6- Vá para a pasta utilizada como destino para o make :

cd ~/BIN

Execute os comando:

make
sudo make install
7- No terminal execute:

sudo gedit /etc/ld.so.conf.d/opencv.conf

E adicione a linha abaixo no arquivo:

/opt/lib. Then sudo ldconfig 

8- No terminal execute:

sudo gedit /etc/bash.bashrc 

E adicione as linhas:

PKG_CONFIG_PATH=$PKG_CONFIG_PATH:/opt/lib/pkgconfig 
export PKG_CONFIG_PATH 

Para testar o OpenCV vá para ~/OpenCV-2.1.0/samples/c e digite no console para compilar todos
os códigos:
./build_all.sh 

Configurando OpenCV para CodeBlocks em Linux

1- Abra o CodeBlocks e crie um novo projeto em branco.

2- Project -> Build Options → Linker Tab.

3- Em “ Other Linker Options” adicione “-lm -lcv -lhighgui -lcvaux”.

4- Search Directories Tab → Compiler Tab e adicione o local dos arquivos Dev (normalmente
localizado em “usr/local/include/opencv” ou “/usr/include/opencv/”)

5- Para habilitar a opção de “auto-completar” vá em “Project->Properties->C/C++ Parser Options”


e adicione o mesmo diretório dos arquivos Dev.