Você está na página 1de 4

Excel: Como verificar se existe valores duplicados

Publicado em: 07/02/2007


Compartilhe

Parte I (Funções)

Neste artigo mostrarei uma forma interessante de como achar Dados


Duplicados em uma seqüência de células, porém, não é o único, mas
ajuda. Vejam abaixo como será feito:

Na Coluna B coloquei algumas datas inclusive duplicadas;


Na Coluna C foram simulados alguns nomes de clientes;
Na Coluna D a Data e o Nome de cada cliente foram concatenados
(unidas) com a Função: =B2&C2. Onde & serve para concatenar
(unir); e
Na Coluna F foi feito a Função do Status, para saber se há
duplicação, veja a Função:
=SE(CONT.SE($D$2:D2;D2)>1;"Duplicado";"Único").

Parte II (Validação de Dados)

Na parte anterior foi visto uma forma de se encontrar Duplicados pela


função, porém, nesta será pela Validação de Dados, veja nas figuras
abaixo:
Assim que a pessoa digitar na célula que está com as bordas
vermelhas, aparecerá uma mensagem dizendo que a o Pedido já
existe, para isso antes de qualquer coisa selecione todas as células da
seqüência neste caso da célula B3:B11, Clique no Menu Dados –
Opção Validação e veja na figura abaixo:

Assim que abrir a Caixa de Validação de Dados, configure conforme


a figura acima, em Permitir escolha Personalizado e em Fórmula
digite a seguinte fórmula =CONT.SE(B$3:B$11; B3) = 1
Explicação da Função: (Essa função quis dizer que caso o valor que
for digitado da B3 para baixo for igual a 1, isso quer dizer caso já
exista, não será possível inserir o valor.)
Depois de ter configurado que os valores não podem ser Duplicados,
vamos configurar uma Mensagem de Erro, para isso veja a figura
abaixo:
Veja que para configurar uma Mensagem de erro, deve-se clicar a
Guia – Alerta de Erro, depois digite o Título e a Mensagem de Erro
como achar melhor, e clique em OK.
Pronto, Validação de Dados configurada. Veja agora na Planilha.

Este é mais um exemplo de como impedir que digitem alguma


informação Duplicada, caso tenha alguma outra forma, podem me
enviar.

Compartilhe