P. 1
Simuladores de Circuitos Eletrônicos

Simuladores de Circuitos Eletrônicos

|Views: 1.782|Likes:

More info:

Published by: Fabricio Michel Denes on May 12, 2011
Direitos Autorais:Attribution Non-commercial

Availability:

Read on Scribd mobile: iPhone, iPad and Android.
download as PDF, TXT or read online from Scribd
See more
See less

05/15/2013

pdf

text

original

Simuladores de Circuitos Eletrônicos

Simuladores de Circuitos Eletrônicos
1. História
Em 1972, o Departamento de Engenharia Elétrica e da Ciência da Computação (EECS) da Universidade da Califórnia, Berkeley, publicou a primeira versão do programa SPICE (Simulation Program with Integrated Circuit Emphasis). O Chefe do Departamento, Donald Pederson, decidiu, na época, que o programa seria distribuído gratuitamente. O SPICE foi escrito originalmente em FORTRAN e recebeu várias atualizações, tais como o SPICE2, em 1975, e a versão atual, SPICE3 de 1985, escrita em linguagem C. Atualmente, versões modificadas do SPICE são comercializadas por várias companhias usando vários nomes. Algumas modificações, como adaptações para uso em PC’s ou Mac’s, são normais e úteis, outras são feitas, apenas, para deixar as várias versões incompatíveis entre si. Os programas fonte, no entanto, são essencialmente os mesmos. Variantes, como o HSPICE e o XSPICE, também estão no mercado.

2. Descrição
O programa SPICE foi desenvolvido originalmente para propiciar aos projetistas de circuitos integrados analógicos a possibilidade de testar seus projetos em uma bancada virtual de laboratório. Sem a existência de simuladores, a criação de circuitos complexos e avançados seria praticamente impossível, principalmente com o advento da eletrônica CMOS submicrométrica. Nos dias atuais, o SPICE é extensivamente usado para praticamente todas as áreas da eletrônica, incluindo eletrônica discretizada de potência e de comunicações em altas freqüências. É, portanto, uma ferramenta imprescindível para o engenheiro eletrônico moderno. As principais versões comerciais de simuladores disponíveis no mercado são: PSpice 10 (Cadence/OrCad): Um dos mais populares simuladores da atualidade. Possui versão mixed mode (PSpice A/D), capaz de simular circuitos analógicos e digitais simultaneamente. Versões demo limitadas e gratuitas estão disponíveis na página: http://www.cadence.com/orcad/ Multisim 7 (EWB-Electronics Workbench): Simulador que se tornou muito popular porque simula instrumentos reais de bancadas de laboratório, como osciloscópios, multímetros, analisadores lógicos, etc.. É mixed mode e possui funções especiais como Carta de Smith. Uma versão gratuita completa, chamada DesignSuite 9 Software, com validade de 45 dias, está disponível na página: http://www.electronicsworkbench.com/

P. R. Veronese

1

SEL-EESC-USP

winspice.com/ - WinSpice (OuseTech Ltd. notadamente para simulações de fontes chaveadas (SMPS). Possui uma versão chamada SIMetrix/SIMPLIS. tais como BSIM3 e BSIM4.spectrum-soft. uma extensão do SPICE3 desenvolvida na Universidade da Geórgia.jsp P. otimizada para simulações de eletrônica de potência. na página: http://www. compatível com o PSpice e que possui modelos otimizados para eletrônica de potência. Está disponível uma versão de avaliação. Apresenta grande precisão e alta rapidez de simulação e é preferido por muitos projetistas de circuitos integrados analógicos. Possui uma versão de avaliação. tais como: heteroestruturas. limitada.com - AIM-Spice 4.linear. limitada e gratuita.2 (Catena Software Ltd.co. limitada e gratuita. Este programa pode ser obtido na página: http://www. na página: http://www. Como está disponível. na página: http://www. para Windows ou Linux. limitada. Suporta o modelo BSIM4 (Level = 14) de Berkeley para transistores MOS com dimensões mínimas inferiores a 130 nm. será o simulador usado neste mini-curso.catena. É mixed mode e traz muitas funções extras que o tornam versátil e fácil de ser usado. Possui uma versão de avaliação. completo e gratuito.com/ - Micro-Cap 8 (Spectrum Software): Um dos mais antigos simuladores disponíveis no mercado. Possui uma versão de avaliação.3 (AIM-Software): Automatic Integrated Circuit Modeling Spice é um simulador que possui alguns modelos avançados para microeletrônica. limitada. Veronese 2 SEL-EESC-USP . Possui uma versão demo.uk.): Simulador que usa o SPICE3f4 de Berkeley e que possui modelos avançados de MOSFET’s.Simuladores de Circuitos Eletrônicos - ICAP/4 (Intusoft): Outro poderoso simulador comercial que usa o SPICE3f5 de Berkeley e o XSPICE. gratuita e sem esquemático.com - SIMetrix 5..intusoft.uk/ - LTSpice/SwCADIII (Linear Technology Co.): Poderoso simulador.): É um simulador versátil e fácil de ser usado. etc. na página: http://www.aimspice.com/designtools/softwareRegistration. R. na página: http://www. MESFET’s e HFET’s de GaAS. gratuita e sem esquemático. heterojunções.

quatro tipos de análise de circuitos: P. na verdade. O simulador não é um programa de síntese de circuitos.pdf 3. A precisão dessa análise.linear. corriqueiramente. está atrelada à precisão dos modelos usados para representar os diversos elementos do circuito. bancadas virtuais de laboratório.com/software/scad3. em inglês. uma poderosa ferramenta de análise de circuitos. isto é. O LTSpice/SwCADIII Simuladores baseados no SPICE são programas capazes de retratar o funcionamento e o comportamento de circuitos eletrônicos com grande precisão. O manual completo do usuário do programa LTSpice/SwCADIII está disponível. É. O SPICE faz. São. não é adequado para o desenvolvimento de projetos. Veronese 3 SEL-EESC-USP . R. na página: http://ltspice.Simuladores de Circuitos Eletrônicos Figura 1 – Circuito Elétrico com Polarização Estática. por outro lado. no entanto.

Na análise DC sweep. Deve ser acertado. Para que essa simulação seja obtida. chamada de ponto de operação. uma fonte de excitação. por exemplo. deve-se solicitar: Simulate → Edit Simulation Cmd → DC sweep → OK → ou . calcula as grandezas quiescentes ou grandezas de repouso do circuito. que possuem. O circuito da Figura 1. com uma. deve-se solicitar: Simulate → Edit Simulation Cmd → Transient → OK → ou . na maioria das vezes. Para que essa simulação seja obtida. pulso. na maioria das vezes. Essa análise pode ser não linear porque obedece equações de modelagem dos vários dispositivos eletrônicos.a.Simuladores de Circuitos Eletrônicos Figura 2 – Grandezas Quiescentes do Circuito da Figura 1. para essa análise.b. apresenta as grandezas quiescentes ou de repouso calculadas pelo simulador e apresentadas na Figura 2. Análise . na verdade. essa análise pode ser não linear porque obedece equações de modelagem dos vários dispositivos eletrônicos. Para que essa simulação seja obtida. 3. mas executada em vários pontos. características não lineares. Para isso.c. O resultado é apresentado em forma de um gráfico que mostra a variação da grandeza desejada em função do tempo. como V1. deve ser variável no tempo (senóide. Análise . por exemplo. P. valor inicial. os valores adequados de nome da fonte (V1). onda quadrada. Veronese 4 SEL-EESC-USP . duas ou três grandezas contínuas do circuito admitidas como variáveis. pelo menos o tempo total de simulação (Stop Time). É.TRAN não linear ≡ Esta análise é feita variando-se uma grandeza elétrica do circuito em função do tempo. Essa análise é muito importante para se determinar o ponto de polarização de circuitos eletrônicos ativos. valor final e incremento da variação.). que possuem. etc.DC não linear ≡ Esta análise é semelhante à anterior. 3. Análise . características não lineares. onda triangular. por exemplo. deve-se solicitar: Simulate → Edit Simulation Cmd → DC op pnt → OK → ou . 3. a tensão da fonte V1 poderia ser estipulada variável na faixa 0 ≤ V1 ≤ 12 V e as grandezas apresentadas na Figura 2 seriam calculadas dentro dessa variação.OP ≡ Esta análise. No circuito da Figura 1. devem ser acertados. O resultado seria apresentado em forma de um gráfico que iria mostrar a variação da grandeza desejada em função da variação de V1. uma análise estática em DC (corrente contínua). R. Como no caso anterior.

isto é. Análise .0 V. também alternativamente.AC linear ≡ Essa análise é feita através da excitação do circuito por uma grandeza elétrica fixa em amplitude. o simulador os substitui por modelos linearizados de pequenos sinais e. nesse caso. para pequenos sinais. deve ser designada a fonte de excitação (Source) e o ponto no qual deve ser feita a análise (Output). Para que essa simulação seja obtida. variação de amplitudes e fases de grandezas elétricas solicitadas versus freqüência. 3. O resultado dessa simulação é plotado em forma de diagrama de Bode. Veronese 5 SEL-EESC-USP . a freqüência inicial e a freqüência final da simulação. posteriormente. pode ser logarítmica (em oitavas ou em décadas) ou linear. como.d. também pode ser solicitada através de: Simulate → Edit Simulation Cmd → DC Transfer → OK → ou . Essa análise é sempre linear porque. Devem ser acertados. mesmo que os dispositivos sejam não lineares.NOISE) e análise de Fourier (. Pode-se. por exemplo.FOUR). A variação da freqüência. R. então. calcula as variáveis do circuito. o número de pontos da análise linear ou o número de pontos da análise por oitava ou por década. deve-se solicitar: Simulate → Edit Simulation Cmd → AC Analysis → OK → ou . P.Simuladores de Circuitos Eletrônicos Figura 3 – Área de Trabalho do LTSpice/SwCAD III. Uma análise linear de transferência em DC. análise de ruído (. 1. ser fornecida uma lista discreta de freqüências a serem analisadas (list). Outras análises que podem ser executadas por esse simulador são: análise térmica (. Nesse caso.TEMP). mas variável em freqüência.

kilo (k). g=109 . giga (g) e tera (t). capacitores. basta levar o cursor do mouse até ele. u=10-6 . transistores de efeito de campo de junção e de porta isolada (JFET e MOSFET) e transistores de efeito de campo metal-semicondutor (MESFET). clica-se o botão direito do mouse para abrir o menu de valores.Simuladores de Circuitos Eletrônicos 4. indutores. Para se estipular valores para os componentes primitivos. como indica a Figura 3. clicando-se no ícone ou através do menu Iniciar.1. Usando o LTSpice 4. Área de Trabalho Após ser aberto. (-). R. Componentes Eletrônicos Primitivos Componentes eletrônicos primitivos são aqueles que possuem modelos próprios individualizados. Para isso. p=10-12 . Veronese 6 SEL-EESC-USP . mili (m). Para isso. meg=106 . diodos. mega (meg). Quando todos os componentes desse tipo já foram posicionados. t=1012 . Para resistores. clicando-se no ícone apropriado da barra de ferramentas. 4. tais como: resistores. capacitores. um resistor de 1000 Ω é igual a um resistor de 1 kΩ. que possuem modelagem própria individualizada. indutores e diodos) podem ser obtidos diretamente na barra de ferramentas. transistores bipolares (BJT). clicando-se no ícone mais à esquerda. girará em torno dele mesmo. Portanto. Passivos Os componentes primitivos passivos (resistores.a. clica-se o botão direito do mouse para sair dessa tarefa. como mostra a Figura 3. Se for clicado Ctrl E enquanto o componente estiver selecionado. basta clicar com o botão esquerdo do mouse sobre o componente desejado.b. Nesse espaço.00000000001 F é igual a um capacitor de 10 pF e um indutor de 0.001 H é igual a um indutor de 1 mH. Lembrandose que: f=10-15 . um capacitor de 0. respectivamente. 4. o programa apresentará a área de trabalho mostrada na Figura 3. deve-se clicar Ctrl R. pode-se abrir um projeto já existente. micro (u). quase todos os componentes físicos possuem um símbolo equivalente que deverá ser adicionado ao circuito através da barra de ferramentas. (-)= 100 . n=10-9 . ou subcircuitos (macros). P. enquanto ele estiver selecionado. k=103 . pico (p). C ou L. ele será espelhado. o projetista deverá inserir o esquemático do circuito que deverá ser analisado. Se o componente precisar ser girado.b. Esses valores podem ser de ordens de grandeza de: fento (f). m=10-3 . nano (n). Esses componentes podem ser primitivos. Quando aparecer uma mãozinha apontando. Na montagem de um esquemático. arrastá-lo até o local escolhido da área de trabalho e liberá-lo clicando-se novamente o botão esquerdo do mouse. capacitores e indutores deve-se escrever seus valores no lugar de R. que possuem internamente vários componentes primitivos ou equações matemáticas que descrevem seu comportamento elétrico. isto é. ou iniciar um novo projeto.

Quando esse ícone for clicado. Ativos Os componentes eletrônicos primitivos ativos devem ser selecionados clicando-se sobre o ícone Inserir Componentes da Biblioteca. Veronese 7 SEL-EESC-USP . isto é. Deve-se notar que os vários tipos de diodos (retificador. diodos (diode. Uma biblioteca de diodos será. então. abrirá um menu com várias bibliotecas e com vários componentes disponíveis. indutor (ind). R. LED. Zener. JFET’s (njf ou pjf). schottky. Esses nomes são: resistor (res). Se o componente for um diodo. varactor). LED.Simuladores de Circuitos Eletrônicos Figura 4 – Vários Componentes Passivos Inseridos na Área de Trabalho.b. como mostra a Figura 3. clica-se o botão direito do mouse para abrir o menu de valores. etc. O modo de se selecionar o componente desejado é o mesmo usado para os primitivos passivos. Schottky.) são automaticamente caracterizados. MOSFET’s (nmos ou pmos) e MESFET’s (mesfet). Deve-se escolher o diodo desejado clicando-se sobre o seu nome e em seguida clicando-se em OK. podem ser selecionados teclandose sobre seus nomes ou escrevendo-se seus nomes no campo apropriado ao lado do desenho. leva-se o cursor do mouse até o componente e quando aparecer uma mãozinha apontando. inclusive os passivos anteriormente descritos. O diodo fica assim selecionado. P. A Figura 4 mostra uma área de trabalho com vários componentes passivos inseridos.2. aberta. zener. o menu de valores apresentará a opção Pick New Diode que deverá ser clicada. transistores bipolares (npn ou pnp). capacitor (cap). Os primitivos. 4.

para serem testados e funcionarem corretamente. aberta. Essas fontes podem ser selecionadas clicando-se sobre o ícone Inserir Componentes da Biblioteca. 127V. A Figura 6 mostra essas fontes.. O valor da tensão dessas fontes pode ser escolhido clicando-se o botão direito do mouse sobre a letra V e escrevendo-se o valor desejado no campo apropriado. 220V ou rede. que deverá ser clicada. então.. A Figura 6 mostra duas dessas fontes inseridas na área de trabalho.. devem ser alimentados com fontes de tensão ou de corrente contínuas e devem ser excitados por fontes de tensão ou de corrente alternadas. P. 4..Vários Componentes Ativos Inseridos na Área de Trabalho. que é uma rede trifásica 220V/127V. podem ser obtidas pelos nomes: 110V. A Figura 5 mostra uma área de trabalho com vários componentes ativos inseridos. Tensões senoidais da rede de 60 Hz. como mostra a Figura 3. de alimentação ou de excitação. Dentro desse menu podem ser selecionadas fontes de tensão contínua (battery ou cell). R. 60 Hz. Uma biblioteca de modelos será. Deve-se escolher o componente desejado clicando-se sobre o seu nome e em seguida clicando-se em OK. Fontes Independentes de Alimentação e de Excitação Os circuitos eletrônicos. por exemplo. O componente fica assim selecionado.Simuladores de Circuitos Eletrônicos Figura 5 . Fontes alternadas..c. O menu de valores apresentará a opção Pick New . O SPICE apresenta vários tipos de fontes independentes de tensão ou de corrente. são apresentadas de várias formas. Veronese 8 SEL-EESC-USP .

apresenta resistência interna nula. por exemplo. fonte de subida e decaimento exponencial (EXP) ou fonte de tensão DC (none). ao invés de tensão. fontes independentes de corrente. Tais como as fontes independentes de tensão. A Figura 6 também mostra esses tipos de fonte. A fonte sinal é ideal. R.d. fonte de sinal aleatório (PWL). facilitando a implementação comportamental de circuitos complexos. é equivalente à fonte signal. com resistência e capacitância internas selecionáveis. A fonte signal também pode ser selecionada pelo nome voltage. e com uma resistência interna muito alta ou infinita. 4. e a fonte gerador apresenta resistência interna de 600 Ω. A fonte selecionada por current. São quatro as fontes dependentes disponíveis: P. podem ser solicitadas. Fontes Dependentes de Alimentação e de Excitação Além das fontes independentes de corrente e de tensão. contínuas ou alternadas. o SPICE permite que fontes dependentes sejam usadas. Fontes de tensão de excitação ou de sinal podem ser obtidas de três modos: sinal. As fontes sinal e gerador são restritas a sinais senoidais. gerador ou signal. isto é. fonte pulsada (PULSE). com amplitudes e freqüências ajustáveis. Veronese 9 SEL-EESC-USP . mas fornecendo corrente. fonte de sinal modulado em freqüência (SFFM). A fonte signal é uma fonte de tensão de excitação mais eclética. Ela pode ser ajustada como fonte senoidal (SINE).Simuladores de Circuitos Eletrônicos Figura 6 – Várias Fontes Inseridas na Área de Trabalho.

designado pela letra F. designado pela letra E. 4.Aυ Onde: n+ é o terminal positivo de saída da fonte.nc+ nc. apresenta em sua saída uma corrente igual a Ai vezes a corrente que passa em um outro ramo do circuito. a fonte [E1 out 0 a b 1] é uma fonte de tensão cuja saída vale Vout =1× V(a. sendo Aυ o ganho de tensão da fonte.2 – Fonte de Corrente Controlada por Corrente (CCCS): Este tipo de fonte.1 – Fonte de Tensão Controlada por Tensão (VCVS): Este tipo de fonte. apresenta em sua saída uma tensão igual a Aυ vezes a tensão entre dois outros pontos do circuito.d. nc+ é o terminal positivo de controle da fonte.b).<Vnome> Ai P. A sintaxe genérica de declaração desse tipo de fonte é: Exxx n+ n. Na Figura 7.Simuladores de Circuitos Eletrônicos Figura 7 – Fontes Dependentes. R. n. nc. Veronese 10 SEL-EESC-USP . sendo Ai o ganho de corrente da fonte. A sintaxe genérica de declaração desse tipo de fonte é: Fxxx n+ n. 4.d.é o terminal negativo de saída da fonte.é o terminal negativo de controle da fonte e Aυ é o ganho de tensão da fonte.

relês. para poder selecioná-lo.nc+ nc. são blocos compostos por vários componentes. estabilizadores de tensão. nc+ é o terminal positivo de controle da fonte.d. transformadores. como.d. incluindo primitivos e fontes. a fonte [F1 out 0 Vref 1] é uma fonte de corrente cuja corrente de saída vale Iout =1× Io. também são modelados em forma de subcircuito. por exemplo. pontes retificadoras. designado pela letra H. n.gm Onde: n+ é o terminal positivo de saída da fonte. Na Figura 7. os IGBT’s. Muitos blocos analógicos modernos. as chaves eletrônicas TRIAC’s e SCR’s e mesmo MOSFET’s com modelos mais elaborados e válvulas são modelados em forma de subcircuitos. apresenta em sua saída uma tensão igual a hr vezes a corrente que passa em um outro ramo do circuito. sendo Io a corrente que passa pela fonte de tensão Vref. apresenta em sua saída uma corrente igual a gm vezes a tensão entre dois outros pontos do circuito. ao contrário dos primitivos que são individualizados. A sintaxe genérica de declaração desse tipo de fonte é: Gxxx n+ n. designado pela letra G. <Vnome> é a fonte de tensão pela qual passa a corrente de controle da fonte e hr é a transresistência da fonte.é o terminal negativo de saída da fonte. os transistores Darlingtons. Na Figura 7. no entanto.é o terminal negativo de saída da fonte.. sendo Io a corrente que passa pela fonte de tensão Vref.4 – Fonte de Tensão Controlada por Corrente (CCVS): Este tipo de fonte.b).3 – Fonte de Corrente Controlada por Tensão (VCCS): Este tipo de fonte. A aquisição desses componentes é feita clicando-se sobre o ícone Inserir Componentes da Biblioteca. Na Figura 7.é o terminal negativo de controle da fonte e gm é a transcondutância da fonte. o nome comercial do componente. 4. 4.e. alto-falantes. Veronese 11 SEL-EESC-USP . sendo gm a transcondutância da fonte. n. lâmpadas. etc. n. P. R. LM741.Simuladores de Circuitos Eletrônicos Onde: n+ é o terminal positivo de saída da fonte. 4. a fonte [G1 out 0 a b 1] é uma fonte de corrente cuja corrente de saída vale Iout =1× V(a. A sintaxe genérica de declaração desse tipo de fonte é: Hxxx n+ n. O usuário deve saber. como os amplificadores operacionais. <Vnome> é a fonte de tensão pela qual passa a corrente de controle da fonte e Ai é o ganho de corrente da fonte.é o terminal negativo de saída da fonte. nc. formando um circuito mais complexo. Circuitos passivos como chaves. sendo hr a transresistência da fonte. Subcircuitos Subcircuitos.<Vnome> hr Onde: n+ é o terminal positivo de saída da fonte. a fonte [H1 out 0 Vref 1] é uma fonte de tensão cuja tensão de saída vale Vout =1× Io.

Quando o fio estiver totalmente traçado. o botão direito do mouse deve ser clicado para desabilitar a função de traçar fios. portanto. levar até o próximo ponto e clicar de novo o mesmo botão. Como não são admitidas linhas oblíquas. para isso. Deve-se notar que todos são nomeados pela letra U. o ícone de Inserir Nomes de Nós. como mostrado na Figura 3. aparecerá uma cruz tracejada na área de trabalho. Usar. em todo ponto de mudança de direção o botão esquerdo do mouse deverá ser clicado. clicar com o botão esquerdo do mouse sobre esse ponto. Confecção de Esquemáticos Após a colocação dos componentes do circuito na área de trabalho. R. o usuário precisa interligá-los para completar o esquema. 4.f. o ícone de Inserir Terminal de Terra. Como mostra a Figura 3. que é a designação de subcircuitos no LTSpice. Isso facilita a confecção de esquemáticos muito grandes. O ponto central da cruz é o ponto de origem da ligação do fio de interligação. para isso. Para facilitar a visualização dos resultados da simulação. Deve-se. P. Veronese 12 SEL-EESC-USP . Nunca deve ser esquecido que pelo menos um terminal de terra deve ser colocado no circuito. vários nós do circuito deverão ser nomeados. mesmo não havendo fios de interligação entre eles. clicando-se sobre o ícone Traçar Fios de Ligação.Simuladores de Circuitos Eletrônicos Figura 8 – Componentes Modelados em Forma de Subcircuitos. colocar essa origem sobre o ponto do circuito onde o fio deve ser iniciado. Usar. Nós que recebem o mesmo nome ficam automaticamente interligados no circuito. A Figura 8 mostra alguns componentes modelados em forma de subcircuito.

A opção Bi-Direct. Output e Bi-Direct.TRAN não fazem sentido. as simulações .AC ou . por exemplo. No menu de nomeação de nós existem quatro de tipos (Port Type): None.TRAN. as simulações . como nas fontes VCVS e CCVS da Figura 7. o circuito poderá ser analisado pelo simulador. deve ser solicitada. .OP. Em um circuito no qual apenas grandezas contínuas estão presentes.OP. b e out. escreve o nome do nó dentro de uma seta bidirecional. A Figura 7 mostra alguns nós com nomes estipulados por a.Simuladores de Circuitos Eletrônicos Figura 9 – Circuito com Simulação .DC Sweep) descritas na Secção 3. como nos nós a e b da Figura 7. Essas opções não possuem função elétrica no circuito. O tipo de simulação exigido dependerá do tipo de circuito e das funções que ele exerce. Em um circuito alimentado por uma tensão senoidal. . As fontes de excitação devem ser apropriadas para os diversos tipos de simulação. . R. Veronese 13 SEL-EESC-USP . Se for selecionada a opção Input. apenas. Se for selecionada a opção Output. por exemplo.AC e . A opção None simplesmente escreve o nome do nó ao lado do fio.AC e .. uma das quatro principais simulações (. mas.DC Sweep não fazem sentido. como a rede de 60 Hz. o nome do nó fica inserido em uma seta apontando para fora do terminal. como está mostrado nas fontes CCCS e VCCS da Figura 7 e na Figura 1. Para isso. Simulação Quando o esquemático estiver pronto. Input. como o circuito da Figura 1. função estética. ou sejam: P.DC Sweep.g. o nome do nó fica inserido em uma seta apontando para dentro do terminal. 4.

O gráfico da Figura 12 mostra que isso é verdade pelo menos até a freqüência em torno de 10 kHz. respectivamente. em forma de uma tabela que abre automaticamente após a simulação mostrando as tensões e correntes em todos os nós e ramos do circuito. A Figura 11 ilustra uma análise desse tipo. Se houver mais do que uma fonte variável. no menu Small signal AC analysis (. . tipo de variação (linear. mas sim. teoricamente. excitado com 1 V na entrada. plotando as grandezas solicitadas em função das fontes variáveis apresentadas. P. com 1001 pontos de análise por década. seja igual a 101 V.OP ≡ O circuito deve estar alimentado por pelo menos uma fonte DC. 2a fonte: 4 V ≤ Vg ≤ 5 V. É a análise do ganho de um amplificador operacional LM741. com incremento linear de 1 V. a partir da qual o LM741 tem seu ganho reduzido. o ganho de tensão desse circuito vale Gυ = 1 + R1/R2.Simuladores de Circuitos Eletrônicos Figura 10 – Resultado da Simulação do Circuito da Figura 9. O resultado da simulação. O resultado da simulação será apresentado em forma de curvas ou gráficos. . por exemplo. incremento da variação. solicitado para a grandeza Id.AC). as outras devem ser declaradas de maneira análoga à da primeira. No menu dessa simulação devem ser declarados: nome da 1a fonte que irá variar. deverá ser excitado por uma fonte de sinal (signal). em décadas ou lista). R. Informações adicionais podem ser obtidas clicando-se: View → SPICE Error Log. em função da freqüência. ajustado para: AC Amplitude = 1 e AC Phase =0. de tensão ou de corrente. Esse menu pode ser aberto clicando-se o botão direito do mouse sobre o símbolo da fonte. com incremento linear de 1 mV. com freqüência inicial de análise igual a 10 Hz e com freqüência final de análise igual a 1 MHz. Como é uma simulação estática. a qual deverá ter o seu valor. o circuito. com incremento linear de 5 V. valor inicial da fonte. A análise foi ajustada para . de tensão ou de corrente. foi simulado para três grandezas variáveis: 1a fonte: 0 ≤ Vd ≤ 10 V. O circuito da Figura 9. está mostrado na Figura 10.AC ≡ Neste caso. valor final da fonte. Até três grandezas contínuas do circuito podem ser admitidas como variáveis. As duas curvas superiores são para Vs = 0 V e as duas curvas inferiores são para Vs = 5 V. é de se esperar que a tensão de saída.DC Sweep ≡ O circuito deve estar alimentado por pelo menos uma fonte DC. 3a fonte: 0 ≤ Vs ≤ 5 V. além de possíveis fontes DC de polarização.AC em décadas. Veronese 14 SEL-EESC-USP . . em oitavas. Como. os resultados não são apresentados em forma de curvas ou gráficos.

Simuladores de Circuitos Eletrônicos Figura 11 – Circuito com Simulação .AC. P. Figura 12 – Resposta em Freqüências do Circuito da Figura 11. R. Veronese 15 SEL-EESC-USP .

Clicando-se sobre as grandezas desejadas (Ctrl-Click se forem várias). Pós-processador ou Probe Tão logo a simulação esteja concluída. Em linhas gerais. Para isso deve-se abrir um menu de inserção com Alt-duplo click sobre a grandeza desejada no menu de variáveis elétricas. com υi = 0. Traços também podem ser eliminados clicando-se no ícone da tesoura na barra de ferramentas e. o pós-processador abrirá uma janela gráfica e traçará as curvas selecionadas. Amplitude(V)=0. Operações algébricas também são aceitas. tensões de nós ou correntes de ramos.141 e Freq(Hz)=1k.) pode ser acionado. acertado para SINE. Deve-se notar. uma pequena defasagem do sinal de saída em relação ao sinal de entrada causada pelas capacitâncias internas do amplificador. clicando-se sobre o nome da curva que deve ser eliminada. além de possíveis fontes DC de polarização. Veronese 16 SEL-EESC-USP . a qual deverá ter o seu valor. por exemplo.Simuladores de Circuitos Eletrônicos Figura 13 .141×sen(2000πt). 5. se não estiver disponível. na curva da Figura 13. posteriormente. ajuste de escalas e de cores. Com os valores: DC offset(V)=0. deverá ser excitado por uma fonte de sinal (signal). . P. Esse menu. o simulador apresenta um menu de grandezas elétricas. o mesmo circuito da Figura 11 apresenta a tensão de saída em função do tempo apresentada na Figura 13. A simulação de Transient foi ajustada para Stop Time=2 ms.TRAN ≡ Neste caso.Resposta Temporal do Circuito da Figura 11. etc. que traça a curva correspondente à razão entre a tensão do nó in e a corrente no resistor R1. R. V(in)/I(R1). que podem ser plotadas. clicando-se o botão direito do mouse em qualquer ponto do gráfico o menu de atuação (zoom. Simulações com pulsos (PULSE) ou outro tipo de excitação também poderiam ser feitas neste caso. pode ser aberto clicando-se em View → Visible Traces ou no ícone . o circuito. inserção ou remoção de traços. como. no menu Functions.

As cores dos traços também podem ser alteradas nesse menu. levado até outro ponto do circuito e. Se no menu SPICE Directive for selecionada a opção Comment. o gráfico da tensão nesse ramo ou nesse nó será plotado. clicando-se o botão esquerdo plota-se a curva de corrente nesse terminal.Medidas Adicionais: Após a análise de Transient. . dentro do intervalo de plotagem. é mostrado. O cursor 2 pode ser deslocado tal qual o cursor 1. A variável horizontal também pode ser mudada no menu Quantity Plotted. no menu Attached Cursor. pois todos são iniciados por um ponto. levando-se o apontador do mouse sobre ele e arrastando-o com o botão esquerdo acionado. se o cursor for colocado na mesma curva do cursor 1. se a análise de Fourier sobre a tensão do nó V(saída) for desejável na freqüência de 1 kHz. ou para facilitar a simulação ou para exigir simulações adicionais. R. Um menu. 6. . o cursor 1 será introduzido.four 1kHz V(saída) no SPICE Directive e adicionar esse menu ao esquemático. Se o botão esquerdo do mouse for clicado nessa situação. Se o apontador do mouse for colocado em um terminal de um componente e aparecer uma flecha vermelha dentro de uma ponta de prova de corrente. Nesse caso. Por exemplo. deve-se clicar o botão direito do mouse sobre o nome da curva desejada e. se o cursor for colocado em outra curva. nessa mesma situação. clicando-se o botão esquerdo do mouse plota-se a curva de dissipação de potência no componente. liberado. deve-se escrever: . Os extremos.Escalas: Colocando-se o apontador do mouse sobre a escala de um dos eixos do gráfico (aparece o desenho de uma régua) e clicando-se o botão esquerdo. no probe. Se o mouse for arrastado com o botão esquerdo apertado. clicando-se o botão esquerdo juntamente com a tecla Ctrl. abre-se um menu de ajuste da respectiva escala. com os valores. correspondentes à curva selecionada. horizontal e vertical.Inserção de Curvas Diretamente do Esquemático: Colocando-se o apontador do mouse sobre um ramo ou um nó do circuito aparecerá o desenho de uma ponta de prova vermelha. Se. várias operações podem ser executadas: . Para isso. A lista completa desses comandos está relacionada em: Help → Help Topics → LTspice → Dot Commands. Esses comandos são chamados de Comandos Pontuados. . que está em cima do gráfico. será aberto um menu que informará o valor médio (Average) e o valor eficaz (RMS) dessa grandeza. Um segundo cursor pode ser adicionado à mesma curva ou à outra curva. Comandos Extras Vários comandos extras podem ser adicionados à área de trabalho do simulador. . ou 2nd.Cursores: Clicando-se o botão esquerdo do mouse sobre o nome da curva.Gráficos Adicionais: No probe vários gráficos podem ser adicionados à área de trabalho clicando-se em: Plot Settings → Add Plot Pane. a flecha vermelha se transformará em um termômetro. P. o comando torna-se apenas um comentário textual. No instante em que o botão do mouse é acionado a ponta de prova torna-se cinza. Veronese 17 SEL-EESC-USP . Comandos desse tipo devem ser inseridos no esquemático através da habilitação Edit → SPICE Directive. Esse cursor poderá ser deslocado.Simuladores de Circuitos Eletrônicos Na janela gráfica do probe. então. quando o apontador do mouse estiver sobre o nome de uma das curvas. será plotado no probe a diferença de potencial entre esses dois pontos. deve-se selecionar 1st & 2nd. a taxa de variação (linear ou logarítmica) ou a unidade de medida (Volt ou dB) da escala podem ser alterados. for apertada a tecla Alt.

Wiley. 7.A. desse gráfico também podem ser alteradas analogamente ao procedimento do item 5.J. Riedel – Electric Circuits w/ PSpice. 1993. R.J. Antognetti and G. Tront – PSpice for Basic Circuit Analysis. 2004. Nilsson and S. McGraw-Hill. Veronese 18 SEL-EESC-USP . horizontal e vertical. Bibliografia . 1993. Uma segunda janela gráfica será aberta plotando o espectro discretizado da Amplitude × Freqüência da grandeza solicitada.G.W. As escalas. P. Essa análise pode ser obtida clicando-se no Probe: View → FFT → Selecionar a variável a ser analisada → OK. . Vladimirescu – The Spice Book. 7th Edition.TRAN). Prentice Hall.Simuladores de Circuitos Eletrônicos Um comando extra fundamental é a análise de Fourier executada por um algoritmo de FFT sobre uma curva plotada em função do tempo (análise . . 2004. McGraw-Hill/Engineering/Math. Massobrio – Semiconductor Device Modeling with SPICE.P. .

You're Reading a Free Preview

Descarregar
scribd
/*********** DO NOT ALTER ANYTHING BELOW THIS LINE ! ************/ var s_code=s.t();if(s_code)document.write(s_code)//-->