Você está na página 1de 8

UNIVERSIDADE ESTADUAL VALE DO ACARA

EXERCCIOS RESOLVIDOS Estruturas de Repetio 1 Faa um algoritmo que imprima todos os nmeros pares no intervalo de 1 a 10. INICIO C: INTEIRO; PARA C = 1 AT 10 PASSO 1 FAA SE (C MOD 2 = 0) ENTO ESCREVA(C); FIMPARA FIM 2a Faa um algoritmo que imprima os nmeros de 120 a 300. INICIO C: INTEIRO; PARA C= 120 AT 300 FAA ESCREVA(C, ); FIMFAA FIM. 3 Faa um algoritmo que o usurio entra com 15 nmeros e seja impressa a raiz quadrada de cada um. INICIO A: INTEIRO; NUMERO: REAL; PARA A = 1 AT 15 PASSO 1 FAA ESCREVA(Digite um nmero:); LEIA(NUMERO); SE (NUMERO >= 0) ENTO ESCREVA(RAIZ QUADRADA DE , NUMERO, EH , SQRT(NUMERO)); SENO ESCREVA(Nmero negativo. No possvel obter raizes reais deste nmero!); FIMPARA FIM.

4 Faa um algoritmo que o usurio informar o nome, o sexo e a idade de 20 pessoas. O algoritmo deve imprimir o nome se a pessoa for do sexo masculino e tiver mais de 21 anos. INICIO IDADE, N: INTEIRO; NOME, SEXO: CARACTERE; PARA N = 1 AT 20 PASSO 1 FAA ESCREVA(Digite o nome: ); LEIA(NOME); ESCREVA(Digite o sexo: ); LEIA(SEXO); ESCREVA(DIGITE A IDADE: ); LEIA(IDADE); SE (((SEXO=MASCULINO) OU (SEXO=M)) E (IDADE>21)) ENTAO ESCREVA(NOME); FIMPARA FIM. 5 Crie um algoritmo que leia os limites inferior e superior de um intervalo e imprima todos os nmeros mltiplos de 6 no intervalo fechado. Suponha que os dados digitados so para um intervalo crescente. Exemplo: Limite inferior: 5 Limite superior: 13 Sada: 6 12 INICIO INICIO, FINAL, N: INTEIRO; ESCREVA(INFORME O VALOR INICIAL DO INTERVALO: ); LEIA(INICIO); ESCREVA(INFORME O VALOR FINAL DO INTERVALO: ) LEIA(FINAL); SE (INICIO MOD 6 = 0) ENTO INICIO<- INICIO + 6; SENO INICIO <- INICIO + (6 (INI MOD 6)); PARA N = INICIO AT FINAL PASSO 6 FAA ESCREVA(N, ); FIMPARA FIM.

6a Criar um algoritmo que leia os limites inferior e superior de um intervalo e imprima todos os nmeros pares no intervalo aberto e seu somatrio. Suponha que os nmeros digitados so um intervalo crescente. Exemplo: Limite inferior: 3 Limite superior: 12 Nmero: 3 Sada: 4 6 8 10 Soma: 28 INICIO INI, VF,SOMA, I: INTEIRO; ESCREVA(DIGITE O VALOR INICIAL); LEIA(INI); ESCREVA(DIGITE O VALOR FINAL); LEIA(VF); SOMA <- 0; SE (INI MOD 2 = 0) ENTO INI <- INI + 2; SENO INI <- INI + 1; VF <- VF 1; PARA I = INI AT VF PASSO 2 FAA SOMA <- SOMA + I; ESCREVA(I, ); FIMPARA ESCREVA(Soma: , SOMA); FIM. 7 Faa um algoritmo que o usurio entre com nmeros e o algoritmo imprima o triplo de cada nmero. O algoritmo encerra quando o usurio entrar com o nmero 999. INICIO NUM: REAL; ESCREVA (DIGITE UM NMERO OU 999 PARA TERMINAR: ); Leia(NUM); FAA ENQUANTO (NUM <> -999) ESCREVA(TRIPLO: , NUM*3); ESCREVA (DIGITE UM NMERO OU 999 PARA TERMINAR: ); Leia(NUM); FIMFAA

8 Faa um algoritmo que leia vrios nmeros e que informe quantos desses nmeros entre 100 e 200 foram digitados. Quando o valor 0 (zero) for lido o algoritmo dever cessar sua execuo. INICIO CONT: INTEIRO; NUM: REAL; CONT <- 0; ESCREVA (DIGITE UM NMERO QUALQUER OU 0 PARA SAIR: ); LEIA (NUM); FAA ENQUANTO (NUM <> 0) SE ((NUM >= 100) E (NUM <= 200)) ENTO CONT <- CONT + 1; ESCREVA (DIGITE UM NMERO QUALQUER OU 0 PARA SAIR: ); LEIA (NUM); FIMFAA ESCREVA(TOTAL: , CONT); FIM. 9 Chico tem 1,50m e cresce 2 centmetros por ano, enquanto Juca tem 1,10m e cresce 3 centmetros por ano. Construir um algoritmo que calcule e imprima quantos anos sero necessrios para que Juca seja maior que Chico.

INICIO ANOS: INTEIRO; C, J: REAL; C <- 1.50; J <- 1.10; ANOS<- 0; FAA ENQUANTO (J <= C) C <- C + 0.02; J <- J + 0.03; ANOS <- ANOS + 1; FIMFAA ESCREVA (Serao necessarios :, ANOS); FIM.

10 Faa um algoritmo que o usurio entre com a idade de vrias pessoas e imprimir: a) Total de pessoas com menos de 21 anos; b) Total de pessoas com mais de 50 anos; O algoritmo ser executado enquanto no for digitada idade menor que zero ou maior do que 140. INICIO IDADE, C21, C50: INTEIRO; C21 <- 0; C50 <- 0; ESCREVA (ENTRE COM UMA IDADE: ); LEIA(IDADE); FAA ENQUANTO ((IDADE >= 0) E (IDADE <= 140)) SE (IDADE < 21) ENTO C21 <- C21 + 1; SENAO SE (IDADE > 50) ENTO C50 <- C50 + 1; ESCREVA (ENTRE COM UMA IDADE: ); LEIA(IDADE); FIMFAA ESCREVA (TOTAL DE IDADES INFERIORES A 21 ANOS: , C21); ESCREVA (TOTAL DE IDADES SUPERIORES A 50 ANOS: , C50); FIM. 11 Faa um algoritmo que o usurio informa um nmero e o algoritmo verifica se ele um nmero triangular. Obs.: Um nmero triangular quando o resultado do produto de trs nmeros consecutivos. Exemplo: 24 = 2 x 3 x 4. INICIO NUM, P, NUM1: INTEIRO; NUM1<- 1; ESCREVA (DIGITE UM NMERO: ); LEIA(NUM); P <- NUM1 * (NUM1+1) * (NUM1 + 2); FAA ENQUANTO (P < NUM) NUM 1 <- NUM1 + 1; P <- NUM1 * (NUM1+1) * (NUM1 + 2); FIMFAA SE (P = NUM) ESCREVA(EH TRIANGULAR); SENO ESCREVA(NO EH TRIANGULAR.); FIM.

12 Criar um algoritmo que o usurio entre com vrios nmeros inteiros e positivos e imprima a mdia dos nmeros que so mltiplos de 3. INICIO NUM, CONT, SOMA: INTEIRO; SOMA<- 0; CONT <- 0; ESCREVA(DIGITE UM NMERO POSITIVO E PARA TERMINAR, UM NEGATIVO OU ZERO: ); LEIA(NUM); FAA ENQUANTO (NUM > 0) SE (NUM MOD 3 = 0 ) ENTO CONT <- CONT + 1; SOMA <- SOMA + NUM; ESCREVA(DIGITE UM NMERO POSITIVO E PARA TERMINAR, UM NEGATIVO OU ZERO: ); LEIA(NUM); FIMFAA SE (CONT <> 0) ENTO ESCREVA(A MDIA DOS NMEROS MULTIPLOS DE 3 EH: , SOMA/CONT); SENAO ESCREVA(NENHUM MULTIPLO DE 3 FOI INFORMADO.); FIM. 13 Crie um algoritmo que o usurio entre com vrios nmeros inteiros e positivos e imprima o produto dos nmeros mpares e a soma dos nmeros pares. Iinicio NUM, PROD, SOMA: INTEIRO; SOMA <- 0; PROD <- 0; ESCREVA(DIGITE UM NMERO POSITIVO E PARA TERMINAR, UM NEGATIVO OU ZERO: ); LEIA(NUM); FAA ENQUANTO (NUM > 0) SE (NUM MOD 2 = 0) ENTO SOMA <- SOMA + NUM; SENAO PROD <- PROD * NUM; ESCREVA(DIGITE UM NMERO POSITIVO E PARA TERMINAR, UM NEGATIVO OU ZERO: ); LEIA(NUM); FIMFAA ESCREVA(O PRODUTO DOS NUMEROS IMPARES EH: , PROD); ESCREVA(A SOMA DOS NUMEROS PARES EH: , SOMA); FIM.

14 Crie um algoritmo que ajude o DETRAN a saber o total de recursos que foram arrecadados com a aplicao de multas de trnsito. O algoritmo deve ler as seguintes informaes para cada motorista: - O nmero da carteira de motorista (de 1 a 4327) - Nmero de multas; - Valor da cada uma das multas. Deve ser impresso o valor da dvida de cada motorista e ao final da leitura o total de recursos arrecadados (somatrio de todas as multas). O algoritmo dever imprimir tambm o nmero da carteira do motorista que obteve o maior nmero de multas. INICIO C, CART, NMULT, MCART, MNMULT: INTEIRO; VALOR, TOTAL: REAL; MNMULT <- 0; ESCREVA(DIGITE A CARTEIRA DE MOTORISTA OU 0 (ZERO) PARA TERMINAR:); LEIA(CART); FAA ENQUANTO (CART <> 0) TOTAL <- 0; ESCREVA(DIGITE O NMERO DE MULTAS: ); LEIA(NMULT); SE (NMULT > MNMULT) MNMULT <- NMULT; MCART <- CART; PARA C= 1 AT C=NMULT PASSO 1 FAA ESCREVA(DIGITE O VALOR DA MULTA: ); LEIA(VALOR); TOTAL <- TOTAL + VALOR; FIMPARA ESCREVA(CARTEIRA DE MOTORISTA: , CART); ESCREVA(VALOR A PAGAR: , TOTAL); ESCREVA(DIGITE A CARTEIRA DE MOTORISTA OU 0 (ZERO) PARA TERMINAR:); LEIA(CART); FIMFAA ESCREVA(NUMERO DA CARTEIRA COM MAIOR NUMERO DE MULTAS: , MCART); FIM.

15 Crie um algoritmo que receba a idade, a altura e o peso de vrias pessoas. Calcule e imprima: - A quantidade de pessoas com idade superior a 50 anos; - A mdia das alturas das pessoas com idade entre 10 e 20 anos; - A porcentagem de pessoas com peso inferior a 40 quilos entre todas as pessoas analisadas. INICIO PESO, ALTURA, SOMA1020: REAL; IDADE, CT, C1020, C50, C40: INTEIRO; SOMA1020 <- 0; CT <- 0; C1020 <- 0; C50 <- 0; C40 <- 0; ESCREVA(ENTRE A IDADE OU 0 (ZERO) PARA TERMINAR: ); LEIA (IDADE); FAA ENQUANTO (IDADE > 0 ) CT <- CT + 1; ESCREVA (INFORME A ALTURA: ); LEIA(ALTURA); ESCREVA(INFORME O PESO); LEIA(PESO); SE (PESO < 40) ENTO C40 <- C40 + 1; SE (IDADE > 50) ENTO C50 <- C50 + 1; SENAO SE ((IDADE > 10) E (IDADE < 20)) ENTAO C1020 <- C1020 + 1; SOMA1020<- SOMA1020 + IDADE; ESCREVA(ENTRE A IDADE OU 0 (ZERO) PARA TERMINAR: ); LEIA (IDADE); FIMFAA SE (C50 > 0) ENTO ESCREVA(TOTAL DE PESSOAS COM MAIS 50 ANOS: , C50); SENO ESCREVA(NINGUM COM MAS DE 50 ANOS); SE (C1020 > 0) ENTO ESCREVA(MEDIA ENTRE 10 E 20 ANOS: , SOMA1020/C1020); SENAO ESCREVA(NINGUEM DENTRO DA FAIXA DE 10 A 20 ANOS); SE (C40 > 0) ENTO ESCREVA(PERCENTUAL DE PESSOAS COM MENOS DE 40 Kg: , c40 * 100/CT); SENO ESCREVA(NINGUM COM MENOS DE 40 Kg.); FIM.