Você está na página 1de 28

CURSO DE CRYSTAL REPORT 8.

- Pg. 1 -

Captulo 1 - Introduo___________________________________________________________4
Caractersticas do produto.........................................................................................................................4 Alteraes na tela de Preview.....................................................................................................................4 Relatrio Condicional.................................................................................................................................4 Sub-relatrios..............................................................................................................................................5 Crystal Query Designer..............................................................................................................................5 Parmetros..................................................................................................................................................5 Objetos Textos.............................................................................................................................................5

Captulo 2 - A Janela de Projeto de Relatrios__________________________________________6


Modos de apresentao...............................................................................................................................6 A Janela Design do Relatrio Report Designer.....................................................................................6 Caractersticas da rea de Impresso (Design Tab) .............................................................................7 Report Header ..........................................................................................................................................7 Page Header...............................................................................................................................................7 Details.......................................................................................................................................................7 Report Footer.............................................................................................................................................7 Page Footer................................................................................................................................................7 Group header.............................................................................................................................................8 Group Footer.............................................................................................................................................8 Preview Tab.................................................................................................................................................8 Criando um relatrio................................................................................................................................10 O Comando Add Database to Report... (Menu Database) ...............................................................10 Inserindo e Formatando Campos.............................................................................................................11 Como inserir campos de dados.................................................................................................................11 Prevendo o Relatrio.................................................................................................................................12 Inserindo Campos de texto.......................................................................................................................12 Formatando Campos (Format Editor)....................................................................................................13 Formatando dados....................................................................................................................................13 Como adicionar cor, sombra, e borda.....................................................................................................13 Como adicionar e editar linhas................................................................................................................14 Adicionando Linhas..................................................................................................................................14 Editando Linhas........................................................................................................................................14 Como adicionar e editar boxes.................................................................................................................15 Adicionando boxes....................................................................................................................................15 Editing boxes.............................................................................................................................................15

Captulo 4 - Selecionado registros___________________________________________________16


Seleo de registro usando Seleo automtica de registros..................................................................16

Captulo 5 Agrupando, Ordenao e Selecionado Dados_______________________________17


Inserindo Grupos......................................................................................................................................17 - Pg. 2 -

Para inserir um grupo..............................................................................................................................17 Inserindo Sumrio, Subtotais, e Grandes totais......................................................................................19 Para usar o Comando Summary..............................................................................................................19 O Comando Subtotal (Insert menu)........................................................................................................21 Para usar o Comando Subtotal...............................................................................................................21 Para usar o Comando Grand Total........................................................................................................22 Como usar o comando Grand Total.......................................................................................................22

Captulo 6 Frmulas____________________________________________________________23
Inserindo Frmulas...................................................................................................................................23 Editando os registros de Seleo de Frmula..........................................................................................25

Captulo 7 Formatao e insero avanadas________________________________________25


Formatando sees....................................................................................................................................25 Para formatar uma seo.........................................................................................................................25

Capitulo 8 Criando outros Tipos de Relatrios_______________________________________27


Criando um Relatrio Sumrio................................................................................................................27 Relatrios Tipo Drill Down......................................................................................................................27 Relatrios Cross-Tab................................................................................................................................27

- Pg. 3 -

Captulo 1 - Introduo
Um relatrio uma apresentao organizada de dados. Como uma ferramenta de administrao, um relatrio usado para proporcionar a direo da empresa subsdios para que ela possa ter como tomar decises baseadas em dados efetivos. Um relatrio uma maneira eficaz de apresentar seus dados em um formato impresso. Como voc tem controle sobre o tamanho e a aparncia de todos os elementos de um relatrio, possvel exibir as informaes da maneira como deseja v-las. O Crystal Reports uma ferramenta para gerar relatrios, podendo acessar diversos tipos de bases de dados. Durante este curso ns estaremos aprendendo como desenvolver relatrios. Caractersticas do produto Crystal Reports, sendo as principais funcionalidades: Subrelatrios Sees com mltiplos detalhes Melhoria nos diversos recursos de integrao de grficos Interface nativa para Oracle / Sybase /SQL Server / DB2 / Centura / Informix Criao pelo usurio de novas funes a serem usadas em frmulas (criando DLLs em VB ou Delphi). Exportao para HTML Relatrios na Web atualizao dinmica dos dados Page-on-demand : otimizando a velocidade de apresentao Crystal Web Report Server Tela de runtime com novas funcionalidades configurveis Drill down na tela de runtime Interface Automation Server (OLE) Hiperlinks Add-ins Access e Excel Alerta em Relatrios Exportao para Formatos PDF e RTF Integrao com Padro XML Alteraes na tela de Preview A partir da verso 5.0 o Crystal permite rapidamente alternar entre duas telas a Design (Projeto ou de Estrutura) e a Preview (que WYSIWYG). Tambm possvel fazer alteraes diretamente na tela de Preview, e visualizar imediatamente o resultado das alteraes. Existe a opo de Undo/Redo que agiliza as simulaes na confeco de relatrios. Relatrio Condicional O Crystal dispe de 5 reas de relatrio: o Cabealho do Relatrio, o Rodap do Rodap, o Detalhe, o Cabealho da pgina e o Rodap da pgina. Com esta verso pode-se criar Multiple Sections em qualquer rea do relatrio, ou seja por exemplo podemos na rea de detalhe criar duas sees de detalhes, a seo A e a seo B. A grande vantagem que se pode imprimir a seo condicionalmente, posso criar uma carta com uma mensagem para funcionrios quem tem dependentes e outra mensagem para os que no tem. Pode ainda imprimir em um formato, por exemplo em vermelho quem est em dbito e em preto quem tem crdito.

- Pg. 4 -

Sub-relatrios Com esta verso do Crystal possvel criar sub-relatrios e inseri-los no seu relatrio. Estes sub-relatrios podem utilizar tabelas relacionadas ou no com o relatrio principal, e podem ainda ligar as informaes do sub-relatrio ao relatrio principal. Isto permite que: Em um nico relatrio comportando 2 ou mais relatrios com dados no relacionados, por exemplo em um nico relatrio podemos ter o faturamento da Empresa e quantidade de micros por funcionrios em cada Departamento. Criar um relatrio que cria diferentes vises dos dados. Por exemplo: no cabealho pode-se incluir um relatrio que totaliza o faturamento por Secretaria e no detalhe um relatrio em que para cada Secretaria totaliza o faturamento por projeto. Ou ainda criar sub-relatrios ligados ao relatrio principal, por exemplo um relatrio principal listando todas as Secretarias e um sub-relatrio listando os projetos daquela Secretaria e outro sub-relatrio listando os equipamentos da Secretaria. Crystal Query Designer um gerador de query que elimina a necessidade de entendimento, bem como os erros de codificao, da linguagem SQL As queries geradas por este aplicativo podem ser utilizadas no Crystal Report. Segundo a Crystal as queries geradas so totalmente compatveis com o padro ANSI. Parmetros

Campos parmetros podem ser definidos no relatrio. Quando o relatrio executado o usurio ser requisitado a informar os valores dos campos. Estes valores podem ser utilizados para mudar ttulos de relatrios, critrios de seleo de registros e ordem dos campos (Sort Records).
Objetos Textos Com objetos textos possvel criar textos, mesclando tambm campos de banco de dados, que so gerenciados por um mini word processor. Pode-se por exemplo criar uma carta ou documento para cada funcionrios independentemente do tamanho do seu nome, de modo semelhante como se fosse feito no Word.

- Pg. 5 -

Captulo 2 - A Janela de Projeto de Relatrios


Modos de apresentao O Crystal Reports apresenta 2 (dois) modos de apresentao. O modo design e o modo Preview. O modo design onde estaremos desenhando o relatrio. Este modo o ideal para incluirmos Ttulos, figuras, campos e frmulas. O modo Preview onde estaremos vendo o relatrio executado. possvel fazermos alguns ajustes neste modo, mas existe o inconveniente se o relatrio for muito grande, ele ir atualizar todo o relatrio.

A Janela Design do Relatrio Report Designer


Comearemos nos familiarizando com a janela principal do Crystal Report. Aps voc selecionar a sua base de dados e as tabelas que sero usadas, O Crystal Reports mostra a tela de Design. Voc estar usando a Design Tab mais que qualquer outra parte do programa. A Design Tab prov o ambiente mais eficiente para projetar seu relatrio porque voc trabalha na Tab com representaes de dados, e no com os dados em si. Quando voc coloca um campo no relatrio, o programa usa uma armao para identificar o campo na Tab; no atualiza os dados. Assim, voc pode somar e pode apagar campos e outros objetos, montando frmulas complexas, movendo os campos e objetos e mais, sem amarrar o computador aos recursos de dados. O relatrio que voc cria na Design Tab um tipo de relatrio virtual; tem a estrutura e as instrues para criar o relatrio final, mas no o prprio relatrio. Quando voc pede para visualizar ou imprimir o relatrio, ele transforma em um relatrio final. Os dados atuais aparecero agora no relatrio. Existem vrias sections (sees) onde poderemos colocar nossas informaes. Voc pode colocar objetos nestas sees, especificar sort de dados, definir grupos, totalizar campos numricos, inserir frmulas, etc.. Quando. voc abre um relatrio novo criado automaticamente 5 sees no Report Designer.

- Pg. 6 -

Caractersticas da rea de Impresso (Design Tab)

Cada section de relatrio tem suas prprias caractersticas de impresso, por isso importante entender cada uma delas. A ordem e a freqncia dos objetos de relatrio afetam de forma diferente quando o relatrio impresso.
As Sections so impressas na mesma ordem que elas aparecem na Design Tab (topo para baixo ). Se h mais de uma seo em uma rea, as sees imprimem na ordem que eles aparecem dentro da rea. Assim, se voc tem trs Header section, todos as trs sees sero impressas, em ordem do topo para baixo. Sua deciso em onde colocar objetos no Design Tab ser mais fcil se voc entender com que freqncia cada section so impressas. Uma vez que voc entendeu isto, a construo do seu relatrio ser mais fcil e rpida. Vejamos cada uma delas. Report Header

a primeira seo que aparece no seu relatrio no Design Tab. Voc pode colocar um ttulo nesta seo, ou algum dado que voc queira que aparea somente na primeira pgina do seu relatrio. Geralmente utilizado para fazer a capa de apresentao do relatrio. Page Header
Esta seo geralmente utilizada para que seja colocado um titulo para o relatrio, um campo que sirva como cabealho, a faixa de valores selecionados, e outras informaes que voc queira apresentar no topo de cada pgina de seu relatrio.. Details Esta seo o corpo do relatrio. O volume maior de dados do seu relatrio aparecer nesta seo. aqui onde so inseridos os campos das suas tabelas de dados.

Report Footer A Report Footer section a ltima seo do seu relatrio. Aqui voc pode colocar um resumo ou comentrios que voc deseja que aparea somente na ltima pgina. Normalmente usada para colocar os subtotais, mdias e totais, resumindo as informaes do seu relatrio. Page Footer Esta seo usualmente contm o nmero da pgina e alguma outra informao que ser mostrada no final de cada pgina. Por default, a seo de pager footer criada com trs linhas. Cada seo possui do lado esquerdo uma identificao com o nome da seo. As sees so separadas por um divisor de sees. Voc constri seu relatrio inserindo campos, frmulas, e outros elementos de um relatrio (contadores de registro, de grupos, etc.) na seo Details section. Voc usa a opo insert do menu, em alguns casos, para selecionar ou criar elementos que voc deseja inserir no seu relatrio.

- Pg. 7 -

O Report Designer usa retngulos para indicar os tamanhos dos campos, posio e tipo de dados e frmulas que voc inseriu. Group header Um Group Header uma section criada pelo programa que permite voc fazer quebras ou agrupar os registros obedecendo a um campo ou frmula, totalizar e gerar subtotais. O Group Header section tipicamente usado para mostrar o nome do grupo ou alguma outra informao.

Group Footer O Group Footer uma section criada pelo programa quando voc insere um grupo, subtotal ou total . O Group Footer section tipicamente usado para mostra um resumo ou subtotal. Preview Tab Quando voc quiser ver como seu relatrio ser impresso antes de imprimi-lo, click na Preview Tab O programa coleta os dados, faz os clculos necessrios, e mostra o relatrio no Preview Tab num papel eletrnico. Com os dados no lugar, voc pode rever os espaos e formatar seu relatrio vendo o resultado atual de todas as sumarizaes , calculando as frmulas, e registro e grupos de seleo. Em verdade com o WYSIWYG (o que Voc V o que Voc Adquire), voc pode trabalhar diretamente nestes dados ao vivo, afinando o relatrio at chegar onde voc quer. O programa trabalha com dados da maneira seguinte: - a primeira vez em que Preview Tab usada, carregue os dados de sua base de dados e salva isto com o relatrio (a menos que voc no queira salvar os dados). - Daquele ponto em, o programa usa os dados economizados sempre que voc prev o relatrio a menos que voc especificamente refresque isto ou soma um campo que exige para o programa recobrar dados novos.

- Pg. 8 -

- Pg. 9 -

Capitulo 3 Inserindo e Formatando Campos


Criando um relatrio

O primeiro passo para a criao de um novo relatrio clicar o boto de Novo Relatrio na barra de botes. A caixa de dilogo que aparece conhecida como Galeria de Relatrios.

A Galeria do relatrio nos oferece o nmero de opes quando construmos um novo relatrio. Apesar de podermos usar uma funo automtica para montar o relatrio, ns iremos montar o relatrio manualmente, pois queremos aprender os fundamentos. Crystal Reports chama isso de montar um relatrio customizado. O Comando Add Database to Report... (Menu Database) Use o comando Add Database to Report para informar qual a base de dados e selecionar as tabelas para uso em seu relatrio. Quando voc est criando um relatrio novo, voc seleciona em primeiro lugar o banco de dados que voc quer usar em seu relatrio. Voc tambm, pode especificar com este comando, outros banco de dados adicionais.

- Pg. 10 -

Inserindo e Formatando Campos

Como inserir campos de dados Click o boto Insert Fields na barra de ferramentas. A caixa de dilogo Field Explorer aparece com o Database Field Tab ativa listando todos os campos da base de dados escolhida.

2 3

Click no campo que voc quer que aparea no seu relatrio. Click o boto Insert para coloc-lo no seu relatrio e mova o campo para onde voc quiser.

- Pg. 11 -

Caso voc queira, Click o boto Browse Data para ver os valores do campo selecionado. Voc pode repetir esta operao se for incluir mais campos ou Click o boto Close para fechar a caixa de dilogo.
Prevendo o Relatrio

Em apenas poucos passos ns geramos um relatrio. Agora vamos olh-lo, imprimindo-o na Janela Preview. Clique na tab Preview para prever seu relatrio com dado real. O programa ir ler os dados e mostrar a primeira pgina. Na Tab Preview, voc pode fazer vrias montagens do relatrio, agrupar, resumir, e formatar operaes, o que tambm pode ser feito na Tab Design. Assim que continuarmos desenvolvendo nosso relatrio, podemos fazer algumas montagens na Janela Preview e algumas na Janela Design. Algumas modificaes de design que fazemos na Janela Preview so transferidas tambm para a Janela Design.

A Barra de Status na Janela Preview fornece informaes sobre o dado usado no relatrio. Ela mostra quantos registros foram selecionados e o total de registros lido. Se estiver usando dados salvados, tambm mostra a data e a hora em que o dado foi lido.
Dica: Quando voc roda um relatrio e ento o salva ou fecha, o programa, por padro, salva os dados com o relatrio. Isso elimina a necessidade do programa de acessar e processar o dado cada vez que voc roda o relatrio. Cada vez que voc roda o relatrio, ele ser baseado nos dados salvados. Quando voc abrir um relatrio, a data e hora em que o dado foi salvo aparece na seo cinza, no topo da Janela Preview, esquerda do boto de Fechamento. Se os bancos de dados nos quais o relatrio baseado esto ficando desatualizados, e essencial que o relatrio esteja com os dados mais atualizados possveis, o programa permite que voc faa um refresh dos dados. Quando voc rel os dados, roda novamente o relatrio baseado em dados mais recentes. Voc rel os dados clicando o boto [ressaltado] ou selecionando o comando Report/Refresh Report Data (F5). Inserindo Campos de texto

Agora vamos adicionar alguns textos ao relatrio. Ns vamos adicionar um ttulo. Podemos adicionar texto de 2 maneiras: - Pg. 12 -

Redigindo o texto diretamente no relatrio, Inserindo um campo de texto. Para esse exemplo, ns inseriremos um campo de texto. Para inserir um campo de texto, clique (boto para Inserir campo texto) na barra de botes ou escolha Insert/Text Object na Barra de menu. Uma caixa de dilogo mostrada, onde voc pode redigir o texto para o campo.
Formatando Campos (Format Editor)

A caixa de dialogo aparece quando: - Voc clica o boto direito do mouse sobre algum campos e seleciona o Format Text.

Dependendo do boto que voc clicou , ou do campo no qual voc clicou o botando direito do mouse, a variedade de tabs que aparecer poder variar dependendo do tipo do campo
Formatando dados Neste ponto da criao do relatrio, voc poder querer fazer alguma formatao bsica. Talvez voc queira mudar o tamanho da fonte ou o tipo de fonte de um texto usado como ttulo. Ou, num campo numrico, seja necessrio colocar casas decimais, ou o smbolo da moeda. Vejamos como podemos fazer estas formataes. Como adicionar cor, sombra, e borda

- Pg. 13 -

Crystal Reports permite que voc adicione cor, borda, e sombra para campos de seu relatrio para enfatizar dados importantes e criar um visual professional para o seu relatrio. 1 Click o boto direito do mouse sobre o campo que voc deseja formatar e escolha o comando Border and Colors.

Selecione o Line Style (estilo de linha), Color e BackGround que voc desejar e click OK para finalizar. O programa formatar o campo selecionado com as especificaes que voc escolheu.
Como adicionar e editar linhas

Crystal Reports permite que voc adicione linhas e caixa (boxes) para que voc enfatize os dados mais importantes do seu relatrio e crie um relatrio com visual profissional.
Adicionando Linhas

Click no boto Insert Line na barra de ferramentas suplementar. Um cursor pencil-shaped ir aparecer. Usando o pencil cursor, desenhe a linha onde desejar.
Editando Linhas

- Pg. 14 -

Click o boto direito do mouse na linha (line) que voc quer formatar e escolha o comando Format Line.

. O Format Editor aparecer com o Format Line Tab ativo.

Faa as mudanas desejadas e click OK quando terminar para retornar ao relatrio.

Como adicionar e editar boxes Adicionando boxes

Click o boto Insert Box na barra de ferramentas suplementar. Um cursor pencil-shaped ir aparecer. Usando o pencil cursor, desenhe um box onde desejar. .
Editing boxes

Click o boto direito no box que voc quer formatar e escolha o comando Format Box. O Format Editor aparecer com o Format Box Tab ativo. Selecione a cor, largura, estilo, e/ou a cor de preenchimento que voc quiser e click OK quando terminar. O programa formatar o box selecionado com a especificaes que voc escolheu.

- Pg. 15 -

Captulo 4 - Selecionado registros


Geralmente em um relatrio voc deve limitar a informao que voc v e fazer o que for necessrio para selecionar os registros que quiser visualizar. Por exemplo, podemos estar apenas interessados em certas empresas ou apenas as empresas em estado selecionadas, etc. Isso conhecido colo uma seleo de registros. Vamos agora especificar um critrio de seleo de registros para nosso relatrio. O Crystal Reports disponibiliza duas opes para seleo de registros: Seleo automtica de registros, a qual ns iremos utilizar aqui, e Editar frmula de seleo de registro, a qual ser mostrada adiante.
Seleo de registro usando Seleo automtica de registros

O Select Records Expert uma forma direta e rpida de criar uma expresso de seleo de registros. Ele ir nos guiar passo a passo atravs do processo de criao. Escolha Report/Select Expert do menu do relatrio. A caixa de dilogo da Create Report Expert ir aparecer.

- Pg. 16 -

O primeiro passo decidir seu critrio de seleo. (Ns estamos interessados em uma da srie de valores ou valores especficos??). Neste caso, estamos interessados em uma srie de valores, ento selecionamos one of da caixa central de seleo de registros. Quando ns fizermos isso, uma terceira caixa de seleo de registros aparecer. Usaremos a ltima caixa de seleo de registros para selecionar quais valores gostaramos no nosso relatrio. Basicamente precisamos completar a sentena . Se sabemos os valores, poderemos digit-los diretamente na caixa. Provavelmente mais seguro, contudo, usar a tecla de seleo de registros, para selecionar valores diretamente. Freqentemente podemos querer ter mais do que um critrio de seleo. Se for este o caso, uma vez terminado com uma seleo, ficaremos no Select Records Expert e escolheremos um <New> Tab. Ento selecionaremos o prximo campo no qual gostaramos de criar um critrio. Uma vez que selecionamos um campo e clicamos OK, a caixa de dilogo da Select Records Expert ir reaparecer com uma nova tabela para o campo selecionado. Crie o critrio de seleo da mesma maneira que anteriormente. Voc pode, dessa maneira, continuar criando critrios de seleo em vrios campos.
Captulo 5 Agrupando, Ordenao e Selecionado Dados

Uma vez que voc tenha criado um relatrio bsico, voc ir querer organizar os dados agrupando as informaes relacionadas , ordenando os registros individualmente, e criar sumrios, subtotais, e totais gerais.
Inserindo Grupos

At agora ns selecionamos informaes especficas para o nosso relatrio usando seleo de registros, mas as informaes so apresentadas na ordem em que esto armazenadas no banco de dados. Provavelmente gostaramos de agrupar as informaes (todos os clientes de So Paulo, os clientes do Rio de Janeiro, etc.). Isso chamado de agrupamento de dados, adicionamos sees ao relatrio e podemos visualizar novas sees no nosso relatrio na Janela Design. Podemos agrupar informaes pelos campos do relatrio ou tambm pelos campos que no esto no relatrio. Nesse relatrio queremos agrupar os dados, de forma que cada estado seja um grupo no relatrio, isto , todas as empresas em um estado especfico estaro agrupadas.
Para inserir um grupo

No menu escolha a opo Insert e selecione Group. Uma caixa chamada Insert Group aparecer uma combo com os nomes das tabelas seguido dos respectivos campos. Selecione um campo. Na combo logo abaixo, voc poder optar pelo tipo de ordenao que voc deseja.

- Pg. 17 -

Os campos podem estar ser classificados em ordem ascendentes ( A at Z, 1 at 9) ou descendente ( Z at A, 9 at 1) Click no boto de OK e logo em seguida voc poder observar no seu relatrio o surgimento de duas novas section chama Group Header e Group Footer seguido do smbolo # e de um nmero. Este nmero indica qual a seqncia do Group Header criado. At agora selecionamos informaes especficas para o relatrio e agrupamos essas informaes juntas. Os registros em cada grupo no foram ainda ordenados, eles aparecem na mesma ordem que no banco de dados. Vamos dizer que queremos listar as empresas alfabeticamente em cada Estado. Ns fazemos isso ordenando os registros de nome da empresa. Existem duas maneiras para ordenar o relatrio. Click (boto de ordenamento de registros) na Barra de ferramentas, ou Selecione Report | Sort Records... na Barra de Menu. Quando voc faz uma dessas duas opes, a caixa de dilogo Record Sort Order aparece.

- Pg. 18 -

Primeiramente ns precisamos selecionar um campo no qual queremos ordenar na caixa de campos do Relatrio. Observe que os grupos j so ordenados automaticamente quando inserimos um novo group. Para selecionarmos outros campos pelos quais queremos ordenar, devemos selecion-lo clicando com o mouse sobre ele e em seguida clicarmos na tecla ADD. Se agora ns clicarmos OK, a ordenao ser ascendente. Se quisermos uma ordem descendente, ns precisamos clicar na opo correspondente.
Inserindo Sumrio, Subtotais, e Grandes totais

Em muitos dos seus relatrios, voc ir fazer algum tipo de sort, group e ir querer totaliz-lo Sumrio tambm so utilizados em nvel de um group, onde voc poder calcular mdias, contar nmero de ocorrncias, e outros grupos de valores agregados. Um sumrio o valor gerado como o resultado de uma avaliao, de uma conta, ou um clculo de um grupo de registros. Um subtotal o somatrio de todos os valores de um campo simples, de todos os registros de um grupo. Na mdia de um grupo, Crystal Reports calcula os valores num grupo de registros; numa conta de grupo, ele conta os valores dos registros do grupo. Valores sumarizados so ferramentas importantes para a criao de relatrios sofisticados.
Para usar o Comando Summary

Selecione o campo que voc quer o sumrio Escolha o comando Summary no menu Insert . A caixa de dilogo Insert Summary ir aparecer.

- Pg. 19 -

Selecione a opo do seu interesse. 4 O segundo scroll box contm uma lista de campos e frmulas usados no relatrio.. Click o scroll arrow para ver toda a lista, e selecione desta lista o campo que voc quer que o programa use para calcular summaries. O programa ir primeiramente fazer a ordenao dos registros do relatrio baseado neste campo Ento ele ir at o fim do relatrio , agrupando e totalizando os registros quando os valores no sort and group by field mudam. 5 A prxima scroll box lista quatro opes de sort. A opo default em ordem ascendente. Se voc quiser mudar a direo do sort, click the scroll arrow para rever as opes e marque a sua seleo desta lista. Click OK quando terminar. O programa ordena, agrupa, e sumariza seus dados e insere o summary no group section de seu relatrio. Voc pode ento mov-lo de posio, para onde voc quiser imprimir nesta section.

- Pg. 20 -

O Comando Subtotal (Insert menu)

Use o comando Subtotal para inserir um subtotal no seu relatrio. Um subtotal um summary que pode ser usado apenas nos campos numricos. O programa ordena, agrupa, e subtotaliza em um nico passo. Quando voc seleciona o comando Subtotal, aparece a caixa de dialogo Insert Subtotal.
Para usar o Comando Subtotal

1 2

Selecione o campo que voc quer o subtotal. Escolha o comando Subtotal no menu Insert. A caixa de dialogo Insert Subtotal aparecer

3 Use esta caixa de dialogo para marcar as condies que iram ser disparadas quando estiver imprimindo o subtotal. Click OK quando termina. O programa automaticamente inserir o subtotal no group section de seu relatrio.

- Pg. 21 -

Para usar o Comando Grand Total

Um Grand Total o resumo de todos os valores numa coluna para o conjunto do relatrio.
Como usar o comando Grand Total

Click no campo que voc quer totalizar (ou achar a mdia, contar, etc).

Escolha o comando Grand Total no menu Insert. A caixa de dialogo Insert Grand Total ir aparecer. 3 Click no combo box para rever a lista de operaes possveis para o grand total.

Selecione a operao que voc quiser e click OK para retornar para Design Tab. O programa calcular o valor do grand total , criar uma Grand Total section para o relatrio, e colocar o valor do Grand Total nesta section.

- Pg. 22 -

Captulo 6 Frmulas
Freqentemente ns gostaramos de apresentar dados um pouco diferentes do que esto armazenados no banco de dados. Por exemplo, se ns temos no banco de dados PRIMEIRO NOME e LTIMO NOME, podemos querer apresentar essa informao reunida para o propsito do relatrio. Ou podemos querer apresentar informaes que no esto armazenadas no banco de dados, mas podem ser calculadas pelos campos do banco de dados, como mdia de vendas ou informao de percentual. Ns podemos fazer isso no CR, usando campos de Frmula.
Inserindo Frmulas

Para inserir um campo de frmula Escolha Insert/Field Object na barra de menu Se j temos campos de frmulas no relatrio, o nome de qualquer frmula existente ser mostrado na caixa de dilogo Insert Formula. Ns podemos escolher modificar uma das frmulas existentes, ou entrar com um nome para criar uma nova frmula. Tendo entrado com um nome seremos levados ao Editor de Frmulas.

- Pg. 23 -

O Editor de Frmulas tem quatro sees:

Caixa de Campos (Fields) Todos os campos de banco de dados e frmulas so listados aqui. Primeiro os campos e frmulas que j foram colocados no relatrio so listados sob Report Fields, ento todos os campos de banco de dados sem uso. Frmulas so listadas precedidas de @. Note que quando voc clica em um campo, o boto Browse Field Data fica ativa. Isso permite que voc olhe para os valores dos campos dos bancos de dados salientados. Caixa de Funes (Functions) Todas as funes avaliadas so listadas, arranjadas por seu uso. Se voc tiver criado algum User Defined Functions, elas sero listadas no final. As caractersticas entre parnteses() indicam os parmetros que devem ser fornecidos para que a funo seja executada. Caixa de Operaes (Operators) Muitas operaes so listadas e podem ser usadas em frmulas. As caractersticas x e y indicam a prpria sintaxe da operao. Caixa de Frmula de Texto (Formula Text) Aqui onde a frmula montada. Campos, Funes e Operaes iro aparecer na posio em que o cursor for clicado duas vezes nas caixas acima. medida que voc tiver selecionado as funes, o programa posicionar o cursor entre os colchetes onde so esperados os parmetros requeridos pela funo. Se voc familiaridade com a linguagem de frmulas, voc pode digit-las manualmente, se quiser.

- Pg. 24 -

Dica: Quando terminar, clique Check encontrado, Clique

para que o programa teste a sua frmula. Se nenhum erro for

para salvar a formula.

Editando os registros de Seleo de Frmula

Quando voc fez a seleo de registros anteriormente no curso, ns utilizamos o Select Records Expert. Na maioria das vezes, ns podemos selecionar registros usando Select Records Expert. Contudo, pode haver ocasies em que prefervel criar registros de seleo de frmulas diretamente ou at editar a seleo de registros criada por uma funo automtica. Para selecionar registros usando esse mtodo: Escolha Report / Edit Selection Formula / Record. O editor de frmula aparece: Se voc tiver algum registro selecionado, ele ser mostrado na Janela de Edio desde que todos registros selecionados criado pelo Select Records Expert seja na verdade criado pelo Editor de Frmula.

Captulo 7 Formatao e insero avanadas


Formatando sees

Ns agora temos as informaes que queremos apresentar no relatrio. Selecionamos registros especficos, agrupamos registros e ordenamos registros e grupos. Tambm acrescentamos informaes resumidas no relatrio. Vamos ver como formatar opes vlidas para as sees completas. Podemos querer inserir uma quebra de pgina antes de cada seo ou esconder uma seo, de forma que no imprima. Esse captulo ir mostrar como.
Para formatar uma seo

Existem dois mtodos para formatar uma seo Voc pode colocar o cursor em cima de uma das sees na esquerda da Janela Design e clicar o boto direito do mouse. Selecione a opo Format Section. A caixa de dilogo da Section Expert aparecer. As selees que voc fizer iro aparecer apenas paras as sees listadas no topo da caixa de dilogo. As sees listadas no topo da caixa de dilogo so determinadas por cada seo em que voc clicar o boto direito do mouse.

- Pg. 25 -

Inserindo campos Especiais Existem algumas informaes que no esto no banco de dados mas so teis para informao do relatrio, como Data do Relatrio (Report Data) e Nmero de Pgina (Page Number) . Clique no Insert Fields para inserir um desses campos. Um menu aparece, listando todas as opes.

- Pg. 26 -

Capitulo 8 Criando outros Tipos de Relatrios


Com o Crystal Reports ns podemos criar uma grande variedade de relatrios. Essa seo ir cobrir a criao de um relatrio sumarizado e tambm um relatrio Cross-Tab
Criando um Relatrio Sumrio

O relatrio que ns vimos at agora um relatrio detalhado, o qual inclui todas linhas de detalhes. Pode ser que o Gerente esteja interessado em informaes sumarizadas, como o total de vendas por estado. Um relatrio sumarizado inclui apenas uma linha resumida para cada grupo no relatrio. muito simples criar um relatrio sumrio de um detalhado. Tudo o que precisamos fazer esconder a seo Details e ento iremos ver apenas a informao do grupo. Para produzir um relatrio sumarizado Selecione Format/Section Escolha Details e clique OK. A caixa de dilogo Format aparecer na tela. Selecione Supress (No Drill-Down) ou Hide (Drill-Down OK)

Relatrios Tipo Drill Down

Drill Down um processo onde estamos olhando a informao sumarizada e decidimos que queremos ver os detalhes por trs destas informaes. Se pegarmos um relatrio detalhado e escondemos a seo detalhe, temos um relatrio sumarizado com capacidade drill down. Um relatrio Drill Down simplesmente um relatrio sumarizado que voc pode analisar na Janela Preview, usando o recurso drill down. Quando ns vemos um relatrio sumarizado na janela Preview, vemos que o cursor movimenta-se sobre o campo sumarizado e o cone muda para uma lente de aumento. O cone lente de aumento indica que existe uma informao detalhada disponvel para drill down. Quando ns clicamos duas vezes no campo de sumrio, uma janela de novo relatrio se abre e os detalhes do sumrio sero mostrados. O programa cria um tab perto dos Tab Design e Preview com o campo de valor do grupo. Se aplicamos o drill down em outro grupo, outro tab ser criado. Podemos ver os detalhes de cada seo drill down clicando nos tabs desejados. Se fecharmos o relatrio sumarizado, fecharemos todos relatrios detalhados tambm. O relatrio sumarizado permanece inalterado e ainda est disponvel para verific-lo clicando no Tab Preview.
Relatrios Cross-Tab

Freqentemente queremos mostrar nossa informao em um formato similar a planilha eletrnica. Ns podemos fazer isso criando um relatrio Cross-Tab. Relatrios Cross-Tab ou relatrio matriz so teis para comparar grupos de dados e tendncias pontuais. Ns podemos estar interessados em um relatrio que sumariza a quantidade total de cada item vendido por cada funcionrio. Isso pode requerer a leitura de registros relevantes do banco de dados e categoriz-los de acordo com qual item foi vendido por qual funcionrio e apresentar resultado sumarizados. O formato Cross-Tab do relatrio fornece uma fcil interface para criar esse relatrio. Para criar, clique no boto Create a New Report na barra de botes. Quando a galeria do relatrio aparecer, escolha o opo Cross-Tab. Escolha seu banco de dados. A caixa de dilogo de Cross-Tab se tornar visvel. Isso tambm refere-se a Tela do Cross Tab Layout.

- Pg. 27 -

Devemos primeiramente, determinar quais campos servem como linhas de cabealho, coluna de cabealho e campos sumarizados.

- Pg. 28 -

Você também pode gostar