Você está na página 1de 3

IESB OESTE Lgica de Programao Introduo a linguagem C Bibliografia: C Completo E Total , SCHILDT, HERBERT,

Editora: MAKRON

Observe o comparativo entre VisualG e a Linguagem C abaixo. VisualG algoritimo inicio // fimalgoritmo escreva(Idade:,Idade) //Idade inteiro leia(A) // A inteiro se A = B entao A <- C seno A <- B fimse enquanto A < 10 faca A <- A + 1; fimenquanto // A inteiro M : vetro [1..10]: inteiro nome:literal //lendo leia(nome) Linguagem C #include<stdio.h> main() { // } printf(Idade:%d,Idade) //Idade int scanf(%d,&A); //A int if (A == B){ A = C; } else { A = B; } while(A < 10){ A++; } //A int int A[10]; char nome[100]; //lendo scanf( %s,nome);

Converta os algoritmos abaixo para a linguagem C: 1. algoritmo "MEDIA" var A1,A2,MEDIA:real inicio leia (A1) leia (A2) MEDIA <- (A1 + A2)/2 escreval (MEDIA) fimalgoritmo 2 algoritmo "NOME_IDADE" var NOME : literal IDADE : numerico inicio escreval("Digite o nome e a idade") leia(NOME) leia(IDADE) escreva("NOME:", NOME, " IDADE:",IDADE) fimalgoritmo 3 algoritmo "semnome" var IDADE : numerico inicio escreval("Informe a IDADE") leia(IDADE) se IDADE > 18 entao

escreva ("Maior de IDADE") fimse se IDADE < 18 entao escreva ("Menor") fimse fimalgoritmo 4 algoritmo lista var CONTA:inteiro inicio CONTA <- 0 enquanto CONTA < 10 faca escreva(CONTA) fimenquanto fimalgoritmo