Você está na página 1de 1

algoritmo "Equacao2Grau" // Funo : Resolver uma equao do 2 grau.

// Autor : F16cent // Data : 17/08/2011 // Seo de Declaraes var b2, x1, x2, delta, a, b, c :real inicio // Seo de Comandos escreva("Digite o valor de a: ") leia(a) escreva("Digite o valor de b: ") leia(b) escreva("Digite o valor de c: ") leia(c) b2 <- b*b delta <- b2 - 4 * a * c se a = 0 entao escreva("'A' tem que ser diferente de '0'") senao se delta > 0 entao escreval("Existem duas raizes") x1 <- (-b+raizQ(delta)) / 2*a x2 <- (-b-raizQ(delta)) / 2*a escreval("Primeira raiz X'", x1) escreval("Segunda raiz X''", x2) senao se delta = 0 entao escreval("Duas raizes iguais") x1 <- (-b+raizQ(delta)) / 2*a x2 <- (-b-raizQ(delta)) / 2*a escreval("Primeira raiz X'", x1) escreval("Segunda raiz X''", x2) senao se delta < 0 entao escreva("No pertence aos reais") fimse fimse fimse fimse fimalgoritmo