Você está na página 1de 4

Comando Incio

Exemplo em Portugol (Visualg) inicio

Exemplo em Fluxograma

Observaes

incio
Variveis var idade, dias: inteiro Nas minhas aulas eu no vejo necessidade dessa informao no fluxograma. Alguns autores usam o smbolo de "dados" (paralelogramo); se eu fosse utilizar, escolheria o smbolo de "preparao de dados" (hexgono alongado). Para lembrar, costumo compara o smbolo com um teclado.

idade, dias
ou

idade, dias
Entrada leia(idade)

idade
Processamento dias <- 365 * idade

dias 365 * idade


Sada escreva(dias) Para lembrar, costumo comparar o smbolo com um monitor (antigo).

dias
Fim fimalgoritmo

fim
Chamada de procedimento/funo nome(valor, ...)

nome(valor, ...)

Portugol (Visualg) Condio (se-ento)

Exemplo se idade < 18 entao ... fimse

Fluxograma

Observaes

idade < 18 S ...

Condio (se-entoseno)

se idade < 18 entao ... senao ... fimse

idade < 18

...

...

Condio (escolhacaso)

escolha dia caso 1 ... caso 2 ... outrocaso ... fimescolha

Alguns autores utilizam apenas um losango, com vrios fluxos saindo dele, cada um com um dos casos previstos.

dia = 1 N

...

dia = 2 N

...

...

Portugol (Visualg) Repetio (enquantofaa)

Exemplo i <- 1 enquanto i <= 10 faca ... i <- i + 2 fimenquanto

Fluxograma

Observaes

i1

i <= 10 S ...

ii+2
Repetio (para) para i de 1 ate 10 passo 2 faca ... fimpara No caso da repetio "para", alguns autores utilizam o smbolo de "preparao de dados" ao invs do losango; dentro dele, colocam o valor inicial, o valor final e o passo.

i1

i <= 10 S ...

ii+2

Portugol (Visualg) Repetio (repita-at)

Exemplo repita ... ate opcao = "sair"

Fluxograma

Observaes

...

opcao = "sair"

Repetio (faaenquanto)

faca

... enquanto opcao <> "sair"

...

Esse comando no existe no Visualg. Mas, existe na maioria das linguagens como C#, Java, etc. O que muda que ele repete enquanto a condio verdadeira.

opcao <> "sair"