Você está na página 1de 3

Fluxo mximo

Aula_09.06

O tipo de problema de fluxo mximo utilizado quando queremos maximizar a quantidade de fluxo de um ponto de origem para um ponto de destino e estamos sujeitos a restries de capacidade de fluxo nos arcos. Esses problemas geralmente envolvem o fluxo de materiais como gua, leo, gs, energia por uma rede de tubos ou cabos, mas tambm podem representar o fluxo mximo de carros em uma malha rodoviria, de produtos em linhas de produo, e assim por diante. Caso LCL GasoBras Ltda A empresa distribuidora de gs LCL GasoBras Ltda deseja determinar a quantidade mxima de metros cbicos por segundo de gs que pode bombear da estao de Campos para o centro consumidor do Rio de Janeiro pela rede de gasodutos existentes. A Figura 1 ilustra a estrutura da rede de distribuio e apresenta a capacidade de fluxo mximo nos trechos (em metros cbicos por segundo).
Figura 1 Rede de gasodutos que ligam Campos ao Rio de Janeiro

Para resolver esse problema, utilizaremos um pequeno artifcio: adicionaremos um arco virtual ligando o n B ao n A (Figura 2). A funo-objetivo, portanto, ser a maximizao do fluxo de gs que passa de B para A. Como o fluxo de B para A na realidade no existe, o valor do fluxo no arco artificial representar o total de gs que pode chegar ao Rio de Janeiro vindo de Campos por mais de um caminho simultaneamente.
Figura 2 - Rede com incluso do arco artificial Rio de Janeiro - Campos

Variveis de deciso Funo-objetivo de gs que saem de A e chegam na Estao 1 de gs que saem de A e chegam na Estao 2 de gs que saem da Estao 1 e chegam na Estao 3 de gs que saem da Estao 1 e chegam na Estao 4 de gs que saem da Estao 2 e chegam na Estao 4 de gs que saem da Estao 3 e chegam na Estao B de gs que saem da Estao 4 e chegam na Estao B de gs que saem da Estao B e chegam na Estao A (arco artificial)

A composio das restries seguir as seguintes condies: .O fluxo em cada arco dever ser maior ou igual a zero. O fluxo em cada arco dever ser menor ou igual capacidade do arco. O fluxo que chega em cada n dever ser igual ao fluxo que sai dele. O fluxo do arco artificial (desconhecido) deve ser grande o bastante para assumir qualquer valor possvel, j que este ser maximizado. Restries de Capacidade 40 30 30 20 30 20 40 9.999 Restries de Fluxo 0 0 0 0 0 0 n A n 1 n 2 n 3 n 4 n B

Uma das possveis modelagens desse problema na planilha Excel mostrada na Figura 3. A clula E13 representa a funo-objetivo, e as clulas E4 a E11, as variveis de deciso do modelo. As clulas H4 a H9 representam os LHS das restries de fluxo, e as clulas I4 a I9, os RHS das clulas.
Figura 3 - Modelagem do caso LCL GasoBras

A Tabela 1 mostra as frmulas utilizadas nos LHS das restries e na clula que denota a funo-objetivo. As condies especificadas para os parmetros e as opes do Solver esto evidenciadas na Figura 4. A Figura 5 mostra a soluo tima apresentada pelo Solver para o problema da LCL GasoBras. Como podemos observar, em funo dos limites de fluxo dos gasodutos, o fluxo mximo que poder chegar ao Rio de Janeiro de 60 metros cbicos por segundo.
Tabela 1 - Frmulas utilizadas nas restries do caso LCL GasoBras Funo-objetivo Clula E13 Restrio Frmula referente funo-objetivo =E11

Clula Frmula referente ao LHS da restrio

0 0 0 0 0 0

H4 H5 H6 H7 H8 H9

=SOMASE($C$4:$C$11;G4;$E$4:$E$11)-SOMASE($B$4:$B$11;G4;$E$4:$E$11) =SOMASE($C$4:$C$11;G5;$E$4:$E$11)-SOMASE($B$4:$B$11;G5;$E$4:$E$11) =SOMASE($C$4:$C$11;G6;$E$4:$E$11)-SOMASE($B$4:$B$11;G6;$E$4:$E$11) =SOMASE($C$4:$C$11;G7;$E$4:$E$11)-SOMASE($B$4:$B$11;G7;$E$4:$E$11) =SOMASE($C$4:$C$11;G8;$E$4:$E$11)-SOMASE($B$4:$B$11;G8;$E$4:$E$11) =SOMASE($C$4:$C$11;G9;$E$4:$E$11)-SOMASE($B$4:$B$11;G9;$E$4:$E$11)

Figura 4 Condies do Solver para o caso GasoBras

Figura 5 Soluo tima para o caso LCL GasoBras