P. 1
Trabalho Em Grupo I - UNOPAR

Trabalho Em Grupo I - UNOPAR

|Views: 833|Likes:
Publicado porFabíola Natally

More info:

Published by: Fabíola Natally on Apr 25, 2012
Direitos Autorais:Attribution Non-commercial

Availability:

Read on Scribd mobile: iPhone, iPad and Android.
download as DOCX, PDF, TXT or read online from Scribd
See more
See less

11/13/2013

pdf

text

original

Curso Superior de Tecnologia em Análise e Desenvolvimento de Sistemas

SISTEMA DE ENSINO PRESENCIAL CONECTADO

CURSO SUPERIOR DE TECNOLOGIA EM ANÁLISE E DESENVOLVIMENTO DE SISTEMAS

Aline Ludmila Costa Alysson Willian Costa e Silva Delio Martins Junior Fabíola Natally Martins Dias

PRODUÇÃO TEXTUAL INTERDISCIPLINAR - GRUPO

Sete Lagoas 2011

UNOPAR VIRTUAL

Veronice de Freitas SUMÁRIO Sete Lagoas 2011 UNOPAR VIRTUAL . para a disciplina Linguagens e Técnicas de Programação I. Prof.Curso Superior de Tecnologia em Análise e Desenvolvimento de Sistemas Aline Ludmila Costa Alysson Willian Costa e Silva Delio Martins Junior Fabíola Natally Martins Dias PRODUÇÃO TEXTUAL INTERDISCIPLINAR – GRUPO Trabalho apresentado ao Curso Superior de Tecnologia em Análise e Desenvolvimento de Sistemas da Universidade Norte do Paraná – UNOPAR.

Desenvolvimento 3. Introdução 2.Curso Superior de Tecnologia em Análise e Desenvolvimento de Sistemas SUMÁRIO: 1. Considerações finais 4. Referências Sete Lagoas 2011 UNOPAR VIRTUAL .

Curso Superior de Tecnologia em Análise e Desenvolvimento de Sistemas 1. O quinto exercício pode ser desenvolvido de forma integral ou através da representação de um código com a documentação de seu funcionamento (o programa deverá ser comentado para que seja possível analisar a forma como foi realizada a conversão). Parte II Traduzir para a linguagem lógica algum conceito de Fundamentos da Administração da Informação e construir a respectiva tabela-verdade. Sete Lagoas 2011 UNOPAR VIRTUAL . INTRODUÇÃO Parte I Desenvolver os quatro primeiros exercícios utilizando o VisuAlg.

Curso Superior de Tecnologia em Análise e Desenvolvimento de Sistemas 2. Vol. CM: real inicio //Obtenção dos dados escreva ("Distância total percorrida (Km): ") leia (Dist) escreva ("Volume de combustível gasto (L): ") Sete Lagoas 2011 UNOPAR VIRTUAL . DESENVOLVIMENTO Parte I 1) Escreva o pseudocódigo equivalente ao fluxograma abaixo: algoritmo "Consumo_Médio" // Função: Calcular o consumo médio de gasolina por quilômetro percorrido var // Declarando as variáveis Dist.

Curso Superior de Tecnologia em Análise e Desenvolvimento de Sistemas leia (Vol) //Cálculo do consumo médio CM <. SALÁRIO BRUTO PROCESSAMENTO: Se o salário for acima de R$1000. SAIDA: Ao final exiba o nome do funcionário. Se o salário for acima de R$1000.Ao final.o salário bruto e o salário com desconto de INSS. dependendo do salário do funcionário var //Declarando as variáveis nome: caracter sal. CM . sal_final: real inicio //Obtenção dos dados escreval ("Digite o nome do funcionário: ") leia (nome) escreval ("Digite o salário do funcionário: ") leia (sal) // Aplicando a função SE Sete Lagoas 2011 UNOPAR VIRTUAL . exiba o nome do funcionário. calcule desconto de 11% do INSS. o salário bruto e o salário com desconto de INSS.Dist/Vol //Exibição dos resultados escreval ("Consumo médio=". calcule 9%. se não. " Km/L") fimalgoritmo 2) Crie um algoritmo que receba pelo teclado o nome de um Funcionário e seu salário bruto. se não.00 calcule 11% de desconto de INSS. calcule 9%. DADOS DE ENTRADA: NOME.00. algoritmo "Desconto_INSS" // Função :Calcular desconto do INSS.

". sal_final.sal-(sal*11/100) senao sal_final<. O algoritmo deverá receber pelo teclado o nome do cliente e o valor total da compra. " por questão do desconto de INSS.000.") filmalgoritmo 3) Crie um algoritmo em que.000. calcula o valor de desconto a ser concedido para um determinado cliente.00 % de desconto 5 10 15 DADOS DE ENTRADA: Nome do cliente.Curso Superior de Tecnologia em Análise e Desenvolvimento de Sistemas se sal>=1000 entao sal_final<.000.00 entao Sete Lagoas 2011 UNOPAR VIRTUAL . Valor total da compra PROCESSAMENTO: comparar o valor da compra para obter o desconto de acordo com a tabela DADOS DE SAIDA: Nome do cliente. " passa a receber ".00 Entre R$ 1.00 a R$ 5. que recebia ". Valor da compra Ate R$ 1. de acordo como valor da compra. ". " reais. desconto: real inicio //----------Entrada------------escreval("***Nome do Cliente:") leia(cliente) escreval("***Valor da Compra:") leia(valor_compra) //---------Processamento--------se valor_compra < 1000.000. sal. valor do desconto algoritmo "Calculo_Desconto_Compra" // Função :Calcula o desconto da compra de acordo com valores da tabela var cliente: literal valor_compra. dada a tabela a seguir.00 Acima de R$ 5.sal-(sal*9/100) fimse // Exibição do resultado escreva ( nome.

cliente) escreval ("Desconto:". media: real inicio //Inicializando soma soma<.: faça as alterações necessárias para que o algoritmo possibilite a média da turma e também imprima quantos alunos estão com a nota abaixo da média. desconto) fimalgoritmo 4) O algoritmo abaixo possibilita calcular a média das notas de 5 alunos. soma.10 fimse se valor_compra > 5000. algoritmo "media_notas" // Função : calcular a media das notas da turma e contar quantas notas estão abaixo da media var //Declarando as variáveis i: inteiro cont_n: inteiro nota.0 //Aplicando o comando de repetição para I de 1 ate 5 faca escreva ("Digite a nota: " ) leia (nota) //Acumulando a nota lida soma <.valor_compra * 0.valor_compra * 0.cont_n +1 fimse Sete Lagoas 2011 UNOPAR VIRTUAL .05 fimse se valor_compra >=1000.00 entao desconto<.Curso Superior de Tecnologia em Análise e Desenvolvimento de Sistemas desconto<.soma + nota // Contando as notas abaixo da media se nota < 6 entao cont_n <. Obs.15 fimse //----------Saida---------------escreval("Cliente:".00 entao desconto <.valor_compra * 0.

o 0 e o 1. e para aqueles que estão mais “presos” ao sistema de numeração décima (0 a 9). cont_n ) fimalgoritmo 5) Na representação da conversão do sistema decimal para binário é obtido pelos restos da divisão como ilustrado no exemplo abaixo.Curso Superior de Tecnologia em Análise e Desenvolvimento de Sistemas fimpara //Calculando a média media <. então o sistema de numeração que naturalmente se adéqua para a representação da informação é o binário em virtude de ser constituído por apenas dois dígitos.soma / 5 //Escrevendo a media calculada escreva ("A media da turma é: ". Esta atividade consiste na elaboração ou na descrição de um algoritmo que possibilite a conversão do sistema decimal para binário (poderá fazer uso de qualquer linguagem de programação para exemplificar o código). media ) // Escrevendo a quantidade de notas abaixo da media escreval (" Quantidade de notas abaixo da media: ". Antes de prosseguirmos. informamos que a única diferença entre estes dois sistemas é o número de dígitos que os compõem. Sete Lagoas 2011 UNOPAR VIRTUAL . Sendo esta um dispositivo digital de dois estados. um programa é executado a partir da memória principal do computador. ligado e desligado. No texto a seguir é representado a conversão de um número decimal para binário (esse exemplo foi colocado somente para ilustrar a forma de conversão). Como sabe. REPRESENTAÇÃO DA INFORMAÇÃO: A representação da informação no computador esta de acordo com o modo de funcionamento dos computadores. a que chamamos bits.

"0" + x senao x <."1" + x fimse y <.x) fimalgoritmo Sete Lagoas 2011 UNOPAR VIRTUAL .y enquanto y > 0 faca se (y mod 2) = 0 entao x <.y div 2 fimenquanto escreval("A representação binária é ".d : inteiro inicio // entrar com o numero em decimal escreva("Entre com um número decimal :") leia(y) d <.Curso Superior de Tecnologia em Análise e Desenvolvimento de Sistemas algoritmo "de decimal para binário" // Função: Converter número decimal para binário var x : caracter y.

Sete Lagoas 2011 UNOPAR VIRTUAL .r) e faça a tabela-verdade para essa proposição composta. A partir da proposições simples p.Curso Superior de Tecnologia em Análise e Desenvolvimento de Sistemas Parte II 1) Traduzir para a linguagem lógica algum conceito de Fundamentos da Administração da Informação e construir a respectiva tabela-verdade. r a seguir.q. r: Conhecimento pode ser compreendido como o conjunto de ferramentas conceituais e categorias usadas pelos seres humanos para criar. q: Informação é o resultado do tratamento dos dados existentes acerca de alguém o alguma coisa. colecionar. escreva em linguagem lógica a proposição composta T (p. T(p.r): Se dados são conjuntos de elementos que expressa um fato isolado gerado por uma atividade que pode ser controlada e informação é o resultado do tratamento dos dados existentes acerca de alguém o alguma coisa. então o conhecimento não pode ser compreendido como o conjunto de ferramentas conceituais e categorias usadas pelos seres humanos para criar. colecionar.q. q. armazenar e compartilhar uma informação. armazenar e compartilhar uma informação. p: Dados são conjuntos de elementos que expressa um fato isolado gerado por uma atividade que pode ser controlada.

Curso Superior de Tecnologia em Análise e Desenvolvimento de Sistemas T=(p ^ ~q) ->~ r p V V V V F F F F q V V F F V V F F r V F V F V F V F ~q F F V V F F V V ~r F V F V F V F V p ^ ~q F F V V F F F F (p ^ ~q)->~r F V F V V V V V Sete Lagoas 2011 UNOPAR VIRTUAL .

CONSIDERAÇÕES O VisuAlg é um aplicativo que fornece aos estudantes que se iniciam nas disciplinas de programação ferramentas para digitar. executar e depurar o pseudocódigo para resolver problemas propostos nas aulas e em exercícios. Ambientes como o VisuAlg promovem a experimentação e permitem desde cedo o entendimento do funcionamento de um programa de computador. fornecendo também aos professores vários recursos didáticos para que expliquem como os programas funcionam. Sete Lagoas 2011 UNOPAR VIRTUAL . visualização do conteúdo das variáveis. embora mais simples e usando uma linguagem de programação sem tantos recursos. O uso deste software nos estágios iniciais do ensino de programação tem-se mostrado bastante produtivo por permitir que desde o início os estudantes tenham contato com um ambiente de desenvolvimento próximo ao que encontrarão em sua vida profissional. etc. tais como execução passo a passo.Curso Superior de Tecnologia em Análise e Desenvolvimento de Sistemas 3.

GUTO. ROBERTO. Introdução a programação: 500 algoritmos resolvidos. Projeto de algoritmos: fundamento. ANITA. análise e exemplos da internet. REFERÊNCIAS GOODRICH. Rio de Janeiro: Elsevier. Porto Alegre: Bookman. 2004 LOPES.Curso Superior de Tecnologia em Análise e Desenvolvimento de Sistemas 4. Ed. Ed. GARCIA. 2002 Sete Lagoas 2011 UNOPAR VIRTUAL . 1. 1.. MICHAEL T. TAMASSIA.

You're Reading a Free Preview

Descarregar
scribd
/*********** DO NOT ALTER ANYTHING BELOW THIS LINE ! ************/ var s_code=s.t();if(s_code)document.write(s_code)//-->