Você está na página 1de 21

PDM Workgroup Manual de Utilizador

Vault
PDM Workgroup

Departamento Tcnico Abril 2009

Pg. 1 de 21

PDM Workgroup Manual de Utilizador


ndice:
1. Introduo ..................................................................................................................... 3 2. Anlise SWOT.............................................................................................................. 4 2.1. Vantagens............................................................................................................... 4 2.2. Inconvenientes ....................................................................................................... 4 3. Conceitos Fundamentais ............................................................................................... 4 4. O PDM no Processo PALBIT....................................................................................... 5 5. Metodologia de trabalho ............................................................................................... 6 6. Manuseamento do Vault ............................................................................................... 7 6.1. Activar o PDM Workgroup ................................................................................... 7 6.2. O PDM Workgroup no ambiente SolidWorks....................................................... 7 6.3. Vista do Vault ........................................................................................................ 8 6.4. Ownership .............................................................................................................. 9 6.5. Vista Local ............................................................................................................. 9 6.6. Login ...................................................................................................................... 9 6.7. rvore do Vault ................................................................................................... 10 6.7.1. Configurar o PDM Workgroup..................................................................... 10 6.7.2. Propriedades visveis na rvore do Vault .................................................... 12 6.8. As Propriedades no SolidWorks e do PDM Workgroup ..................................... 13 6.8.1. Propriedades para Pastilhas ..................................................................... 13 6.8.2. Propriedades para Ferramentas de Corte .............................................. 14 6.8.3. Propriedades para Ferramentas de Prensagem.............................................. 15 6.8.4. Consideraes Gerais.................................................................................... 15 7. Sistema de Revises do Drawing................................................................................ 16 8. Check In ...................................................................................................................... 17 8.1. Definio do Cabealho....................................................................................... 18 8.2. Alterao de Campos ........................................................................................... 18 8.3. Buscar Drawing de uma part ou assembly ....................................................... 19 9. Pesquisar no Vault ................................................................................................... 20 9.1. Procedimento da pesquisa avanada.................................................................... 20

Departamento Tcnico Abril 2009

Pg. 2 de 21

PDM Workgroup Manual de Utilizador


1. Introduo
A aplicao PDM Workgroup (Product Data Management) um software complementar da SolidWorks que permite o gerenciamento de arquivos. O PDM pode ser executado dentro do ambiente de trabalho do SolidWorks, e tambm atravs do aplicativo SolidWorks Explorer. Em qualquer uma dessas vertentes, o aplicativo possui um manuseamento da informao to intuitivo quanto o Windows Explorer. O PDM tem como base um cofre (Vault), no qual sero armazenados os arquivos relacionados com o software CAD em vigor, mas tambm permite a insero/anexao de outros tipo de ficheiros: pdf, txt, xls, jpg, etc. Com a implementao deste aplicativo, pretende-se organizar o fluxo de trabalho intra-departamento, fluxo este, que estar sujeito a certas

condicionantes (acessibilidade, obrigatoriedades, etc.). O PDM possui a capacidade de criao de propriedades e que estas se relacionem com as propriedades das Parts ou Assemblies do SolidWorks. Isso permitir automatizar certas operaes como a tabelas de Revises. De modo a colmatar as restries prprias se um qualquer software CAD, em que ficheiros CAD s podem ser vistos/abertos no prprio CAD ou em softwares com capacidade de intromisso equivalente, o PDM possui um mecanismo que permite extrair um pdf do ficheiro CAD seleccionado, sem o abrir. Adjacente a este aplicativo, e de forma a homogeneizar, dentro das possibilidades, foram criados templates do Software CAD (SolidWorks), nas Parts e Assemblies, com propriedades especificas, que linkam para campos especficos nos Drawings.

Departamento Tcnico Abril 2009

Pg. 3 de 21

PDM Workgroup Manual de Utilizador


2. Anlise SWOT
2.1. Vantagens
Obriga a laborar no PC local, evitando sobrecarga na rede Permite uma melhor organizao da metodologia de trabalho Garante a segurana dos ficheiros nele existentes Permite carregar para o Vault ficheiros no CAD Permite anexar aos ficheiros CAD, outros ficheiros relevantes Possibilita a automao de pequenas tarefas Folhas dos desenhos em Ingls, para uma melhor relao com o cliente

2.2. Inconvenientes
Diminui a esfera de acesso aos ficheiros no Vault No permisso a Viewers, colaboradores sem SolidWorks ou SolidWorks Explorer (necessita licena especifica)

3. Conceitos Fundamentais
Vault: Cofre onde so guardados os ficheiros. Open/Check Out Document: Procedimento que permite retirar do Vault um determinado documento. Save and Check In: Procedimento que guarda no PC local o trabalho realizado, antes de enviar para o Vault um determinado documento. My Workgroup PDM Documents: Localizao no PC local, onde so guardados os documentos dos quais se fez o Check In ou o Check Out. Workgroup PDM Vault: a localizao do Vault existente no servidor. Take Ownership: Procedimento em que um user se apodera do documento, restringindo assim o acesso a outros users. Release Ownership: Procedimento inverso ao Take Ownership. Status: Estado do projecto: Aprovar, Arquivar e Alterar.

Departamento Tcnico Abril 2009

Pg. 4 de 21

PDM Workgroup Manual de Utilizador


4. O PDM no Processo PALBIT

Figura 1 Fluxograma do PDM Workgroup

Departamento Tcnico Abril 2009

Pg. 5 de 21

PDM Workgroup Manual de Utilizador


5. Metodologia de trabalho

Figura 2 Fluxograma da metodologia de trabalho do Departamento Tcnico

Departamento Tcnico Abril 2009

Pg. 6 de 21

PDM Workgroup Manual de Utilizador


6. Manuseamento do Vault
6.1. Activar o PDM Workgroup
Existem duas formas de activar a aplicao PDM Workgroup: 1. Pela barra de menus Executando: Tools > Add-Ins 2. Pelo cone Clicando na seta do cone, seleccione a opo Add-Ins

Figura 3 cone de opes e Add-Ins

Aps isso, na instruo SolidWorks Workgroup PDM 2009, seleccione as check box para Active Add-ins e Start Up, conforme na figura 4.

Figura 4 Activao do Add-Ins

6.2. O PDM Workgroup no ambiente SolidWorks


Aps activar, a disposio do ambiente SolidWorks altera-se. Caso a Task Pane no esteja visvel, torne-a segundo o procedimento na barra de Menus: View > Toolbars > Task Pane
Figura 5 cone PDM

Na Task Pane surge um novo logo que indica a activao do Vault e possibilita aceder s diversas opes nele existentes.

Departamento Tcnico Abril 2009

Pg. 7 de 21

PDM Workgroup Manual de Utilizador


Assim, o ambiente do SolidWorks ter o seguinte aspecto:

Barra do PDM

Vista Local

cone do PDM

Vista do Vault

Figura 6 Ambiente SolidWorks com o PDM

O cone do PDM na Task Pane permite o acesso Vista Local e Vista do Vault. Na Vista Local tem acesso directo a 3 itens: Open in SolidWorks (Documentos abertos no SolidWorks), Desktop (Ambiente de trabalho do PC em causa) e My Workgroup PDM Documents (documentos existentes na pasta Vault do PC local). Na Vista do Vault, surge todo o contedo existente no Vault em formato de rvore.

6.3. Vista do Vault


A figura 7 apresenta a estrutura dos ficheiros no Vault. Aqui possvel ter uma percepo resumida da informao relevante

associada a cada ficheiro.


Figura 7 Ficheiros na Vista do Vault

Departamento Tcnico Abril 2009

Pg. 8 de 21

PDM Workgroup Manual de Utilizador


Neste caso, surge: O nome do ficheiro principal e das suas subdivises; A reviso em que cada ficheiro (principal e secundrio) se encontra; O estado do ciclo de vida em que os ficheiros se encontram; O proprietrio do ficheiro, que est associado ao ciclo de vida.

Nota: Todo este resumo de informao associada aos ficheiros provm das seleces que se efectuam em SolidWorks Workgroup PDM Options (6.7.1)
1- Pesquisa no Vault; 2- Informao acerca do documento seleccionado; 3- Gera relatrio do ficheiro seleccionado e suas Figura 8 Opes da Vista do Vault ramificaes; 4- Actualiza o Vault.

6.4. Ownership
A figura 9 - O usurio no tem posse do ficheiro - O usurio tem posse do ficheiro
Figura 9 Diferentes ficheiros com e sem ownership

diferencia o conceito de posse do documento.

6.5. Vista Local


Os documentos na Vista Local do Vault possuem cones que traduzem:
- Ficheiro mais antigo do que o do Vault; - Ficheiro igual ao do Vault; - Ficheiro no existe no Vault; - Ficheiro mais recente do que o do Vault.

6.6. Login

Figura 10 Vista Vault Local

Aps activar, pode ver a barra do PDM Workgroup, recorrendo aco: View > Toolbars > SolidWorks Workgroup PDM O login pode ser efectuado de duas formas: Acedendo ao cone da barra do PDM, como apresentado na figura 11.
Figura 11 Login pela barra PDM

Departamento Tcnico Abril 2009

Pg. 9 de 21

PDM Workgroup Manual de Utilizador


Acedendo ao cone da chave de Login existente na Vista do Vault. Para efectuar o Login ter que preencher o seguinte formulrio: Nos campos Vault computer e Vault description servidor-sbs. Insira o Name e a Password, e active as opes save name e save insira, caso no surja,
Figura 12 Acesso ao login pela Vista do Vault

password, para evitar reinserir esta informao.


Figura 13 Formulrio de Login

6.7. rvore do Vault


As pastas podem assumir uma das seguintes cores: Laranja (acesso de leitura), Preto (acesso de leitura e escrita), Cinza (sem acesso) e Azul (no gera reviso).
Figura 14 Vista do Vault aps login

6.7.1. Configurar o PDM Workgroup


Em primeiro lugar, necessrio configurar as opes do Vault local. Para tal, execute: Lado direito do rato em My Vault > SolidWorks Workgroup PDM Options Ir abrir um formulrio multi-pgina.
Figura 15 Opes do Vault Local

Departamento Tcnico Abril 2009

Pg. 10 de 21

PDM Workgroup Manual de Utilizador


O formulrio Local permite escolher os componentes a mostrar na rvore, configurar o uso do Ctrl no arrastar, como abrir os ficheiros dwg e dxf e a possibilidade de manter quer o tamanho, formulrios.
Figura 16 Formulrio Local das opes

quer

posio

dos

O formulrio References/Where Used permite mostrar referncias a um ou em todos os nveis, procurar por referncias ou outros modelos

associados (Drawings ou Assemblies) ou especificar uma localizao para tal.


Figura 17 Formulrio References / Where Used

Este formulrio permite comparar o ficheiro do check-out com o existente na memria ou no PC Local, alterar password, definir a forma de

delimitao dos campos aquando da gerao de um relatrio em xls ou txt.


Figura 18 Formulrio Vault

O Command Default possui opes no check in. Include drawings deve ser activada e para quem no aprove projectos devem activar Working copy default. Permite opes ao nvel do check out e uma caixa de dilogo quando o projecto tem ramificaes.
Figura 19 Formulrio Command Default

Departamento Tcnico Abril 2009

Pg. 11 de 21

PDM Workgroup Manual de Utilizador


O formulrio Folders permite definir o directrio do Vault Local onde vo ser guardados todos os ficheiros e um directrio temporrio de visualizao dos mesmos. Periodicamente, ser necessrio
Figura 20 Formulrio Folders

efectuar uma limpeza em ambos os directrios.

Este formulrio permite escolher a identificao do ficheiro (nome ou descrio) e as propriedades que

estaro presentes no Vista do Vault. Para alm das propriedades standard, h a possibilidade de acrescentar uma propriedade extra.
Figura 21 Formulrio Labels

6.7.2. Propriedades visveis na rvore do Vault


Na rvore do Vault, possvel definir quais as propriedades a visualizar aquando da existncia de ficheiros CAD. Por defeito, o PDM gera as seguintes propriedades: Document Name, Number, Description, Revision, Status e Owner. Nota: As propriedades Number e Description no tero utilidade prtica.
Figura 22 Definio das propriedades a visualizar na rvore do Vault

Departamento Tcnico Abril 2009

Pg. 12 de 21

PDM Workgroup Manual de Utilizador


Existe tambm a possibilidade de acrescentar uma outra propriedade ao conjunto que ficar visvel na rvore do Vault. Para aceder, execute: Lado direito do rato em My Vault > Display Labels With > Select Ir surgir o formulrio da figura 23. Neste formulrio surgem as propriedades j antes seleccionadas e no campo Choose 1 custom property to display deve ser activada a check box que ir permitir escolher a propriedades extra a visualizar na rvore do Vault. A opo Save as default permite guardar as definies existentes.
Figura 23 Definio da propriedade extra a visualizar na rvore do Vault

6.8. As Propriedades no SolidWorks e do PDM Workgroup


Para responder s necessidades da PALBIT, foram criados vrios templates, que se dividem em 3 categorias: Pastilhas, Ferramentas de Prensagem e Ferramentas de Corte. Para cada uma delas existem templates de Parts e Assembies, com propriedades especficas. As tabelas 1,2 e 3 apresentam os diferentes tipos de propriedades com a seguinte legenda:
Propriedades do Documento Propriedades de Aprovao Propriedades da Tabela de Materiais Propriedades de Pesquisa no Vault Propriedades da Tabela de Revises Propriedades Naturais do Vault Propriedades do Documento e de Pesquisa no Vault

6.8.1. Propriedades para Pastilhas


A modelao das Pastilhas pode ser uma Part (pastilhas convencionais) ou um Assembly (ex: Pastilhas PCD ou CBN)

Departamento Tcnico Abril 2009

Pg. 13 de 21

PDM Workgroup Manual de Utilizador


Sem nenhum check in efectuado Part
DESIGNAO CDIGO DESENHADO DATA DES

Com pelo menos 1 check in efectuado Part


DESIGNAO CDIGO DESENHADO DATA DES

Assembly
DESIGNAO CDIGO DESENHADO DATA DES

Drawing

Assembly
DESIGNAO CDIGO DESENHADO DATA DES

Drawing
CDIGO

APROVADO DATA APROV C% Material OBSERVAO CLIENTE GEOMETRIA APLICAO CLIENTE GEOMETRIA APLICAO C% C% Material OBSERVAO CLIENTE GEOMETRIA APLICAO MQUINA (PRENSA) DESC ALTERAES DESC ALTERAES DESC ALTERAES Number Description Revision Author Project Status OBSERVAO CLIENTE GEOMETRIA APLICAO MQUINA (PRENSA) DESC ALTERAES Number Description Revision Author Project Status C%

APROVADO DATA APROV

OBSERVAO CLIENTE GEOMETRIA APLICAO MQUINA (PRENSA) DESC ALTERAES Number Description Revision Author Project Status

Tabela 1 Propriedades das Pastilhas

6.8.2. Propriedades para Ferramentas de Corte


Sem nenhum check in efectuado Part
DESIGNAO CDIGO DESENHADO DATA DES

Com pelo menos 1 check in efectuado Part


DESIGNAO CDIGO DESENHADO DATA DES

Assembly
DESIGNAO CDIGO DESENHADO DATA DES

Drawing

Assembly
DESIGNAO CDIGO DESENHADO DATA DES

Drawing
CDIGO

APROVADO DATA APROV N DESENHO Dureza Material OBSERVAO N DESENHO Dureza N DESENHO Dureza Material OBSERVAO CLIENTE GEOMETRIA APLICAO MQUINA (PRENSA) DESC ALTERAES DESC ALTERAES DESC ALTERAES Number Description Revision Author Project Status OBSERVAO CLIENTE GEOMETRIA APLICAO MQUINA (PRENSA) DESC ALTERAES Number Description Revision Author Project Status N DESENHO Dureza

APROVADO DATA APROV

OBSERVAO CLIENTE GEOMETRIA APLICAO MQUINA (PRENSA) DESC ALTERAES Number Description Revision Author Project Status

Tabela 2 Propriedades das Ferramentas de Corte

Departamento Tcnico Abril 2009

Pg. 14 de 21

PDM Workgroup Manual de Utilizador


6.8.3. Propriedades para Ferramentas de Prensagem
Sem nenhum check in efectuado Part
DESIGNAO CDIDO KIT CDIGO COMP. DESENHADO DATA DES

Com pelo menos 1 check in efectuado Part


DESIGNAO CDIDO KIT CDIGO COMP. DESENHADO DATA DES

Assembly
DESIGNAO CDIDO KIT CDIGO COMP. DESENHADO DATA DES

Drawing

Assembly
DESIGNAO CDIDO KIT CDIGO COMP. DESENHADO DATA DES

Drawing

APROVADO DATA APROV MQUINA (PRENSA) C% Dureza Material OBSERVAO MQUINA (PRENSA) C% MQUINA (PRENSA) C% Dureza Material OBSERVAO CDIGO CLIENTE GEOMETRIA APLICAO DESC ALTERAES DESC ALTERAES DESC ALTERAES Number Description Revision Author Project Status OBSERVAO CDIGO CLIENTE GEOMETRIA APLICAO DESC ALTERAES Number Description Revision Author Project Status MQUINA (PRENSA) C%

APROVADO DATA APROV MQUINA (PRENSA)

OBSERVAO CDIGO CLIENTE GEOMETRIA APLICAO DESC ALTERAES Number Description Revision Author Project Status

Tabela 3 Propriedades das Ferramentas de Prensagem

6.8.4. Consideraes Gerais


Sem efectuar um check in, o documento mantm as suas propriedades originais; Aps efectuar pelo menos um check in, ao documento original so indexadas as propriedades naturais e de pesquisa no Vault; Um Drawing no seu estado inicial possui somente propriedades que permitam a aprovao do mesmo (evita abrir o modelo 3D). Aps um 1 check in adquire as propriedades naturais e de pesquisa do Vault. As propriedades da tabela de materiais tm carcter facultativo, pois existem situaes que no necessitam da listagem de materiais. As propriedades da tabela de revises tm igualmente carcter facultativo.

Departamento Tcnico Abril 2009

Pg. 15 de 21

PDM Workgroup Manual de Utilizador


7. Sistema de Revises do Drawing
O PDM Works possui uma funcionalidade que gera as revises automaticamente. O sistema de revises apresenta duas ramificaes:

R## Indica um incremento na Reviso R## (W)


- Indica uma cpia de trabalho (Working Copy). No

incrementa reviso no desenho.

O tipo de reviso a inserir seleccionado aquando do Check in. O procedimento a efectuar o seguinte:

File > Save and Check in


Figura 24 Definio do tipo de Reviso

Ir surgir o formulrio da figura 24. Clicando no cabealho

Revision, a Combobox no topo do formulrio fica activa.

Pressionando a seta dessa combobox, surgem as opes presentes na figura 25. Descrio das Opes: Default mantm as revises inalterveis; Next Primary Revision no se aplica ao modelo implementado na PALBIT. Como reviso primria existe somente um registo (R);
Figura 25 Opes possveis para a Reviso

Departamento Tcnico Abril 2009

Pg. 16 de 21

PDM Workgroup Manual de Utilizador


Next Secundary Revision incrementa mais uma reviso j existente. De uso aquando da passagem para o estado Arquivado; Working Copy no incrementa reviso no desenho. Comum a todos os estados, excepto aquando da passagem para Arquivar; Read from File a reviso a aplicar ser extrada das propriedades do documento; Other permite digitar uma reviso, mas que est sempre sujeita s especificaes existentes na esfera do administrador.

Em todo o seu ciclo de vida, o desenho assume sempre o estatuto de Working Copy como reviso. Apenas quando o desenho aprovado e se efectua o check in para arquivar, deve ser accionada a opo de Next Secundary Revision O processo de revises inicia-se em R (-01) , isto para que quando o desenho atingir pela 1 vez o estado de arquivado, a reviso presente no desenho seja R (00) .

8. Check In
O Check in o procedimento que envia os documentos em causa para o Vault. Para efectuar, execute: File > Save and check In Nota: Para que essa opo surja activa necessrio guardar previamente o documento no Vault Local.
123Figura 26 Check In 4Indicao de Check in Mantm Ownership ( Liberta ownership) apaga cpia do

No apaga cpia no Vault Local ( Vault local) Documento no existe no Vault ( superior ao do Vault) e (

igual ao Vault), (

inferior ao Vault) part), ( assemby)

56-

Documento do tipo draw ( Nome do ficheiro

Departamento Tcnico Abril 2009

Pg. 17 de 21

PDM Workgroup Manual de Utilizador


8.1. Definio do Cabealho
Como j foi referido, existem propriedades naturais do PDM Worgroup que no vo ser

aplicadas no Vault. As mesmas podem ser omitidas aquando de um check in. So elas: Description, Number, Note e Info.

Ao execute

efectuar para

um cada acima

check uma

in, das

Figura 27 Definir propriedades no check in a omitir

propriedades

referidas,

conforme figura 27. Lado direito do rato no

cabealho da propriedade > Hide Column Aps esconder todas as


Figura 28 Guardar cabealho das propriedades omitidas

propriedades, execute conforme a figura 28.

8.2. Alterao de Campos


Um check in pode ter vrios ficheiros, e possvel alterar

propriedades de um s ficheiro. A figura 29 mostra o check in da part e do drawing da pea P, contudo um clique no campo DESCR. ALTER. relativo ao
Figura 29 Inserir propriedade para um ficheiro

drawing permite personalizar essa propriedade para esse ficheiro.

Departamento Tcnico Abril 2009

Pg. 18 de 21

PDM Workgroup Manual de Utilizador


Com um clique no cabealho DESCR. ALTER., selecciona-se todos os campos dessa

propriedade de todos os ficheiros existentes para check in. Na hiperbole a vermelho na figura, exibe quantos ficheiros esto seleccionados, neste caso DESCR. ALTER.(2):.
Figura 30 Inserir propriedade para um conjunto de ficheiros

A figura 31 mostra que o campo DESCR. ALTER. para os dois ficheiros vai ser alterada. A alterao em causa

chamfro (demarcada na fig.). Nota: imperativo que aps digitar a alterao, pressionar o boto Apply.
Figura 31 Relevncia do comando apply

8.3. Buscar Drawing de uma part ou assembly


Quando se est a efectuar o check in de uma Part, o PDM possui uma aplicao que permite ir ao Vault Local e Buscar o desenho associado. Para tal, aquando do check in da Part, pressione Drawings, surge o formulrio Question, onde j por defeito vem o directrio do Vault local. Pressione Find Now e se houve algum desenho associado, ele ser adicionado listagem do check in.
Figura 32 Buscar Drawing

Departamento Tcnico Abril 2009

Pg. 19 de 21

PDM Workgroup Manual de Utilizador


9. Pesquisar no Vault
As figuras 33 e 34 apresentam as duas formas de iniciar uma pesquisa no Vault. Ambas se encontram na Vista do Vault. Para efectuar a pesquisa
Figura 33 cone Find / Search no Vault

conforme a figura 34, execute: Lado direito do rato em My Vault > Find / Search
Figura 34 Find / Search no Vault

O Vault possui dois gneros de pesquisa: simplificado e avanado. O Simplificado bastante intuitivo,

contudo, no possui as capacidades da pesquisa avanada.


Figura 35 Formulrio de pesquisa simples

Figura 36 Formulrio de pesquisa avanada

9.1. Procedimento da pesquisa avanada


Para gerar um critrio de pesquisa, defina qual a propriedade na qual se pretende efectuar a mesma. A figura 37 mostra todas as opes disponveis. Pode especificar qual a propriedade em causa ou definir algo mais abrangente, como All Properties.
Figura 37 Opes de pesquisa

Departamento Tcnico Abril 2009

Pg. 20 de 21

PDM Workgroup Manual de Utilizador


Aps definir a opo, defina a condio de pesquisa. Na figura 38 esto presentes as diversas condies. NOTA: A condio is (exactly) pode induzir uma pesquisa em erro. Refere-se ao valor/expresso exacta. Assim, prefervel o uso das condies contains ou starts with Aps definir a condio, h que especificar no
Figura 38 Condies de pesquisa

campo Value: um valor ou expresso a ser assumido pela condio. Com o critrio criado, pressione anexar pesquisa. critrios, o Add, critrio Insira para

outros a

recorrendo

And ou Or de forma a relaciona-los e pressione Generate Report para

obter um relatrio. O comando Find


Figura 39 Pesquisa de ficheiros com status J Castro ALTERAR

percorre todos os ficheiros

da rvore do Vault aos quais a pesquisa se aplica.

Figura 40 Generate Report da pesquisa efectuada

Departamento Tcnico Abril 2009

Pg. 21 de 21