Você está na página 1de 22
VisuAlg: pseudocódigo Prof. Byron Leite Engenharia da Computação DSC - UPE
VisuAlg: pseudocódigo Prof. Byron Leite Engenharia da Computação DSC - UPE

VisuAlg: pseudocódigo

Prof. Byron Leite

Engenharia da Computação

DSC - UPE

Visualg: a ferramenta • Ferramenta que permite a iniciantes em programação o exercício dos seus
Visualg: a ferramenta • Ferramenta que permite a iniciantes em programação o exercício dos seus

Visualg: a ferramenta

Ferramenta que permite a iniciantes em programação o exercício dos seus conhecimentos

Evitar “executar no papel”

Simular o que acontece no computador com um algoritmo estruturado em pseudocódigo

Visualg 3

Visualg

Visualg 3
Visualg 3

3

Linguagem • Uma ação por linha • Palavras-chave sem acentos • Formato básico de um
Linguagem • Uma ação por linha • Palavras-chave sem acentos • Formato básico de um

Linguagem

Uma ação por linha

Palavras-chave sem acentos

Formato básico de um algoritmo

algoritmo "semnome" // Função : // Autor : // Data : // Seção de Declarações
algoritmo "semnome"
// Função :
// Autor :
// Data :
// Seção de Declarações
inicio
// Seção de ações
fimalgoritmo
Variáveis • Nomes atribuídos a valores • Valores armazenados na memória do computador são referenciados

Variáveis

Variáveis • Nomes atribuídos a valores • Valores armazenados na memória do computador são referenciados através

Nomes atribuídos a valores

Valores armazenados na memória do computador são referenciados através dos endereços de memória

Endereços de memória são números grandes (em formato hexadecimal normalmente)

Mais fácil atribuir apelidos a estes endereços Tais apelidos são conhecidos como variáveis

É mais fácil lembrar da palavra máximo do que do número 4D5Fh

• Tipos de variáveis Variáveis – inteiro: numérico sem casas decimais – real: numérico com

Tipos de variáveis

Variáveis

• Tipos de variáveis Variáveis – inteiro: numérico sem casas decimais – real: numérico com casas

inteiro: numérico sem casas decimais

real: numérico com casas decimais

caractere: define variáveis como letras (cadeia de caracteres)

logico: valor VERDADEIRO ou FALSO

Os nomes das variáveis devem começar por uma letra e depois conter letras, números ou underline

Exemplos

var a: inteiro valor1, valor2: real nomeDoAluno: caractere sinalizador: logico

Atribuição • Valores e outras variáveis podem ser atribuídos a uma variável • Exemplos (no

Atribuição

Atribuição • Valores e outras variáveis podem ser atribuídos a uma variável • Exemplos (no algoritmo)

Valores e outras variáveis podem ser atribuídos a uma variável

Exemplos (no algoritmo)

a <- 3 valor1 <- 1.5 valor2 <- valor1 + a nomeDoAluno <- "José da
a <- 3
valor1 <- 1.5
valor2 <- valor1 + a
nomeDoAluno <- "José da Silva"
sinalizador <- FALSO
Entrada e saída dos dados escreva (< lista-de-expressoes> ) • Escreve no dispositivo de saída
Entrada e saída dos dados escreva (< lista-de-expressoes> ) • Escreve no dispositivo de saída

Entrada e saída dos dados

escreva (<lista-de-expressoes>)

Escreve no dispositivo de saída padrão (janela inferior direita) escreval (<lista-de-expressoes>)

Idem, mas pula uma linha em seguida

Entrada e saída dos dados leia (<lista-de-variáveis>) • Recebe valores digitados pelos usuário,
Entrada e saída dos dados leia (<lista-de-variáveis>) • Recebe valores digitados pelos usuário,

Entrada e saída dos dados

leia (<lista-de-variáveis>)

Recebe valores digitados pelos usuário, atribuindo-os às variáveis cujos nomes estão em <lista-de-variáveis>, na ordem em que aparecem

Exemplo algoritmo "exemplo 1" var x: inteiro inicio leia (x) escreva (x) fimalgoritmo 10

Exemplo

Exemplo algoritmo "exemplo 1" var x: inteiro inicio leia (x) escreva (x) fimalgoritmo 10
algoritmo "exemplo 1" var x: inteiro inicio leia (x) escreva (x) fimalgoritmo
algoritmo "exemplo 1"
var
x: inteiro
inicio
leia (x)
escreva (x)
fimalgoritmo
Exemplo algoritmo "exemplo 1" var x: inteiro inicio leia (x) escreva (x) fimalgoritmo 10

10

Ação condicional “SE” • A depender do valor lógico, o condicional SE pode modificar fluxo
Ação condicional “SE” • A depender do valor lógico, o condicional SE pode modificar fluxo

Ação condicional “SE”

A depender do valor lógico, o condicional SE pode modificar fluxo de execução de um algoritmo

Ele tem a forma

se <expressão-lógica> entao <seqüência-de-ações> fimse

Pode ser mais completo (dois caminhos possíveis

se <expressão-lógica> entao

<seqüência-de-ações-1>

senao

<seqüência-de-ações-2>

fimse

Ação condicional “SE” algoritmo "exemplo 2" var nota: real inicio leia (nota) se (nota >=
Ação condicional “SE” algoritmo "exemplo 2" var nota: real inicio leia (nota) se (nota >=

Ação condicional “SE”

algoritmo "exemplo 2" var nota: real inicio leia (nota) se (nota >= 7) entao escreva("Aprovado")
algoritmo "exemplo 2"
var
nota: real
inicio
leia (nota)
se (nota >= 7) entao
escreva("Aprovado")
Senao
escreva("Reprovado")
fimse
fimalgoritmo
Endentação e espaços!! algoritmo "exemplo 2" var nota: real Deixar o algoritmo fácil de ler
Endentação e espaços!! algoritmo "exemplo 2" var nota: real Deixar o algoritmo fácil de ler

Endentação e espaços!!

algoritmo "exemplo 2" var nota: real Deixar o algoritmo fácil de ler e entender inicio
algoritmo "exemplo 2"
var
nota: real
Deixar o
algoritmo
fácil de ler e entender
inicio
leia (nota)
se (nota >= 7) entao
escreva("Aprovado")
senao
escreva("Reprovado")
fimse
fimalgoritmo
Exercício • Calcule a média de duas notas fornecidas pelo usuário e responda se o

Exercício

Exercício • Calcule a média de duas notas fornecidas pelo usuário e responda se o aluno

Calcule a média de duas notas fornecidas pelo usuário e responda se o aluno está aprovado, prova final ou reprovado Menos que 3: reprovado 3 até menos que 7: prova final 7 ou mais: aprovado

Ação de repetição com condição • Repete-se instruções enquanto um dado predicado for verdadeiro •
Ação de repetição com condição • Repete-se instruções enquanto um dado predicado for verdadeiro •

Ação de repetição com condição

Repete-se instruções enquanto um dado predicado for verdadeiro

Ele tem a forma

enquanto <expressão-lógica> faca <seqüência-de-ações> fimenquanto

As ações são uma lista de instruções

Ações serão executadas enquanto o predicado for verdadeiro

Caso a condição seja falsa, execução do programa continua na ação imediatamente seguinte ao enquanto

Exemplo algoritmo "Números de 1 a 10" var j: inteiro inicio j <- 1 enquanto

Exemplo

Exemplo algoritmo "Números de 1 a 10" var j: inteiro inicio j <- 1 enquanto j
algoritmo "Números de 1 a 10" var j: inteiro inicio j <- 1 enquanto j
algoritmo "Números de 1 a 10"
var j: inteiro
inicio
j <- 1
enquanto j <= 10 faca
escreva (j:3)
j <- j
+
1
fimenquanto
fimalgoritmo
enquanto j <= 10 faca escreva (j:3) j <- j + 1 fimenquanto fimalgoritmo Número de

Número de espaços usados na saída

Entrada aleatória • Definido um intervalo, ação leia() pode ser preenchida pela máquina 17
Entrada aleatória • Definido um intervalo, ação leia() pode ser preenchida pela máquina 17

Entrada aleatória

Definido um intervalo, ação leia() pode ser preenchida pela máquina

Entrada aleatória • Definido um intervalo, ação leia() pode ser preenchida pela máquina 17
Exercício • Leia (aleatoriamente) as notas de 10 alunos • Escreva no final do algoritmo

Exercício

Exercício • Leia (aleatoriamente) as notas de 10 alunos • Escreva no final do algoritmo a

Leia (aleatoriamente) as notas de 10 alunos

Escreva no final do algoritmo a maior nota, a menor nota e a média das notas

Depuração • Execuções passo-a-passo – Encontrar falhas e suas razões – Entender o algoritmo •

Depuração

Execuções passo-a-passo

Encontrar falhas e suas razões

Entender o algoritmo

Encontrar falhas e suas razões – Entender o algoritmo • Usaremos a janela inferior esquerda do

Usaremos a janela inferior esquerda do Visualg

Tabela com nome da variável, tipo e valor (inspeção das variáveis)

Execução passo-a-passo • Tecla F8 – Inicia processo – Vai para a próxima ação 20
Execução passo-a-passo • Tecla F8 – Inicia processo – Vai para a próxima ação 20

Execução passo-a-passo

Tecla F8

Inicia processo

Vai para a próxima ação

Execução passo-a-passo • Tecla F8 – Inicia processo – Vai para a próxima ação 20

20

Breakpoint • Apertar F5 na linha desejada, depois executar – Execução vai parar neste local,

Breakpoint

Breakpoint • Apertar F5 na linha desejada, depois executar – Execução vai parar neste local, onde

Apertar F5 na linha desejada, depois executar

Execução vai parar neste local, onde as variáveis podem ser inspecionadas

F5 na linha desejada, depois executar – Execução vai parar neste local, onde as variáveis podem

21

Exercícios • Faça um algoritmo para decidir qual o maior dentre 3 números A, B

Exercícios

Exercícios • Faça um algoritmo para decidir qual o maior dentre 3 números A, B e

Faça um algoritmo para decidir qual o maior dentre 3 números A, B e C

Faça um algoritmo para calcular o fatorial de um número N

Faça um algoritmo para decidir quando um número N é primo

Faça um algoritmo para calcular quantos segundos se passaram em um dia tomando como base a hora corrente H:M:S