Você está na página 1de 18

SISTEMA DE ENSINO PRESENCIAL CONECTADO NOME DO CURSO

JESUSMAR DA SILVA OLIVEIRA

ALGORITIMO

Palmas 2012

JESUSMAR DA SILVA OLIVEIRA

ALGORITIMO

Trabalho apresentado ao Curso de analise e desenvolvimento de sistemas da UNOPAR - Universidade Norte do Paran, para a disciplina Educao Distncia. Fundamentos da Administrao da Informao Fundamentos de Lgica e Matemtica Discreta Organizao de Computadores Linguagens e Tcnicas de Programao I Seminrios I Prof. Everson Morais Thiago Nunes Bazoli Merris Mozer Adriane Loper Veronice de Freitas

Palmas 2012

SUMRIO 1 INTRODUO...........................................................................................................3 2 DESENVOLVIMENTO...............................................................................................4 Algoritimo de calculo de crdito.................................................................................14 CONCLUSO.............................................................................................................16 REFERNCIAS..........................................................................................................17

1 INTRODUO Os algoritmos apresentados neste portiflio foram desenvolvidos na ferramenta VisuAlg por ser um programa que edita, interpreta e executa algoritmos com uma linguagem prxima do portugus estruturado e por ser a ferramenta utilizada no curso para a disciplina de Linguagens e Tcnicas de Programao I.

2 DESENVOLVIMENTO 2.1. DETECTOR DE INCNDIO Para construir um detector de incndio com sensores de entrada e sada precisa programar portas OR Tabela- 1 portas OR A 0 0 1 1 B 0 1 0 1 S 0 1 1 1

PORTA OR. Figura 2 porta Or

Ento o sensor de incndio em sua estrutura fica assim; Tabela- 3 sensor Sensor1 0 0 1 1 Sensor2 0 1 0 1 S 0 1 1 1

Figura 3 -sensor anti incndio

Para a programao de mais sensores basta programar mais portas or.

PROGRAMAO

Programa para fazer cadastro de pessoas realizando em visualg. Seu cdigo fonte. algoritmo "cadastro" // Funo : realizar cadastro // Autor :Jesusmar da silva oliveira // Data : 05/06/2012 // Seo de Declaraes var rg,cep,lote:inteiro nome,sobrenome,sexo,orgaoexpeditor,ruaequadra,bairro,cidade,estado:literal inicio // Seo de Comandos escreval("dados pessoais") escreva("Nome------------------: ") leia(nome) escreva("Sobrenome-------------: ") leia(sobrenome) escreva("R.G. somente numeros--: ") leia(rg) escreva("orgo expeditor-------: ") leia(orgaoexpeditor) escreva("Sexo------------------: ") leia(sexo) escreval("") escreval("********************************************************************") escreval("") escreval("Endereo") escreva("Rua e Quadra----------: ") leia(ruaequadra) escreva("Lote------------------: ") leia(lote) escreva("Bairro----------------: ") leia(bairro) escreva("Cidade----------------: ")

leia(cidade) escreva("Estado----------------: ") leia(estado) escreva("Cep somente numeros---: ") leia(cep) fimalgoritmo figura 4- programa para gerar cadastro

CONCEITOS

Proposio: chama-se proposio todo conjunto de palavras ou smbolos que exprimem um pensamento de sentido completo. As proposies transmitem pensamentos, isto , afirmam fatos ou exprimem juzos que formamos a respeito de determinados entes. Segundo Quine , toda proposio uma frase mas nem toda frase uma proposio; uma frase uma proposio apenas quando admite um dos dois valores lgicos Falso (F) ou Verdadeiro (V). p: Dados so conjuntos de elementos que expressa um fato isolado gerado por uma atividade que pode ser controlada. q: Informao o resultado do tratamento dos dados existentes acerca de algum ou de alguma coisa. r: Conhecimento pode ser compreendido como o conjunto de ferramentas conceituais e categorias usadas pelos seres humanos para criar, colecionar armazenar e compartilhar uma informao. T (p,q,r): Se dados so conjuntos de elementos que expressa um fato isolado gerado por uma atividade que pode ser controlada e informao no o resultado do tratamento dos dados existentes acerca de algum ou de alguma coisa, ento o conhecimento no pode ser compreendido como o conjunto de ferramentas conceituais e categorias usadas pelos seres humanos para criar, colecionar armazenar e compartilhar uma informao. Tabela verdade p V V V V F F F F q V V F F V V F F r V F V F V F V F

Condicional A proposio Condicional, ou apenas condicional, uma proposio representada por se p ento q , ou p q, cujo o valores lgico a falsidade ( F ) , somente no caso em que p verdadeira e q falsa. Em todos os outros casos, p verdadeira.

(V)

p V V F F

q V F V F

pvq V V V F

Cenrio Nossa locadora de Livros

10

Programa para totalizar livros em classes divididos em diamante ouro prata e bronze e cada um com seu valor de locao diamante $20 ouro $15 prata $10 E bronze $ 5 e gera o valor por classificao. O cdigo fonte deste programa. algoritmo "totalizador_de_livro" // Funo : gerar cadastro // Autor :Ricardo Fernandes de sousa // Data : 05/06/2012 // Seo de Declaraes var diamante,ouro,prata,bronze,opcao:inteiro inicio // Seo de Comandos diamante<-0 ouro<-0 prata<-0 bronze<-0 repita escreval("***** locao de livros *****") escreval("") escreval("1- livro- diamante") escreval("2- livro- ouro") escreval("3- livro- prata") escreval("4- livro- bronze") escreval("0- sair") escreva("escolha sua opo: ") leia(opcao) escreval("") Escreval("***************************************************************") escreval("") escolha opcao caso 1 diamante<-diamante+20 caso 2

11

ouro<-ouro+15 caso 3 prata<-prata+10 caso 4 bronze<-bronze+5 caso 0 escreval("encerrando") limpatela fimescolha ate opcao=0 escreval("total de livros diamante ---R$ ",diamante) escreval("total de livros ouro -------R$ ",OURO) escreval("total de livros prata ------R$ ",prata) escreval("total de livros bronze -----R$ ",bronze) fimalgoritmo Figura -5 programa classificar livros

Algoritimo de melhor time de futebol

12

algoritmo "TIME" // Funo : // Autor : Jesusmar da silva oliveira // Data : 15/11/2012 // Seo de Declaraes var fla,flu,fogo,vasco,op,total, cont_votos:inteiro resposta, continuarPesquisa : caracter inicio escreval("Qual seu time? ") escreval(" 1- flamengo ") escreval(" 2- botafogo ") escreval(" 3- vasco ") escreval(" 4- fluminense ") continuarPesquisa := "S" // inicia a varivel continuarPesquisa com "S" enquanto continuarPesquisa = "s" faca // enquanto contpesquisa for = "S" faa, por isso que iniciou com "S" cont_votos := cont_votos + 1 // essa varivel serve para contar os votos, para quando l na frente tiver uma soma de 4 ele perguntar se quer continuar a pesquisa escreva ("Qual o melhor time do RIO: ") // para ficar mais ilustrado leia(op) escolha op caso 1 fla<-fla+1 // fla recebe fla + 1 - isso para que os votos de fla acumulem na variavel fla, da mesma forma com os outros caso 2 fogo<-fogo+1 caso 3 vasco<-vasco+1 caso 4 flu<-flu+1 outrocaso // caso no seja nenhum desses casos : 1,2,3 ou 4 entao vai aparecer um erro escreval ("ERRO - opo invlida") cont_votos := cont_votos - 1 // como o erro no pode contar no cont_votos, ento coloca-se cont_votos - 1, ou se no quando colocar uma opo maior que 4 vai contar fimescolha se cont_votos = 4 entao // quando cont_votos for = 4 o programa pergunta se vc quer continuar a pesquisa, se "S" vai continuar, se "N" para e dar os resultados cont_votos := 0 // sempre que a soma dos votos for = 4 vai zerar, para que recomece e no d problemas j que a condio se cont_votos for = 4 escreva ("Deseja continuar a pesquisa (S/N): ") leia (continuarPesquisa) fimse

13

fimenquanto escreval ("") escreval ("Flamengo obteve", fla, " Votos") // (RESULTADOS) escreval ("Botafogo obteve", fogo, " Votos") // vai mostrar a quantidade de votos que cada um tem. escreval ("Vasco obteve", vasco, " Votos") escreval ("Fluminense obteve", flu, " Votos") escreval ("") se (fla > fogo) e (fla > vasco) e (fla > flu) entao // condies de melhor time escreva ("O Flamengo o melhor time do Rio") senao se (fogo > fla) e (fogo > vasco) e (fogo > flu) entao escreva ("O Botafogo o melhor time do Rio") senao se (flu > fla) e (flu > vasco) e (flu > fogo) entao escreva ("O Fluminense o melhor time do Rio") senao escreva ("O Vasco o melhor time do Rio") fimse fimse fimse fimalgoritmo

14

ALGORITIMO DE CALCULO DE CRDITO

Saldo Mdio De 0 a 200 De 201 a 400 De 401 a 600 Acima de 601

Percentual Nenhum crdito 20% do Valor do salrio mdio 30% do valor salrio mdio 40% do valor do salrio mdio

algoritmo "Saldo Medio" // Funo : // Autor : Jesusmar da silva oliveira // Data : 15/11/2012 // Seo de Declaraes var saldo_medio, credito: real resp: caracter inicio repita //--------entrada dos dados------------// escreval("digite seu saldo mdia") leia(saldo_medio) //processamento e saida dos dados informdos// se (saldo_medio >= 0) e (saldo_medio <= 200) entao credito <- 0 escreval("seu s mdio de: ", saldo_medio, " seu credito foi de: ", credito) senao se (saldo_medio >= 201) e (saldo_medio <= 400) entao credito <- (saldo_medio*20)/100 escreval("seu saldo mdio de: ", saldo_medio, " seu credito foi de: ", credito) senao se (saldo_medio >= 401) e (saldo_medio <= 600) entao credito <- (saldo_medio*30)/100 escreval("seu saldo mdio de: ", saldo_medio, " seu credito foi de: ", credito) senao se saldo_medio > 601 entao credito <- (saldo_medio*40/)100 escreval("seu saldo mdio de: ", saldo_medio, " seu credito foi de: ", credito)

15

fimse fimse fimse fimse // comando para repetir ou no a operao// escreval("deseja continuar a operao, s/n?") leia(resp) ate resp= "n" fimalgoritmo

16

CONCLUSO Compreender as etapas para desenvolver um algoritmo com passos bem definidos e sem redundncias nos permite criar cdigos que posteriormente podero ser transcritos em vrias linguagens de programao sem a preocupao de estarem com a semntica incorreta. Com a prtica obtida durante a elaborao do trabalho adquiri conhecimento no desenvolvimento de algoritmos e a aplicao dos recursos mais adequados a determinada situao.

17

REFERNCIAS

AUDY, Jorge Luis Nicolas; ANDRADE, Gilberto Keller de; CIDRAL, Alexandre. Fundamentos de sistemas de informao. Porto Alegre: Artmed, 2005. AUDY, Jorge Luis Nicolas; BRODBECK, ngela Freitag. Sistemas de informao: planejamento e alinhamento estratgico nas organizaes. Porto Alegre: Bookman,2009. . MARTINS, Paulo Roberto; PAIANO, Valessa C. Linguagens e tcnicas de Pogramao I. So Paulo: Pearson Education do Brasil, 2009. 192 p. TANENBAUM, Andrew S. Organizao estruturada de computadores. 5. ed. So Paulo: Pearson, 2009. 450 p. http://www.apoioinformatica.inf.br/o-visualg http://www.infoescola.com/matematica/operacoes-da-logica-proposicional/ UNOPAR: Materiais disponibilizados na rea do aluno referente a disciplina de Fundamentos da Administrao da Informao.