http://www.scribd.

com/doc/10166445/4289Logica-de-Programacao

LISTA DE EXERC�CIOS IV ----------------------MAT�RIA: Algoritmos & Programa��o PROGRAMA: Dev C++ FALCULDADE: UniFacs - Salvador, BA CURSO: Engenharia de Produ��o ----COMANDOS ----# include <stdio.h> ----- usa os codigos de dev c++. # include <math.h> ------ usa opera��es matematicas. main () ----------------- fun��o principal, identifica o programa. {} ---------------------- abre/fecha estruturas de comando (main (),if, else, for, while, switch). () ---------------------- abre/fecha comandos espec�ficos para as estruturas. ; ----------------------- fecha uma linha de comando. int --------------------- variaveis inteiras. float ------------------- variaveis flutuantes (numeros com virgula). char -------------------- caracteres. printf (" ") ------------ escreve o que voc� quiser entre os " ". printf (" \n") ---------- \n serve para quebrar uma linha. printf (" %x ", y) ------ imprime valor da variavel y. scanf ("%x", &y) -------- %x pode ser variaveis do int (%d), float (%f) ou char (%c) e y corresponde a variavel escolhida pelo usu�rio. && ---------------------- e || ---------------------- ou == ---------------------- igual != ---------------------- diferente > ----------------------- maior < ----------------------- menor <= ---------------------- menor ou igual >= ---------------------- maior ou igual * ----------------------- multiplica��o / ----------------------- divis�o % ----------------------- resto da divis�o (n�o � porcentagem) if () ------------------- se for () ------------------ para while () ---------------- enquanto switch () --------------- se system ("pause") -------- impede a janela do programa de fechar ap�s executar o programa. 1) Ler 3 numeros e verificar se eles podem ou n�o ser lados de um tri�ngiulo #include <stdio.h> //S� ir� existir um tri�ngulo se, somente se, os seus lados obedeceram � seguinte regra: um de seus lados deve ser maior que o valor absoluto (m�dulo) da diferen�a dos outros dois lados e menor que a soma dos outros dois lados:

if (h<0){ printf ("escreva a altura sem sinal"). &h). } if(a<|b-c| || a>b+c || b<|a-c| || b< a+c || c<|b-a| || c> b+a){ printf ("o triangulo nao existe"). if (a>|b-c| && a< b+c && b>|a-c| && a< a+c && c>|b-a| && c< b+a){ printf ("O triangulo existe"). scanf ("%f%f%f". h. H.8)(2h/9. O programa dever� ler a op��o da figura desejada.8 m/s^2 e que a queda livre � determinada pela f�rmula: H = Ho + VoT + (gT^2)/2 #include <stdio. A.|b-c|<a<b+c |a-c|<b<a+c |a-b|<c<a+b main (){ float a.b. cilindro ou esfera?\n") scanf ("%c". switch (op){ case char == cone: . um cilindro ou uma esfera. printf ("Digite o valor dos lados"). R.2f segundos para atingir o solo". &b. scanf ("%f%".h> #include <math. &op).h> main (){ float vol. // Cone reto V = pi*r*r*(H/3) e A = pi*r*sgrt(r*r+H*H). } system ("pause"). char op printf ("cone.c. printf ("o corpo leva %. printf ("Qual a altura em metros?"\n).t). &c). } } 3) Calcular e imprimir o volume e a �rea de superf�cie de um cone reto. ent�o T = (2h/g)^2 float t. &a. // Cilindro V = pi*r*r*H e A = 2pi*r*H // Esfera V = 4/(3*pi*r*r*r) e A = 4*pi*r*r #include <stdio.8).h> main (){ // Em queda livre Vo = 0 e H = 0. } 2) Determinar quanto tempo um corpo em repouso leva para atingir o solo a a partir de uma certa altura informada pelo usu�rio. scanf ("%f%". Considere g = -9. } if (h>0){ t = (2/9. &h).

14*r*r printf ("volume = %f e area = %f". &H). } .h> main(){ float a. if (a>|b-c| && a< b+c && b>|a-c| && a< a+c && c>|b-a| && c< b+a){ printf ("O triangulo existe"). vol. scanf ("%f%f".} if(c==b && a!=c){ printf ("triangulo isosceles"). printf ("volume = %f e area = %f". &a. A). break. &c). printf ("Digite o valor dos lados").14*r*r*(H/3). &H). scanf ("%f%f". } system ("pause"). A). &r. case char == esfera: printf ("o raio e a altura?"). scanf ("%f%f". printf ("volume = %f e area = %f". scanf ("%c". A = 2*3. #include <stdio. vol.b. if(a!=b && a!=c && c!=b){ printf ("triangulo escaleno"). vol = 3. } } 4)Construa um algoritmo pedindo os lados de um triangulo e depois dando sua classifica��o. &H). A = 3. vol.14*r*r*H. vol = 3. A). &r.} } if(a<|b-c| || a>b+c || b<|a-c| || a< a+c || c<|b-a| || c> b+a){ printf ("o triangulo nao existe"). break.14*r*sgrt((r*r)+(H*H)). break. &b. break.c. default: printf ("op��o invalida. Qual a figura?").14*r*r*r) A = 4*3. scanf ("%f%f%f".} if(a==b && a==c && c==b){ printf ("triangulo equil�tero"). &op").} if(a==b || a==c && c!=b){ printf ("triangulo isosceles"). vol = 4/(3*3. case char == cilindro: printf ("o raio e a altura?"). &r.14*r*H.printf ("o raio e a altura?").

f3. f5p. idade. } } printf ("o maior numero � %f e o menor � %f". menor = num. i++){ if (idade>=18){ contador = contador + 1 } } maiores = contador. f5. f2. &idade). &num). f1p.h> main (){ int contador=0.h> main (){ int idade. system ("pause"). printf ("numero?"\n). printf ("%d sao maiores". i<10. } 7) Ler a data de nascimento de 5 pessoas e informar 1. float f1. #include <stdio. if (num > maior){ maior = num. scanf ("%d". f4. . maior = num. maiores. f4p. #inclide <stdio. i<10. f3p. maior. menor). system ("pause"). } if (num < menor){ menor = num.h> main (){ float num. printf ("digite a idade"). for (i=0. scanf ("%f".a quantidade de pessoas em cada faixa etaria e 2. maiores). menor. maior. i++){ printf ("proximo numero?"\n).5) Ler a idade de 10 pessoas e imprimir quantas s�o maiores de idade. f2p.a porcentagem de cada faixa etaria. scanf ("%f". &num). for (i=0. } 6) Ler 10 numeros e informar o menor e o maior #include <stdio.

%f pessoas entre 31-45 e %f pessoas entre 46-60 e %f pessoas maiores de 60 ". %f pessoas entre 16-30. f2*100 = f2p. i<5. i<5. f3*100 = f3p.for (i=0. } 8) Ler 5 numeros e informar quantos desses eram �mpares. %f % sao entre 31-45. %f % sao entre 46-60 e %f % sao maiores de 60 ". f1.h> main (){ int N=0 . scanf ("%f". f3p. f4p. f1p. f2 = 5/contB. f5*100 = f5p. &idade). i++){ . %f % sao entre 16-30. f5p\n). float n . if (idade <= 15){ contA++ } if (idade > 15) && idade <=30){ contB++ } if (idade > 30) && idade <=45){ contC++ } if (idade > 45) && idade <=60){ contD++ } if (idade >= 60)){ contE++ } } f1 = 5/contA. f2p. f5\n). f2. f1*100 = f1p. f5 = 5/contE. f3 = 5/contC. &n). f4. printf ("Existem %f menores de 15 anos. scanf ("%d".i++){ printf ("diga ai"). system ("pause"). for (i=0. printf ("%f % sao menores de 15 anos. f3. f4*100 = f4p. f4 = 5/contD. printf ("numero?"\n). #include <stdio.

i<130. amMenor. ahMedia=0. scanf ("%f". } 10) Ler a altura e o sexo de 15 pessoas (M para homem e F para mulher) e informe 1-a menor e a maior altura. ahMedia = (ahMedia + a)/cont. } } printf ("%d numeros impares\n".} . &sexo). #include <stdio. #include <stdio. } } printf ("%d numeros impares\n". ahMenor = a.} if (a < ahMenor){ a = ahMenor. scanf ("%f". i++){ printf ("numero?"\n). float n .h> main (){ int N=0 . ahMaior. float a. switch(sexo){ case char == M: printf ("informe altura\n").if (n%2!=0){ N = N + 1.h> main (){ int cont=0. } 9) Ler 130 numeros e informar quantos desses eram �mpares. cont = cont + 1. printf ("informe M para homem ou F para mulher\n"). N).ahMenor. ahMaior = a. 3-a altura da mulher mais alta 4-quantos eram os homens. system ("pause"). &a). N). amMaior. scanf ("%c". if (a > ahMaior){ a = ahMaior. &n). char sexo. if (n%2!=0){ N = N + 1. 2media da altura dos homens. for (i=0. system ("pause").

printf ("informe M para homem ou F para mulher\n). default: printf ("sexo errado\n"). amMaior = a. amMenor = a. com F variando de 50 a 65. ahMenor). case char == F: printf ("informe altura\n").} if (amMenor > amMenor){ printf ("a menor altura � %f\n". ahMedia).break.} break. for (i=50. ahMaior). amMenor). Escrever uma tabela de convers�o de F pra C. cont). } system ("pause"). amMaior). . printf ("%d em farenheit e %f em celcius".} printf ("a mulher mais alta tem %f metros\n". scanf ("%f". } if (ahMaior > amMaior){ printf ("a maior altura � %f\n". } 11) Convers�o de graus farenheit em celcius atrav�s da formula c/9 = f .h> main (){ int i. printf ("a media da altura dos homens � %f\n".} if (a < amMenor){ a = amMenor. system ("pause"). i. &a).} if (ahMenor < amMenor){ printf ("a menor altura � %f\n". i++){ c = (i-32)*9/5. i<65.} if (amMaior < amMaior){ printf ("a maior altura � %f\n". printf ("%f homens participaram\n".32 /5. c). break. amMaior). scanf ("%c". #include <stdio. if (a > amMaior){ a = amMaior. &sexo). float c.

MpesoC. pesoB. %f. switch (op){ case char == +: printf ("3 numeros?\n"). n4. contB. r. printf ("idade? peso?"). } MpesoA = pesoA/contA. scanf ("%f%f". %f ---. contA. for (i=0. &id. %f. } if (id >30){ contD++ pesoD = pesoD + p. i++){ if (id <=10){ contA++ pesoA = pesoA + p. As faixas de 1 a 10 anos. MpesoD\n).Pessoas por faixa etaria ----". MpesoA.h> #include <math. Calcular e imprimir as m�dias de peso das pessoas da mesma faixa etaria e quantas sao de cada faixa etaria. prinf ("qual a opera��o?\n"). } if (id >21 && id <=30){ contC++ pesoC = pesoC + p.h> main (){ int id. .h> main(){ char op. pesoC. #include <stdio. MpesoB. } Ex) Fazer uma calculadora simples #include <stdio. &p). i<15. MpesoB. pesoD. pesoA.M�dia de pesos por faixa etaria ----". %f. n2. MpesoA. float p. } if (id >11 && id <=20){ contB++ pesoB = pesoB + p. contD\n). float n1. contC. MpesoC = pesoC/contC. scanf ("%c".} 12) Ler a idade e o peso de 15 pessoas. } system ("pause"). MpesoC. MpesoB = pesoB/contB. n3. &op). printf ("%f. %f. %f ---. MpesoD. printf ("%f. de 11-20. MpesoD = pesoD/contD. de 21-30 e maiores de 30.

n3. break.r).r). &n1. scanf ("%f". r = n1 + n2 + n3. scanf ("%f%f". r = n1*n2.} else { r = n1/n2. case char == -: printf ("3 numeros?\n").&n2). break.&n3). printf ("%. printf ("%.} break.2f". printf ("%.&n2).r). scanf ("%f". &n1). scanf ("%c". else{ r = sqrt(n1). &n1. int i.} if (n1 == 0 && n2 ==0){ printf ("indetermina��o").} break. scanf ("%f%f". if (n2 == 0){ printf ("erro"). case char == /: printf ("2 numeros?\n").2f". r = n1 .2f".&n3). &num). case char == *: printf ("2 numeros?\n").} if (n1 == 0 && n2 ==0){ printf ("indetermina��o").2f". printf ("%. &n1. break. if (n2 == 0){ printf ("erro").2f".r). case char == %: printf ("2 numeros?\n").} break. if (n1 < 0){ printf ("n�o existe").r). scanf ("%f%f%f". break.&n2). printf ("numero?"). case char == raiz: printf ("numero?\n").scanf ("%f%f%f".2f".r). scanf ("%f%f".n2 .&n2. . default: printf ("opera��o inv�lida.&n2. &n1. printf ("%. &op). &n1.} else { r = n1/n2. fat=1. Qual opera��o?\n"). } } Ex) Fatorar um numero main (){ float num. printf ("%.

} if (r < 4){ printf ("reprovado"). Um programa teve ter um loop infinito ate que digite '0' na matricula. n4. n3. Tsoma=0. //um numero perfeito � quando a some de seus divisores com exce��o dele mesmo resultam nesse numero. i<num. Tmedia. // Detalhe que o programa n�o vai interagir com o usu�rio. printf ("%f � a media da turma". main (){ int mat. scanf ("%f%f%f%f". &n4). if (r >= 7){ printf ("aprovado").for (i=1. n2. n�o passou ou vai para a recupera��o (precisando de tantos pontos). main (){ int n=0. Tmedia). scanf ("%d". i++){ fat = num*i. &n3. Tsoma = Tsoma + r. i. Al�m disso tire a media da turma. } } Ex) Use c�digos para que um programa leia 4 notas de um aluno (a 1o tem peso 3. &mat). } } printf ("matricula?"). system ("pause"). float n1.(r*7).. while (mat!=0){ cont = cont + 1 printf ("as quatro notas?"). onde 1 + 2 + 3 = 6. a 2o 2 e a 3o e 4o peso 1). printf ("matricula?"). acumulador=0. scanf ("%d".. } Ex) Encontrar os cinco primeiros numeros perfeitos. cont=0. Tmedia = Tsoma / cont. r. p=0. fat). printf ("precisa de %d pontos na final". } if (r<7 && r>=4){ printf ("final"). Para ter id�ia pit�goras s� chegou at� o quarto numero perfeito. &n1. // Ao executar o programa a maquina fica lenta porque s�o muitos calculos. &mat). . printf ("%f". final. &n2. r = ((n1*3) + (n2*2) + n3 + n4) /4. Calcule a m�dia e diga se ele passou. final = 50 . Por exemplo: 6. final).

&n). 1<n. } } Ex) Ler n numeros e contar quantos s�o pares. scanf ("%d". } } if (acumulador == n){ p = p + 1. printf ("%d � perfeito".n). i++){ if (n%i == 0){ acumulador = acumulador + i. } n = n + 1. n). O pragrama deve parar quando ler um multiplo de 11. } . acumulador = 0. if (n%2==0){ cont = cont + 1.while (p!=5){ for (i=1. } } printf ("%d numeros foram pares". while (n%11!=0){ printf ("qual o numero?"). system ("pause"). cont=0. main (){ int n=1.

n4. Vale lembrar que a principal tarefa do programador não é programar em si. soma: inteiro inicio escreva ("Digite o primeiro número: ") leia (n1) escreva ("Digite o segundo número: ") leia (n2) escreva ("Digite o terceiro número: ") leia (n3) escreva ("Digite o quarto número: ") leia (n4) soma <. nada como resolver alguns algoritmos para treinar desde já a resolução de problemas. var n1. utilizando a sintaxe do Visualg. mas a sintaxe é um pouco diferente. n2. calcule e mostre a média aritmética entre elas.n1 + n2 + n3 + n4 escreva (soma) // Seção de Comandos fimalgoritmo 2) Faça um algoritmo que receba três notas. é possível usar o Portugol. var n1. n2. A principal tarefa do programador é resolver problemas para conseguir criar o software desejado pela empresa onde trabalha.Alguns algoritmos resolvidos O post de hoje é um post especial: é sobre algoritmos. tipo.. Algoritmos são as principais dificuldades que o programador encontra no início dos seus estudos. 1) Faça um algoritmo que receba quatro números inteiros. n3. media: real inicio escreva ("Digite a primeira nota: ") leia (n1) escreva ("Digite a segunda nota: ") .. n3. calcule e mostre a soma desses números. Abaixo estão listados 18 algoritmos resolvidos. Se essa é a vida do programador. fazer códigos. Se preferir.

novoSal: real inicio escreva ("Digite o salário: ") leia (sal) novoSal< . media) // Seção de Comandos fimalgoritmo 3) Faça um algoritmo que receba três notas e seus respectivos pesos.sal * 1.25 escreva ("O salário com aumento é: ". sabendo-se que este sofreu um aumento de 25%. calcule e mostre o novo salário. var sal. p3. p1. n3. calcule e mostre a média ponderada dessas notas.(n1 + n2 + n3) / 3) escreva ("A média das notas é: ". var sal. n2. var n1. mediaPon: real inicio escreva ("Digite a primeira nota: ") leia (n1) escreva ("Digite a segunda nota: ") leia (n2) escreva ("Digite a terceira nota: ") leia (n3) escreva ("Digite o peso da primeira nota: ") leia (p1) escreva ("Digite o peso da segunda nota: ") leia (p2) escreva ("Digite o peso da terceira nota: ") leia (p3) mediaPon< . mediaPon) // Seção de Comandos fimalgoritmo 4) Faça um algoritmo que receba o salário de um funcionário. novoSal: real inicio .((n1 * p1) + (n2 * p2) + (n3 * p3)) / (p1 + p2 + p3) escreva ("A média ponderada das três notas é: ". p2. aumento. novoSal) // Seção de Comandos fimalgoritmo 5) Faça algoritmo que receba o salário de um funcionário e o percentual de aumento e calcule e mostre o valor do aumento e o novo salário.leia (n2) escreva ("Digite a terceira nota: ") leia (n3) media <.

imp. total) // Seção de Comandos fimalgoritmo 9) Faça um algoritmo que calcule e mostre a área de um círculo. calcule e mostre o valor do rendimento e o valor total depois do rendimento.sal * 0.imp novoSal< .aumento + sal escreval ("O valor do aumento é: ". desc. novoSal: real inicio escreva ("Digite o salário-base do funcionário: ") leia (sal) imp< . rend) escreva ("O valor total após o rendimento é: ".sal .deposito + rend escreval ("O valor do rendimento é: ". calcule e mostre o salário a receber.05 imp< . novoSal) // Seção de Comandos fimalgoritmo 8) Faça um algoritmo que receba o valor de um depósito e o valor da taxa de juros.00 e paga imposto de 10% sobre o salário-base. novoSal: real inicio escreva ("Digite o sálário base do funcionário: ") leia (sal) grat< . novoSal) // Seção de Comandos fimalgoritmo 7) Faça um algoritmo que receba o salário-base de um funcionário. grat. var deposito. var area: real inicio area< . area) // Seção de Comandos fimalgoritmo .sal * 0.10 novoSal< . novoSal) // Seção de Comandos fimalgoritmo 6) Faça um algoritmo que receba o salário-base de um funcionário. var sal. var sal.07 desc< . Sabendo-se que esse funcionário tem gratificação de R$ 50. calcule e mostre seu salário a receber. aumento) escreva ("O valor do novo salário é: ". sabendo-se que esse funcionário tem gratificação de 5% sobre o salário base e paga imposto de 7% sobre o salário base.imp) + 50 escreva ("O salário que o funcionário tem a receber é: ". taxa.14 * 10) ^ 2 escreva ("A área do círculo é: ".escreva ("Digite o valor do salário: ") leia (sal) escreva ("Digite o valor do aumento em porcentagem: ") leia (aumento) aumento <. Sabe-se que: Area=ΠR2. total: real inicio escreva ("Digite o valor do depósito: ") leia (deposito) escreva ("Digite o valor da taxa de juros: ") leia (taxa) rend< .(sal .sal * (aumento / 100) novoSal< .desc + grat escreva ("O salário do funcionário a receber é: ". imp.sal * 0. rend.(3.deposito * (taxa / 100) total <.

3) rQuadrada< . num2.10) Faça um algoritmo que receba um número positivo e maior que zero.exp(num. quadrado) escreval ("O número ao cubo é: ".(2017 . var aNasc.exp(num. c)A raiz quadrada do número digitado. idFut: inteiro inicio escreva ("Digite o ano de nascimento da pessoa: ") leia (aNasc) escreva ("Digite o ano atual: ") leia (aAtual) idPres< . 2) cubo <. result) // Seção de Comandos fimalgoritmo 12) Faça um algoritmo que receba o ano de nascimento de uma pessoa e o ano atual. rQuadrada.exp(num.exp(num. b)O número digitado ao cubo. rQuadrada) escreva ("A raiz cúbica do número é: ". Calcule e mostre: a)A idade dessa pessoa. var num.(aAtual . num2) escreva ("O número ". calcule e mostre: a)O número digitado ao quadrado. num2. 1/3) escreval ("O número ao quadrado é: ".aNasc) idFut< . var num. b)Quantos anos essa pessoa terá em 2017. quadrado. d)A raiz cúbica do número digitado. rCubica) // Seção de Comandos fimalgoritmo 11) Faça um algoritmo que receba dois números maiores que zero. aAtual. num. idPres. result: real inicio escreva ("Digite um número maior do que zero: ") leia (num) escreva ("Digite outro número maior do que zero: ") leia (num2) result< . rCubica: real inicio escreva ("Digite um número positivo e maior do que zero: ") leia (num) quadrado <. 1/2) rCubica< .aNasc) escreval ("A idade da pessoa é: ". calcule e mostre um elevado ao outro. idPres) escreva ("A idade que a pessoa terá em 2017 será: ". " é: ". idFut) // Seção de Comandos fimalgoritmo . " elevado a ".exp(num. cubo. cubo) escreval ("A raiz quadrada do número é: ".

imp escreva ("O salário a receber será: ".nHorasTrab * hTrabalhada imp< .pFabr * (vImp / 100) pFinal< . vImp. c)O preço final do veículo. salBruto. pFinal: real inicio escreva ("Digite o preço de fábrica: ") leia (pFabr) escreva ("Digite o percentual de lucro: ") leia (pLucro) escreva ("Digite o percentual de impostos: ") leia (vImp) pLucro< . pFinal) // Seção de Comandos fimalgoritmo 14) Faça um algoritmo que receba o número de horas trabalhadas e o valor do salário mínimo. imp.salBruto * 0. pLucro. sARec: real inicio escreva ("Digite o número de horas trabalhadas: ") leia (nHorasTrab) escreva ("Digite o valor do salário mínimo: ") leia (mSalMin) hTrabalhada< .13) O custo ao consumidor de um carro novo é a soma do preço de fábrica com o percentual de lucro do distribuidor e dos impostos aplicados ao preço de fábrica. d)O salário a receber equivale ao salário bruto menos o imposto.pFabr * (pLucro / 100) vImp< . o percentual de lucro do distribuidor e o percentual de impostos. c)O imposto equivale a 3% do salário bruto. hTrabalhada. pLucro) escreval ("O valor correspondente aos impostos é: ".mSalMin / 2 salBruto< . var pFabr. sARec) . b)O salário bruto equivale ao número de horas trabalhadas multiplicado pelo valor da hora trabalhada.salBruto .03 sARec< . Faça um algoritmo que receba o preço de fábrica de um veículo. mSalMin. var nHorasTrab.(pFabr + pLucro + vImp) escreval ("O valor do lucro do distribuidor é: ". Calcule e mostre o salário a receber seguindo as regras abaixo: a)A hora trabalhada vale a metade do salário mínimo. Calcule e mostre: a)O valor correspondente ao lucro do distribuidor b)O valor correspondente aos impostos. vImp) escreva ("O preço final do veículo é: ".

0. b)A idade dessa pessoa em meses. portanto. idade. ".// Seção de Comandos fimalgoritmo 15) Um trabalhador recebeu seu salário e depositou em sua contra corrente bancária. Calcule e mostre o salário a receber seguindo as regras a seguir: a)A hora trabalhada vale 1/8 do salário mínino.") escreval ("Podemos concluir que ela tem ".38% e o saldo inicial da conta está zerado.idade * 12 dias <. var hTrab. sFinal: real inicio // Seção de Comandos escreva ("Digite o número de horas trabalhadas: ") leia (hTrab) escreva ("Digite o valor do salário mínimo: ") leia (salMin) escreva ("Digite o número de horas extras trabalhadas: ") . salMin.idade * 52 escreval ("A pessoa tem ".parcial parcial2 <. c)O salário bruto equivale ao número de horas trabalhadas multiplicado pelo valor da hora trabalhada. cpmf. d)A idade dessa pessoa em semanas.") fimalgoritmo 17) Faça um algoritmo que receba o número de horas trabalhadas.0038 parcial <. hETrab. dias.ano meses <.") escreval ("E exatamente ". d)A quantia a receber pelas horas extras equivale ao número de horas extras trabalhadas multiplicado pelo valor da hora extra. b)A hora extra vale ¼ do salário mínimo. vHT. meses. meses. Esse trabalhador emitiu dois cheques e agora deseja saber seu saldo atual. salMinimo) fimalgoritmo 16) Faça um algoritmo que receba o ano de nascimento de uma pessoa e o ano atual calcule e mostre: a)A idade dessa pessoa em anos.salMinimo * cpmf salMinimo< . var ano. o valor do salário mínimo e o número de horas extras trabalhadas. parcial. semanas: inteiro inicio // Seção de Comandos escreva ("Digite o ano de nascimento da pessoa: ") leia (ano) idade <. HExtraARec.salMinimo . var salMinimo.parcial2 escreva ("O salário do trabalhador após as retiradas é: ". " semanas. " meses. semanas. vHET. e)O salário a receber equivale ao salário bruto mais a quantia a receber pelas horas extras. parcial2: real inicio // Seção de Comandos escreval ("Digite o valor do salário do trabalhador: ") leia (salMinimo) cpmf< . salBruto. c)A idade dessa pessoa em dias. " dias de vida. Sabe-se que cada operação bancária de retirada paga CPMF de 0. dias.salMinimo . idade.2012 .idade * 365 semanas <. " anos.salMinimo * cpmf salMinimo< .") escreva ("Ela possui.

sFinal) fimalgoritmo 18) Faça um algoritmo que receba a quantidade de dinheiro em reais que uma pessoa que vai viajar possui. marco alemão e libra esterlina. dolar.salMin / 4 salBruto< .") escreval (marco.") fimalgoritmo . Sabe-se que a cotação do dólar é de R$ 1.80.00 libra <. var reais. O algoritmo deve fazer as conversões e mostrá-las.57. dolar.reais / 2. Essa pessoa vai passar por vários países e precisa converter seu dinheiro em dólares.reais / 1. " libras.reais / 1.salMin / 8 vHET< .leia (hETrab) vHT< .57 escreval ("O dinheiro da pessoa equivale a ".salBruto + HExtraARec escreva ("O salário a receber é de: ".80 marco <. do marco alemão é de R$ 2. " dólares. marco.hTrab * vHT HExtraARec< . " marcos ou") escreva (libra.hETrab * vHET sFinal< . libra: real inicio // Seção de Comandos escreva ("Digite a quantidade de dinheiro em reais que a pessoa possui: ") leia (reais) dolar< .00 e da libra esterlina é de R$ 1.

Sign up to vote on this title
UsefulNot useful