Você está na página 1de 9

FACULDADE ANHANGUERA TECNOLOGIA EM ANALISE E DESENVOLVIMENTO DE SISTEMAS

Relatrio Tcnico ATPS DE CONSTRUO DE ALGORITIMOS (PSEUCDIGOS, FLUXOGRAMAS)

Turma: 307

Alunos:

Alexandre Bonifcio Anderson de Souza da Silva Edinilson Pereira da Silva Israel Cardoso Lino Alves Maria Romualdo

RA 2504109265 RA: 1108350871 RA: 2504006103 RA: 1190422454 RA: 2504013620

Professor: Valrio

Sumrio:

Teste 1 - Converso de Dlar Americano para a moeda x Teste 2 - Converso da moeda x para Dlar Americano Teste 3 - Diferena percentual entre Comercial, Turismo e Paralelo Descrio do Sistema Converso de moedas Algoritmo Conversor de Moedas Fluxograma Converso de moedas Referncias Bibliogrficas

Teste 1 - Converso de Dlar Americano para a moeda x


Este cdigo faz a converso do dlar (turismo, paralelo e comercial) para as demais moedas apresentadas. O sistema solicita para informar o valor de umas das cotaes base desejado para a possvel converso das moedas apresentadas, e em seguida informar o valor que se deseja saber a converso. O clculo e muito simples, basta multiplicar o valor desejado a converter pela base da cotao desejada do dlar e em seguida dividi-lo pela base da moeda deseja que ser o valor da moeda final que se deseja. Inicio real: real1<-1.00, dolarcnd<-1.64, euro<-2.27, dolartur<-1.63, valor, mbase; escreva("Informe o valor da base da moeda dolar para converso:"); escreva(" [US$ = 1.63 turismo] [US$ = 1.73 paralelo] [US$ = 1.57 comercial]"); escreva("Valor da moeda base: "); leia(mbase); escreva("Valor a converter: "); leia(valor); escreva("O Resultado e: R$ ",(valor*mbase/real1)); escreva("O Resultado e: CDN$ ",(valor*mbase/dolarcnd)); escreva("O Resultado e: E$ ",(valor*mbase/euro)); fim.

Teste 2 - Converso da moeda x para Dlar Americano


Este cdigo consiste em converter algumas moedas distintas desejas para uma das as trs cotaes do dlar americano como: turismo, paralelo e comercial. O sistema solicita para informar o valor base da moeda desejada que se deseje converter e em seguida informar o valor desejado desta mesma moeda, para que seja processado os clculos para converso, o resultado e informado nas cotaes do dlar americano (turismo, paralelo e comercial), a base de clculo destas cotaes so atualizados continuamente na inicializao das variveis manualmente e claro. A frmula utilizada e a seguinte: dividi-se a base da moeda deseja a converter pela base da cotao do dolar que muda continuamente e depois multiplica esse resultado pelo valor que se deseja saber para a converso em dlares. inicio real: dolarcom<-1.57, dolartur<-1.63, dolarpar<-1.73, valor, mbase; escreva("Informe o valor da base da moeda para verificar a cotao em dolares:"); escreva("Exemplos de base: [cnd$ = 1.64] [E$ = 2.27] [R$ = 1.00]"); escreva("Valor da moeda base: "); leia(mbase); escreva("Valor a converter: "); leia(valor); escreva("Cotacao em dolar turismo : US$ ",(mbase/dolartur)*valor); escreva("Cotacao em dolar paralelo : US$ ",(mbase/dolarpar)*valor); escreva("Cotacao em dolar comercial: US$ ",(mbase/dolarcom)*valor); fim.

Teste 3 - Diferena percentual entre Comercial, Turismo e Paralelo


Este cdigo basicamente informa a diferena percentual em ambas s cotaes do dlar americano (turismo, paralelo e comercial) que varia continuamente de acordo com a bolsa de valores. O clculo que valida este algoritmo e resumido da seguinte forma: subtrai a primeira maior cotao pela menor cotao e multiplica o resultado por 100 divido pela menor cotao, o mesmo processo e repetido, porm subtraindo a segunda maior cotao etc. inicio real: dolarcom, dolartur, dolarpar; escreva("Informe os valores base da cotacao dolar para obter a diferena percentual!"); escreva("Exemplo de valores: US$ [turismo = 1.63 paralelo = 1.73 comercial = 1.57]"); escreva("Valor do US$ turismo: "); leia(dolartur); escreva("Valor do US$ paralelo: "); leia(dolarpar); escreva("Valor do US$ comercial: "); leia(dolarcom); se (dolartur < dolarcom e dolartur < dolarpar) ento inicio dif1<-(dolarcom-dolartur)*(100/dolartur); dif2<-(dolarpar-dolartur)*(100/dolartur); escreva("A dif. perc. do dolar tur. para o comercial e de ",dif1,"%"); escreva("A dif. perc. do dolar tur. para o paralelo e de ",dif2,"%"); fim seno se (dolarcom < dolartur e dolarcom < dolarpar) ento inicio dif1<-(dolartur-dolarcom)*(100/dolarcom); dif2<-(dolarpar-dolarcom)*(100/dolarcom); escreva("A dif. perc. do dolar com. para o turismo e de ",dif1,"%"); escreva("A dif. perc. do dolar com. para o paralelo e de ",dif2,"%"); fim seno se (dolarpar < dolarcom e dolarpar < dolartur) ento inicio dif1<-(dolarcom-dolarpar)*(100/dolarpar); dif2<-(dolartur-dolarpar)*(100/dolarpar); escreva("A dif. perc. do dolar par. para o comercial e de ",dif1,"%"); escreva("A dif. perc. do dolar par. para o paralelo e de ",dif2,"%"); fim seno escreva("Dolar Americano [Tur./Par./Com.] sem diferena percentual"); fimse; fimse; fimse; fim.

Descrio do Sistema Converso de moedas


Este algoritmo foi criado com base na etapa um para atender alguns requisitos bsicos solicitados por uma agncia de turismo, ele consistia em converter trs moedas para o real, e mais tarde foi aperfeioado de acordo com as novas solicitaes do diretor de uma agncia de turismo. A nova concepo do sistema agora faz converso de ambas as moedas bastando apenas informar o tipo da moeda e o valor desejado e para qual moeda ser feita a converso. Tambm e possvel converter um tipo de moeda qualquer para o dlar americano e obter o resultado em turismo, comercial e paralelo que facilita a analise de valores gastos em cartes de crditos ou outra forma de gasto baseado no dlar americano. O sistema tambm permite verificar a diferena em percentual da menor cotao do dlar americano para os demais como exemplo: dlar comercial para (turismo e paralelo) ou dependendo das atualizaes instantneas do mercado de cambio dos valores das cotaes a todo instante. O aplicativo funciona da seguinte forma: em primeira instancia o sistema solicita a escolha da opo desejada da moeda a converter, enquanto a opo no for coerente com a suportada pelo aplicativo ele pede para informar novamente uma nova opo, uma vez aceita a mesma informa moeda que foi escolhida e solicita agora o valor para converso, feito isto, em seguida so apresentadas as opes das moedas suportadas pelo aplicativo que ser a moeda final a que se deseja verificar o valor da converso, ento o sistema fica esperando mais uma vez a opo certa para mostrar o valor da converso, se opo escolhida for invalida ele solicita a escolha mais uma vez ate que seja satisfeita. Uma vez apresentado as converses desejas e os valores finais da moeda desejada, o sistema e finalizado.

Algoritmo Conversor de Moedas


inicio real: real<-1.00, dolarcnd<-1.64, euro<-2.27, valor, mbase,dif1,dif2; real: dolarcom<-1.57, dolartur<-1.63, dolarpar<-1.73; inteiro: opco1,opco2; escreva("<- Conversor de Moedas ->"); escreva("Informe a opco da moeda base desejada para converso"); ecreva("[1]R$ - [2]CND$ - [3]E$ - [4]US$(turismo)"); enquanto (opco1<>1 e opco1<>2 e opco1<>3 e opco1<>4 ); faa escreva("Opco: "); leia(opco1); se opco1 = 1 ento inicio escreva("Voc optou pela moeda Real!"); mbase<-real; fim seno se opco1 = 2 ento inicio escreva("Voc optou pela moeda Dolar Canadense!"); mbase<-dolarcnd; fim seno se opco1 = 3 ento inicio escreva("Voc optou pela moeda Euro!"); mbase<-euro; fim seno se opco1 = 4 ento inicio escreva("Voc optou pela moeda Dolar Americano[turismo]!"); mbase<-dolartur; fim seno escreva("Opco invlida, escolha outro opo!"); fimse; fimse; fimse; fimse; fimenquanto; escreva("Informe o valor a converter: "); leia(valor); escreva("Informe para qual moeda se deseja converter!");

escreva("[1]R$ - [2]CND$ - [3]E$ - [4]US$(Tur.- Par.- Com.)"); enquanto (opcao2<>1 e opcao2<>2 e opcao2<>3 e opcao2<>4 ); faa escreva("Opco: "); leia(opco2); se opco2 = 1 ento inicio escreva("Voc optou a converso para Reais!"); escreva("O Resultado : R$ ",(valor*mbase/real)); fim seno se opcao2 = 2 ento inicio escreva("Voc optou a converso para Dolares Canadense!"); escreva("O Resultado : CDN$ ",(valor*mbase/dolarcnd)); fim seno se opcao2 = 3 ento inicio escreva("Voc optou a converso para Euros!"); escreva("O Resultado : E$ ",(valor*mbase/euro)); fim seno se opcao2 = 4 ento inicio escreva("Voc optou a converso para Dolar Americano [Tur./Par./Com.]!"); escreva("Cotaco em dolar turismo : US$ ",(mbase/dolartur)*valor); escreva("Cotaco em dolar paralelo : US$ ",(mbase/dolarpar)*valor); escreva("Cotaco em dolar comercial: US$ ",(mbase/dolarcom)*valor); se (dolartur < dolarcom e dolartur < dolarpar) ento inicio dif1<-(dolarcom-dolartur)*(100/dolartur); dif2<-(dolarpar-dolartur)*(100/dolartur); escreva("A dif. perc. do dolar tur. para o comercial e de ",dif1,"%"); escreva("A dif. perc. do dolar tur. para o paralelo e de ",dif2,"%"); fim seno se (dolarcom < dolartur e dolarcom < dolarpar) ento inicio dif1<-(dolartur-dolarcom)*(100/dolarcom); dif2<-(dolarpar-dolarcom)*(100/dolarcom); escreva("A dif. perc. do dolar com. para o turismo e de ",dif1,"%"); escreva("A dif. perc. do dolar com. para o paralelo e de ",dif2,"%"); fim seno se (dolarpar < dolarcom e dolarpar < dolartur) ento inicio dif1<-(dolarcom-dolarpar)*(100/dolarpar); dif2<-(dolartur-dolarpar)*(100/dolarpar); escreva("A dif. perc. do dolar par. para o comercial e de ",dif1,"%"); escreva("A dif. perc. do dolar par. para o paralelo e de ",dif2,"%"); fim seno escreva("Dolar Americano [Tur./Par./Com.] sem diferena percentual"); fimse; fimse; fimse; fim seno escreva("Opco invlida, escolha outro opo!"); fimse; fimse; fimse; fimse; fimenquanto; fim.

Fluxograma Converso de moedas


INCIO real : real 1.00, dolarcnd 1.64, euro 2.27, valor , mbase, dif1, dif2; real : dolarcom 1,57 , dolartur 1.63 , dolarpar 1.73 ; nteiro : opo1, opo2; escreva(" conversor de moeda "); escreva(" informe a opo da moeda base desejada para converso "); escreva(" [1]R$ - [2]CDN$ - [3]E$ - [4]US$(turismo)" );

(opo1<>1 e opo1<>2 e opo1<>3 e opo1<>4 );

FAA escreva("Opo: "); leia(opo1) ;

opo1=1 SIM

NO

escreva(" Voc optou pela moeda Real!" ); mbase<-real; opo1=2 1 SIM escreva("Voc optou pela moeda Dolar Canadense!"); mbase<-dolarcnd; NO

1 NO opo1=3 SIM escreva("Voc optou pela moeda Euro!");

opo1=4 SIM

SENO

escreva("Voc optou pela moeda Dolar Americano[turismo]!");

mbase<-euro;

1 fimenquanto;

mbase<-dolartur;

escreva("Opo invlida, escolha outro opo!");

escreva("Informe o valor a converter: "); leia(valor); escreva("Informe para qual moeda se deseja converter!");

escreva("[1]R$ - [2]CND$ - [3]E$ - [4]US$(Tur.- Par.- Com.)");

(opo2<>1 e opo2<>2 e opo2<>3 e opo2<>4 ) FAA escreva("Opo: "); leia(opo2);

opo2=1 SIM

NO

escreva("Voc optou a converso para Reais!"); escreva("O Resultado : R$ ",(valor*mbase/real));

opo2=2 SIM

NO

escreva("Voc optou a converso para Dolares Canadense!");

escreva("O Resultado : CDN$ ",(valor*mbase/dolarcnd));

3 NO NO opo2=4 SIM ("Voc optou a conver para Dolar Americano [Tur./Par./Com.] "); escreva("Cotaco dolar turismo : US$ ",(mbase/dolartur)*valor); escreva("Cotaco dolar paralelo : US$ ",(mbase/dolarpar)*valor); 3 escreva("Cotaco dolar comercial: US$ ",(mbase/dolarcom)*valor); opo2=3 SIM escreva("Voc optou a converso para Euros!"); escreva("O Resultado : E$ ",(valor*mbase/euro));

3 escreva("Opo invlida, escolha outro opo!");

fimenquanto;

4 fim.

(dolartur < dolarcom e dolartur < dolarpar) SIM dif1<-(dolarcom-dolartur)*(100/dolartur); dif2<-(dolarpar-dolartur)*(100/dolartur);

NO

escreva("A dif. perc. do dolar tur. para o comercial e de ",dif1,"%"); escreva("A dif. perc. do dolar tur. para o paralelo e de ",dif2,"%"); 3 NO (dolarcom< dolartur e dolarcom < dolarpar) SIM dif1<-(dolartur-dolarcom)*(100/dolarcom); dif2<-(dolarpar-dolarcom)*(100/dolarcom); escreva("A dif. perc. do dolar com. para o turismo e de ",dif1,"%");

escreva("A dif. perc. do dolar com. para o paralelo e de ",dif2,"%");

(dolarpar < dolarcom e dolarpar < dolartur) SIM dif1<-(dolarcom-dolarpar)*(100/dolarpar); dif2<-(dolartur-dolarpar)*(100/dolarpar);

SENO

escreva("A dif. perc. do dolar par. para o comercial e de ",dif1,"%");

escreva("A dif. perc. do dolar par. para o paralelo e de ",dif2,"%");

3 escreva("Dolar Americano [Tur./Par./Com.] sem diferena percentual");

Referncias Bibliogrficas:
http://economia.uol.com.br/cotaces Lgica de Programao A Construo de Algoritmos e Estruturas de Dados So Paulo: Forbellone, Andr Luiz Villar - MAKRON, 1993.

Você também pode gostar