Você está na página 1de 6

SE

Page 1 of 6

Excel > Referncia de funo > Lgico

SE
Ocultar tudo Retorna um valor se uma condio que voc especificou avaliar como VERDADEIRO e um outro valor se for avaliado como FALSO. Use SE para efetuear testes condicionais com valores e frmulas. Sintaxe SE(teste_lgico;valor_se_verdadeiro;valor_se_falso) Teste_lgico qualquer valor ou expresso que possa ser avaliado como VERDADEIRO ou FALSO. Por exemplo, A10=100 uma expresso lgica; se o valor da clula A10 for igual a 100, a expresso ser considerada VERDADEIRO. Caso contrrio, a expresso ser considerada FALSO. Esse argumento pode usar qualquer operador de clculo de comparao. Valor_se_verdadeiro o valor retornado se teste_lgico for VERDADEIRO. Por exemplo, se esse argumento for a seqncia de caracteres de texto "Dentro do oramento" e o argumento teste_lgico for considerado VERDADEIRO, a funo SE exibir o texto "Dentro do oramento". Se teste_lgico for VERDADEIRO e valor_se_verdadeiro for vazio, o argumento retornar 0 (zero). Para exibir a palavra VERDADEIRO, use o valor lgico VERDADEIRO para esse argumento. Valor_se_verdadeiro pode ser outra frmula. Valor_se_falso o valor retornado se teste_lgico for FALSO. Por exemplo, se esse argumento for a seqncia de caracteres de texto "Acima do oramento" e o argumento teste_lgico for considerado FALSO, a funo SE exibir o texto "Acima do oramento". Se teste_lgico for FALSO e valor_se_falso for omitido (ou seja, se no houver vrgula aps valor_se_verdadeiro), o valor lgico FALSO ser retornado. Se teste_lgico for FALSO e valor_se_falso for vazio (ou seja, se houver uma vrgula aps valor_se_verdadeiro seguida do parnteses de fechamento), o valor 0 (zero) ser retornado. Valor_se_falso pode ser outra frmula. Comentrios

Podem ser aninhadas at 64 funes SE como argumentos valor_se_verdadeiro e valor_se_falso para criar testes mais elaborados. (Consulte o Exemplo 3 para ver uma amostra das funes SE aninhadas). Como alternativa, para testar vrias condies, considere utilizar as funes PROC, PROCV ou PROCH. (Consulte o Exemplo 4 para ver uma amostra da funes PROC.) Quando os argumentos valor_se_verdadeiro e valor_se_falso so avaliados, SE retorna o valor que foi retornado por essas instrues. Se algum dos argumentos de SE for matriz(matriz: usada para criar frmulas nicas que produzem vrios resultados ou que operam em um grupo de argumentos organizados em linhas e colunas. Um intervalo de matrizes compartilha uma frmula comum; uma constante de matriz um grupo de constantes usado como um argumento.), cada elemento da matriz ser avaliado quando a instruo SE for executada. O Microsoft Excel fornece funes adicionais que podem ser usadas para analisar os dados com base em uma condio. Por exemplo, para contar o nmero de ocorrncias de uma seqncia de caracteres de texto

ms-help://MS.EXCEL.12.1046/EXCEL/content/HP10069829.htm

10/03/2013

SE

Page 2 of 6

ou um nmero dentro de um intervalo de clulas, use a funo de planilha CONT.SE e CONT.SES. Para calcular uma soma baseada em uma seqncia de caracteres de texto ou em um nmero dentro de um intervalo, use a funo de planilha SOMASE e SOMASES. Exemplo 1 Talvez seja mais fcil de compreender o exemplo se voc copi-lo para uma planilha em branco. Como copiar um exemplo

1. 2.

Crie uma pasta de trabalho ou planilha em branco. Selecione o exemplo no tpico da Ajuda.
OBSERVAO

No selecione os cabealhos de linha ou de coluna.

Selecionando um exemplo na Ajuda

3. 4. 5.

Pressione CTRL+C. Na planilha, selecione a clula A1 e pressione CTRL+V. Para alternar entre exibir os resultados e exibir as frmulas que retornam os resultados, pressione CTRL+` (acento grave) ou, na guia Frmulas, no grupo Auditoria de Frmulas, clique no boto Mostrar Frmulas.

1 2

A Dados 50 Frmula =SE(A2<=100;"Dentro do oramento";"Acima do oramento") =SE(A2=100;SOMA(B5:B15);"") Descrio (resultado) Se o nmero acima for menor ou igual a 100, a frmula exibir "Dentro do oramento". Caso contrrio, a funo exibir "Acima do oramento" (Dentro do oramento) Se o nmero acima for 100, o intervalo B5:B15 ser calculado. Caso contrrio, o texto vazio ("") ser retornado ()

Exemplo 2 Talvez seja mais fcil de compreender o exemplo se voc copi-lo para uma planilha em branco. Como copiar um exemplo

ms-help://MS.EXCEL.12.1046/EXCEL/content/HP10069829.htm

10/03/2013

SE

Page 3 of 6

1. 2.

Crie uma pasta de trabalho ou planilha em branco. Selecione o exemplo no tpico da Ajuda.
OBSERVAO

No selecione os cabealhos de linha ou de coluna.

Selecionando um exemplo na Ajuda

3. 4. 5.

Pressione CTRL+C. Na planilha, selecione a clula A1 e pressione CTRL+V. Para alternar entre exibir os resultados e exibir as frmulas que retornam os resultados, pressione CTRL+` (acento grave) ou, na guia Frmulas, no grupo Auditoria de Frmulas, clique no boto Mostrar Frmulas.

1 2 3 4

A Despesas reais 1500 500 500 Frmula =SE(A2>B2;"Acima do oramento";"OK") =SE(A3>B3;"Acima do oramento";"OK")

B Despesas previstas 900 900 925 Descrio (resultado) Verifica se a primeira linha est acima do oramento (Acima do oramento) Verifica se a segunda linha est acima do oramento (OK)

Exemplo 3 Talvez seja mais fcil de compreender o exemplo se voc copi-lo para uma planilha em branco. Como copiar um exemplo

1. 2.

Crie uma pasta de trabalho ou planilha em branco. Selecione o exemplo no tpico da Ajuda.
OBSERVAO

No selecione os cabealhos de linha ou de coluna.

ms-help://MS.EXCEL.12.1046/EXCEL/content/HP10069829.htm

10/03/2013

SE

Page 4 of 6

Selecionando um exemplo na Ajuda

3. 4. 5.

Pressione CTRL+C. Na planilha, selecione a clula A1 e pressione CTRL+V. Para alternar entre exibir os resultados e exibir as frmulas que retornam os resultados, pressione CTRL+` (acento grave) ou, na guia Frmulas, no grupo Auditoria de Frmulas, clique no boto Mostrar Frmulas.

1 2 3 4

A Resultado 45 90 78 Frmula =SE(A2>89;"A";SE(A2>79;"B"; SE(A2>69;"C";SE (A2>59;"D";"F")))) =SE(A3>89;"A";SE(A3>79;"B"; SE(A3>69;"C";SE (A3>59;"D";"F")))) =SE(A4>89;"A";SE(A4>79;"B"; SE(A4>69;"C";SE (A4>59;"D";"F")))) Descrio (resultado) Atribui uma letra ao primeiro resultado (F) Atribui uma letra ao segundo resultado (A) Atribui uma letra ao terceiro resultado (C)

No exemplo anterior, a segunda instruo SE tambm o argumento valor_se_falso para a primeira instruo SE. Da mesma maneira, a terceira instruo SE o argumento valor_se_falso para a segunda instruo SE. Por exemplo, se o primeiro teste_lgico (Mdia>89) for VERDADEIRO, "A" ser retornado. Se o primeiro teste_lgico for FALSO, a segunda instruo SE avaliada e assim por diante. As letras so atribudas a nmeros usando a seguinte chave. Se Resultado for Ento retornar Maior do que 89 De 80 a 89 De 70 a 79 De 60 a 69 Menor do que 60 Exemplo 4 A B C D F

ms-help://MS.EXCEL.12.1046/EXCEL/content/HP10069829.htm

10/03/2013

SE

Page 5 of 6

Neste exemplo, a funo PROC utilizada no lugar da funo SE, pois h treze condies para serem testadas e pode ser mais fcil para ler e manter. Talvez seja mais fcil de compreender o exemplo se voc copi-lo para uma planilha em branco. Como copiar um exemplo

1. 2.

Crie uma pasta de trabalho ou planilha em branco. Selecione o exemplo no tpico da Ajuda.
OBSERVAO

No selecione os cabealhos de linha ou de coluna.

Selecionando um exemplo na Ajuda

3. 4. 5.

Pressione CTRL+C. Na planilha, selecione a clula A1 e pressione CTRL+V. Para alternar entre exibir os resultados e exibir as frmulas que retornam os resultados, pressione CTRL+` (acento grave) ou, na guia Frmulas, no grupo Auditoria de Frmulas, clique no boto Mostrar Frmulas.

1 2 3 4

A Resultado 45 90 78 Frmula =PROC(A2,{0,60,63,67,70,73,77,80,83,87,90,93,97},{"F","D-","D","D+","C","C","C+","B-","B","B+","A-","A","A+"}) =PROC(A3,{0,60,63,67,70,73,77,80,83,87,90,93,97},{"F","D-","D","D+","C","C","C+","B-","B","B+","A-","A","A+"}) =PROC(A4,{0,60,63,67,70,73,77,80,83,87,90,93,97},{"F","D-","D","D+","C","C","C+","B-","B","B+","A-","A","A+"}) Descrio (resultado) Atribui uma letra ao primeiro resultado (F) Atribui uma letra ao segundo resultado (A-) Atribui uma letra ao terceiro resultado (C+)

Consulte tambm

Adicionar nmeros Calcular a mdia de um grupo de nmeros Contar com que freqncia um valor ocorre Contar valores nicos dentre duplicatas

ms-help://MS.EXCEL.12.1046/EXCEL/content/HP10069829.htm

10/03/2013

SE

Page 6 of 6

Criar frmulas condicionais Exibir ou ocultar valores nulos Funes lgicas PROC Verificar se um nmero maior ou menor que outro nmero Verificar se uma clula contm texto (no diferencia maisculas de minsculas)

ms-help://MS.EXCEL.12.1046/EXCEL/content/HP10069829.htm

10/03/2013

Você também pode gostar