Você está na página 1de 4

COMO CREAR UN JUEGO EN EXCEL Primer paso: elegir la temtica Es la base del juego.

La temtica puede estar relacionada con contenidos escolares, personajes de historieta, deportes, marcas, pelculas, automviles, grupos musicales, o cualquier otro tema que admita este tipo de dinmica. En la clase, podemos utilizarlo tambin como el cierre de un trabajo de investigacin. Segundo paso: seleccionar las imgenes Nuestro juego va a estar basado en la observacin de imgenes; por lo tanto, debemos almacenar en nuestro equipo todas las imgenes que puedan resultarnos de utilidad para el propsito. Es importante buscar imgenes de buena calidad y que no contengan texto que pueda orientar la respuesta. Si es necesario, podemos borrar partes de la imagen utilizando la herramienta Recortar (Herramientas de imagen/Tamao/Recortar) en Excel, o llevar la imagen a Paint o cualquier otro programa para editar imgenes, si necesitamos borrar o adaptar partes de la misma. Tercer paso: preparar el espacio de trabajo I 1. Abrir un nuevo libro de Excel 2. Como solo vamos a utilizar una sola hoja de este libro, eliminamos la Hoja2 y la Hoja3 (clic con el botn derecho del mouse sobre la etiqueta de la hoja, y en el men contextual elegimos Eliminar) 3. A partir de la fila 6, comenzamos a ubicar las imgenes (las primeras filas las utilizaremos para colocar los datos del juego, tales como el nombre y el contador de aciertos) 4. Para colocar las imgenes, vamos a Insertar/Ilustraciones/Imagen, y en la ventana Insertar imagen buscamos la primera imagen que vamos a colocar. 5. Repetimos el paso 4 con todas las imgenes que vamos a utilizar. 6. Es importante que todas las imgenes tengan el mismo tamao. Para ello, seleccionamos la imagen y podemos ajustar el tamao desde los controles de imagen o colocar las medidas especficas desde Herramientas de imagen/Tamao y colocar el ancho y el alto. 7. Ajustar el ancho de las columnas: para mejorar el aspecto visual de nuestro juego, ajustaremos el ancho de las columnas pares (B, D, F, etc.) al ancho de la imagen. A las columnas impares (A, C, E, etc.) les daremos un tamao menor, solo para provocar una separacin entre las imgenes. 8. Solo colocaremos imgenes tomando el ancho que se ve en pantalla, para evitar desplazamientos horizontales que puedan resultar molestos. Una vez que completamos la primera tanda de imgenes, dejamos 3 filas libres para comenzar a colocar la segunda tanda. Y as sucesivamente. Dependiendo del tamao que le hayamos dado a las imgenes, podemos utilizar 3 o 4 tandas. 9. Para mejorar el aspecto visual de nuestro juego, vamos a quitar las lneas de cuadrcula y aplicaremos un color de relleno a las celdas:

Para quitar la cuadrcula, vamos a Vista/Mostrar u ocultar, y desmarcamos la opcin Lneas de cuadrcula.

Para aplicar un color de relleno a todas las celdas, hacemos clic en el marcador entre la columna A y la fila 1

O presionamos Ctrl + E (seleccionaremos todas las celdas de la hoja de clculo), y luego vamos a Inicio/Fuente/Color de relleno, y seleccionamos el color de nuestra preferencia. Tambin podemos aplicar colores de relleno diferentes para el encabezado y para la seccin de las imgenes. Para ello, seleccionamos las filas a las que le vamos a aplicar un color haciendo clic con el mouse sobre el nmero de la primera fila que queremos seleccionar, y luego arrastramos hasta completar la seleccin, y aplicamos un color de relleno. Luego, seleccionamos el resto de las filas, y aplicamos otro color. 10. Vamos a quitarle el color a todas las celdas en las que los jugadores deben escribir las respuestas. Para ello, debemos seleccionar todas las celdas que se encuentran debajo de cada imagen. Para seleccionarlas en un solo paso, seleccionamos la primera, y hacemos clic con el mouse sobre cada una de las restantes, mientras mantenemos presionada la tecla Ctrl. Una vez realizada la seleccin, Vamos a Inicio/Fuente/Color de relleno, y elegimos Sin relleno. Cuarto paso: preparar el espacio de trabajo II 1. Como solo vamos a utilizar una parte de la hoja de clculo, no quedara prolijo que se vieran las celdas en las que no hemos hecho nada. Por lo tanto, vamos a ocultarlas. 2. Para ocultar las columnas que no utilizamos: seleccionamos la primera columna vaca haciendo clic con el mouse sobre la letra del encabezado, y luego presionamos Ctrl + Shift + flecha derecha. Luego, hacemos clic con el botn secundario del mouse sobre esta seleccin y desde el men contextual elegimos la opcin Ocultar. 3. Para ocultar las filas que no utilizamos: seleccionamos la primera fila vaca haciendo clic con el mouse sobre el nmero del encabezado, y luego presionamos Ctrl + Shift + flecha abajo. Luego, hacemos clic con el botn secundario del mouse sobre esta seleccin y desde el men contextual elegimos la opcin Ocultar. 4. ATENCIN: usamos Ocultar, y no Eliminar, porque tal vez necesitemos recuperar algunas filas o columnas para ajustar el aspecto de nuestro juego. 5. Vamos a dejar siempre visibles las filas del encabezado. Es decir que aunque nos desplacemos por la pantalla, siempre podamos leer los datos del encabezado. Para ello, seleccionamos la ltima fila que dejamos libre al principio (encima de las imgenes) y vamos a Vista/Inmovilizar paneles/Inmovilizar paneles. 6. Completaremos los datos del encabezado, colocando un ttulo para el juego, los nombres de los autores y un contador de aciertos. Podemos aplicarle los formatos que deseemos, para mejorar la esttica y la presentacin.

Quinto paso: programar el juego Programar las respuestas Debajo de la primera celda que dejamos en blanco para las respuestas, tenemos que escribir una funcin SI para las posibilidades. Recordemos que la funcin SI tiene 3 elementos en su argumento: =SI(CONDICIN; QU DEBE HACER SI SE CUMPLE; QU DEBE HACER SI NO SE CUMPLE) En este caso, la condicin es la palabra que debe aparecer en la celda en blanco; si se cumple esta condicin (es decir, si se escribi la palabra correcta), tenemos que provocar un mensaje de felicitacin; en caso contrario, debe aparecer un mensaje de error. Por ejemplo: =SI(B14=KEVINGSTON;BIEN!!!;UUPS!)

Debemos repetir esta operacin EN CADA UNA DE LAS CELDAS CORRESPONDIENTES A CADA IMAGEN. Programar el contador de aciertos Vamos al encabezado, y en la celda que dejamos disponible para el contador de aciertos vamos a utilizar una funcin CONTAR.SI. Por ejemplo: =CONTAR.SI(B14:J27;BIEN!!!)

Sexto paso: el toque final Vamos a proteger nuestra hoja de clculo para evitar que otro usuario pueda hacer modificaciones y solo se pueda escribir en las celdas en blanco, adems de ocultar el contenido de las celdas que tienen escritas las funciones. Para ello: 1. Seleccionamos todas las celdas de nuestra hoja de clculo y hacemos clic con el botn derecho del mouse sobre la seleccin. En el men contextual elegimos Formato de celdas, y en la solapa Proteger tildamos las opciones Bloqueada y Oculta. Hacemos clic en Aceptar. 2. Luego, seleccionamos solamente las celdas en blanco (recuerden utilizar la tecla Ctrl mientras hacen clic con el mouse sobre cada una de ellas). Hacemos clic con el botn derecho del mouse sobre esta seleccin y elegimos Formato de celdas; en la solapa Proteger, destildamos las opciones Bloqueada y Oculta. 3. Luego, vamos a la ficha Revisar y en el grupo Cambios hacemos clic en Proteger hoja (podemos agregar una contrasea para evitar que otro usuario quite la proteccin)

Listo! Ahora a jugar!