Você está na página 1de 5

fACULDADE Anhanguera educacioNAL | ATPS ALGORITMO E PROGRAMAO | | | | Sumrio 1 etapa 2 Passo 1 2 Passo 2 3 Passo 3 4 2 etapa 6 Passo 1 6 Bibliografia 12 1 etapa

Passo 1 * Pseudocdigo: |INICIO |real: cot_dolar, valor_dolar, valor_real; | |escreva("Sr usuario escreva o valor que deseja converter de dlar para real: "); |leia(valor_dolar); |escreva("Sr usuario escreva a cotao do dlar: "); |leia(cot_dolar); | |valor_real <- (valor_dolar*cot_dolar); | |escreva("O valor U$", valor_dolar, igual a R$,"valor_real") FIM. * Descrio narrativa: * * * * * * Pedir ao usurio que informe o valor que deseja converter; Guardar este valor; Pedir ao usurio que informe a cotao do valor a converter; Guardar este valor; Realizar a multiplicao do valor informado pela cotao; Informar o resultado ao usurio;

* Fluxograma Inicio ? Pedir ao usurio que informe o valor que deseja converter; ? Guardar este valor; ? Pedir ao usurio que informe a cotao do valor a converter; ? Guardar este valor; ? Realizar a multiplicao do valor informado pela cotao; ? Informar o resultado ao usurio; ? FIM Passo 2

* Pseudocdigo |Inicio | |real: valor_dolar, valor_reais, valor_euro, valor_dolarcan, cot_euro, cot_dolar can, cot_dolar; | |escreva("Sr usuario informe a quantia em reais que deseja converter, R$"); |leia(valor_reais); |escreva("Sr usuario informe a cotao do dolar canadense: "); |leia(cot_dolarcan); |valor_dolarcan <- (valor_reais*cot_dolarcan); |escreva("Sr usuario informe a cotao do dolar americano: "); |leia(cot_dolar); |valor_dolar <- (valor_reais*cot_dolar); |escreva("Sr usuario informe a cotao do euro: "); |leia(cot_euro); |valor_dolar <- (valor_reais*cot_euro); | |escreva("O valor R$", valor_reias,"convertido : Euro=", valor_euro, "dolar ameri cano="valor_dolar, "dolar canadense=", valor_dolarcan); | | FIM. * Fluxograma: Inicio ? Pedir ao usurio que informe quantia em reais que ele deseja converter; ? Guardar este valor; ? Perguntar ao usurio a cotao do dlar canadense; ? Guardar este valor; ? Calcular o valor em reais vezes a cotao; ? Perguntar ao usurio a cotao do dlar americano; ? Guardar este valor ? Calcular o valor em reais vezes a cotao; ? Perguntar ao usurio a cotao do euro; ? Guardar este valor ? Calcular o valor em reais vezes a cotao; ? Informar ao usurio o seu valor digitado convertido para cada moeda; ? FIM. Passo 3 |Inicio | |real: valor_reais, cot_euro, cot_dolarcan, cot_dolar, valor_convertido;

| |escreva("Sr usuario informe a quantia em reais que deseja converter, R$"); |leia(valor_reais); |escreva("Sr usuario informe a cotao do dolar canadense: "); |leia(cot_dolarcan); | |escreva("Sr usuario informe a cotao do dolar americano: "); |leia(cot_dolar); | |escreva("Sr usuario informe a cotao do euro: "); |leia(cot_euro); | |escreva("Sr usuario escreva para qual moeda deseja a converso: dolar americano=D , dolar canadense=C, euro=E "); |leia(moeda); | | se (moeda = C) | entao valor_convertido <- valor_reais*cot_dolarcan; | senao se (moeda = D) | entao valor_convertido <- valor_reais*cot_dolar; | senao valor_convertido <- valor_reais*cot_euro; | fimse; | fimse; |escreva("O valor converito :"), valor_converito; | |FIM. A estrutura de controle utilizada foi a do se, que uma estrutura de seleo utilizad o no caso para poder selecionar qual moeda o usurio deseja a converso, se ele digi tar a letra correspondente o prprio algoritmo direciona ele e faz a converso de ac ordo com o que ele desejar. 2 etapa Passo 1 |Inicio | |real: valor_converter, valor_convertido, cot_converter; |caracter: moeda_base, moeda_conversao; | |escreva("Sr usurio informe a moeda base, opes: Dlar Americano (D), Dlar Canadense (C ), Euro (E), Real (R)"); |leia(moeda_base); |escreva("Sr usurio informe a moeda para a qual deseja a converso, opes: Dlar America no (D), Dlar Canadense (C), Euro (E), Real (R)"); |leia(moeda_conversao); | escolha(moeda_base) | caso (D): se (moeda_conversao = c ) | entao | Inicio | esreva("Informe a cotao da moeda para a qual deseja a converso: "); | leia(cot_converter); | valor_convertido <- (valor_converter*cot_converter); | fim; | senao se (moeda_conversao = E ) | entao | Inicio | esreva("Informe a cotao da moeda para a qual deseja a converso: "); | leia(cot_converter); | valor_convertido <- (valor_converter*cot_converter);

| fim; | senao se (moeda_conversao = R ) | entao | Inicio | esreva("Informe a cotao da moeda para a qual deseja | leia(cot_converter); | valor_convertido <- (valor_converter*cot_converter); | fim; | senao escreva("Opo invlida!"); | fimse; | fimse; | fimse; | caso (C): se (moeda_conversao = D ) | entao | Inicio | esreva("Informe a cotao da moeda para a qual deseja | leia(cot_converter); | valor_convertido <- (valor_converter*cot_converter); | fim; | senao se (moeda_conversao = E ) | entao | Inicio | esreva("Informe a cotao da moeda para a qual deseja | leia(cot_converter); | valor_convertido <- (valor_converter*cot_converter); | fim; | senao se (moeda_conversao = R ) | entao | Inicio | esreva("Informe a cotao da moeda para a qual deseja | leia(cot_converter); | valor_convertido <- (valor_converter*cot_converter); | fim; | senao escreva("Opo invlida!"); | fimse; | fimse; | fimse; | caso (E): se (moeda_conversao = c ) | entao | Inicio | esreva("Informe a cotao da moeda para a qual deseja | leia(cot_converter); | valor_convertido <- (valor_converter*cot_converter); | fim; | senao se (moeda_conversao = D ) | entao | Inicio | esreva("Informe a cotao da moeda para a qual deseja | leia(cot_converter); | valor_convertido <- (valor_converter*cot_converter); | fim; | senao se (moeda_conversao = R ) | entao | Inicio | esreva("Informe a cotao da moeda para a qual deseja | leia(cot_converter); | valor_convertido <- (valor_converter*cot_converter); | fim; | senao escreva("Opo invlida!");

a converso: ");

a converso: ");

a converso: ");

a converso: ");

a converso: ");

a converso: ");

a converso: ");

| fimse; | fimse; | fimse; |caso (R): se (moeda_conversao = | entao

c )

| Inicio | esreva("Informe a cotao da moeda para a qual deseja a converso: "); | leia(cot_converter); | valor_convertido <- (valor_converter*cot_converter); | fim; | senao se (moeda_conversao = E ) | entao | Inicio | esreva("Informe a cotao da moeda para a qual deseja a converso: "); | leia(cot_converter); | valor_convertido <- (valor_converter*cot_converter); | fim; | senao se (moeda_conversao = D ) | entao | Inicio | esreva("Informe a cotao da moeda para a qual deseja a converso: "); | leia(cot_converter); | valor_convertido <- (valor_converter*cot_converter); | fim; | senao escreva("Opo invlida!"); | fimse; | fimse; | fimse; | | Caso contrrio: escreva("Opo invlida!"); | Fim escolha; | | escreva("O valor convertido : "), valor_convertido; | |FIM. Neste algoritmo foi utilizado um sistema de escolha que dentro de cada caso h um sistema de se que faz com que a moeda escolhida como moeda base possa ser conver tida para qualquer outra e assim existe um caso para cada uma das moedas, assim se o usurio digitar a letra correspondente a moeda base ele entra dentro do caso e l seleciona a moeda escolhida como moeda de converso e assim de acordo com o val or a ser convertido e a cotao da moeda escolhida o programa realiza a converso de q ualquer moeda, dentro das opes, para qualquer outra. Bibliografia * http://economia.uol.com.br/cotacoes * https://docs.google.com/a/aedu.com/viewer?a=v&pid=sites&srcid=YWVkdS5jb218am VmZmVyc29uc2NtfGd4OjQ2MjUwNzQ0MzJhMmM1NTI&pli=1