Você está na página 1de 7

1) Escreva um algoritmo que armazene o valor 10 em uma varivel A e o valor 20 em uma varivel B.

A seguir (utilizando apenas atribuies entre variveis) troque os seus contedos fazendo com que o valor que est em A passe para B e vice-versa. Ao final, escrever os valores que ficaram armazenados nas variveis. inicio A, B, AUX: numerico A <- 10 B <- 20 AUX <- 0 AUX <- A A <- B B <- AUX escreva "O valor de A : ", A, " e ", "O valor de B : ", B fim O valor de A : 20 e O valor de B : 10 2) Analise os algoritmos abaixo e diga o que ser impresso na tela ao serem executados: A-) A <- 10 B <- 20 Escrever B B <- 5 Escrever A,B 20 105 B-) A <- 30 B <- 20 C <- A + Escrever B <- 10 Escrever C <- A + Escrever

B C B,C B A,B,C

50 1050 301040 C-) A <- 10 B <- 20 C <- A B <- C A <- B Escrever A,B,C

101010 D-) A <- 10 B <- A + A <- B + B <- A + Escrever A <- B + 1 1 1 A 1

12 3) Escreva um algoritmo para ler um valor numrico (do teclado) e escrever (na tela) o seu antecessor. inicio NUM1, NUM2: numerico NUM1 <- 0 NUM2 <- 0 leia "Digite o nmero: ", NUM1 NUM2 <- NUM1 - 1 escreva "O nmero antecessor : ", NUM2 fim 4) Escreva um algoritmo para ler as dimenses de um retngulo (base e altura), calcular e escrever a rea do retngulo (base x Altura). inicio RETANGULO, BASE, ALTURA: numerico RETANGULO <- 0 BASE <- 0 ALTURA <- 0 leia "Digite a base do retngulo: ", BASE leia "Digite a altura do retngulo: ", ALTURA RETANGULO <- BASE*ALTURA escreva "A rea do retngulo : ", RETANGULO fim 5) Ler um valor e escrever a mensagem MAIOR QUE 10! se o valor lido for maior que 10, caso contrrio escrever NO MAIOR QUE 10! inicio NUMERO: numerico NUMERO <- 0 leia "Digite o nmero: ", NUMERO se NUMERO > 10 ento escreva " MAIOR QUE 10!" seno escreva "NO MAIOR QUE 10!" fim-se fim 6)Ler um valor e escrever se positivo ou negativo (considere o valor zero como positivo). inicio NUMERO: numerico NUMERO <- 0 leia "Digite o nmero: ", NUMERO se NUMERO >= 0 ento escreva "O nmero positivo" seno escreva "O nmero negativo" fim-se fim 7) Ler as notas da 1a. e 2a. avaliaes de um aluno. Calcular a mdia aritmtica simples e escrever uma mensagem que diga se o aluno foi ou no aprovado (considerar que nota igual ou maior que 6 o aluno aprovado). Escrever tambm a mdia calculada. inicio

MEDIA, NOTA1, NOTA2: numerico MEDIA <- 0 NOTA1 <- 0 NOTA <- 0 leia "Digite a primeira nota: ", NOTA1 leia "Digite a segunda nota: ", NOTA2 MEDIA <- (NOTA1 + NOTA2) /2 se MEDIA >= 6 ento escreva "Media do aluno: ", MEDIA, " APROVADO" seno escreva "Media do aluno: ", MEDIA, " REPROVADO" fim-se fim 8)Ler o nome de 2 times e o nmero de gols marcados na partida (para cada time). Escrever o nome do vencedor. Caso no haja vencedor dever ser impressa a palavra EMPATE. inicio TIME1, TIME2: alfanumerico GOL1, GOL2: numerico TIME1 <- " " TIME2 <- " " GOL1 <- 0 GOL2 <- 0 leia "Digite o nome do primeiro time: ", TIME1 leia "Digite o nmero de gol do primeiro time: ", GOL1 leia "Digite o nome do segundo time: ", TIME2 leia "Digite o nmero de gols do segundo time: ", GOL2 se GOL1 = GOL2 ento escrever "EMPATE ", TIME1, " ", GOL1, " x ", GOL2, " ", TIME2 seno se GOL1 > GOL2 ento escreva "Time vencedor: ", TIME1 seno escreva "Time vencedor: ", TIME2 fim-se fim-se fim 9)Seja o seguinte algoritmo: inicio leia leia z <se Z seno se z <= 100 ento resposta <- "B" seno resposta <- "C" fim-se fim-se escrever z, reposta fim Faa o teste de mesa e complete o quadro a seguir para os seguintes valores: X Y Z Resposta x y (x*y) + 5 <= 0 ento resposta <- "A"

3 150 7 -2 50

2 3 -1 5 3

11 455 -2 -5 155

B C A A C

10) Escreva um algoritmo para ler 2 valores e se o segundo valor informado for ZERO, deve ser lido um novo valor, ou seja, para o segundo valor no pode ser aceito o valor zero e imprimir o resultado da diviso do primeiro valor lido pelo segundo valor lido. (utilizar a estrutura REPITA). inicio RESULTADO, NUM1, NUM2: numerico leia "Digite o primeiro nmero: ", NUM1 repita leia "Digite o segundo nmero: ", NUM2 at que NUM2 <> 0 RESULTADO <- NUM1 / NUM2 escreva "O resultado dos valores so: ", RESULTADO fim 11) Reescreva o exerccio anterior utilizando a estrutura ENQUANTO. Inicio RESULTADO, NUM1, NUM2: numerico leia "Digite o primeiro nmero: ", NUM1 NUM2 <- 0 enquanto NUM2 = 0 faa leia "Digite o segundo nmero: ", NUM2 fim-enquanto RESULTADO <- NUM1 / NUM2 escreva "O resultado dos valores so: ", RESULTADO fim 12) Ler um valor N e imprimir todos os valores inteiros entre 1 (inclusive) e N (inclusive). Considere que o N ser sempre maior que ZERO. (usando para) inicio NUM1,NUM2,CONTROLE: numerico NUM1 <- 1 NUM2 <- 0 leia "Digite o nmero: ", NUM2 enquanto NUM2 < 1 {extra ao exercicio - para validar o numero digitado} ento leia "Numero invalido - Digite o nmero novamente: ", NUM2 fim-enquanto para CONTROLE de 1 at 100 passo 1 faa escreva NUM2, " - " fim-para fim 13)Escreva um algoritmo que calcule e imprima a tabuada do 8 (1 a 10). (usando para) inicio CONTROLE, NUMERO: numerico

NUMERO <- 8 para CONTROLE de 1 at 10 passo 1 faa escreva CONTROLE*NUMERO, " - " fim-para fim 14)Escreva um algoritmo para ler 10 nmeros e ao final da leitura escrever a soma total dos 10 nmeros lidos. inicio CONTROLE, SOMA: numerico NUMERO: vetor [1..10] numerico SOMA <- 0 para CONTROLE de 1 at 10 passo 1 faa leia "Digite o nmero: ", NUMERO[CONTROLE] SOMA <- SOMA + NUMERO[CONTROLE] fim-para escreva "O valor total de todos os nmeros so: ", SOMA fim 15)Uma loja est levantando o valor total de todas as mercadorias em estoque. Escreva um algoritmo que permita a entrada das seguintes informaes: a) o nmero total de mercadorias no estoque; b) o valor de cada mercadoria. Ao final imprimir o valor total em estoque e a mdia de valor das mercadorias. inicio CONTROLE,VALOR,VALOR_TOTAL,QUANTIDADE,MEDIA: numerico QUANTIDADE <- 0 VALOR_TOTAL <- 0 VALOR <- 0 CONTROLE <- 0 leia "Quantidade de produtos no estoque: ", QUANTIDADE enquanto CONTROLE <= QUANTIDADE faa CONTROLE <- CONTROLE +1 leia "Digite o valor: ", VALOR VALOR_TOTAL <- VALOR_TOTAL + VALOR fim-enquanto MEDIA <- VALOR_TOTAL / QUANTIDADE escreva "Valor total em estoque: ", VALOR_TOTAL, " Valor mdio em estoque: ", MEDIA fim 16) Escreva um algoritmo que permita a leitura dos nomes de 10 pessoas e armaze os nomes lidos em um vetor. Aps isto, o algoritmo deve permitir a leitura de mais 1 nome qualquer de pessoa e depois escrever a mensagem ACHEI, se o nome estiver entre os 10 nomes lidos anteriormente (guardados no vetor), ou NO ACHEI caso contrrio. inicio CONTROLE: numerico NOME: alfanumerico AUX_ACHEI: alfanumrico AUX_ACHEI <- "NO achei" NOMES: vetor [1..10] alfanumerico para CONTROLE de 1 at 10 passo 1 faa leia "Digite o nome: ", NOMES[CONTROLE] fim-para

leia "Digite o nome para verificar se existe: ", NOME para CONTROLE de 1 at 10 passo 1 faa se NOME = NOMES[CONTROLE] AUX_ACHEI <- "ACHEI" fim-se fim-para escreva AUX_ACHEI fim 17)Escreva um algoritmo que permita a leitura das notas de uma turma de 20 alunos. Calcular a mdia da turma e contar quantos alunos obtiveram nota acima desta mdia calculada. Escrever a mdia da turma e o resultado da contagem. inicio CONTROLE,MEDIA,ACIMA_MEDIA: numerico NOTA: vetor [1..20] numerico ACIMA_MEDIA <- 0 para CONTROLE de 1 at 20 passo 1 faa leia "Digite a nota: ", NOTA[CONTROLE] MEDIA <- MEDIA + NOTA[CONTROLE] fim-para MEDIA <- MEDIA / 20 {calcula a media da turma} para CONTROLE de 1 at 20 passo 1 faa se NOTA[CONTROLE] > MEDIA ento ACIMA_MEDIA <- ACIMA_MEDIA + 1 fim-se fim-para escreva "Mdia da turma: ", MEDIA, "Quantidade de notas acima da mdia: ", ACIMA_MEDIA fim 18) Exerccios da pgina 267 do livro. 1) Cadastrar os dados pessoais de 50 professores: nome, endereo, cidade, UF, CEP, telefone, CPF, RG, data de nascimento, grau de escolaridade, curso em que se formou. Ler dez nomes e mostrar RG e CPF de cada pessoa. inicio tipo DADOS = registro NOME,RUA,BAIRRO,CIDADE,UF,GRAU_ESC,CURSO_FORMADO: alfanumerico NUMERO,CPF,RG,DATA_NASC,TELEFONE: numerico fim-registro CONTROLE,CONTROLE2: numerico NOME_PROCURAR: alfanumerico PROFESSOR: vetor [1..60] DADOS para CONTROLE de 1 at 50 passo 10 faa leia "Nome: ", PROFESSOR[CONTROLE].NOME leia "Rua: ", PROFESSOR[CONTROLE].RUA leia "N: ", PROFESSOR[CONTROLE].NUMERO leia "Bairro: ", PROFESSOR[CONTROLE].BAIRRO leia "Cidade: ", PROFESSOR[CONTROLE].CIDADE leia "UF: ", PROFESSOR[CONTROLE].UF leia "CEP: ", PROFESSOR[CONTROLE].CEP leia "Telefone: ", PROFESSOR[CONTROLE].TELEFONE leia "RG: ", PROFESSOR[CONTROLE].RG leia "CPF: ', PROFESSOR[CONTROLE].CPF

leia "Data de nascimento: ", PROFESSOR[CONTROLE].DATA_NASC leia "Grau de escolaridade: ", PROFESSOR[CONTROLE].GRAU_ESC leia "Curso formado: ", PROFESSOR[CONTROLE].CURSO_FORMADO fim-para para CONTROLE de 1 at 10 passo 1 faa leia "Nome: ', NOME_PROCURAR para CONTROLE2 de 1 at 50 passo 10 faa se NOME_PROCURAR = PROFESSOR[CONTROLE2].NOME escreva "RG: ", PROFESSOR[CONTROLE2].RG escreva "CPF: ", PROFESSOR[CONTROLE2].CPF fim-se fim-para fim-para fim