Você está na página 1de 13

COMANDO DE REPETIO

1. Fazer um algoritmo para imprimir os nmeros inteiros de 1 at 100.

Portugol
algoritmo "exercicio01" // Funo : // Autor : // Data : 11/09/2012 // Seo de Declaraes var i: inteiro inicio i<-1 Enquanto (i<=100) faca Escreval(i) i<-i+1 fimenquanto fimalgoritmo

C++
#include <cstdlib> #include <iostream> using namespace std; int main(int argc, char *argv[]) { int i; i==1; while (i<=100) { cout<<i<<endl; i=i+1; } system("PAUSE"); return EXIT_SUCCESS; }

2. Fazer um algoritmo para somar os nmeros inteiros de 1 at 100. Imprimir o resultado.

Portugol
algoritmo "exercicio02" // Funo : // Autor : // Data : 11/09/2012 // Seo de Declaraes var i,ac:inteiro inicio i<-1 ac<-1 Enquanto (i<100)faca i<-i+1 ac<-i+ac Fimenquanto Escreval("O valor da soma e ",ac) fimalgoritmo

C++
#include <cstdlib> #include <iostream> using namespace std; int main(int argc, char *argv[]) { int i,ac; i==1; ac==1; while (i<100) { i=i+1; ac=i+ac; } cout<<"O valor da soma e "<<ac<< " "<<endl; system("PAUSE"); return EXIT_SUCCESS; }

3. Fazer um algoritmo que imprime os valores pares de 1 at 100.

Portugol
algoritmo "exercicio03" // Funo : // Autor : // Data : 11/09/2012 // Seo de Declaraes var i:Inteiro inicio i<-2 Enquanto (i<=100) faca Escreval(i) i<-i+2 fimenquanto fimalgoritmo

C++
#include <cstdlib> #include <iostream> using namespace std; int main(int argc, char *argv[]) { int i; i==2; while (i<=100) { cout<<i<<endl; i=i+2; } system("PAUSE"); return EXIT_SUCCESS; }

4. Fazer um algoritmo que imprime os valores impares de 1 at 100.

Portugol
algoritmo "exercicio04" // Funo : // Autor : // Data : 11/09/2012 // Seo de Declaraes var i:Inteiro inicio i<-1 Enquanto (i<=100) faca Escreval(i) i<-i+2 fimenquanto fimalgoritmo

C++
#include <cstdlib> #include <iostream> using namespace std; int main(int argc, char *argv[]) { int i; i==1; while (i<=100) { cout<<i<<endl; i=i+2; } system("PAUSE"); return EXIT_SUCCESS; }

5. Fazer um algoritmo que imprime cada valor inteiro de 1 at 100 indicando se o valor par ou impar.

Portugol
algoritmo "exercicio05" // Funo : // Autor : // Data : 11/09/2012 // Seo de Declaraes var i,ac:inteiro inicio i<-1 ac<-2 Enquanto (i<=100) e (ac<=100) faca Escreval(i) Escreval("Valor Impar") Escreval(ac) Escreval("Valor Par") i<-i+2 ac<-ac+2 fimenquanto fimalgoritmo

C++
#include <cstdlib> #include <iostream> using namespace std; int main(int argc, char *argv[]) { int a,b; a==1; b==2; while (a<=100) { cout<<a<<endl; cout<<"Valor Impar"<<endl; cout<<b<<endl; cout<<"Valor Par"<<endl; a=a+2; b=b+2; } system("PAUSE"); return EXIT_SUCCESS;

}
6. Fazer um algoritmo que some os valores pares e imprima os impares entre um e 100.

Portugol
algoritmo "exercicio06" // Funo : // Autor : // Data : 11/09/2012 // Seo de Declaraes var p,i,ac:inteiro inicio i<-1 p<-2 ac<-0 Enquanto (i<=100) e (p<=100) faca Escreval(i) i<-i+2 p<-p+2 ac<-p+ac fimenquanto Escreval("O valor da soma dos pares e ",ac) fimalgoritmo

C++
#include <cstdlib> #include <iostream> using namespace std; int main(int argc, char *argv[]) { int p,i,ac; i==1; p==2; ac==0; while (i<=100) { cout<<i<<endl; i=i+2; p=p+2; ac=p+ac; } cout<<"O valor da soma dos pares e "<<ac<<endl; system("PAUSE"); return EXIT_SUCCESS;

7. Faa um algoritmo que possibilite ao usurio digitar uma sequncia qualquer de nmeros reais positivos quando o usurio digitar um valor negativo imprima o maior e o menor valor da sequncia e termine o programa.

Portugol
algoritmo "exercicio07 " // Funo : // Autor : // Data : 20/09/2012 var valor,maior,menor: inteiro inicio escreval("informe um valor positivo->") leia(valor) maior <- valor menor <- valor enquanto (valor>0) faca se (valor>maior) entao maior <- valor fimse se (valor<menor) entao menor <- valor fimse escreval("informe um valor positivo->") leia (valor) fimenquanto fimalgoritmo

C++
#include <cstdlib> #include <iostream> using namespace std; int main(int argc, char *argv[]) { float a,ma,me; cout<<"Informe um valor-> "<<endl; cin>>a; ma==a; me==a; while (a>0) { cout<<"informe outro valor-> "<<endl; if (a>ma) { ma=a; } if (a<me) { me=a; } cin>>a; } cout<<"O maior valor e-> "<<ma<<" "<<endl; cout<<"O menor valor e-> "<<me<<" "<<endl; system("PAUSE"); return EXIT_SUCCESS; }

8. Faa um algoritmo que calcule X elevado a Y se utilizar o operador de potencia. Voc deve utilizar um comando de repetio.

Portugol
algoritmo "exercicio08" var x,y,i,ac :inteiro inicio escreval("indique um valor ->") leia(x) escreval("indique outro valor ->") leia(y) i<- 1 ac <- 1 enquanto (i <= y) faca ac <- ac*x i <- i+1 fimenquanto escreval ("o resultado e ", ac) fimalgoritmo

C++
#include <cstdlib> #include <iostream> using namespace std; int main(int argc, char *argv[]) { int x,y,i,ac; cout<<"indique um valor ->"<<endl; cin>>x; cout<<"indique outro valor ->"<<endl; cin>>y; i==1; ac==1; while (i <= y) { ac = ac*x; i = i+1; } cout<<"o resultado e "<<ac<<endl; system("PAUSE"); return EXIT_SUCCESS; }

9. Fazer um algoritmo que imprima um menu com 5 opes: 1 soma, 2 subtrai, 3 multiplica, 4 divide e 5 sair. Quando a opo escolhida for operao aritmtica pea dois valores e realize a operao. Caso o usurio escolha a opo sair termine o programa. Ao terminar o programa avise o usurio que o programa acabou.

Portugol
algoritmo "exercicio09" // Funo : // Autor : // Data : 12/09/2012 // Seo de Declaraes var op,n1,n2,r:Real i:inteiro inicio i<-0 Escreval("Escreva 1-Soma,2-Subtrair,3Mutiplicar,4-Divisao,5-Sair") Leia(op) Enquanto (op<5) e (i<=0) faca Escreval("Informe um valor-> ") Leia(n1) Escreval("Informe outra valor -> ") Leia(n2) Enquanto (op=1) e (i<=0) faca i<-i+1 r<-n1+n2 Escreval("O resultado e-> ",r) fimenquanto Enquanto (op=2) e (i<=0) faca i<-i+1 r<-n1-n2 Escreval("O resultado e-> ",r) fimenquanto Enquanto (op=3) e (i<=0) faca i<-i+1 r<-n1*n2 Escreval("O resultado e-> ",r) fimenquanto Enquanto (op=4) e (i<=0) faca i<-i+1 r<-n1/n2 Escreval("O resultado e-> ",r) fimenquanto fimenquanto Enquanto (op=5) e (i<=0) faca i<-i+1 Escreval("Programa acabou") fimenquanto fimalgoritmo

C++
#include <cstdlib> #include <iostream> using namespace std; int main(int argc, char *argv[]) { //algoritmo "exercicio09" // Funo : // Autor : // Data : 12/09/2012 float op,n1,n2,r; int i; i==0; cout<<"Escreva 1-Soma,2-Subtrair,3Mutiplicar,4-Divisao,5-Sair"<<endl; cin>>op; while ((op<5) && (i<=0)) { cout<<"Informe um valor-> "<<endl; cin>>n1; cout<<"Informe outra valor -> "<<endl; cin>>n2; } while ((op=1) && (i<=0)) { i=i+1; r=n1+n2; cout<<"O resultado e-> "<<r<<endl; } while ((op=2) && (i<=0)) { i=i+1; r=n1-n2; cout<<"O resultado e-> "<<r<<endl; } while ((op=3) && (i<=0)) { i=i+1; r=n1*n2; cout<<"O resultado e-> "<<r<<endl; }

while ((op=4) && (i<=0)) { i=i+1; r=n1/n2; cout<<"O resultado e-> "<<r<<endl; } while ((op=5) && (i<=0)) { i=i+1; cout<<"Programa acabou"<<endl; } system("PAUSE"); return EXIT_SUCCESS; }

10. Calcule a soma de dois valores. A operao s pode ser realizada se ambos os valores forem positivos.

Portugol
algoritmo "exercicio10" // Funo : // Autor : // Data : 12/09/2012 // Seo de Declaraes var n1,n2,r:real i:inteiro inicio i<-0 Escreval("Informe um valor -> ") Leia(n1) Escreval("Informe outro valor -> ") Leia(n2) Enquanto (n1>0) e (n2>0) e (i<=0) faca i<-i+1 r<-n1+n2 Escreval("O valor da soma e-> ",r) fimenquanto fimalgoritmo

C++
#include <cstdlib> #include <iostream> using namespace std; int main(int argc, char *argv[]) { float n1,n2,r,i; i==0; cout<<"Informe um valor"<<endl; cin>>n1; cout<<"Informe outro valor"<<endl; cin>>n2; while ((n1>0) && (n2>0) && (i<=0)) { i=i+1; r=n1+n2; cout<<"o valor da soma e-> " <<r<<endl; } system("PAUSE"); return EXIT_SUCCESS; }

11. Leia um valor inteiro. Leia o outro valor inteiro e s aceite este novo valor se for maior que o anterior caso contrrio leia outro valor novamente.

Portugol
algoritmo "exercicio11" // Funo : // Autor : // Data : 18/09/2012 // Seo de Declaraes var n1,n2:inteiro inicio Escreval("Informe um valor-> ") Leia(n1) Escreval("Informe outro valor-> ") Leia(n2) Enquanto (n1>n2) faca Escreval("Informe outro valor-> ") Leia(n2) fimenquanto fimalgoritmo

C++
#include <cstdlib> #include <iostream> using namespace std; int main(int argc, char *argv[]) { int n1,n2; cout<<"Informe um valor-> "<<endl; cin>>n1; cout<<"Informe outro valor-> "<<endl; cin>>n2; while (n1>n2) { cout<<"Informe outro valor -> "<<endl; cin>>n2; } system("PAUSE"); return EXIT_SUCCESS; }

12. Leia dois valores inteiros e imprima a soma dos valores pares e o produto dos valores mpares entre eles. Voc deve aceitar a situao onde o primeiro valor maior que o segundo e vice-versa. Nas operaes de soma e multiplicao no devem ser considerados os valores lido pela operao envolver apenas valores entre eles.

Portugol
Algoritmo "exercicio12" var n1,n2,maior,menor,menorpar, menorimpar,acpar,acimpar:inteiro inicio escreval("digite um valor inteiro: ") leia(n1) escreval("digite outro valor inteiro: ") leia(n2) enquanto n1=n2 faca escreval("Digite valores diferentes") escreval("digite um valor inteiro: ") leia(n1) escreval("digite outro valor inteiro: ") leia(n2) fimenquanto se (n1 > n2) entao maior<-n1 menor <-n2 senao maior<-n2 menor<-n1 fimse se ((menor mod 2)=0) entao //par menorpar <- (menor+2) menorimpar <- (menor+1) senao menorpar <- (menor+1) menorimpar <- (menor+2) fimse acpar<-0//soma enquanto menorpar<maior faca acpar<-acpar+menorpar menorpar<-menorpar+2 fimenquanto acimpar<-1//mult enquanto menorimpar<maior faca acimpar<-acimpar*menorimpar menorimpar<-menorimpar+2 fimenquanto Escreval("A soma dos nmeros pares do intervalo ->",acpar) Escreval("O produto dos nmeros impares do intervalo ->",acimpar) Fimalgoritmo

C++
#include <cstdlib> #include <iostream> using namespace std; int main(int argc, char *argv[]) { int n1,n2,maior,menor,menorpar,menorimpar,ac par,acimpar; cout<<"digite um valor inteiro: "<<endl; cin>>n1; cout<<"digite outro valor inteiro: "<<endl; cin>>n2; while(n1=n2) { cout<<"Digite valores diferentes"<<endl; cout<<"digite um valor inteiro: "<<endl; cin>>n1; cout<<"digite outro valor inteiro: "<<endl; cin>>n2; } if (n1 > n2) { maior=n1; menor=n2; } if (n1 < n2) { maior=n2; menor=n1; } if ((menor % 2)==0) { menorpar =(menor+2); menorimpar =(menor+1); } if ((menor % 2)!=0) { menorpar =(menor+1); menorimpar = (menor+2); } acpar==0; while (menorpar<maior) { acpar=(acpar+menorpar); menorpar=(menorpar+2);

} acimpar==1; while (menorimpar<maior) { acimpar=(acimpar*menorimpar); menorimpar=(menorimpar+2); } cout<<"A soma dos numeros pares do intervalo eh->"<<acpar<<endl; cout<<"O produto dos numeros impares do intervalo eh->"<<acimpar<<endl; system("PAUSE"); return EXIT_SUCCESS; } 13. Calcule a soma de dois valores utilizando apenas o operador de soma com a unidade 1.

Portugol
algoritmo "exercicio13" var a,b:real inicio escreval("indique um valor para a ->") leia(a) escreval("indique um valor para b -> ") leia(b) enquanto (b<>0) faca a <- a-1 b <- b-1 fimenquanto escreval("A soma dos valores e ", a) fimalgoritmo

C++
#include <cstdlib> #include <iostream> using namespace std; int main(int argc, char *argv[]) { float a,b; cout <<"Informe um valor a ser somado."<<endl; cin>>a; cout<<"Informe outro valor a ser somado."<<endl; cin>>b; while (b!=0) { a=a+1; b=b-1; } cout<<"O resultado da soma e."<<a<<endl; system("PAUSE"); return EXIT_SUCCESS; }

14. Calcule a diferena de dois valores utilizando apenas o operador de soma com a unidade 1.

Portugol
Algoritmo "exercicio14" var a,b:real inicio escreval("informe um valor para a ->") leia(a) escreval("informe um valor para b -> ") leia(b) enquanto (b<>0) faca a <- a-1 b <- b-1 fimenquanto escreval("A soma eh ", a) fimalgoritmo

C++
#include <cstdlib> #include <iostream> using namespace std; int main(int argc, char *argv[]) { float a,b; cout<<"Informe um valor a ser subtraido."<<endl; cin>>a; cout<<"Informe outro valor a ser subtraido."<<endl; cin>>b; while(b!=0) { a=a-1; b=b-1; } cout<<"O resultado da soma e:"<<a<<endl; system("PAUSE"); return EXIT_SUCCESS; }

15. Faa uma algoritmo para calcular o fatorial de um valor n inteiro qualquer. Fatorial de 1 = 1 = 1 Fatorial de 2 = 1x2 = 2 Fatorial de 3 = 1x2x3 = 6 Fatorial de 4 = 1x2x3x4 = 24 Fatorial de 5 = 1x2x3x4x5 = 120

Portugol
algoritmo "Fatorao" // Funo : // Autor : // Data : 20/09/2012 // Seo de Declaraes var a,res: real inicio // Seo de Comandos escreval("Informe um numero a ser fatorado:") leia(a) res<-1 enquanto (a>1) faca res<- res*a

C++
#include <cstdlib> #include <iostream> using namespace std; int main(int argc, char *argv[]) { //var float x,y,a; //inicio { cout<<"Informe o valor de y->"; } cin>>y; x=1;

a<-a-1 fimenquanto escreval("O resultado eh:",res) fimalgoritmo

while (y>0) cout<<"Informe o valor de x(informe repetitivas vezes):"; cin>>x; { x=x*a; } { y=y-1; } cout<<"x elevado a y e:"<<x; system("PAUSE"); return EXIT_SUCCESS; } ..

16. Faa um algoritmo que receba um valor inteiro positivo e calcule o termo da serie de Fibonacci equiavalente. 11 5 _5 21 6 _8 32 7_13 43

Portugol
Algoritmo "fibonacci" var entrada,termo,anterior,posicao:REAL inicio // Seo de Comandos escreval("Digite um valor inteiro positivo>:" ) leia (entrada) enquanto (entrada<=0) faca escreva("Digite um valor inteiro positivo maior que 0->") leia(entrada) fimenquanto anterior<-0 termo<-1 posicao <-1 enquanto (entrada <> posicao) faca termo<- anterior+termo anterior <- termo-anterior posicao <- posicao+1 fimenquanto escreval("o termo de",entrada," na sequencia de fibonacci :",termo) fimalgoritmo

C++
#include <cstdlib> #include <iostream> using namespace std; int main(int argc, char *argv[]) { float entrada,termo,anterior,posicao; cout<<"Digite um valor inteiro positivo>:"<<endl; cin>>(entrada); while (entrada<=0) { cout<<"Digite um valor inteiro positivo maior que 0->"; cin>>(entrada); } anterior=0; termo=1; posicao=1; while(entrada != posicao) { termo=(anterior+termo); anterior=(termo-anterior); posicao=(posicao+1); } cout<<"o termo de"<<entrada<<" na sequencia de fibonacci eh>"<<termo<<endl; system("PAUSE"); return EXIT_SUCCESS; }