Você está na página 1de 4

Exerccios de Lgica de Programao Portugol

1) Escreva um algoritmo para imprimir os nmeros de 1 (inclusive) a 10 (inclusive) em ordem crescente.


Programa EX01 var num, inicio num = 1 enquanto num <= 10 faca escreva (num) num = num + 1 fimenquanto fim

2) Escreva um algoritmo para imprimir os nmeros de 1 (inclusive) a 10 (inclusive) em ordem decrescente.


Programa var inicio num = 10 enquanto num >= 1 faca escreva (num) num = num - 1 fimenquanto fim Ex02 num;

3) Escreva um algoritmo para imprimir os 10 primeiros nmeros inteiros maiores que 100.
Programa EX03 var num,cont; inicio (num) <= 101 (cont) = 1 enquanto (num) <= 110 faca escreva (num) (num) = cont + num fimenquanto fim

4) Ler um valor N e imprimir todos os valores inteiros entre 1 (inclusive) e N (inclusive). Considere que o N ser sempre maior que ZERO.
Programa EX04 var n1,n2; inicio (n2) = 1 escreva ("Entre um N: ") Leia (n1) enquanto (n2) < = (n1) faca escreval (n2) (n2) = (n2) + 1 fimenquanto fim

5) Modifique o exerccio anterior para aceitar somente valores maiores que 0 para N. Caso o valor informado (para N) no seja maior que 0, dever ser lido um novo valor para N.
Programa EX05 var n1,n2; inicio (n2) = 1 escreva ("Entre um N: ") Leia (n1) enquanto (n2) < = (n1) faca escreva (n2) (n2) = (n2) + 1 fimenquanto se (n1) < = 0 entao escreva ("Entre um N valido: ") leia (n1) repita escreva ("Entre um N valido: ") leia (n1) enquanto (n2) < = (n1) faca escreva (n2) (n2) = (n2) + 1 fimenquanto ate (n1) > 0 Fimse fim

6) Escreva um algoritmo que calcule e imprima a tabuada a partir de um numero inserido pelo usurio.
Programa EX06 var n,cont; inicio cont = 0 escreva ("Entre um N: ") Leia (n) enquanto cont < = 9 faca cont = cont + 1 escreva (cont * n) fimenquanto fim

7) Escreva um algoritmo para ler 2 valores e se o segundo valor informado for ZERO, deve ser lido um novo valor, ou seja, para o segundo valor no pode ser aceito o valor zero e imprimir o resultado da diviso do primeiro valor lido pelo segundo valor lido. (utilizar a estrutura REPITA).
Programa EX07 var n1,n2; inicio escreva ("Entre o primeiro N: ") Leia (n1) escreva ("Entre o segundo N: ") Leia (n2) se (n2) = 0 entao escreva ("Entre um segundo N vlido: ") leia (n2) repita escreva ("Entre um segundo N vlido: ") leia (n2) ate (n2) > 0 fimse escreva ("o resultado da diviso do primeiro pelo segundo N : ", n1 / n2) fimrepita fim

8) Reescreva o exerccio anterior utilizando a estrutura ENQUANTO.


Programa EX08 var n1,n2; inicio escreva ("Entre o primeiro N: ") Leia (n1) escreva ("Entre o segundo N: ") Leia (n2) se n2 = 0 entao escreva ("Entre um segundo N vlido: ") leia (n2) enquanto (n2) = 0 faca escreva ("Entre um segundo N vlido: ") leia (n2) fimenquanto fimse escreva ("o resultado da diviso do primeiro pelo segundo N : ", n1 / n2) fim

9) Acrescentar uma mensagem de 'VALOR INVLIDO' no exerccio [6] caso o segundo valor informado seja ZERO.
Programa EX09 var n, contador; inicio (contador) = 0 escreva ("Entre um N: ") Leia (n) se (n) > 0 entao enquanto (contador) < = 9 faca (contador) = (contador) + 1 escreva (contador * n) fimenquanto senao escreva ("Valor Invlido") fimse fim

10) Acrescentar uma mensagem de 'VALOR INVLIDO' no exerccio [2] caso o segundo valor informado seja ZERO.
Programa EX10 var n1,n2; inicio escreva ("Entre o primeiro N: ") Leia (n1) escreva ("Entre o segundo N: ") Leia (n2) se (n2) > 0 entao escreva ("o resultado da diviso do primeiro pelo segundo N : ", n1 / n2) senao escreva ("Valor invlido! ") fimse fim

11) Escreva um algoritmo para ler as notas da 1a. e 2a. avaliaes de um aluno, calcule e imprima a mdia (simples) desse aluno. S devem ser aceitos valores vlidos durante a leitura (0 a 10) para cada nota.
Programa EX11 var nota1,nota2,media; inicio repita escreva ("Entre a 1 Nota: ") leia (nota1) ate((nota1 > = 0) e (nota1 < = 10)) repita escreva ("Entre a 2 Nota: ") leia (nota2) ate((nota2 > = 0) e (nota2 < = 10)) (media) = (nota1 + nota2)/2 Escreva ("A mdia : ", (media)) fim