Você está na página 1de 5

05/03/2010

Tipos Primitivos de Informao


Informao a matria-prima que faz com que seja necessria a existncia de computadores, pois eles so capazes de manipular e armazenar um grande volume de dados com alta performance, liberando o homen para outras tarefas nas quais seu conhecimento indispensvel. Informao: Franklin Misael Pacheco Tena, DSc. Lab. de Modelagem Ambiental Sala 140 Bloco 20
Numrica, Caractere, Lgico.

Tipos Primitivos de Informao


CONSTANTES
Uma informao constante quando no sofre nenhuma variao no decorrer do tempo.

Formao de Identificadores
Regras de formao
Devem comear por um caractere alfabtico; Podem ser seguidos por mais caracteres alfabticos e/ou numricos; 3. No permitido o uso de caracteres especiais. 4. Os caracteres alfabticos devem ser obrigatoriamente ser escritos em maisculo.
1. 2.

VARIVEL
Uma informao classificada de varivel quando tem a possibilidade de ser alterada em algum instante no decorrer do tempo.

Declarao de Variveis
No ambiente computacional, as informaes variveis so guardadas em dispositivos eletrnicos analogamente chamados de memoria. Podemos imaginar essa memoria como sendo um armrio repleto de gavetas, no qual as gavetas seriam os locais fsicos responsveis por armazenar objetos; os objetos (que podem ser substitudos) seriam as informaes e as gavetas, as variveis. Visto que na memria (armrio) existem inmeras variveis (gavetas), precisamos diferenci-las, o que feito por meio de identificadores (etiquetas). Cada varivel (gaveta), no entanto, pode guardar apenas uma informao (objet0) de cada vez, sendo sempre do mesmo tipo (material).

Declarao de Variveis
Exemplos: Dada a declarao de variveis
Inteiro: X; Real: ABC, XPTO, PESO, DOLAR; Caractere: NOME, RUA, DATA; Lgico: RESPOSTA, H286;

RESPOSTA o nome de local de memria que s pode conter valores de tipo lgico, ou seja por conveno, verdadeiro ou falso. X o nome de um local de memria que s pode conter valores de tipo inteiro, qualquer um deles.

05/03/2010

Exerccios de fixao
1.

Exerccios de fixao
2. Supondo que as variveis NB, NA, NMAT, SX sejam

Assinale os identificadores vlidos


a) b) c) d) e)

(X) U2 AH! ALUNO #55

UYT AB*C h) O&O i) P{O} j) B52


f) g)

utilizadas para armazanar a nota do aluno, o nome do aluno, o nmero de matricula e o sexo, declare-as corretamente.

Expresses Aritmticas
Denominamos expresso aritmtica aquela cujos operadores so aritmeticos e cujos operandos so constantes e/ou variveis do tipo numrico (interio e/ou real). Operadores Aritmticos
Adio (+) Substrao (-) Multiplicao (*) Diviso (/)

Exemplos
2+3 7*4 3.2 * 9 5.0 / 2.0 11 / 2 2-9 8* 3% % 10

10

Operadores aritmticos
Observaes:
Os operadores so binrios, isto , devem sempre trabalhar com um par de elementos. A exceo esta regra so os operadores + e -, que podem aparecer sozinhos esquerda (como em +8 ou -9.3); No permitido omitir o operador da multiplicao.

Prioridades ou Hierarquia 1. Contedo dos parnteses, comeando dos mais


internos;
2. Potenciaes, da direita para a esquerda; 3. Multiplicaes e divises, da esquerda para a direita; 4. Adies e subtraes, da esquerda para a direita.

11

12

05/03/2010

Exerccios A 3.0 1) Resultado


B C D E F G 2.0 5.0 4.0 10.0 2.0 3.0
2) Resultado

Expresses Lgicas
Resultado sempre do tipo lgico; Operandos so relaes e/ou variveis e/ou constantes do tipo lgico; Operadores so lgicos e/ou relacionais.

A*B+C*D+E/F^G A *(B + C)*D + (E / F) ^ G 3) Resultado A *(B + C) * (D + E) / F^G 4) 2 + 3 5 * 8 / 4 5) 7 4 / 2 + 9 - 6

13

14

Operadores
Lgicos
OPERADOR .OU. .E. .NO. OPERAO disjuno conjuno negao

Prioridades
1. 2. 3.
OPERAO igualdade desigualdade menor menor ou igual maior maior ou igual
15 16

Relacionais
OPERADOR = < >

4. 5.

Todos os operadores aritmticos so avaliados na ordem descrita anteriormente; Todos os operadores relacionais so avaliados, da esquerda para a direita; Todos os operadores .no. so avaliados, da esquerda para a direita; Todos os operadores .e. so avaliados, da esquerda para a direita; Todos os operadores .ou. so avaliados, da esquerda para a direita.

Expresses Aritmticas
Funes Matemticas
sen(x) cos(x) tg(x) arctg(x) abs(x) int(x) frac(x) - seno de x; - coseno de x; - tangente de x; - arco cuja tangente x; - valor absoluto (mdulo) de x; - a parte inteira de um nmero fracionrio; - a parte fracionrio de x;

Comando de Atribuio
Um comando de atribuio permitenos fornecer um valor a uma certa varivel (guardar um objeto numa certa gaveta), onde o tipo dessa informao deve ser compatvel com o tipo da varivel. O comando de atribuio tem a forma geral apresentada a seguir:
identificador expresso

Onde: Identificador: o nome da varivel qual esta sendo atribuido o valor; : o smbolo de atribuio; Expresso: pode ser uma expresso aritmtica, expresso lgica ou expresso literal.

05/03/2010

Comandos de Entrada e Sada


Sabe-se que as unidades de entrada e sada so dispositivos que possibilitam a comunico entre o usuario e o computador. Por exemplo, atravs de um teclado, o usuario consegue dar entrada ao programa ao programa e a os dados na memoria do computador. Por sua vez, o computador pode emitir os resultados e outras mensagens para o usurio atravez da tela do PC.

Comandos de Entrada e Sada


Um comando de entrada construida de acordo com a forma geral:
Leia (Lista -de identificadores) Onde: Leia: uma palavra chave; Lista -de identificadores: so os nomes das variveis separados por virgula nas quais sero armazenados os valores provenientes do meio de entrada.

Analogamente , um comando de sada tem a forma geral:


Escreva (Lista -de identificadores) Onde: Escreva: uma palavra chave; Lista -de identificadores: so os nomes das variveis separados por virgula, cujos contedos sero mostrados ao usuario atraves de um meio de sada.

Estruturas de controle
ESTRUTURA SEQUENCIAL: Algoritmo {comeo do algoritmo}
{declarao de variveis};

Exerccios de Algoritmos
Ex 1: Escrever um algoritmo que calcule a mdia final (aritmtica ) entre trs notas quaisquer fornecidas pelo usurio. Dados de Entrada:

Comando a; Comando b; Comando c; . . . Comando n; Fim do algoritmo

Dados de Sada:

O que devemos fazer para transformar trs notas numa media final:

Estruturas de controle
ESTRUTURA SEQUENCIAL: Algoritmo {comeo do algoritmo}
{declarao de variveis};

Estruturas de controle
ESTRUTURA S DE SELEO SELEO SIMPLES: Algoritmo {Questo 3}

Comando a; Comando b; Comando c; . . . Comando n; Fim do algoritmo

Se <condio> ento Comando 1; Comando 2; Comando n; Fim se

Fim do algoritmo

05/03/2010

Estruturas de controle
ESTRUTURA S DE SELEO SELEO COMPOSTA: Algoritmo {Questo 3}

Estruturas de controle
ESTRUTURA S DE SELEO SELEO ENCADEADA: Algoritmo {Questo 3}
Se <condio> ento Comando 1; Seno Se <condio> ento Comando 2; Comando 3; Fim se; Comando 4; Fim se Fim do algoritmo

Se <condio> ento Comando 1; Seno Comando 2); Fim se

Fim do algoritmo

Exerccios de Algoritmos
Comando Para: Ex 1: Escrever um algoritmo que determine o fatorial de um nmero inteiro no-negativo.
O fatorial de nmero inteiro no-negativo N (N!) definido por:
N! = 1*2*3*.......*(N-1)*N N! = 1 se N=0 se N>0

Algoritmo {Questo 3}
Caractere: nm Inteiro: qea, nvmv; Real: pvmv; Leia: nm, qea, nvmv; pvmv nvmv/qea*100; Se qea>20000.e.pvmv<=50 ento escreva: ('o municipio ',nm,'tem 2o turno'); Seno escreva: ('o municipio ',nm,'no tem 2o turno'); Fim se Fim do algoritmo

Algoritmo {Fatorial}
Inteiro: N, Fator, J; Leia: N; Fator 1; Para J de 1 at N Faa Fator Fator*J Fim Para Escreva: ( fatorial de N =, N, =, Fator); Fim do Algoritmo