Você está na página 1de 15

Algoritmos Resolvidos Lista 1

Algoritmo Ex1"
Faa um algoritmo que receba dois nmeros e exiba o resultado da sua soma.
// Seo de Declaraes var x, y: inteiro inicio // Seo de Comandos escreval("Digite o primeiro nmero: ") leia(x) escreval("Digite o segundo nmero: ") leia(y) escreva("A soma dos nmeros : ",x+y) fimalgoritmo

1 Carlo Carlos Eduardo Martins contato@desenvolvefacil.com.br www.desenvolvefacil.com.br

Algoritmos Resolvidos Lista 1

Algoritmo Ex2"
Faa um algoritmo que receba dois nmeros e ao final mostre a soma, subtrao, multiplicao e a diviso dos nmeros lidos.
// Seo de Declaraes var x, y: real inicio // Seo de Comandos escreva("Digite o primeiro nmero: ") leia(x) escreva("Digite o segundo nmero: ") leia(y) escreval("A soma : ",x+y) escreval("A subtrao : ",x-y) escreval("A multiplicao : ",x*y) escreval("A diviso : ",x/y) fimalgoritmo

2 Carlo Carlos Eduardo Martins contato@desenvolvefacil.com.br www.desenvolvefacil.com.br

Algoritmos Resolvidos Lista 1

Algoritmo Ex3"
Escrever um algoritmo para determinar o consumo mdio de um automvel sendo fornecida a distncia total percorrida pelo automvel e o total de combustvel gasto.
// Seo de Declaraes var distancia, combustivel: real inicio // Seo de Comandos escreval("========== Clculo de consumo mdio de combustvel =========") escreva("Digite a distncia pecorrida: ") leia(distancia) escreva("Digite o combustvel gasto: ") leia(combustivel) escreval("O consumo mdio de combustvel do seu veculo : ",distancia/combustivel) fimalgoritmo

3 Carlo Carlos Eduardo Martins contato@desenvolvefacil.com.br www.desenvolvefacil.com.br

Algoritmos Resolvidos Lista 1

Algoritmo Ex4"
Escrever um algoritmo que leia o nome de um vendedor, o seu salrio fixo e o total de vendas efetuadas por ele no ms (em dinheiro). Sabendo que este vendedor ganha 15% de comisso sobre suas vendas efetuadas, informar o seu nome, o salrio fixo e salrio no final do ms.
// Seo de Declaraes var nome: caractere salario: real vendas: real comissao: real salarioFinal: real inicio // Seo de Comandos escreval("<><><><><> Sistema de gesto de vendedores <><><><><>") escreva(">>> Digite o nome do vendedor: ") leia(nome) escreva(">>> Digite o salrio: ") leia(salario) escreva(">>> Informe a quantidade de vendas deste no ms: ") leia(vendas) // Clculo da comisso e salrio final comissao <- 0.15 * vendas salarioFinal <- salario + comissao limpatela escreval(">>>>>>>>>> RESUMO <<<<<<<<<<") 4 Carlo Carlos Eduardo Martins contato@desenvolvefacil.com.br www.desenvolvefacil.com.br

Algoritmos Resolvidos Lista 1


escreval("-- Nome: ",nome) escreval("-- Salrio: ",salario) escreval("-- Salrio Final (salrio + comisso): ",salarioFinal) escreval(">>>>>>>>>><><><><><<<<<<<<<<") fimalgoritmo

5 Carlo Carlos Eduardo Martins contato@desenvolvefacil.com.br www.desenvolvefacil.com.br

Algoritmos Resolvidos Lista 1

Algoritmo Ex5"
Escrever um algoritmo que leia o nome de um aluno e as notas das trs provas que ele obteve no semestre. No final informar o nome do aluno e a sua mdia (aritmtica).
// Seo de Declaraes var aluno: caractere notas: vetor[1..3] de real x: inteiro media: real inicio // Seo de Comandos escreval("============== Mdia de alunos ==============") escreva("Digite o nome do aluno: ") leia(aluno) para x de 1 ate 3 faca escreva("Digite a ",x," nota ") leia(notas[x]) fimpara media <- (notas[1] + notas[2] + notas[3]) / 3 limpatela escreval("==============", aluno," ==============") escreval(">>> Mdia: ",media) escreval("=======================================") fimalgoritmo

6 Carlo Carlos Eduardo Martins contato@desenvolvefacil.com.br www.desenvolvefacil.com.br

Algoritmos Resolvidos Lista 1

7 Carlo Carlos Eduardo Martins contato@desenvolvefacil.com.br www.desenvolvefacil.com.br

Algoritmos Resolvidos Lista 1

Algoritmo Ex6"
Ler dois valores para as variveis A e B, e efetuar as trocas dos valores de forma que a varivel A passe a possuir o valor da varivel B e a varivel B passe a possuir o valor da varivel A. Apresentar os valores trocados.
// Seo de Declaraes var a, b, troca: inteiro

inicio // Seo de Comandos escreva("Digite o valor(numrico) da varivel A: ") leia(a) escreva("Digite o valor(numrico) da varivel B: ") leia(b) troca <- a a <- b b <- troca limpatela escreval("===========================") escreval("O novo valor de A : ",a) escreval("O novo valor de B : ",b) escreval("===========================") fimalgoritmo

8 Carlo Carlos Eduardo Martins contato@desenvolvefacil.com.br www.desenvolvefacil.com.br

Algoritmos Resolvidos Lista 1

Algoritmo Ex7"
Ler uma temperatura em graus Celsius e apresent-la convertida em graus Fahrenheit. A frmula de converso : F= (9*C+160) / 5, sendo F a temperatura em Fahrenheit e C a temperatura em Celsius.
// Seo de Declaraes var cel, far: real inicio // Seo de Comandos escreval("=-=-=-=-=- Tabela de converso: Celcius -> Fahrenheit -=-=-=-=-=") escreva("Digite a temperatura em Celcius: ") leia(cel) far <- (9*cel+160)/5 escreval("A nova temperatura : ",far,"F") fimalgoritmo

9 Carlo Carlos Eduardo Martins contato@desenvolvefacil.com.br www.desenvolvefacil.com.br

Algoritmos Resolvidos Lista 1

Algoritmo Ex8"
Elaborar um algoritmo que efetue a apresentao do valor da converso em real (R$) de um valor lido em dlar (US$). O algoritmo dever solicitar o valor da cotao do dlar e tambm a quantidade de dlares disponveis com o usurio.
// Seo de Declaraes var rs, us, cotacao, dolaDisponivel: real inicio // Seo de Comandos escreval("========= Cotao do Dlar ==========") escreva("Qual a cotao atual do dlar? ") leia(cotacao) escreva("Quantos dlares voc possui? ") leia(us) rs <- us/cotacao limpatela escreval(us," Dlares equivalem : ",rs," R$") fimalgoritmo

10 Carlo Carlos Eduardo Martins contato@desenvolvefacil.com.br www.desenvolvefacil.com.br

Algoritmos Resolvidos Lista 1

Algoritmo Ex9"
Faa um algoritmo que receba um valor que foi depositado e exiba o valor com rendimento aps um ms. Considere fixo o juro da poupana em 0,70% a. m.
// Seo de Declaraes var correcao, deposito: real

inicio // Seo de Comandos escreval("Sistema de depsito do Banco do Oeste") escreva("Digite o valor depositado: ") leia(deposito) correcao <- 0.7 * deposito escreva("O rendimento do depsito aps um ms de: ",deposito+correcao) fimalgoritmo

11 Carlo Carlos Eduardo Martins contato@desenvolvefacil.com.br www.desenvolvefacil.com.br

Algoritmos Resolvidos Lista 1

Algoritmo Ex10"
A Loja Mamo com Acar est vendendo seus produtos em 5 (cinco) prestaes sem juros. Faa um algoritmo que receba um valor de uma compra e mostre o valor das prestaes.
// Seo de Declaraes var compra, prestacao: real inicio // Seo de Comandos escreval("========== Loja Mamo com Acar ==========") escreva("Digite o valor da compra: ") leia(compra) prestacao <- compra/5 escreval("O cliente dever pagar 5 prestaes de R$",prestacao," cada") fimalgoritmo

12 Carlo Carlos Eduardo Martins contato@desenvolvefacil.com.br www.desenvolvefacil.com.br

Algoritmos Resolvidos Lista 1

Algoritmo Ex11"
Faa um algoritmo que receba o preo de custo de um produto e mostre o valor de venda. Sabe-se que o preo de custo receber um acrscimo de acordo com um percentual informado pelo usurio.
// Seo de Declaraes var custo, venda, percent: real inicio // Seo de Comandos escreva("Digite o custo do produto: ") leia(custo) escreva("Digite o percentual para venda: ") leia(percent) percent <- (percent/100) * custo venda <- custo + percent escreval("O valor de venda : ",venda) fimalgoritmo

13 Carlo Carlos Eduardo Martins contato@desenvolvefacil.com.br www.desenvolvefacil.com.br

Algoritmos Resolvidos Lista 1

Algoritmo Ex12"
O custo ao consumidor de um carro novo a soma do custo de fbrica com a percentagem do distribuidor e dos impostos (aplicados, primeiro os impostos sobre o custo de fbrica, e depois a percentagem do distribuidor sobre o resultado). Supondo que a percentagem do distribuidor seja de 28% e os impostos 45%. Escrever um algoritmo que leia o custo de fbrica de um carro e informe o custo ao consumidor do mesmo.
// Seo de Declaraes var custoFabrica, custoFinal: real inicio // Seo de Comandos escreva("Informe o custo de fbrica do veculo: ") leia(custoFabrica) custoFinal <- (custoDeFabrica * 1.45) * 1.28 escreval("O custo para o consumidor final de: ",custoFinal) fimalgoritmo

14 Carlo Carlos Eduardo Martins contato@desenvolvefacil.com.br www.desenvolvefacil.com.br

Algoritmos Resolvidos Lista 1

Algoritmo Ex13"
Faa um algoritmo que receba um nmero e mostre uma mensagem caso este nmero seja maior que 10.
// Seo de Declaraes var numero: inteiro inicio // Seo de Comandos escreva("Digite um nmero: ") leia(numero) se numero > 10 entao escreval("O nmero maior que 10") fimse fimalgoritmo

15 Carlo Carlos Eduardo Martins contato@desenvolvefacil.com.br www.desenvolvefacil.com.br