Algoritmos Resolvidos – Lista 1

Algoritmo “Ex1"
Faça um algoritmo que receba dois números e exiba o resultado da sua soma.
// Seção de Declarações var x, y: inteiro inicio // Seção de Comandos escreval("Digite o primeiro número: ") leia(x) escreval("Digite o segundo número: ") leia(y) escreva("A soma dos números é: ",x+y) fimalgoritmo

1 Carlão – Carlos Eduardo Martins contato@desenvolvefacil.com.br www.desenvolvefacil.com.br

Algoritmos Resolvidos – Lista 1 Algoritmo “Ex2" Faça um algoritmo que receba dois números e ao final mostre a soma. // Seção de Declarações var x.com.br www. y: real inicio // Seção de Comandos escreva("Digite o primeiro número: ") leia(x) escreva("Digite o segundo número: ") leia(y) escreval("A soma é: ". subtração.com. multiplicação e a divisão dos números lidos.br .x+y) escreval("A subtração é: ".x-y) escreval("A multiplicação é: ".x/y) fimalgoritmo 2 Carlão – Carlos Eduardo Martins contato@desenvolvefacil.desenvolvefacil.x*y) escreval("A divisão é: ".

desenvolvefacil.Algoritmos Resolvidos – Lista 1 Algoritmo “Ex3" Escrever um algoritmo para determinar o consumo médio de um automóvel sendo fornecida a distância total percorrida pelo automóvel e o total de combustível gasto.com.distancia/combustivel) fimalgoritmo 3 Carlão – Carlos Eduardo Martins contato@desenvolvefacil.br .br www. // Seção de Declarações var distancia.com. combustivel: real inicio // Seção de Comandos escreval("========== Cálculo de consumo médio de combustível =========") escreva("Digite a distância pecorrida: ") leia(distancia) escreva("Digite o combustível gasto: ") leia(combustivel) escreval("O consumo médio de combustível do seu veículo é: ".

informar o seu nome.0.com.Algoritmos Resolvidos – Lista 1 Algoritmo “Ex4" Escrever um algoritmo que leia o nome de um vendedor.15 * vendas salarioFinal <. // Seção de Declarações var nome: caractere salario: real vendas: real comissao: real salarioFinal: real inicio // Seção de Comandos escreval("<><><><><> Sistema de gestão de vendedores <><><><><>") escreva(">>> Digite o nome do vendedor: ") leia(nome) escreva(">>> Digite o salário: ") leia(salario) escreva(">>> Informe a quantidade de vendas deste no mês: ") leia(vendas) // Cálculo da comissão e salário final comissao <.salario + comissao limpatela escreval(">>>>>>>>>> RESUMO <<<<<<<<<<") 4 Carlão – Carlos Eduardo Martins contato@desenvolvefacil. Sabendo que este vendedor ganha 15% de comissão sobre suas vendas efetuadas.desenvolvefacil. o seu salário fixo e o total de vendas efetuadas por ele no mês (em dinheiro).br www. o salário fixo e salário no final do mês.br .com.

com.Algoritmos Resolvidos – Lista 1 escreval("-.nome) escreval("-.com.br .Nome: ".salarioFinal) escreval(">>>>>>>>>><><><><><<<<<<<<<<") fimalgoritmo 5 Carlão – Carlos Eduardo Martins contato@desenvolvefacil.Salário: ".br www.Salário Final (salário + comissão): ".salario) escreval("-.desenvolvefacil.

." ==============") escreval(">>> Média: ". // Seção de Declarações var aluno: caractere notas: vetor[1.(notas[1] + notas[2] + notas[3]) / 3 limpatela escreval("==============".desenvolvefacil.br www. aluno.com.br .com.x.media) escreval("=======================================") fimalgoritmo 6 Carlão – Carlos Eduardo Martins contato@desenvolvefacil.3] de real x: inteiro media: real inicio // Seção de Comandos escreval("============== Média de alunos ==============") escreva("Digite o nome do aluno: ") leia(aluno) para x de 1 ate 3 faca escreva("Digite a "."º nota ") leia(notas[x]) fimpara media <. No final informar o nome do aluno e a sua média (aritmética).Algoritmos Resolvidos – Lista 1 Algoritmo “Ex5" Escrever um algoritmo que leia o nome de um aluno e as notas das três provas que ele obteve no semestre.

br .br www.com.com.Algoritmos Resolvidos – Lista 1 7 Carlão – Carlos Eduardo Martins contato@desenvolvefacil.desenvolvefacil.

// Seção de Declarações var a. Apresentar os valores trocados.com.br www.b) escreval("===========================") fimalgoritmo 8 Carlão – Carlos Eduardo Martins contato@desenvolvefacil. troca: inteiro inicio // Seção de Comandos escreva("Digite o valor(numérico) da variável A: ") leia(a) escreva("Digite o valor(numérico) da variável B: ") leia(b) troca <.Algoritmos Resolvidos – Lista 1 Algoritmo “Ex6" Ler dois valores para as variáveis A e B.b b <.desenvolvefacil.a a <.a) escreval("O novo valor de B é: ".br . e efetuar as trocas dos valores de forma que a variável A passe a possuir o valor da variável B e a variável B passe a possuir o valor da variável A.com. b.troca limpatela escreval("===========================") escreval("O novo valor de A é: ".

(9*cel+160)/5 escreval("A nova temperatura é: ". // Seção de Declarações var cel.far. far: real inicio // Seção de Comandos escreval("=-=-=-=-=. sendo F a temperatura em Fahrenheit e C a temperatura em Celsius.com.desenvolvefacil.Algoritmos Resolvidos – Lista 1 Algoritmo “Ex7" Ler uma temperatura em graus Celsius e apresentá-la convertida em graus Fahrenheit."ºF") fimalgoritmo 9 Carlão – Carlos Eduardo Martins contato@desenvolvefacil.com.Tabela de conversão: Celcius -> Fahrenheit -=-=-=-=-=") escreva("Digite a temperatura em Celcius: ") leia(cel) far <. A fórmula de conversão é: F= (9*C+160) / 5.br www.br .

dolaDisponivel: real inicio // Seção de Comandos escreval("========= Cotação do Dólar ==========") escreva("Qual a cotação atual do dólar? ") leia(cotacao) escreva("Quantos dólares você possui? ") leia(us) rs <.br www.us/cotacao limpatela escreval(us. us." Dólares equivalem á: ".Algoritmos Resolvidos – Lista 1 Algoritmo “Ex8" Elaborar um algoritmo que efetue a apresentação do valor da conversão em real (R$) de um valor lido em dólar (US$)." R$") fimalgoritmo 10 Carlão – Carlos Eduardo Martins contato@desenvolvefacil. cotacao.com.com.br . // Seção de Declarações var rs. O algoritmo deverá solicitar o valor da cotação do dólar e também a quantidade de dólares disponíveis com o usuário.desenvolvefacil.rs.

br . // Seção de Declarações var correcao.7 * deposito escreva("O rendimento do depósito após um mês é de: ".br www. m.Algoritmos Resolvidos – Lista 1 Algoritmo “Ex9" Faça um algoritmo que receba um valor que foi depositado e exiba o valor com rendimento após um mês.com.70% a.com. deposito: real inicio // Seção de Comandos escreval("Sistema de depósito do Banco do Oeste") escreva("Digite o valor depositado: ") leia(deposito) correcao <. Considere fixo o juro da poupança em 0.0.deposito+correcao) fimalgoritmo 11 Carlão – Carlos Eduardo Martins contato@desenvolvefacil.desenvolvefacil.

// Seção de Declarações var compra. Faça um algoritmo que receba um valor de uma compra e mostre o valor das prestações.com.com.desenvolvefacil.br www.Algoritmos Resolvidos – Lista 1 Algoritmo “Ex10" A Loja Mamão com Açúcar está vendendo seus produtos em 5 (cinco) prestações sem juros." cada") fimalgoritmo 12 Carlão – Carlos Eduardo Martins contato@desenvolvefacil.prestacao. prestacao: real inicio // Seção de Comandos escreval("========== Loja Mamão com Açúcar ==========") escreva("Digite o valor da compra: ") leia(compra) prestacao <.br .compra/5 escreval("O cliente deverá pagar 5 prestações de R$".

com.Algoritmos Resolvidos – Lista 1 Algoritmo “Ex11" Faça um algoritmo que receba o preço de custo de um produto e mostre o valor de venda.br www.custo + percent escreval("O valor de venda é: ". Sabe-se que o preço de custo receberá um acréscimo de acordo com um percentual informado pelo usuário.venda) fimalgoritmo 13 Carlão – Carlos Eduardo Martins contato@desenvolvefacil.desenvolvefacil. // Seção de Declarações var custo. percent: real inicio // Seção de Comandos escreva("Digite o custo do produto: ") leia(custo) escreva("Digite o percentual para venda: ") leia(percent) percent <.(percent/100) * custo venda <. venda.com.br .

e depois a percentagem do distribuidor sobre o resultado). // Seção de Declarações var custoFabrica. Escrever um algoritmo que leia o custo de fábrica de um carro e informe o custo ao consumidor do mesmo. custoFinal: real inicio // Seção de Comandos escreva("Informe o custo de fábrica do veículo: ") leia(custoFabrica) custoFinal <.28 escreval("O custo para o consumidor final é de: ".45) * 1.br www. Supondo que a percentagem do distribuidor seja de 28% e os impostos 45%.custoFinal) fimalgoritmo 14 Carlão – Carlos Eduardo Martins contato@desenvolvefacil.Algoritmos Resolvidos – Lista 1 Algoritmo “Ex12" O custo ao consumidor de um carro novo é a soma do custo de fábrica com a percentagem do distribuidor e dos impostos (aplicados.desenvolvefacil.com. primeiro os impostos sobre o custo de fábrica.com.(custoDeFabrica * 1.br .

com.br .Algoritmos Resolvidos – Lista 1 Algoritmo “Ex13" Faça um algoritmo que receba um número e mostre uma mensagem caso este número seja maior que 10.com. // Seção de Declarações var numero: inteiro inicio // Seção de Comandos escreva("Digite um número: ") leia(numero) se numero > 10 entao escreval("O número é maior que 10") fimse fimalgoritmo 15 Carlão – Carlos Eduardo Martins contato@desenvolvefacil.desenvolvefacil.br www.

Sign up to vote on this title
UsefulNot useful