Você está na página 1de 4

algoritmo "Efetua a leitura de dez nomes de pessoas e reapresenta os 10 nomes. var nomes: vetor [1..

10] de caractere indice : inteiro inicio para indice de 1 ate 10 faca escreva ("Digite um nome: ") leia (nomes[indice]) fimpara escreval ("===========================") escreval ("Os nomes digitados foram: ") escreval ("===========================") para indice de 1 ate 10 faca escreval (nomes [indice]) fimpara fimalgoritmo

algoritmo "Os valores dos elementos sero os do Vetor A multiplicados por 3" var A: vetor [1..8] de inteiro B: vetor [1..8] de inteiro x: inteiro inicio para x de 1 ate 8 faca escreva("Digite um valor para o vetor A: ") leia(A[x]) fimpara para x de 1 ate 8 faca B[x] <- A[x] * 3 escreval ("Valores dos elementos de B :", B[x]) fimpara fimalgoritmo algoritmo "semnome" var A: vetor [1..9] de real B: vetor [1..9] de real C: vetor [1..9] de real x: inteiro inicio Para x de 1 ate 9 faca escreva ("Digite um valor para o vetor A: ") leia (A[x]) escreva ("Digite um valor para o vetor B: ") leia (B[x])

C[x] <- A[x] - B[x] fimpara Para x de 1 ate 9 faca escreval ("Valores do vetor C: ",C[x]) fimpara fimalgoritmo

algoritmo "Fatorial" var a : vetor [1..8] de inteiro b : vetor [1..8] de real x, fatorial : inteiro inicio // No consegui fazer uma funo, mas como dito anteriormente por tu: O importante que funcione (: para x de 1 ate 8 faca escreva("Vetor A, valor", x, ": ") leia (a[x]) b[x]<-a[x] para fatorial de a[x] ate 1 passo -1 faca b[x]<-b[x]*fatorial fimpara fimpara para x de 1 ate 8 faca escreval("Fatorial de", a[x], " : ", b[x]) fimpara fimalgoritmo algoritmo "Construir um programa que leia um Vetor A de 8 elementos caractere e um Vetor B de 5 elementos caractere" var a:vetor [1..8] de caractere b:vetor [9..13] de caractere c:vetor [1..13] de caractere indice:inteiro inicio para indice de 1 ate 8 faca escreva("Contedo do vetor A [",indice,"]: ") leia (a[indice]) c[indice] <- a[indice] fimpara

escreval("--------------") para indice de 9 ate 13 faca escreva("Contedo do vetor B [",indice,"]: ") leia (b[indice]) c[indice] <- b[indice] fimpara escreval("--------------") escreval("Contedo do vetor C:") para indice de 1 ate 13 faca escreval("C [",indice,"]",": ", c[indice]) fimpara fimalgoritmo algoritmo "O elemento de A passa a ser o ltimo elemento de B e vice-versa" var a: vetor [1..10] de inteiro b: vetor [1..10] de inteiro indice, z, y: inteiro inicio para indice de 1 ate 10 faca escreva("Vetor A[",indice,"]: ") leia (a[indice]) fimpara z<-0 escreval("........................") para y de 10 ate 1 passo -1 faca z <- z + 1 b[y] <- a[z] fimpara para indice de 1 ate 10 faca escreval("Vetor B[",indice,"]:",b[indice]) fimpara fimalgoritmo algoritmo "semnome" var nomes: vetor [1..20] de caractere

x: inteiro nome: caractere cont: inteiro inicio para x de 1 ate 20 faca escreva ("Digite um nome: ") leia (nomes [x]) fimpara escreva ("Digite um nome a ser pesquisado: ") leia (nome) cont <- 0 para x de 1 ate 20 faca se (nome = nomes[x]) entao cont <- cont + 1 fimse fimpara se (cont <> 0) entao escreval ("Foram encontrados", cont, " nomes cadastrados!") senao escreval ("O nome no foi encontrado!") fimse fimalgoritmo