Você está na página 1de 9

GOVERNO DO ESTADO DO ESPRITO SANTO

SECRETARIA DE ESTADO DA EDUCAO


EEEM PROF. FERNANDO DUARTE RABELO

Questionrio 5 de Algoritmos
RESOLVA OS ALGORITMOS ABAIXO, UTILIZANDO MATRIZ
1) Faa um algoritmo para preencher uma matriz de 34 com nmeros reais e depois
exibir o elemento do canto superior esquerdo e do canto inferior direito.
2) Fazer um algoritmo para preencher uma matriz de 5X5 e gerar outra em que cada
elemento o quadrado do elemento respectivo na matriz original. Imprima depois o
elemento do meio desta nova matriz.
3) Fazer um algoritmo para preencher uma matriz de 2X3 real e depois gerar e imprimir
sua transposta (matriz 3X2 equivalente). Imprimir linha a linha a matriz.
4) Fazer um algoritmo para preencher uma matriz de 4X3 real e imprimir a soma dos
elementos de uma linha L fornecida pelo usurio.
5) Fazer um algoritmo para preencher uma matriz de 4X3 real. Depois, mostre qual o
elemento armazenado em uma linha L e coluna C fornecidos pelo usurio.
6) Crie uma matriz 7X8 onde cada elemento o produto dos ndices de sua posio dentro
da matriz.
7) Fazer um algoritmo para preencher de 3X3 onde seja preenchida com valores aleatrios
de 0 a 10 usando a funo rand() que sorteia um nmero.
8) Fazer um algoritmo com a matriz anterior e dizer:
Qual o maior valor;
Qual o menor valor;
Quantas vezes repete o nmero 4;
Qual nmero repete mais.

Exemplo do jogo da velha no visualg


1.

var

2.

nome:vetor[1..2] de caractere

3.

v:vetor[1..3,1..3]de caractere

4.

ctr:caractere

5.

i,j,cont1,cont2,auxc,auxl,controd:inteiro

6.

inicio

7.

escreval (" _|_|_ ***********************")

8.

escreval (" _|_|_ **** JOGO DA VELHA ****")

GOVERNO DO ESTADO DO ESPRITO SANTO


SECRETARIA DE ESTADO DA EDUCAO
EEEM PROF. FERNANDO DUARTE RABELO
9.

escreval (" | | ***********************")

10.

escreval

11.

para i de 1 ate 2 faca

12.

escreval ("Digite o Nome do",i," Jogador")

13.

leia (nome[i])

14.

fimpara

15.

escreval ("********************************")

16.

escreval ("* ",nome[1]," Jogador 1 ==> [X] *")

17.

escreval ("* ",nome[2]," Jogador 2 ==> [O] *")

18.

escreval ("********************************")

19.

escreval

20.

escreval ("Efetuando Sorteio do 1 Jogador que ir jogar")

21.

i<-0

22.

repita

23.

para i de 1 ate 3 faca

24.

para j de 1 ate 3 faca

25.

v[i,j]<-""

26.

fimpara

27.

fimpara

28.

i<-0

29.

enquanto (i<1)faca

30.

i<-randi(3)

31.

se (i=0) entao

32.

i<-randi(3)

33.

fimse

34.

fimenquanto

35.

se (i=1) entao

36.

escreval ("*",nome[1]," Jogador 1 Comea *")

GOVERNO DO ESTADO DO ESPRITO SANTO


SECRETARIA DE ESTADO DA EDUCAO
EEEM PROF. FERNANDO DUARTE RABELO
37.

senao

38.

escreval ("*",nome[2]," Jogador 2 Comea *")

39.

fimse

40.

escreval (" | | ")

41.

escreval (" 1,1 | 1,2 | 1,3 ")

42.

escreval (" | | ")

43.

escreval (" ___________|__________|__________ ")

44.

escreval (" | | ")

45.

escreval (" 2,1 | 2,2 | 2,3 ")

46.

escreval (" | | ")

47.

escreval (" ___________|__________|__________ ")

48.

escreval (" | | ")

49.

escreval (" 3,1 | 3,2 | 3,3 ")

50.

escreval (" | | ")

51.

escreval (" | | ")

52.

escreval

53.

repita

54.

escreval ("Jogador ",i," Insira a Coordenada desejada [Linha depois a Coluna embaixo]")

55.

leia (auxl,auxc)

56.

se (v[auxl,auxc]="X") ou (v[auxl,auxc]="O") entao

57.

escreval ("Este Lugar j esta sendo usado <=============")

58.

escreval ("Digite Uma Posio Vazia <=================")

59.

senao

60.

se (i=1)entao

61.

v[auxl,auxc]<-"X"

62.

i<-i+1

63.

controd<-controd+1

64.

senao

GOVERNO DO ESTADO DO ESPRITO SANTO


SECRETARIA DE ESTADO DA EDUCAO
EEEM PROF. FERNANDO DUARTE RABELO
65.

se (i=2) entao

66.

v[auxl,auxc]<-"O"

67.

i<-1

68.

controd<-controd+1

69.

fimse

70.

fimse

71.

fimse

72.

escreval (" | | ")

73.

escreval (" ",v[1,1]," | ",v[1,2]," | ",v[1,3]," ")

74.

escreval (" | | ")

75.

escreval (" ___________|__________|__________ ")

76.

escreval (" | | ")

77.

escreval (" ",v[2,1]," | ",v[2,2]," | ",v[2,3]," ")

78.

escreval (" | | ")

79.

escreval (" ___________|__________|__________ ")

80.

escreval (" | | ")

81.

escreval (" ",v[3,1]," | ",v[3,2]," | ",v[3,3]," ")

82.

escreval (" | | ")

83.

escreval (" | | ")

84.

escreval

85.

escreval ("PLACAR PARCIAL")

86.

escreval (nome[1]," ===> ",cont1)

87.

escreval (nome[2]," ===> ",cont2)

88.

escreval ("O PLACAR Atualizado no fim da rodada")

89.

escreval

90.

se (v[1,1]=v[2,2]) e (v[2,2]=v[3,3]) entao

91.

se (v[1,1]="x") entao

92.

escreval ("Jogador 1 Venceu")

GOVERNO DO ESTADO DO ESPRITO SANTO


SECRETARIA DE ESTADO DA EDUCAO
EEEM PROF. FERNANDO DUARTE RABELO
93.

escreval (nome[1]," Parabens")

94.

cont1<-cont1+1

95.

controd<-9

96.

senao

97.

se (v[1,1]="O") entao

98.

escreval ("Jogador 2 Venceu")

99.

escreval (nome[2]," Parabens")

100.

cont2<-cont2+1

101.

controd<-9

102.

fimse

103.

fimse

104.

senao

105.

se (v[1,3]=v[2,2]) e (v[2,2]=v[3,1]) entao

106.

se (v[1,3]="x") entao

107.

escreval ("Jogador 1 Venceu")

108.

escreval (nome[1]," Parabens")

109.

cont1<-cont1+1

110.

controd<-9

111.

senao

112.

se (v[1,3]="O") entao

113.

escreval ("Jogador 2 Venceu")

114.

escreval (nome[2]," Parabens")

115.

cont2<-cont2+1

116.

controd<-9

117.

fimse

118.

fimse

119.

senao

120.

se (v[1,1]=v[1,2]) e (v[1,2]=v[1,3]) entao

GOVERNO DO ESTADO DO ESPRITO SANTO


SECRETARIA DE ESTADO DA EDUCAO
EEEM PROF. FERNANDO DUARTE RABELO
121.

se (v[1,1]="x") entao

122.

escreval ("Jogador 1 Venceu")

123.

escreval (nome[1]," Parabens")

124.

cont1<-cont1+1

125.

controd<-9

126.

senao

127.

se (v[1,1]="O") entao

128.

escreval ("Jogador 2 Venceu")

129.

escreval (nome[2]," Parabens")

130.

cont2<-cont2+1

131.

controd<-9

132.

fimse

133.

fimse

134.

senao

135.

se (v[2,1]=v[2,2]) e (v[2,2]=v[2,3]) entao

136.

se (v[2,1]="x") entao

137.

escreval ("Jogador 1 Venceu")

138.

escreval (nome[1]," Parabens")

139.

cont1<-cont1+1

140.

controd<-9

141.

senao

142.

se (v[2,1]="O") entao

143.

escreval ("Jogador 2 Venceu")

144.

escreval (nome[2]," Parabens")

145.

cont2<-cont2+1

146.

controd<-9

147.

fimse

148.

fimse

GOVERNO DO ESTADO DO ESPRITO SANTO


SECRETARIA DE ESTADO DA EDUCAO
EEEM PROF. FERNANDO DUARTE RABELO
149.

senao

150.

se (v[3,1]=v[3,2]) e (v[3,2]=v[3,3]) entao

151.

se (v[3,1]="x") entao

152.

escreval ("Jogador 1 Venceu")

153.

escreval (nome[1]," Parabens")

154.

cont1<-cont1+1

155.

controd<-9

156.

senao

157.

se (v[3,1]="O") entao

158.

escreval ("Jogador 2 Venceu")

159.

escreval (nome[2]," Parabens")

160.

cont2<-cont2+1

161.

controd<-9

162.

fimse

163.

fimse

164.

senao

165.

se (v[1,1]=v[2,1]) e (v[2,1]=v[3,1]) entao

166.

se (v[1,1]="x") entao

167.

escreval ("Jogador 1 Venceu")

168.

escreval (nome[1]," Parabens")

169.

cont1<-cont1+1

170.

controd<-9

171.

senao

172.

se (v[1,1]="O") entao

173.

escreval ("Jogador 2 Venceu")

174.

escreval (nome[2]," Parabens")

175.

cont2<-cont2+1

176.

controd<-9

GOVERNO DO ESTADO DO ESPRITO SANTO


SECRETARIA DE ESTADO DA EDUCAO
EEEM PROF. FERNANDO DUARTE RABELO
177.

fimse

178.

fimse

179.

senao

180.

se (v[1,2]=v[2,2]) e (v[2,2]=v[3,2]) entao

181.

se (v[1,2]="x") entao

182.

escreval ("Jogador 1 Venceu")

183.

escreval (nome[1]," Parabens")

184.

cont1<-cont1+1

185.

controd<-9

186.

senao

187.

se (v[1,2]="O") entao

188.

escreval ("Jogador 2 Venceu")

189.

escreval (nome[2]," Parabens")

190.

cont2<-cont2+1

191.

controd<-9

192.

fimse

193.

fimse

194.

senao

195.

se (v[1,3]=v[2,3]) e (v[2,3]=v[3,3]) entao

196.

se (v[1,3]="x") entao

197.

escreval ("Jogador 1 Venceu")

198.

escreval (nome[1]," Parabens")

199.

cont1<-cont1+1

200.

senao

201.

se (v[1,3]="O") entao

202.

escreval ("Jogador 2 Venceu")

203.

escreval (nome[2]," Parabens")

204.

cont2<-cont2+1

GOVERNO DO ESTADO DO ESPRITO SANTO


SECRETARIA DE ESTADO DA EDUCAO
EEEM PROF. FERNANDO DUARTE RABELO
205.

controd<-9

206.

fimse

207.

fimse

208.

senao

209.

se (controd=9) entao

210.

escreval ("IXAAAAAAAAA DEU VELHAAAAAAAAAAAAAA")

211.

fimse

212.

fimse

213.

fimse

214.

fimse

215.

fimse

216.

fimse

217.

fimse

218.

fimse

219.

fimse

220.

ate (controd=9)

221.

escreval ("Deseja Jogar Novamente [s],[n]?")

222.

leia (ctr)

223.

ate (ctr="n")

224.

limpatela

225.

escreval ("PLACAR FINAL")

226.

escreval (nome[1]," ===> ",cont1)

227.

escreval (nome[2]," ===> ",cont2)

228.

escreval ("Obrigado Por ter Jogado Velha's Gaming")

229.

fimalgoritmo