Você está na página 1de 6

Referencias absolutas y Relativas.

Cuando copiamos, el contenido de la frmula se actualiza a medida que copiamos en horizontal o en vertical. Si te sitas en las celdas C15 y D15 del ejemplo mostrado en la barra de frmulas, se observa que cada celda contiene la frmula de su columna correcta. La referencia indica la posicin de la celda contenida en la frmula. Observa la siguiente hoja:

En este caso, en la primera frmula de la celda C15 hemos sumado la columna. En la primera celda no pasa nada, pero si volvemos a copiar la frmula en las celdas de al lado, observaremos en la celda D15 lo siguiente: =D4+D5+D6+D7+D8+D9+D10+D11+D12+D13+D14. Es decir, Excel ha copiado la frmula, pero tambin ha desplazado la referencia de la celda C15 y ahora la ha convertido en D15. Excel ha tomado las referencias de la primera celda como posiciones relativas y las ha copiado hacia su derecha. Para que no ocurra esto, debemos convertir la celda C15 en referencia absoluta es decir, que aunque copiemos la frmula en otras posiciones, la referencia a la celda C15 no cambie nunca.

Tipos de Referencia de celdas:

Celdas relativas: son celdas que su formulacin depende de la posicin donde se comience a utilizar, la referenciacin. Por ejemplo una celda que tome la informacin de datos a la derecha si se llegar a copiar a otra posicin tomara el dato que se encuentre a la derecha de esta nueva celda. Celdas absolutas: referencian solamente una celda y su posicin independientemente de la posicin donde sea llamada o solicitada siempre ser la misma as se arrastren las formulas, el smbolo que se utiliza es ($). Por ejemplo $C$4, Celdas mixtas: combina los dos tipos de referencia anteriores. Por ejemplo: $C4, C$4... Por ejemplo: C$4 O $C4 dependiendo que es lo que se quiere dejar variable o fijo. Una celda se convierte en absoluta posicionando el cursor al lado del nombre de la columna y escribiendo el smbolo pesos ($) o y pulsando la tecla F4. Esto aade automticamente el signo pesos a la columna y la convierte en absoluta, si de forma repetida pulsamos esta tecla el signo cambiara de posicin.

Funciones en Excel
Es una frmula ya programada y preparada para realizar clculos y reducir el uso de frmulas extensas, algunas de ellas no son posibles ser construidas con operaciones matemticas. Las funciones tienen un nombre propio declarado en el idioma que se encuentra el computador o la seleccin del idioma en la instalacin de Programa, existen multitud de funciones clasificadas en categoras.

La razn de las funciones frente a las ecuaciones es simplificar las operaciones y su formulacin. 4.1.4 Sintaxis de una funcin Todas las funciones deben mantener unas reglas de sintaxis o estructura, tal y como se indica

en el siguiente ejemplo:
Argumentos separados por punto y coma o solamente coma y encerrados entre parntesis

=SUMA(A1:A200;100)
Signo igual Nombre de la funcin

En el ejemplo, se sumar todo el rango A1:A200 y aparte el nmero 100. Es decir, que dentro de los parntesis que forman el contenido de la funcin, hay dos argumentos a sumar. Cuando no se conoce la sintaxis de una ecuacin, es posible solicitar la edicin de la misma por medio del rea de edicin de ecuaciones aparece la siguiente ventana: , para el caso de suma

Ilustracin 10: Ventana de Argumentos de funcin

All se exponen de forma individual cada argumento, su explicacin y su resultado. Aunque este sea un error. El acceso de la ayuda desde esta ventana es fcil y contienen ejemplos del uso de la funcin 4.1.5 Algunas funciones Importantes Existen algunas funciones mas utilizadas que otras. Ya sea por su funcionabilidad o por su uso especializado en resultados. Suma Promedio Potencia Mximo o Mnimo Si condicional

4.1.5.1 Funcin =Suma( Es una de las operaciones de mayor utilidad en las hojas de clculo, razn por la cual se proporciona con mltiples acceso y formas.

Para utilizar una funcin, podemos escribirla manualmente o en el botn:

de la cinta Frmulas , biblioteca de funciones.

4.1.5.2 Funcin =PROMEDIO( Esta muy relacionada con la funcin suma, funciona exactamente igual que la suma, pero no existe ninguna tecla predefinida, por lo que debemos introducirla manualmente, o formularla por medio de la combinacin de las funciones =suma( , y =contar(. Cuando introducimos una funcin mediante el teclado, podemos escribirla por completo o hacer lo siguiente: 1. Borra el contenido de la ltima frmula 2. Escribe lo siguiente: =PROMEDIO( 3. Selecciona con el mouse el rango de nmeros. 4. Cierra el parntesis escribindolo a mano. 5. El resultado obtenido es la media de los datos numricos. Otra opcin es utilizar la ventana de la formula:

Ilustracin 11: pantalla de la Funcin Promedio

4.1.5.3 Otras funciones: = MAX(, =MIN( y =CONTAR( Estas funciones son de las primeras formas de encontrar informacin en una tabla o grupo de datos ordenados. Entregan el valor solicitado dentro de un grupo de datos ya sean nmeros, fechas o resultados de funciones. Y Contar cuenta la cantidad de datos sin importar su tipo.

La funcin =MIN( encuentra el valor mnimo La funcin =MAX( encuentra el valor mximo dentro de un grupo La funcin =CONTAR( regresa el nmero de datos seleccionados 4.1.5.4 La funcin =SI() Una de las funciones que tiene un gran nmero de aplicaciones especialmente en el campo de las decisiones y automatizacin de operaciones es la funcin =SI(, que se utilizan en Excel,Su estructura esta compuesta de tres argumentos asi: =SI(condicin;verdadero;falso) Donde condicin es una comparacin de argumentos que se tiene que cumplir , y se utilizan los smbolos de las operaciones de comparacin . Si sta se cumple, se ejecutar verdadero, o en caso contrario, se ejecutar falso. Por ejemplo: =SI(A2>B12; Paga pliza;No paga) Si la celda A2 es mayor que la celda B12, aparecer la palabra Paga pliza, en caso contrario, aparecer la palabra No paga =SI(A1=cliente;Factura;cotizacin) Si la celda A1 contiene la palabra cliente, en la celda actual aparecer la palabra factura, en caso contrario, aparecer la palabra cotizacin. =SI(O(A1=B1,C1=D1),"Bien", suma(30,5)) En esta formula de cumplirse varias condiciones. Ntese la utilizacin del operador O, o la funcin lgica =O( , que se tiene que cumplir una de las dos condiciones. Si es verdadera la respuesta ser Bien y si es falsa la respuesta ser 35

Ilustracin 12: ventana de la funcin =SI(

4.1.6 Funciones anidadas Son funciones que estn contenidos dentro de otras y sus respuestas que actan como argumento de otra funcin. En el proceso de clculo, Excel realiza primero el clculo de la funcin interior y despus, el resultado de la funcin exterior teniendo ya en cuenta el resultado que se ha obtenido con la funcin interior. Por ejemplo, la funcin: =SUMA(RAZ(25));3) Primero calcular el resultado de la funcin interior, o sea, de la RAZ, cuyo resultado es 5 y luego se calcular el resultado de la exterior SUMA, teniendo en cuenta ya este resultado. El resultado de esta operacin es 8. Las ltimas versiones permiten hacer un rastreo de las operaciones por medio del men Formulas. Que permiten al usuario buscar el destino o precedentes de los datos calculados.

Ilustracin 13: Auditoria de Formulas