Você está na página 1de 7

BENEMRITA UNIVERSIDAD AUTONOMA DE PUEBLA

Preparatoria 2 de Octubre de 1968

Informtica III

Algoritmos

Profesora: Minerva Gmez Marcos Orali Gonzlez Conde

3DM

CICLO ESCOLAR 2013-2014

Ejercicios de clase (12-Noviembre-2013) 1.- Elaborar un programa que realice la multiplicacin de nmeros y nos muestre el resultado: D. Entrada= pnumero, snumero D. Salida= producto
Proceso sin_titulo Escribir "introduce el primer numero"; Leer pnumero; Escribir "introduce el segundo numero"; Leer snumero; producto<-(pnumero*snumero); Escribir "el resultado es",producto; FinProceso

(Algoritmo que muestra los nmeros que se multiplicaron y el resultado juntos) Proceso sin_titulo Escribir "introduce el primer numero"; Leer pnumero; Escribir "introduce el segundo numero"; Leer snumero; producto<-(pnumero*snumero); Escribir "el resultado de ", pnumero, "*",snumero," = ",producto; FinProceso

2.- Manuel tiene un hermano menor en 2 de primaria y no puede aprenderse las tablas de multiplicar, por lo que necesita un programa que dado el nmero de tabla se muestre como a continuacin: Ejemplo: escribe un numero: 5 (valor introducido por el usuario) 5*1=5 5*2=10 5*10=50

Proceso tablamultiplicar Escribir "introduce el numero de la tabla que quieres aprender"; Leer ntabla; Escribir ntabla," x 1 =",ntabla*1; Escribir ntabla," x 2 =",ntabla*2; Escribir ntabla," x 3 =",ntabla*3; Escribir ntabla," x 4 =",ntabla*4; Escribir ntabla," x 5 =",ntabla*5; Escribir ntabla," x 6 =",ntabla*6; Escribir ntabla," x 7 =",ntabla*7; Escribir ntabla," x 8 =",ntabla*8; Escribir ntabla," x 9 =",ntabla*9; Escribir ntabla," x 10 =",ntabla*10; FinProceso

3.- Un empleado desea calcular el pago neto que percibe resultante de las siguientes deducciones IMSS 5%, INVONAVIT 16%, ISPT 23%; a partir del pago bruto basado en una jornada en horas y con un precio de $100 hora D.Entrada= Horas trabajadas Das trabajados D. Salida= Pago neto

Proceso pagodejornada Escribir "dame en numero de horas trabajadas"; Leer nhoras; Escribir "dame el numero de dias laborados"; Leer ndias; pagototal<-(nhoras*100)*(ndias); deducciones<-(pagototal*44)/100; pagobruto<-pagototal-deducciones; Escribir "tu pago es:",pagobruto; FinProceso

Algoritmos de tarea para 19 de Noviembre de 2014 1.- Programa que pida la temperatura en grados Celsius y la convierta a grados Fahrenheit (y viceversa) mostrando en pantalla un mensaje del tipo xxx.xx grados Celsius son yyy.yy grados Fahrenheit D.Entrada= tgcelsius, tgfahrenheit D. Salida= Temperatura en grados Fahrenheit

Proceso temperatura Escribir "Dame la temperatura en grados Celsius"; Leer tgcelsius; temperaturafahren<-((tgcelsius*9)/5)+32; Escribir tgcelsius,"Grados Celsius son:",temperaturafahren,"Grados Fahrenheit" Escribir "Dame la temperatura en Grados Fahrenheit"; Leer tgfahrenheit; temperaturacelsius<-((tgfahrenheit-32)*5)/9; Escribir tgfahrenheit, "Grados Fahrenheit son:",temperaturacelsius,"Grados Celsius"; FinProceso

2.- Miriam necesita realizar un experimento donde la medida del azcar se da en onzas y desea conocer su equivalente a gramos y kilogramos para poder llevar a cabo el proceso de mezclado de dicho trabajo. D. Entrada= aenonzas D. Salida= Gramos, Kilogramos

Proceso Azucar Escribir "Dame la medida del azucar en onzas"; Leer aenonzas; Gr<-(aenonzas*28.4); Kg<-(aenonzas*0.03); Escribir "El azucar en onzas equivale a:",Gr,"Gramos y a:",Kg,"Kilogramos"; FinProceso

3.- Una Casa de Valores presenta a sus usuarios las conversiones de su dinero (Moneda Nacional) a otras divisas como el Euro, Dlar, Yen, Dlar Canadiense. Presentar un algoritmo para resolver este proceso. D. Entrada= MNacional D. Salida= Euros, Dlares, Yenes, Dlares Canadienses

Proceso casavalores
Escribir "Deme la cantidad de dinero en moneda nacional"; Leer MNacional; Escribir "Su dinero equivalente en Euros es:",MNacional/17.40; Escribir "Su dinero equivalente en Dolares es:",MNacional/12.87; Escribir "Su dinero equivalente en Yenes es:",MNacional/.13; Escribir "Su dinero equivalente en Dolares Canadienses es:",MNacional/12.37; FinProceso