Você está na página 1de 32

Aula 11 Introduo ao Pseudocdigo

Disciplina: Fundamentos de Lgica e Algoritmos Prof. Bruno Gomes http://www3.ifrn.edu.br/~brunogomes

Agenda da Aula

Representao de Algoritmos em Pseudocdigo:


Sintaxe; Tipos de Dados; Variveis; Impresso de Dados.

Revisando

Para que representar um algoritmo?

Quais as formas de representao de um Algoritmo?

Lembrando: Fluxograma

Formas Geomtricas:
Incio do algoritmo Instruo / Processamento Fim do Algoritmo

Lembrando: Fluxograma

Calcular a Mdia de um Aluno:

Obter as 2 notas Calcular Mdia Exibir a Mdia

PSEUDOCDIGO

Pseudocdigo

Tcnica textual de representao de um algoritmo. Baseado no PDL (Program Design Language):

Linguagem genrica;

Forma intermediria entre a linguagem natural e uma linguagem de programao de alto nvel; Utiliza uma linguagem simples, sendo uma forma genrica de se desenvolver; O mais conhecido: Portugol.

Portugol

Pseudolinguagem de programao;

Criada originalmente em ingls, com a proposta de ser independente da linguagem nativa; Notao para algoritmos.

Estrutura

Estrutura pode variar, mas a semntica sempre a mesma; Estrutura:


algoritmo nome var

inicio
fimalgoritmo

Primeira Regra Bsica


Todo algoritmo deve ter um nome; O nome deve ser a primeira coisa definida em um algoritmo; Exemplo: algoritmo media var inicio fimalgoritmo

Segunda Regra Bsica

Em todo algoritmo deve ser definido o seu incio e o fim. Exemplo:


algoritmo media var inicio

Instrues do Algoritmo

fimalgoritmo

Palavras Chaves

Fazem parte da Gramtica da Linguagem:

Tipos de Dados

Computador manipula informaes; Necessrio trabalhar com diferentes tipos de dados em um programa; Internamente, o computador manipula somente nmeros; As linguagens de programao permitem que utilizemos outros tipos de dados.

Converso de dados.

Tipos de Dados

Analogias:

Supermercado; Clculo da Mdia de Alunos.

Linguagens de Programao so limitadas:

No podem manipular todos os tipos existentes de dados;

Deve-se utilizar os tipos de dados definidos nas linguagens de programao.

Tipos de Dados

A linguagem Portugol permite 4 tipos de dados:


Tipos de Dados

Numrico

Caractere

Lgico

Real

Inteiro

Tipos de Dados

inteiro: define variveis numricas do tipo inteiro, ou seja, sem casas decimais.

Exemplos: 14.

real: define variveis numricas do tipo real, ou seja, com casas decimais.

Exemplos: 5,6.

caractere: define variveis do tipo string, ou seja, cadeia de caracteres.

Exemplos: Texto.

logico: define variveis do tipo booleano;

Exemplos: VERDADEIRO ou FALSO.

Armazenamento dos Dados

As informaes manipuladas pelo computador geralmente necessitam ser armazenadas;


Para manter as informaes; Para utilizao em operaes posteriores.

Exemplo:

Clculo da mdia.

Soluo: utilizao de variveis.

Variveis

Servem para armazenar algum valor; Cada varivel armazena um tipo de dado; Representam uma posio, localizada na memria; frequentemente

Existem somente em tempo de execuo.

Como utilizar Varivel?

Inicialmente declaramos a varivel:


Criao da varivel; Feita na seo var.

Sintaxe:
var lista-de-variveis : tipo-de-dado

Exemplo

Criao de uma varivel chamada numero, do tipo inteiro;


algoritmo "variaveis" var numero : inteiro inicio

fimalgoritmo

Exemplo

Variveis: numero, idade e frase.


algoritmo "variaveis"
var numero, idade : inteiro frase : caractere inicio fimalgoritmo

Como utilizar Varivel?

Aps a declarao, agora iremos inicializ-la.


Armazenar um valor dentro da varivel; Feito dentro do corpo do algoritmo; Utilizao do operador <-

Sintaxe:
variavel <- valor

Exemplo

A varivel numero recebe o valor inteiro 10;


algoritmo "variaveis" var numero, idade : inteiro frase : caractere

Declarao

Inicializao

inicio numero <- 10 idade <- 20 frase <- "Testando" fimalgoritmo

Valores do tipo caractere sempre utilizam aspas

Exemplo

As casas decimais de separadas por . (ponto) Exemplo:

nmeros

reais

so

algoritmo "variaveis" var preco : real inicio preco <- 15.50 fimalgoritmo

Exemplo

Valores lgicos recebem os valores VERDADEIRO ou FALSO. Exemplo:


algoritmo "variaveis" var ligado : logico

inicio ligado <- VERDADEIRO fimalgoritmo

Sada de Dados

Impresso de dados pelo Algoritmo;

Utilizao da funo escreval()


Sintaxe:

escreval(valor)

Exemplo

Impresso do nome Bruno Gomes:


algoritmo "impressao" var

inicio escreval("Bruno Gomes") fimalgoritmo

Exemplo

Impresso do nome Bruno Gomes, e na prxima linha o texto Prof. do IFRN:


algoritmo "impressao" var inicio escreval("Bruno Gomes") escreval(Prof. do IFRN") fimalgoritmo

Exemplo

Impresso do valor da varivel idade:


algoritmo "impressao" var idade : inteiro inicio idade <- 20 escreval(idade) fimalgoritmo

O que ser impresso?

Dvidas?

Vamos Praticar

Criar um Algoritmo que:


O nome seja: PrimeiroAlgoritmo; Ele deve imprimir:


Nome Completo Matrcula Curso

Vamos Praticar

Criar um Algoritmo que:


O nome seja: Notas; Ele deve conter duas variveis, do tipo real; A primeira receber o valor 7,5; A segunda receber o valor 8,0; Ao fim, deve imprimir o valor das duas variveis.