Você está na página 1de 14

algoritmo "ex1" // Funo : Faa um algoritmo que receba dois nmeros e exiba o resultado da sua soma.

// Autor : // Data : 30/11/2010 // Seo de Declaraes var x, y: inteiro inicio // Seo de Comandos escreval("Digite o primeiro nmero: ") leia(x) escreval("Digite o segundo nmero: ") leia(y) escreva("A soma dos nmeros : ",x+y) algoritmo "ex2" // Funo : Faa um algoritmo que receba dois nmeros e ao final mostre a soma, subtrao, multiplicao e a diviso dos nmeros lidos. // Autor : // Data : 30/11/2010 // Seo de Declaraes var x, y: real inicio // Seo de Comandos escreva("Digite o primeiro nmero: ") leia(x) escreva("Digite o segundo nmero: ") leia(y) escreval("A soma : ",x+y) escreval("A subtrao : ",x-y) escreval("A multiplicao : ",x*y) escreval("A diviso : ",x/y) algoritmo "ex3" // Funo : Escrever um algoritmo para determinar o consumo mdio de um automvel sendo fornecida a distncia total percorrida pelo automvel e o total de combustvel gasto. // Autor : // Data : 30/11/2010 // Seo de Declaraes var distancia, combustivel: real inicio // Seo de Comandos escreval("========== Clculo de consumo mdio de combustvel =========") escreva("Digite a distncia pecorrida: ") leia(distancia) escreva("Digite o combustvel gasto: ") leia(combustivel)

escreval("O consumo mdio de combustvel do seu veculo : ",distancia/combustivel) algoritmo "ex4" // Funo : Escrever um algoritmo que leia o nome de um vendedor, o seu salrio fixo e o total de vendas efetuadas por ele no // ms (em dinheiro). Sabendo que este vendedor ganha 15% de comisso sobre suas vendas efetuadas, informar o // seu nome, o salrio fixo e salrio no final do ms // Autor : // Data : 30/11/2010 // Seo de Declaraes var nome: caractere salario: real vendas: real comissao: real salarioFinal: real inicio // Seo de Comandos escreval("<><><><><> Sistema de gesto de vendedores <><><><><>") escreva(">>> Digite o nome do vendedor: ") leia(nome) escreva(">>> Digite o salrio: ") leia(salario) escreva(">>> Informe a quantidade de vendas deste no ms: ") leia(vendas) // Clculo da comisso e salrio final comissao <- 0.15 * vendas salarioFinal <- salario + comissao limpatela escreval(">>>>>>>>>> RESUMO <<<<<<<<<<") escreval("-- Nome: ",nome) escreval("-- Salrio: ",salario) escreval("-- Salrio Final (salrio + comisso): ",salarioFinal) escreval(">>>>>>>>>><><><><><<<<<<<<<<") algoritmo "ex5" // Funo : Escrever um algoritmo que leia o nome de um aluno e as notas das trs provas que ele obteve no semestre. No final // informar o nome do aluno e a sua mdia (aritmtica) // Autor : // Data : 30/11/2010 // Seo de Declaraes var aluno: caractere notas: vetor[1..3] de real x: inteiro media: real

inicio // Seo de Comandos escreval("============== Mdia de alunos ==============") escreva("Digite o nome do aluno: ") leia(aluno) para x de 1 ate 3 faca escreva("Digite a ",x," nota ") leia(notas[x]) fimpara media <- (notas[1] + notas[2] + notas[3]) / 3 limpatela escreval("==============", aluno," ==============") escreval(">>> Mdia: ",media) escreval("================================== =====")

inicio // Seo de Comandos escreval("=-=-=-=-=- Tabela de converso: Celcius -> Fahrenheit -=-=-=-=-=") escreva("Digite a temperatura em Celcius: ") leia(cel) far <- (9*cel+160)/5 escreval("A nova temperatura : ",far,"F") algoritmo "ex8" // Funo : Elaborar um algoritmo que efetue a apresentao do valor da converso em real (R$) de um valor lido em dlar // (US$). O algoritmo dever solicitar o valor da cotao do dlar e tambm a quantidade de dlares disponveis com o usurio. // Autor : // Data : 30/11/2010 // Seo de Declaraes var rs, us, cotacao, dolaDisponivel: real inicio // Seo de Comandos escreval("========= Cotao do Dlar ==========") escreva("Qual a cotao atual do dlar? ") leia(cotacao) escreva("Quantos dlares voc possui? ") leia(us) rs <- us/cotacao limpatela escreval(us," Dlares equivalem : ",rs," R$") algoritmo "ex9" // Funo : Faa um algoritmo que receba um valor que foi depositado e exiba o valor com rendimento aps um ms. // Considere fixo o juro da poupana em 0,70% a. m. // Autor : // Data : 1/12/2010 // Seo de Declaraes var correcao, deposito: real

algoritmo "ex6" // Funo : Ler dois valores para as variveis A e B, e efetuar as trocas dos valores de forma que a varivel A passe a possuir o // valor da varivel B e a varivel B passe a possuir o valor da varivel A. Apresentar os valores trocados. // Autor : // Data : 30/11/2010 // Seo de Declaraes var a, b, troca: inteiro inicio // Seo de Comandos escreva("Digite o valor(numrico) da varivel A: ") leia(a) escreva("Digite o valor(numrico) da varivel B: ") leia(b) troca <- a a <- b b <- troca limpatela escreval("===========================") escreval("O novo valor de A : ",a) escreval("O novo valor de B : ",b) escreval("===========================") algoritmo "ex7" // Funo : Ler uma temperatura em graus Celsius e apresent-la convertida em graus Fahrenheit. A frmula de converso : // F=(9*C+160) / 5, sendo F a temperatura em Fahrenheit e C a temperatura em Celsius. // Autor : // Data : 30/11/2010 // Seo de Declaraes var cel, far: real

inicio // Seo de Comandos escreval("Sistema de depsito do Banco do Oeste") escreva("Digite o valor depositado: ") leia(deposito) correcao <- 0.7 * deposito escreva("O rendimento do depsito aps um ms de: ",deposito+correcao) algoritmo "ex10"

// Funo : A Loja Mamo com Acar est vendendo seus produtos em 5 (cinco) prestaes sem juros. Faa um algoritmo que // receba um valor de uma compra e mostre o valor das prestaes. // Autor : // Data : 1/12/2010 // Seo de Declaraes var compra, prestacao: real inicio // Seo de Comandos escreval("========== Loja Mamo com Acar ==========") escreva("Digite o valor da compra: ") leia(compra) prestacao <- compra/5 escreval("O cliente dever pagar 5 prestaes de R$",prestacao," cada") algoritmo "ex11" // Funo : Faa um algoritmo que receba o preo de custo de um produto e mostre o valor de venda. Sabese que o preo de // custo receber um acrscimo de acordo com um percentual informado pelo usurio. // Autor : // Data : 1/12/2010 // Seo de Declaraes var custo, venda, percent: real inicio // Seo de Comandos escreva("Digite o custo do produto: ") leia(custo) escreva("Digite o percentual para venda: ") leia(percent) percent <- (percent/100) * custo venda <- custo + percent escreval("O valor de venda : ",venda) algoritmo "ex12" // Funo : O custo ao consumidor de um carro novo a soma do custo de fbrica com a percentagem do distribuidor e dos // impostos (aplicados, primeiro os impostos sobre o custo de fbrica, e depois a percentagem do distribuidor sobre o // resultado). Supondo que a percentagem do distribuidor seja de 28% e os impostos 45%. Escrever um algoritmo que // leia o custo de fbrica de um carro e informe o custo ao consumidor do mesmo. // Autor : // Data : 1/12/2010 // Seo de Declaraes

var custoFabrica, custoFinal: real inicio // Seo de Comandos escreva("Informe o custo de fbrica do veculo: ") leia(custoFabrica) custoFinal <- custoFabrica + (0.28 * custoFabrica) + (0.45 * custoFabrica) custoFinal <- custoFinal + (0.45 * custoFinal) escreval("O custo para o consumidor final de: ",custoFinal) algoritmo "ex13" // Funo : Faa um algoritmo que receba um nmero e mostre uma mensagem caso este nmero seja maior que 10. // Autor : // Data : 1/12/2010 // Seo de Declaraes var numero: inteiro inicio // Seo de Comandos escreva("Digite um nmero: ") leia(numero) se numero > 10 entao escreval("O nmero maior que 10") fimse algoritmo "ex14" // Funo : Escrever um algoritmo que leia dois valores inteiro distintos e informe qual o maior. // Autor : // Data : 1/12/2010 // Seo de Declaraes var num1, num2: inteiro inicio // Seo de Comandos escreva("Digite o primeiro nmero: ") leia(num1) escreva("Digite o segundo nmero: ") leia(num2) se num1 > num2 entao escreva("O primeiro nmero ",num1," maior que o segundo",num2) senao escreva("O segundo nmero",num2," maior que o primeiro",num1) fimse algoritmo "ex15"

// Funo : Faa um algoritmo que receba um nmero e diga se este nmero est no intervalo entre 100 e 200. // Autor : // Data : 1/12/2010 // Seo de Declaraes var numero: inteiro inicio // Seo de Comandos escreva("Digite um nmero: ") leia(numero) se numero >= 100 entao se numero <= 200 entao escreval("O nmero est no intervalo entre 100 e 200") senao escreval("O nmero no est no intervalo entre 100 e 200") fimse senao escreval("O nmero no est no intervalo entre 100 e 200") fimse algoritmo "ex16" // Funo : Escrever um algoritmo que leia o nome e as trs notas obtidas por um aluno durante o semestre. Calcular a sua // mdia (aritmtica), informar o nome e sua meno aprovado (media >= 7), Reprovado (media <= 5) e Recuperao // (media entre 5.1 a 6.9). // Autor : // Data : 1/12/2010 // Seo de Declaraes var nome: caractere n1, n2, n3, media: real inicio // Seo de Comandos escreval("Sistema de mdias") escreva("Digite a primeira nota: ") leia(n1) escreva("Digite a segunda nota: ") leia(n2) escreva("Digite a terceria nota: ") leia(n3) media <- (n1 + n2 + n3) / 3 se media >= 7 entao escreval("Aluno aprovado!") senao se media <= 5 entao escreval("Aluno reprovado!") senao

escreval("Aluno em recuperao...") fimse fimse algoritmo "ex17" // Funo : Ler 80 nmeros e ao final informar quantos nmero(s) est()o no intervalo entre 10 (inclusive) e 150 (inclusive). // Autor : // Data : 1/12/2010 // Seo de Declaraes var x, num, intervalo: inteiro inicio // Seo de Comandos para x de 1 ate 80 faca escreva("Digite um nmero: ") leia(num) se num >= 10 entao se num <= 150 entao intervalo <- intervalo + 1 fimse fimse fimpara escreval("Ao total, foram digitados",intervalo,"nmeros no intervalo entre 10 e 150")

algoritmo "ex18" // Funo : Faa um algoritmo que receba a idade de 75 pessoas e mostre mensagem informando "maior de idade" e "menor de // idade" para cada pessoa. Considere a idade a partir de 18 anos como maior de idade. // Autor : // Data : 1/12/2010 // Seo de Declaraes var x, idade: inteiro inicio // Seo de Comandos para x de 1 ate 75 faca escreva("Digite a idade: ") leia(idade) se idade >= 18 entao escreval("Fulano maior de idade!") fimse fimpara algoritmo "ex19" // Funo : Escrever um algoritmo que leia o nome e o sexo de 56 pessoas e informe o nome e se ela homem ou mulher. No // final informe total de homens e de mulheres.

// Autor : // Data : 1/12/2010 // Seo de Declaraes var nome, sexo: caractere x, h, m: inteiro inicio // Seo de Comandos para x de 1 ate 5 faca limpatela escreva("Digite o nome: ") leia(nome) escreva("H - Homem ou M - Mulher: ") leia(sexo) escolha sexo caso "H" h <- h + 1 caso "M" m <- m + 1 outrocaso escreval("Sexo s pode ser H ou M!") fimescolha fimpara limpatela escreval("Foram inseridos",h," Homens") escreval("Foram inseridos",m," Mulheres") algoritmo "ex20" // Funo : A concessionria de veculos CARANGO VELHO est vendendo os seus veculos com desconto. Faa um // algoritmo que calcule e exiba o valor do desconto e o valor a ser pago pelo cliente de vrios carros. O desconto // dever ser calculado de acordo com o ano do veculo. At 2000 - 12% e acima de 2000 - 7%. O sistema dever // perguntar se deseja continuar calculando desconto at que a resposta seja: \u201c(N) No\u201d . Informar total de carros com // ano at 2000 e total geral. // Autor : // Data : 1/12/2010 // Seo de Declaraes var programa, opc: caractere ano, total, total2000: inteiro valor, valorFinal, desconto: real inicio // Seo de Comandos programa <- "S" enquanto programa <> "N" faca limpatela escreva("Digite o valor do carro: ") leia(valor) escreva("Digite o ano do carro: ")

leia(ano) se ano <= 2000 entao desconto <- 0.12 total2000 <- total2000 + 1 total <- total + 1 senao desconto <- 0.07 total <- total + 1 fimse desconto <- desconto * valor valorFinal <- valor - desconto escreval("O valor do carro com desconto de: ",valorFinal) escreval("") escreva("Deseja continuar calculando? (S) Sim - (N) No - ") leia(opc) escolha opc caso "S" programa <- "S" caso "N" programa <- "N" outrocaso programa <- "S" limpatela escreval("As opes disponveis so apenas S ou N!!!") leia(opc) fimescolha fimenquanto escreval("Foram calculados",total2000," carro(s) com ano at 2000") escreval("Total geral: ",total) algoritmo "ex21" // Funo : Escrever um algoritmo que leia os dados de N pessoas (nome, sexo, idade e sade) e informe se est apta ou no // para cumprir o servio militar obrigatrio. Informe os totais. // Autor : // Data : 1/12/2010 // Seo de Declaraes var programa, idade, apto: inteiro nome, sexo, saude, opc: caractere totApto, total: inteiro inicio // Seo de Comandos programa <- 1 enquanto programa = 1 faca limpatela apto <- 1 saude <- "B" total <- total + 1 escreva("Digite o nome: ") leia(nome) escreva("Digite o sexo (M/F): ")

leia(sexo) escreva("Digite a idade: ") leia(idade) se idade < 18 entao apto <- 0 fimse escreval("Digite o estado de sade: ") escreva("(B) Bom - (R) - Ruim - ") leia(saude) se saude = "R" entao apto <- 0 senao se saude <> "B" entao apto <- 0 fimse fimse se apto = 1 entao totApto <- totApto + 1 fimse escreval("Deseja continuar filtrando (S/N)? ") leia(opc) se opc = "N" entao programa <- 0 fimse fimenquanto limpatela escreval("Resumo geral: ") escreval("Foram filtrados: ",total," pessoas") escreval("Aptos: ",totApto) escreval("") algoritmo "ex22" // Funo : Faa um algoritmo que receba o preo de custo e o preo de venda de 40 produtos. Mostre como resultado se // houve lucro, prejuzo ou empate para cada produto. Informe media de preo de custo e do preo de venda. // Autor : // Data : 1/12/2010 // Seo de Declaraes var x: inteiro precoVenda, precoCusto: real mediaCusto, mediaVenda: real inicio // Seo de Comandos para x de 1 ate 40 faca limpatela escreva("Digite o preo de custo: ") leia(precoCusto) mediaCusto <- mediaCusto + precoCusto escreva("Digite o preo de venda: ") leia(precoVenda) mediaVenda <- mediaVenda + precoVenda se precoVenda < precoCusto entao escreval("Houve prejuzo na venda")

senao se precoVenda = precoCusto entao escreval("Houve empate na venda") fimse se precoVenda > precoCusto entao escreval("Houve lucro na venda") fimse fimse fimpara limpatela escreval("A mdia de preo de custo foi: ",mediaCusto/40) escreval("A mdia de preo de venda foi: ",mediaVenda/40) algoritmo "ex23" // Funo : Faa um algoritmo que receba um nmero e mostre uma mensagem caso este nmero sege maior que 80, menor // que 25 ou igual a 40. // Autor : // Data : 1/12/2010 // Seo de Declaraes var numero: inteiro inicio // Seo de Comandos escreva("Digite um nmero: ") leia(numero) se numero > 80 entao escreval("O nmero maior que 80") senao se numero < 25 entao escreval("O nmero menor que 25") senao se numero = 40 entao escreval("O nmero igual a 40") fimse fimse fimse algoritmo "ex24" // Funo : Faa um algoritmo que receba N nmeros e mostre positivo, negativo ou zero para cada nmero. // Autor : // Data : 1/12/2010 // Seo de Declaraes var programa, numero: inteiro opc: caractere inicio // Seo de Comandos programa <- 1 enquanto programa = 1 faca

limpatela escreva("Digite um nmero: ") leia(numero) se numero > 0 entao escreval("Positivo") senao se numero = 0 entao escreval("O nmero igual a 0") fimse se numero < 0 entao escreval("Negativo") fimse fimse algoritmo "ex25" // Funo : Faa um algoritmo que leia dois nmeros e identifique se so iguais ou diferentes. Caso eles sejam iguais imprima // uma mensagem dizendo que eles so iguais. Caso sejam diferentes, informe qual nmero o maior, e uma // mensagem que so diferentes. // Autor : // Data : 1/12/2010 // Seo de Declaraes var num1, num2: inteiro inicio // Seo de Comandos escreva("Digite o primeiro nmero: ") leia(num1) escreva("Digite o segundo nmero: ") leia(num2) se num1 = num2 entao escreval("Os nmeros so iguais!") senao se num1 > num2 entao escreval("O nmero",num1," maior que o nmero",num2) escreval("Eles so diferentes!!!") senao escreval("O nmero",num2," maior que o nmero",num1) escreval("Eles so diferentes!!!") fimse fimse algoritmo "ex26" // Funo : Faa um algoritmo que leia um nmero de 1 a 5 e escreva por extenso. Caso o usurio digite um nmero que no // esteja neste intervalo, exibir mensagem: nmero invlido. // Autor : // Data : 1/12/2010 // Seo de Declaraes var numero: inteiro

inicio // Seo de Comandos escreva("Digite um nmero de 1 a 5: ") leia(numero) escolha numero caso 1 escreval("Um") caso 2 escreval("Dois") caso 3 escreval("Trs") caso 4 escreval("Quatro") caso 5 escreval("Cinco") outrocaso escreval("Nmero Invlido!!!") fimescolha algoritmo "ex27" // Funo : A concessionria de veculos CARANGO est vendendo os seus veculos com desconto. Faa um algoritmo que // calcule e exiba o valor do desconto e o valor a ser pago pelo cliente. O desconto dever ser calculado sobre o valor // do veculo de acordo com o combustvel (lcool \u2013 25%, gasolina \u2013 21% ou diesel \u201314%). Com valor do veculo zero // encerra entrada de dados. Informe total de desconto e total pago pelos clientes. // Autor : // Data : 1/12/2010 // Seo de Declaraes var desconto, valorPago, valorVeiculo: real totalDesconto, totalPago: real combustivel, opc: caractere inicio // Seo de Comandos valorVeiculo <- 1 opc <- "x" enquanto valorVeiculo <> 0 faca limpatela escreva("Digite o valor do veculo: ") leia(valorVeiculo) se valorVeiculo <> 0 entao escreval("Digite o combustvel") escreva("(G)asolina / (A)lcool / (D)iesel: ") leia(combustivel) escolha combustivel caso "A" desconto <- 0.25 * valorVeiculo caso "G" desconto <- 0.21 * valorVeiculo caso "D" desconto <- 0.14 * valorVeiculo outrocaso

escreval("Combustvel invlido!") escreval("No havero descontos!") desconto <- 0 fimescolha valorPago <- valorVeiculo - desconto totalDesconto <- totalDesconto + desconto totalPago <- totalPago + valorPago escreval("Desconto no veculo: ",desconto) escreval("Valor total a ser pago: ",valorPago) escreval("Tecle enter para continuar...") leia(opc) fimse fimenquanto limpatela escreval("Resumo geral: ") escreval("Total de descontos: ",totalDesconto) escreval("Total Pago pelos clientes: ",totalPago) algoritmo "ex28" // Funo : Escrever um algoritmo para uma empresa que decide dar um reajuste a seus 584 funcionrios de acordo com os // seguintes critrios: // a) 50% para aqueles que ganham menos do que trs salrios mnimos; // b) 20% para aqueles que ganham entre trs at dez salrios mnimos; // c) 15% para aqueles que ganham acima de dez at vinte salrios mnimos; // d) 10% para os demais funcionrios. // Leia o nome do funcionrio, seu salrio e o valor do salrio mnimo. Calcule o seu novo salrio reajustado. Escrever o // nome do funcionrio, o reajuste e seu novo salrio. Calcule quanto empresa vai aumentar sua folha de pagamento. // Autor : // Data : 1/12/2010 // Seo de Declaraes var salarioMinimo, novoSalario, reajuste, reajusteTotal, folha, novaFolha, calc, salario: real nome, opc: caractere x: inteiro inicio // Seo de Comandos opc <- "x" escreval("<><><><><> Sistema de reajuste salarial <><><><><>") escreva("Digite o valor atual do salrio mnimo: ") leia(salarioMinimo) para x de 1 ate 584 faca limpatela escreva("Digite o nome: ") leia(nome) escreva("Digite o salrio: ") leia(salario) calc <- salarioMinimo * 3

se salario < calc entao reajuste <- 0.50 // Reajuste de 50% reajusteTotal <- reajuste + (reajuste * salario) // Valor total de reajuste folha <- folha + salario // Folha de pagamento antiga novoSalario <- salario + (reajuste * salario) // Salrio reajustado novaFolha <- novaFolha + novoSalario // Nova folha de pagamento limpatela escreval(">>> Nome: ",nome) escreval(">>> Reajuste = 50%: ",reajuste*salario) escreval(">>> Novo salrio: ",novoSalario) escreval(">>> Tecle enter para continuar...") leia(opc) senao calc <- salarioMinimo * 10 se salario <= calc entao reajuste <- 0.20 // Reajuste de 20% reajusteTotal <- reajuste + (reajuste * salario) // Valor total de reajuste folha <- folha + salario // Folha de pagamento antiga novoSalario <- salario + (reajuste * salario) // Salrio reajustado novaFolha <- novaFolha + novoSalario // Nova folha de pagamento limpatela escreval(">>> Nome: ",nome) escreval(">>> Reajuste = 20%: ",reajuste*salario) escreval(">>> Novo salrio: ",novoSalario) escreval(">>> Tecle enter para continuar...") leia(opc) senao calc <- salarioMinimo * 20 se salario <= calc entao reajuste <- 0.15 // Reajuste de 15% reajusteTotal <- reajuste + (reajuste * salario) // Valor total de reajuste folha <- folha + salario // Folha de pagamento antiga novoSalario <- salario + (reajuste * salario) // Salrio reajustado novaFolha <- novaFolha + novoSalario // Nova folha de pagamento limpatela escreval(">>> Nome: ",nome) escreval(">>> Reajuste = 15%: ",reajuste*salario) escreval(">>> Novo salrio: ",novoSalario) escreval(">>> Tecle enter para continuar...") leia(opc) senao

reajuste <- 0.10 // Reajuste de 10% reajusteTotal <- reajuste + (reajuste * salario) // Valor total de reajuste folha <- folha + salario // Folha de pagamento antiga novoSalario <- salario + (reajuste * salario) // Salrio reajustado novaFolha <- novaFolha + novoSalario // Nova folha de pagamento limpatela escreval(">>> Nome: ",nome) escreval(">>> Reajuste = 10%: ",reajuste*salario) escreval(">>> Novo salrio: ",novoSalario) escreval(">>> Tecle enter para continuar...") leia(opc) fimse fimse fimse fimpara escreval("") escreval("A empresa aumentou a folha de pagamento em:",novaFolha - folha," Reais") algoritmo "ex29" // Funo : Faa um algoritmo que receba o nmero do ms e mostre o ms correspondente. Valide ms invlido // Autor : // Data : 1/12/2010 // Seo de Declaraes var mes: inteiro inicio // Seo de Comandos escreval("Digite o nmero do ms: ") leia(mes) escolha mes caso 1 escreval("Janeiro") caso 2 escreval("Fevereiro") caso 3 escreval("Maro") caso 4 escreval("Abril") caso 5 escreval("Maio") caso 6 escreval("Junho") caso 7 escreval("Julho") caso 8 escreval("Agosto") caso 9 escreval("Setembro")

caso 10 escreval("Outubro") caso 11 escreval("Novembro") caso 12 escreval("Dezembro") outrocaso escreval("Ms invlido!") fimescolha algoritmo "ex30" // Funo : Faa um algoritmo que receba o nome a idade, o sexo e salrio fixo de um funcionrio. Mostre o nome e o salrio lquido: // Autor : // Data : 1/12/2010 // Seo de Declaraes var nome, sexo: caractere idade, x: inteiro salario: real inicio // Seo de Comandos escreva("Digite o nome do funcionrio: ") leia(nome) x <- 1 enquanto x = 1 faca escreva("Digite o sexo (F/M): ") leia(sexo) se sexo <> "F" entao se sexo <> "M" entao x <- 1 senao x <- 0 fimse senao x <- 0 fimse fimenquanto escreva("Digite a idade: ") leia(idade) escreva("Digite o salrio: ") leia(salario) se sexo = "M" entao se idade >= 30 entao salario <- salario + 100 senao salario <- salario + 50 fimse senao se idade >= 30 entao salario <- salario + 200 senao salario <- salario + 80 fimse fimse limpatela

escreval(">>> Nome: ",nome) escreval(">>> Salrio: ",salario) algoritmo "ex31" // Funo : Escrever um algoritmo que leia trs valores inteiros distintos e os escreva em ordem crescente // Autor : // Data : 1/12/2010 // Seo de Declaraes var num1, num2, num3: inteiro ordena: vetor[1..3] de inteiro inicio // Seo de Comandos escreva("Digite o primeiro nmero: ") leia(num1) escreva("Digite o segundo nmero: ") leia(num2) escreva("Digite o terceiro nmero: ") leia(num3) se num1 > num2 entao ordena[3] <- num1 ordena[2] <- num2 se num3 > num1 entao ordena[3] <- num3 ordena[2] <- num1 ordena[1] <- num2 senao se num3 > num2 entao ordena[3] <- num1 ordena[2] <- num3 ordena[1] <- num2 senao ordena[3] <- num1 ordena[2] <- num2 ordena[1] <- num3 fimse fimse senao ordena[3] <- num2 ordena[2] <- num1 se num3 > num2 entao ordena[3] <- num3 ordena[2] <- num2 ordena[1] <- num1 senao se num3 > num1 entao ordena[3] <- num2 ordena[2] <- num3 ordena[1] <- num1 senao ordena[3] <- num2 ordena[2] <- num1 ordena[1] <- num3 fimse fimse fimse

escreval("Os nmeros em ordem crescente so: ") escreval(">",ordena[1]) escreval(">",ordena[2]) escreval(">",ordena[3]) algoritmo "ex32" // Funo : Dados trs valores A, B e C, em que A e B so nmeros reais e C um caractere, pede-se para imprimir o resultado // da operao de A por B se C for um smbolo de operador aritmtico; caso contrrio deve ser impressa uma // mensagem de operador no definido. Tratar erro de diviso por zero. // Autor : // Data : 1/12/2010 // Seo de Declaraes var A, B: real C: caractere inicio // Seo de Comandos escreva("Digite o primeiro nmero: ") leia(A) escreva("Digite o segundo nmero: ") leia(B) escreva("Digite a operao desejada (+ - / *): ") leia(C) escolha C caso "+" escreval("A+B =",A+B) caso "-" escreval("A-B =",A-B) caso "*" = escreval("A*B =",A*B) caso "/" se B = 0 entao escreval("Erro, um nmero no pode ser dividido por 0!") senao escreval("A/B =",A/B) fimse outrocaso escreval("Operador no definido!") fimescolha algoritmo "ex33" // Funo : Escrever um algoritmo que leia trs valores inteiros e verifique se eles podem ser os lados de um tringulo. Se // forem, informar qual o tipo de tringulo que eles formam: equiltero, isscele ou escaleno // Autor : // Data : 1/12/2010 // Seo de Declaraes var la, lb, lc, triangulo: inteiro inicio

// Seo de Comandos escreva("Digite o lado A do tringulo: ") leia(la) escreva("Digite o lado B do tringulo: ") leia(lb) escreva("Digite o lado C do tringulo: ") leia(lc) se la < (lc+lb) entao triangulo <- 1 senao se lb < (lc + la) entao triangulo <- 1 senao se lc < (lb + la) entao triangulo <- 1 fimse fimse fimse se triangulo = 1 entao se la = lb entao se lb = lc entao escreval(" um tringulo equiltero!") senao escreval(" um tringulo isrcele") fimse senao se lb = lc entao escreval(" um tringulo isrcele") senao escreval(" um tringulo escaleno") fimse fimse fimse algoritmo "ex34" // Funo : A escola \u201cAPRENDER\u201d faz o pagamento de seus professores por hora/aula. Faa um algoritmo que calcule e exiba o // salrio de um professor. Sabe-se que o valor da hora/aula segue a tabela abaixo: // Professor Nvel 1 R$12,00 por hora/aula // Professor Nvel 2 R$17,00 por hora/aula // Professor Nvel 3 R$25,00 por hora/aula // Autor : // Data : 1/12/2010 // Seo de Declaraes var nivel, horas: inteiro inicio // Seo de Comandos escreval(">>>>> Escola APRENDER <<<<<") escreva("Digite o nvel do professor (1/2/3): ") leia(nivel) escreva("Digite o nmero de horas trabalhadas: ") leia(horas) se nivel = 1 entao

escreval("O professor ganha",horas*12) senao se nivel = 2 entao escreval("O professor ganha",horas*17) senao escreva("O professor ganha",horas*25) fimse fimse algoritmo "ex35" // Funo : // Autor : // Data : 1/12/2010 // Seo de Declaraes var idade: inteiro inicio // Seo de Comandos escreva("Digite a idade do nadador: ") leia(idade) escolha idade caso 5,6,7 escreval("Infantil A") caso 8,9,10 escreval("Infantil B") caso 11,12,13 escreval("Juvenil A") caso 14,15,16,17 escreval("Juvenil B") caso 18,19,20,21,22,23,24,25 escreval("Snior") outrocaso escreval("Idade fora da faixa etria") fimescolha algoritmo "ex36" // Funo : // Autor : // Data : 1/12/2010 // Seo de Declaraes var residencia, kw: inteiro consumo: real inicio // Seo de Comandos escreval("Informe o tipo de residncia: ") escreval("1 - Residncia") escreval("2 - Comrcio") escreval("3 - Indstria") leia(residencia) escolha residencia caso 1 escreva("Informe a quantidade de KW gastos no ms: ") leia(kw) consumo <- kw * 0.60 escreval("Valor da conta: ",consumo)

caso 2 escreva("Informe a quantidade de KW gastos no ms: ") leia(kw) consumo <- kw * 0.48 escreval("Valor da conta: ",consumo) caso 3 escreva("Informe a quantidade de KW gastos no ms: ") leia(kw) consumo <- kw * 1.29 escreval("Valor da conta: ",consumo) outrocaso escreval("Tipo de residncia invlido!") fimescolha algoritmo "ex37" // Funo : // Autor : // Data : 1/12/2010 // Seo de Declaraes var nome, sexo: caractere idade, x: inteiro altura, peso: real inicio // Seo de Comandos escreva("Digite o nome: ") leia(nome) x <- 1 enquanto x = 1 faca escreva("Digite o sexo (F/M): ") leia(sexo) se sexo = "F" entao x <- 0 fimse se sexo = "M" entao x <- 0 fimse fimenquanto escreva("Digite a altura: ") leia(altura) escreva("Digite a idade: ") leia(idade) se sexo = "M" entao se altura > 1.70 entao se idade <= 20 entao peso <- (72.7 * altura) - 58 senao se idade <= 39 entao peso <- (72.7 * altura) - 53 senao peso <- (72.7 * altura) - 45 fimse fimse senao se altura <= 1.70 entao

se idade <= 40 entao peso <- (72.7 * altura) - 50 senao peso <- (72.7 * altura) - 58 fimse fimse fimse senao se altura > 1.50 entao peso <- (62.1 * altura) - 44.7 senao se idade >= 35 entao peso <- (62.1 * altura) - 45 senao peso <- (62.1 * altura) - 49 fimse fimse fimse limpatela escreval("Nome: ",nome) escreval("Peso Ideal: ",peso) algoritmo "ex38" // Funo : // Autor : // Data : 1/12/2010 // Seo de Declaraes var nota1, nota2, nota3: real media: real nome, classificacao: caractere matricula: inteiro inicio // Seo de Comandos escreva("Digite o nome: ") leia(nome) escreva("Informe a matrcula: ") leia(matricula) escreva("Digite a nota do trabalho de laboratrio: ") leia(nota1) escreva("Digite a nota da avaliao semestral: ") leia(nota2) escreva("Digite a nota do exame final: ") leia(nota3) media <- ((nota1 * 2) + (nota2 * 3) + (nota3 * 5))/10 se media >= 8.10 entao classificacao <- "A" senao se media >= 7.8 entao classificacao <- "B" senao se media >= 6.7 entao classificacao <- "C" senao se media >= 5.6 entao

classificacao <- "D" fimse fimse fimse fimse se media < 5.6 entao classificacao <- "R" fimse limpatela escreval("Nome: ",nome) escreval("Matrcula: ",matricula) escreval("Nota final: ",media) escreval("Classificao: ",classificacao) algoritmo "ex39" // Funo : // Autor : // Data : 1/12/2010 // Seo de Declaraes var idade, grupo: inteiro nome, grupoRisco: caractere inicio // Seo de Comandos escreva("Digite o nome: ") leia(nome) escreva("Digite a idade: ") leia(idade) escreval("Informe o Grupo de risco: ") escreval("(B)aixo / (M)dio / (A)lto ") leia(grupoRisco) se (idade >= 17) e (idade <= 70) entao se idade <= 20 entao escolha grupoRisco caso "B" grupo <- 1 caso "M" grupo <- 2 caso "A" grupo <- 3 fimescolha senao se idade <= 24 entao escolha grupoRisco caso "B" grupo <- 2 caso "M" grupo <- 3 caso "A" grupo <- 4 fimescolha senao se idade <= 34 entao escolha grupoRisco caso "B" grupo <- 3

caso "M" grupo <- 4 caso "A" grupo <- 5 fimescolha senao se idade <= 64 entao escolha grupoRisco caso "B" grupo <- 4 caso "M" grupo <- 5 caso "A" grupo <- 6 fimescolha senao escolha grupoRisco caso "B" grupo <- 2 caso "M" grupo <- 3 caso "A" grupo <- 4 fimescolha fimse fimse fimse fimse senao escreval("Idade fora da cobertura!") fimse escreval("Nome: ",nome) escreval("Idade: ",idade) escreval("Categoria: ",grupo) algoritmo "ex40" // Funo : // Autor : // Data : 1/12/2010 // Seo de Declaraes var mat1: vetor[1..4,1..4] de inteiro mat2: vetor[1..4,1..4] de inteiro x, y: inteiro soma1, soma2: inteiro inicio // Seo de Comandos // Recebimento dos valores da matriz para x de 1 ate 4 faca para y de 1 ate 4 faca escreva("Digite o valor",x,"-",y,": ") leia(mat1[x,y]) fimpara fimpara

// Troca entre as posies entre duas matrizes para x de 1 ate 4 faca mat2[1,x] <- mat1[4,x] mat2[4,x] <- mat1[1,x] fimpara para x de 1 ate 4 faca mat2[2,x] <- mat1[2,x] mat2[3,x] <- mat1[3,x] fimpara // Impresso dos valores das matrizes limpatela escreval("Matriz original: ") para x de 1 ate 4 faca escreval(mat1[x,1],mat1[x,2],mat1[x,3],mat1[x,4]) fimpara escreval("Matriz modificada: ") para x de 1 ate 4 faca escreval(mat2[x,1],mat2[x,2],mat2[x,3],mat2[x,4]) fimpara escreval("") // Soma entre os termos das matrizes para x de 1 ate 4 faca para y de 1 ate 4 faca soma1 <- soma1 + mat1[x,y] fimpara fimpara para x de 1 ate 4 faca para y de 1 ate 4 faca soma2 <- soma2 + mat2[x,y] fimpara fimpara // Resultado final escreval("") escreval("Soma da matriz 1 + matriz 2 = ",soma1+soma2) escreval("Soma dos valores da matriz 1 menos a soma da matriz 2 = ",soma1-soma2)