Você está na página 1de 11
Programa da Cisco Networking Academy M M ÓDULO ÓDULO 2 2 P P RINCIPAIS RINCIPAIS

Programa da Cisco Networking Academy

Programa da Cisco Networking Academy M M ÓDULO ÓDULO 2 2 P P RINCIPAIS RINCIPAIS COMANDOS

MMÓDULOÓDULO 22

PPRINCIPAISRINCIPAIS COMANDOSCOMANDOS DODO IOSIOS

1. Comandos show

2. Gerenciamento do IOS

3. Configuração de Interfaces

4. Conhecimento de Vizinhos

5. Configuração do roteamento

6. Listas de Acesso Padrão e Estendida

Índice

Índice
PARTE 1 – Comandos Básicos e Modos do Roteador 1 1.1 – Comandos Básicos O

PARTE 1 – Comandos Básicos e Modos do Roteador

1 1.1 – Comandos Básicos

O IOS fornece ajuda aos comandos em todos os modos. Digitando-se cl? o prompt responde com todos os comandos que iniciam com cl no modo atual.

1 Router> history size

Descrição: define o tamanho do buffer de comandos. Máximo de 256 comandos.

o tamanho do buffer de comandos. Máximo de 256 comandos. 2 Router> no terminal editing Descrição

2 Router> no terminal editing

Descrição: desativa o modo de edição avançada (desativa teclas de atalho)

Teclas do modo de edição avançado

teclas de atalho) Teclas do modo de edição avançado 3 Router> en ou enable Descrição :

3 Router> en ou enable

Descrição: Acessa o modo executivo privilegiado ou modo de ativação.

4 Router# dis ou disable

Descrição: Volta para o modo EXEC de usuário onde não são permitidas alterações no roteador. Normalmente utilizadas para monitoramento do router.

5 Router> show flash ou sh flash

Descrição: visualiza a quantidade de memória flash disponível

6 Router> copy tftp flash

Descrição: copia uma nova versão do CISCO IOS para a memória flash instalada. Serão requisitados o endereço IP do servidor TFTP, o nome do arquivo de origem e o nome do arquivo de destino no roteador.

7 Router> clock set <hora hh:mm:ss> <dia mês ano>

Descrição: acerta o relógio do roteador

2 1.2 - Modos do roteador:

2 1.2 - Modos do roteador: 3 ROM Monitor 8 ROMMON> Descrição : Permite recuperação de

3

ROM Monitor

8

ROMMON>

Descrição: Permite recuperação de senhas e operações de baixo nível para diagnóstico do equipamento CISCO. Acessado apenas pelo console de gerenciamento

4

Boot ROM

9

Router(boot)>

Descrição: Permite a atualização do CISCO IOS na memória FLASH

5

Cisco IOS

10

Router>

Descrição: Operação normal para os modos EXEC e EXEC privilegiado

6 2.1 – Comandos Básicos de Configuração

2.1.1 – Nome do roteador e senhas

11 Router(config)#hostname Tokyo

Tokyo(config)#

Descrição: nomeia ou renomeia um roteador. No exemplo nomeado para Tokyo.

Router(config)#line console 0

Router(config-line)#password <senha>

Router(config-line)#login

Descrição: Define a senha para a linha de console. Ela será pedida quando da conexão por Console.

Router(config)#line vty 0 4

Router(config-line)#password <senha>

Router(config-line)#login

Descrição: Define a senha para a linha de telnet. A linha acima define a mesma senha para 5 linhas de conexão Telnet

Router(config)#enable password <senha>

Descrição: Define a senha de ativação que não usa criptografia.

Router(config)#enable secret <senha>

Descrição: Define o segredo de ativação que usa criptografia MD5. Precedente em relação à senha de ativação.

Router(config)#service password-encryption

Descrição: Impede a visualização das senhas pela comando show

2.1.2 – Comandos Show e configuração de rede

2.1.2 – Comandos Show e configuração de rede 12 Router> show version ou sh ver

12

Router> show version ou sh ver

Descrição: visualiza características do IOS da Cisco e de hardware com o processador, memória RAM, memória FLASH, etc. Este comando exibe:

Versão e informações descritivas do IOS em uso; Versão da Bootstrap ROM; Versão da Boot ROM; Tempo decorrido desde a

inicialização do roteador; Método utilizado na última reinicialização do roteador; Arquivo da imagem do sistema em uso e sua localização; Plataforma de hardware do roteador e Valor do configuration register.

Router#show ip interface brief

Descrição: Exibe a descrição resumida das uma interfaces, status, endereçamento utilizado

Router#show interfaces

Descrição: Exibe a descrição das uma interfaces, status, endereçamento utilizado e outras características de todas as interfaces do roteador. Este comando pode ser resumindo com o acréscimo do nome de uma interface específica

Router(config)#interface serial 0/0

Router(config-if)#ip address <endereço IP> <máscara de rede>

Descrição: Configura o endereço IP de uma interface serial. A máscara deve ser digitada octeto por octeto pois o IOS não aceita resumo por barras.

Router(config)#interface serial 0/0

Router(config-if)#clock rate 56000

Router(config-if)#no shutdown

Descrição: Configura o clock rate para uma porta serial. Necessário para a simulação em laboratório. Uma das interfaces seriais devem simular o dispositivo DCE.

Router(config)#interface FastEthernet 0/0

Router(config-if)#ip address <endereço IP> <máscara de rede> Router(config-if)#no shutdown

Descrição: Configura o endereço IP de uma interface FastEthernet. A máscara deve ser digitada octeto por octeto pois o IOS não aceita resumo por barras.

Router(config)#interface FastEthernet 0/0

Router(config-if)#description <descrição da interface>

Descrição: Define uma descrição para uma interface. Este comando pode ser utilizado em uma interface serial

Router#copy running-config startup-config

Descrição: Salva a configuração atual na NVRAM

Router#erase startup-config

Descrição: Apaga a configuração gravada na NVRAM

Router(config)#banner motd # <Aqui vai a mensagem do dia> #

Descrição: Define um banner de login exibido na inicialização do roteador

Router(config)#ip host computador1 192.168.1.23

Descrição: Associa o nome de um computador a um endereço IP. Serve apenas para resolução de nomes para o roteador, ou seja não funciona como servidor DNS para a rede.

Router# show hosts

Router#show hosts

Descrição: Mostra a tabela de hosts configurada no roteador

PARTE 2 – Descoberta dos Vizinhos CISCO

7 3 – Cisco Discovery Protocol e Telnet

3.1 – Cisco Discovery Protocol

Router#show cdp

Descrição: Exibe o intervalo entre transmissões de anúncios, tempo de vida do anúncio e a versão do CDP utilizada localmente

Router#show cdp interface

Descrição: Exibe informações sobre o CDP nas interfaces locais.

Router#show cdp neighbors

Descrição: Mostra a tabela resumida de dispositivos vizinhos

: Mostra a tabela resumida de dispositivos vizinhos ID ou nome ID ou nome do dispositivo

ID ou nome

ID ou nome

do dispositivo

do dispositivo

vizinho

vizinho

Interface local

conectada ao

dispositivo vizinho

Tempo que a atualização estará disponível

Plataforma

Plataforma

do dispositivo

do dispositivo

conectado

conectado

Interface

Interface

conectada do

conectada do

dispositivo

dispositivo

vizinho

vizinho

Router#show cdp neighbors detail

Descrição: Mostra a tabela detalhada de dispositivos vizinhos

Router#show cdp entry <id do dispositivo>

Descrição: Mostra a tabela detalhada de um dispositivos específico definido no campo id do dispositivo

Router(config)#cdp run

Descrição: Ativa globalmente o CDP no roteador ou switch CISCO

Router(config-if)#cdp enable

Descrição: Ativa o CDP em uma interface específica em um roteador ou switch CISCO

Router(config)#no cdp run

Descrição: Desativa globalmente o CDP no roteador ou switch CISCO

Router(config-if)#no cdp enable

Descrição: Desativa o CDP em uma interface específica em um roteador ou switch CISCO

Router#telnet <IP> ou <id do dispositivo>

Descrição: Faz uma conexão Telnet a um dispositivo remoto

Descrição : mostra quais sessões Telnet estão ocorrendo. As tecla < CTRL > < SHIFT

Descrição: mostra quais sessões Telnet estão ocorrendo.

As tecla <CTRL> <SHIFT> <6> <x> suspendem uma sessão Telnet

PARTE 3 – Gerenciamento do CISCO IOS

8 4 – Gerenciamento do CISCO IOS

router(config)#boot system flash

Descrição: Define o boot pelo IOS gravado na memória FLASH. O configuration register deve ser configurado para 0x2102.

router(config)#boot system flash:C1700-y-mz.12.1-3.bin

Descrição: Define o boot por um IOS específico gravado na memória FLASH. O configuration register deve ser configurado para 0x2102.

A memória Flash pode armazenar vários IOS e o administrador pode definir o boot por um IOS específico colocando no nome do IOS ao final do comando boot system flash:

router(config)#boot system tftp C1700-y-mz.12.1-3.bin 192.168.2.2

Descrição: Define o boot por um por um servidor TFTP. Para que este recurso funcione é necessário que a interface FastEthernet seja configurada anteriormente pelo modo de configuração de interface.

router(config)#boot system rom

Descrição: Força a próxima inicialização no modo BootROM

router(config)#config-register 0x2102

Descrição: Configura a inicialização do roteador obedecer as instruções inseridas no comando boot system

router(config)#config-register 0x2100

Descrição: Força a inicialização no modo ROM Monitor.

router(config)#config-register 0x2142

Descrição: Modo de recuperção de senha. Ignora na inicialização as configurações salvas no startup-config. O roteador inicia com uma configuração limpa.

router#copy running-config tftp

Descrição: Copia para o servidor TFTP a configuração atual do roteador

router#copy tftp running-config

Descrição: Copia a configuração do servidor TFTP para o roteador. Para o acesso a um servidor TFTP pelo menos uma interface FastEthernet precisa estar configurada.

router#copy flash tftp

Descrição: Copia o IOS gravado na FLASH para o servidor TFTP.

Descrição: Copia o IOS gravado no servidor TFTP para a FLASH do roteador

Descrição: Copia o IOS gravado no servidor TFTP para a FLASH do roteador

PARTE 4 – Configurando Rotas 5 – Configuração de Rotas Estáticas

PARTE 4 – Configurando Rotas

5

– Configuração de Rotas Estáticas

routerconfig)#ip route 172.16.3.0 255.255.255.0 s0

Descrição: Configura uma rota para a rede 172.16.3.0/24 utilizando a porta serial 0 local como gateway.

Router(config)#ip route 172.16.3.0 255.255.255.0 172.16.4.1 130

Descrição: Configura uma rota para a rede 172.16.3.0/24 utilizando o endereço gateway (próximo salto) 172.16.4.1 com a distância administrativa 130

Observação: Para que uma rota estática funcione corretamente a rede destino deve possuir uma rota estática para sua rede.

Router#show ip route static

Descrição: mostra a tabela de roteamento apresentando apenas as rotas estáticas.

6

– Configuração do Protocolo de Roteamento Vetor de distância RIP

A) Configuração do RIP

router(config)#router rip – Seleciona o RIP como o protocolo de roteamento

router(config-router)#network 10.0.0.0 – Especifica uma rede conectada diretamente

router(config-router)#network 10.10.0.0 – Especifica uma rede conectada diretamente

Router(config)#no router rip

Descrição: elimina o protocolo de roteamento RIP.

Router(config-router)#no network 10.10.0.0

Descrição: elimina a rede 10.10.0.0 das atualizações RIP. Esta rede não será anunciada para outros roteadores.

Router(config-router)#distance 75

Descrição: altera a distância administrativa do RIP para 75 no modo de configuração do RIP.

Router(config-router)#passive interface f0/0

Descrição: impede que o RIP envie atualizações através da interface f0/0

Router(config)#ip classless

Descrição: roteador recebe pacotes destinados a uma sub-rede desconhecida de uma rede que possui sub-redes conectadas diretamente. Para que o software Cisco IOS encaminhe esses pacotes à melhor rota de super-rede possível, use o comando de configuração global

B) Verificando a Configuração do RIP

Router#show ip protocols

Descrição: mostra que protocolos de roteamento estão transportando o tráfego IP no roteador.

Router#show ip route rip

Descrição: mostra a tabela de roteamento apresentando apenas as rotas aprendidas pelo RIP

Router#show running-config

Descrição: mostra a configuração realizada para o RIP

Router#debug ip rip

Descrição: mostra a atividade realizada para o RIP para envio e recebimento e atualizações de roteamento.

7 – Configuração do Protocolo de Roteamento Vetor de distância IGRP A) Configuração do IGRP

7 – Configuração do Protocolo de Roteamento Vetor de distância IGRP

A) Configuração do IGRP

router(config)#router igrp 101– Seleciona o igrp com o número do sistema autônomo como o protocolo de roteamento

router(config-router)#network 10.0.0.0 – Especifica uma rede conectada diretamente

router(config-router)#network 10.10.0.0 – Especifica uma rede conectada diretamente

Router(config)#no router igrp 101

Descrição: elimina o protocolo de roteamento IGRP.

B) Verificando a Configuração do IGRP

Router#show ip protocols

Descrição: mostra que protocolos de roteamento estão transportando o tráfego IP no roteador.

Router#show ip route igrp

Descrição: mostra a tabela de roteamento apresentando apenas as rotas aprendidas pelo IGRP

Router#show running-config

Descrição: mostra a configuração realizada para o IGRP

Router#debug ip igrp transactions

Descrição: mostra a atividade realizada para o IGRP para envio e recebimento e atualizações de roteamento.

7 – Configuração de Rotas Padrão

Router(config)#ip route 0.0.0.0 0.0.0.0 s0

Descrição: Configura uma rota padrão comutando os pacotes que não apresentam correspondência na tabela de roteamento para a interface s0.

Router(config)#redistribute static

Router(config)#  redistribute static

Descrição: Faz o protocolo de roteamento RIP enviar a rota padrão configurada estaticamente

Router(config)#ip default-network 192.168.17.0

Descrição: Elege a rede 192.168.17.0 como candidata a rota padrão. O RIP irá anunciar automaticamente esta rota para outros roteadores RIP.

PARTE 5 – Listas de Controle de Acesso 8 – Listas de Controle de Acesso

PARTE 5 – Listas de Controle de Acesso

8 – Listas de Controle de Acesso A)ACL Padrão

Router(config)#access-list 1 permit 192.168.4.2

Descrição: Cria uma lista de acesso padrão permitindo todo o trafego IP para o host 192.168.4.2

Router(config)#access-list 1 deny 192.168.4.2

Descrição: Cria uma lista de acesso padrão negando todo o trafego IP para o host 192.168.4.2

Router(config)#access-list 1 permit 192.168.4.0 0.0.0.255

Descrição: Cria uma lista de acesso padrão permitindo todo o trafego IP para a rede 192.168.4.0

Router(config)#access-list 1 permit any

Descrição: Permite acesso a qualquer pacote IP para a lista de acesso 1. Normalmente utilizada no final de uma ACL

Router(config)#access-list 1 permit any

Descrição: Permite acesso a qualquer pacote IP para a lista de acesso 1. Normalmente utilizada no final de uma ACL

Router(config-if)#ip access-group 1 out

Descrição: aplica a lista de acesso 1 para pacotes que saiam por uma interface. Acesse o modo de configuração da interface apropriada

Router(config-if)#ip access-group 1 in

Descrição: aplica a lista de acesso 1 para pacotes que entram por uma interface. Acesse o modo de configuração da interface apropriada

Router(config)# noaccess-list 1

Descrição: Elimina toda a lista de acesso 1

Router(config)# showaccess-lists

Descrição: mostra todas as listas de acesso criadas

A) ACL Estendida

Router(config)#access-list 101 permit tcp 192.168.4.2 any eq 23

Descrição: Cria uma lista de acesso estendida permitindo todo o trafego Telnet do host 192.168.4.2 para qualquer rede (any)

Router(config)#access-list 101 permit tcp 192.168.4.2 any eq 23

Descrição: Cria uma lista de acesso estendida permitindo todo o trafego Telnet do host 192.168.4.2 para qualquer rede (any)

Router(config)#access-list 101 permit tcp 192.168.4.0 0.0.0.255 any eq 23

Descrição: Cria uma lista de acesso estendida permitindo todo o trafego Telnet da rede 192.168.4.0 para qualquer rede (any)