Você está na página 1de 4

How to configure BGP using Route Reflectors?

When your network have grown and a full mesh isn't feasible n*(n-1)/2 where n = the number of iBGP speaking routers. If
we have 200 routers in our network that would give us 19900 BGP sessions. 

SOLUTIONS

   Route Reflectors
   Confederations

Using standard Internal Border Gateway Protocol (IBGP) configurations, all BGP systems within an Autonomous System
(AS) must peer with all other BGP systems, forming a full-mesh configuration. This presents scaling concerns, as all
external information must be propagated/distributed to all BGP systems within the AS, resulting in far more information
being shared between the IBGP peers then is necessary. BGP Route Reflectors (RR) provides a mechanism for both
minimizing the number of update messages transmitted within the AS, and reducing the amount of data that is propagated
in each message. The deployment of BGP Route Reflectors leads to much higher levels of network scalability.  

A ROUTE REFLECTOR REFLECTS IBGP ROUTING INFORMATION

♦ From clients to iBGP peers and other clients

♦ From iBGP peers to clients

♦ Never from iBGP peers to iBGP peers (as before)

♦ Should not change the attributes

   NEXT_HOP
   AS_PATH
   LOCAL_PREF
   MED

BASIC CONFIGURATION OF ROUTER-A


A(config)# interface serial 1/0
A(config-if)# ip address 1.1.1.1 255.0.0.0

A(config-if)# no shutdown

A(config-if)# interface ethernet 2/0

A(config-if)# ip address 200.100.50.1 255.0.0.0

A(config-if)# no shutdown

BASIC CONFIGURATION OF ROUTER-B


B(config)# interface serial 1/0

B(config-if)# ip address 1.1.1.2 255.0.0.0

B(config-if)# no shutdown

B(config-if)# clock rate 64000

B(config)# interface serial 1/1

B(config-if)# ip address 2.1.1.1 255.0.0.0

B(config-if)# no shutdown

B(config-if)# clock rate 64000  

BASIC CONFIGURATION OF ROUTER-C


C(config)# interface serial 1/1

C(config-if)# ip address 2.1.1.2 255.0.0.0

C(config-if)# no shutdown

C(config)# interface serial 1/0

C(config-if)# ip address 3.1.1.1 255.0.0.0

C(config-if)# no shutdown 

BASIC CONFIGURATION OF ROUTER-D


D(config)# interface serial 1/1

D(config-if)# ip address 3.1.1.2 255.0.0.0

D(config-if)# no shutdown

RUNNING EBGP AT ROUTER-A


A(config)# router bgp 10

A(config-router)# no synchronization
A(config-router)# neighbor 1.1.1.2 remote-as 20

A(config-router)# network 200.100.50.0  

RUNNING EBGP AT ROUTER-B


B(config)# router bgp 20

B(config-router)# no synchronization

B(config-router)# neighbor 1.1.1.1 remote-as 10

RUNNING OSPF AT ROUTER-B


B(config)# router ospf 1

B(config-router)# network 2.0.0.0 0.255.255.255 area 0

B(config-router)# network 1.0.0.0 0.255.255.255 area 0

RUNNING OSPF AT ROUTER-C


C(config)# router ospf 1

C(config-router)# network 2.0.0.0 0.255.255.255 area 0

C(config-router)# network 3.0.0.0 0.255.255.255 area 0 

RUNNING OSPF AT ROUTER-D


C(config)# router ospf 1

C(config-router)# network 3.0.0.0 0.255.255.255 area 0

RUNNING IBGP AT ROUTER-B


B(config)# router bgp 20

B(config-router)# no synchronization

B(config-router)# neighbor 1.1.1.1 remote-as 20

B(config-router)# neighbor 2.1.1.2 remote-as 20

RUNNING IBGP AT ROUTER-C


C(config)# router bgp 20

C(config-router)# no synchronization

C(config-router)# neighbor 2.1.1.1 remote-as 20

C(config-router)# neighbor 3.1.1.2 remote-as 20 


RUNNING IBGP AT ROUTER-D
D(config)# router bgp 20

D(config-router)# no synchronization

D(config-router)# neighbor 3.1.1.1 remote-as 20 

APPLYING ROUTE-REFLECTOR AT ROUTER-C


C(config)# router bgp 20

C(config-router)# neighbor 2.1.1.1 route-reflector-client

C(config-router)# neighbor 3.1.1.2 route-reflector-client

Você também pode gostar