Você está na página 1de 7

Comandos Bsicos de Roteadores

Cisco.
Configurando um nome.
Router>enable
Router#configure terminal
Router(config)#hostname ti-redes
ti-redes#

Configurando senha enable.
Router>enable
Router#configure terminal
Router(config)#enable password ti-redes

Configurando senha enable secret.
Router>enable
Router#configure terminal
Router(config)#enable secret ti-redes

Configurando senha da console.
Router>enable
Router#configure terminal
Router(config)#line console 0
Router(config-line)#password ti-redes

Configurando acesso telnet para 05 usurios.
Router>enable
Router#configure terminal
Router(config)#line vty 0 4
Router(config-line)#login
Router(config-line)#password ti-redes

Configurando IP na interface ethernet.
Router>enable
Router#configure terminal
Router(config)#interface ethernet 0/1
Router(config-if)#ip address 192.168.1.1 255.255.255.0
Router(config-if)#no shutdown

Configurando IP na interface fastethernet.
Router>enable
Router#configure terminal
Router(config)#interface fastEthernet 0/1
Router(config-if)#ip address 192.168.1.1 255.255.255.0
Router(config-if)#no shutdown

Configurando IP na interface serial.
Router>enable
Router#configure terminal
Router(config)#interface serial 0/1/0
Router(config-if)#ip address 192.168.1.1 255.255.255.0
Router(config-if)#clock rate 128000 (somente se a serial for DCE)
Router(config-if)#no shutdown

Configurando roteamento RIP v1.
Router#
configure terminal
Router(config)#router rip
Router(config-router)#network 192.168.1.0
Router(config-router)#network 10.0.0.0

Configurando uma rota default por ip do prximo salto.
Router#configure terminal
Router(config)#ip route 0.0.0.0 0.0.0.0 192.168.1.1

Configurando rota default por interface.
Router#configure terminal
Router(config)#ip route 0.0.0.0 0.0.0.0 serial 0/1/0

Configurando rota esttica por ip do prximo salto.
Router#configure terminal
Router(config)#ip route 192.168.0.0 255.255.255.0 192.168.1.1

Configurando rota esttica por interface.
Router#configure terminal
Router(config)#ip route 192.168.0.0 255.255.255.0 serial 0/0

Configurando roteamento entre vlans.
Router>enable
Router#configure terminal
Router(config)#interface fastEthernet 0/1
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#interface fastEthernet 0/0.1 (ID da sub-interface)
Router(config-subif)#encapsulation dot1Q 10 (ID da vlan)
Router(config-subif)#ip address 192.168.1.1 255.255.255.0
Router(config-subif)#exit
Router(config)#interface fastEthernet 0/0.2 (ID da sub-interface)
Router(config-subif)#encapsulation dot1Q 20 (ID da vlan)
Router(config-subif)#ip address 192.168.2.1 255.255.255.0

Comandos de verificao e diagnstico.
Router#show ?
(O comando show ? fornece uma lista dos comandos show disponveis)

Router#show arp
(Exibe a tabela ARP do roteador)

Router#sh interfaces
(Verifica detalhadamente as configuraes das interfaces)

Router#sh ip interface brief
(Verifica resumidamente as configuraes das interfaces)

Router#sh ip route
(Verifica a tabela de roteamento)

Router#sh running-config
(Verifica as configiraes ativas na RAM)

Router#sh startup-config
(Verifica as configuraes da NVRAM)

Router#sh flash:
(Verifica os arquivos de sistema operacional da Flash)

Router#copy running-config startup-config
(Salva as configuraes ativas na RAM para a NVRAM)


Configurao de Nome e Senha Enable
em Roteadores Cisco
Colocar um "nome" em um roteador uma configurao simples e til, imagine voc
gerenciando 50 roteadores sem que nenhum deles tenham uma identificao de localidade ou
de funo, voc faz um acesso remoto e no sabe se realmente est acessando o
equipamento correto.
Uma outra configurao simples e importante a configurao da senha enable ou enable
secret, ambas senhas possuem a mesma funo (proteger o acesso ao modo privilegiado do
roteador) a diferena que a senha enable mostra a senha configurada em texto claro nas
configuraes do roteador e a senha enable secret mostra a senha criptografada. Ao
configurar uma senha enable secret ela ir sobrepor a senha enable por oferecer maior
segurana.

Veja abaixo como realizado as configuraes de "nome" e das senhas enable e enable
secret:
- Configurando um nome -
Router>enable (muda do modo usurio para o privilegiado)
Router#configure terminal (muda do modo privilegiado para o de configurao global)
Router(config)#hostname ti-redes (configura o nome ti-redes)
ti-redes#

- Configurando a senha enable (senha texto claro) -
Router>enable (muda do modo usurio para o privilegiado)
Router#configure terminal (muda do modo privilegiado para o de configurao global)
Router(config)#enable password 1234 (configura a senha enable para 1234)

- Configurando a senha enable secret (senha criptografada )-
Router>enable (muda do modo usurio para o privilegiado)
Router#configure terminal (muda do modo privilegiado para o de configurao global)
Router(config)#enable secret 4321 (configura a senha enable criptografada para 4321)

- Comandos de verificao e diagnstico-
Router#show running-config (verifica as configuraes ativas no roteador running-config
=RAM do roteador)

Comandos Bsicos de Switches Cisco
Configurando um nome
Switch>enable
Switch#configure terminal
Switch(config)#hostname ti-redes
ti-redes#

Configurando senha enable
Switch>enable
Switch#configure terminal
Switch(config)#enable password ti-redes

Configurando senha enable secret
Router>enable
Router#configure terminal
Router(config)#enable secret ti-redes

Configurando senha da console
Router>enable
Router#configure terminal
Router(config)#line console 0
Router(config-line)#password ti-redes

Configurando acesso telnet para 05 usurios-
Switch>enable
Switch#configure terminal
Switch(config)#line vty 0 4
Switch(config-line)#login
Switch(config-line)#password ti-redes

Configurando o endereo IP do switch-
Switch>enable
Switch#configure terminal
Switch(config)#interface vlan 1
Switch(config-if)#ip address 1.0.0.1 255.255.255.0
Switch(config-if)#no shutdown

Configurando o gateway do switch
Switch>enable
Switch#configure terminal
Switch(config)#ip default-gateway 1.0.0.2

Configurando vlan no switch
Switch>enable
Switch#configure terminal
Switch(config)#vlan 10
Switch(config-vlan)#name dep-administrativo
Switch(config-vlan)#exit
Switch(config)#
Switch(config)#interface fastEthernet 0/1
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 10
Switch(config-if)#exit
Switch(config)#exit
Switch#sh vlan

Configurando trunk no switch
Switch>enable
Switch#configure terminal
Switch(config)#interface fastEthernet 0/1
Switch(config-if)#switchport mode trunk

Comandos de verificao e diagnstico-
Switch#show ?
(O comando show ? fornece uma lista dos comandos show disponveis)

Switch#show arp
(Exibe a tabela ARP do roteador)

Switch#sh interfaces
(Verifica detalhadamente as configuraes das interfaces)

Switch #sh ip interface brief
(Verifica as configuraes das interfaces)

Switch#show mac-address-table dynamic
(Verifica a tabela de endereamento MAC)

Switch#show vlan
(Exibe as vlans configuradas)

Switch #sh running-config
(Verifica as configiraes ativas na RAM)

Switch#sh startup-config
(Verifica as configuraes da NVRAM)

Switch#sh flash:
(Verifica os arquivos de sistema operacional da Flash)

Switch#copy running-config startup-config
(Salva as configuraes ativas na RAM para a NVRAM)


Recuperao de Senha de Switch Cisco
Catalyst Srie 2900
Neste procedimento vamos realizar a recuperao de senhas de switches Cisco Catalyst Srie
2900 mantendo as configuraes existentes, ou seja, caso o switch tenha configuraes como
vlans, stp, vtp, span entre outras as mesmas sero mantidas mesmo aps o procedimento de
recuperao do acesso ao switch.

1) Desligue o switch e ligue-o novamente mantendo pressionado o boto MODE


2) Para inicializar o sistema de arquivos e concluir a carga do sistema operacional, digite os
seguintes comandos:

flash_init
load_helper
dir flash:

3) Renomeia o arquivo de configurao que contm as senhas.

rename flash:config.text flash:config.old

4) Faa um dir flash: e veja que o arquivo confg.text foi renomeado para confg.old

5) Inicialize o sistema

boot

6)Digite N no prompt de dialogo do Setup ou digite Ctrl+c.

Continue with the configuration dialog? [yes/no]: N

7) Renomeia o arquivo de configurao com o nome original.

Switch#rename flash:config.old flash:config.text

8) Copie o arquivo de configurao para memria RAM:

Switch#copy flash:config.text system:running-config

9)Modifique as antigas senhas desconhecidas da seguinte maneira:

Switch#configure terminal
Switch(config)#enable secret ti-redes
Switch(config)#line console 0
Switch(config-line)#password ti-redes
Switch(config-line)#exit
Switch(config)#line vty 0 15
Switch(config-line)#password ti-redes
Switch(config-line)#exit
Switch(config)#exit
Switch#copy running-config startup-config

10) Reinicie ou desligue/ligue o switch e certifique-se de que as senhas j estejam
funcionando. Caso negativo, refaa os passos acima novamente.

Configurando SSH em Roteadores
Cisco
Router>enable
Router#configure terminal
Router(config)#hostname ti-redes
ti-redes(config)# ip domain-name ti-redes.com (utilizado para o nome da chave rsa)
ti-redes(config)# crypto key generate rsa (cria uma chave de criptografia rsa, escolha a
quantidade de bits)
ti-redes(config)# ip ssh time-out 60 (tempo para fechar a sesso caso o usurio fique sem
utilizar a conexo)
ti-redes(config)# ip ssh authentication-retries 2 (nmero mximo de re-tentativas de acesso)
ti-redes(config)# username lucas priv 15 secret 1234 (cria um usurio lucas com privilgio
15 e senha secret 1234, voc pode criar diversos usurios com outros privilgios)
ti-redes(config)# line vty 0 4 (entra na configurao de telnet)
ti-redes(config)#login local (utiliza autenticao local)
ti-redes(config-line)# transport input ssh (acesso telnet passa a ser via ssh)

Comandos de verificao e diagnstico

Router#debug ip ssh
(mostra as mensagens de debug do ssh)

Router#show ssh
(mostra o status das conexes ssh)

Router#show ip ssh
(mostra a verso e configurao ip do ssh)


Ler mais: http://www.ti-redes.com/gerenciamento/ssh/roteadores-cisco/