Você está na página 1de 8

Application Notes: DHCP Relay

Funcionamento do DHCP Relay


Application Notes: DHCP Relay
Funcionamento do DHCP Relay
Documento de Uso Pblico. Data 29/10/2009
Parecer
Introduo
Desenvolvimento
Funcionamento do DHCP
Funcionamento do DHCP Relay
Configurao do Servidor DHCP
Configurao do DHCP Relay
Configurao do DHCP Relay com Option 82
Configurao do Servidor DHCP para utilizar o Option 82
Aplicao
Parecer
Este documento visa mostrar a configurao, explicao e um exemplo de aplicao da feature DHCP
Relay existente na linha DM3000 e DM4000 dos switches DATACOM.
Introduo
O Protocolo DHCP (Dynamic Host Configuration Protocol) utiliza pacotes UDP (User Datagram
Protocol) Broadcast para atribuir endereo IPs aos clientes, devido a equipamentos da camada 3 Rede no
encaminharem Broadcasts para outras redes ser necessrio ter um servidor DHCP para cada rede, no
entanto com a utilizao da feature DHCP Relay elimina esta necessidade.
Desenvolvimento
Funcionamento do DHCP
Diagrama de funcionamento do DHCP
Documento de Uso Pblico DATACOM 1
1. O cliente DHCP envia um pacote DHCP Discover (Broadcast).
2. O servidor DHCP responde com um pacote DHCP Offer (Unicast), esta mensagem inclui o IP
oferecido ao cliente, o endereo gateway default, o lease time para este endereo IP, entre outros
parmetros.
3. O cliente responde com o pacote DHCP Request (Broadcast), esta mensagem a solicitao por parte
do cliente ao endereo IP fornecido anteriormente pelo DHCP Offer.
4. O Servidor DHCP responde com ACK (Unicast) confirmando que o IP ser cedido ao cliente.
Funcionamento do DHCP Relay
Diagrama de funcionamento do DHCP Relay
Documento de Uso Pblico DATACOM 2
Com a utilizao do DHCP Relay os pacotes do Cliente so enviados da mesma forma que anteriormente,
porm os pacotes entre o switch e o servidor so Unicast, o switch utiliza o IP da Vlan em que o servidor
se encontra para enviar as mensagens DHCP Discover e DHCP Request e o servidor responde as
mensagens DHCP Offer e DHCP ACK utilizando como IP de destino o IP do campo Relay agent IP
address do pacote DHCP.
Configurao do Servidor DHCP
A instalao e configurao do servidor DHCP mostrada neste documento foi executada no sistema
operacional Ubuntu 8.0.4 Long Term Support LTS.
apt-get install dhcp3-server

/etc/dhcp3/dhcpd.conf

ddns-updates off;

subnet 192.168.200.0 netmask 255.255.255.128 {
range 192.168.200.3 192.168.200.126;
}

subnet 192.168.200.128 netmask 255.255.255.128 {
range 192.168.200.130 192.168.200.254;
}

subnet 192.168.201.0 netmask 255.255.255.0 {
range 192.168.201.2 192.168.201.254;
}
Documento de Uso Pblico DATACOM 3
Configurao do DHCP Relay
1. Habilita o DHCP Relay globalmente.
ip dhcp relay
2. Depois de habilitar o DHCP Relay necessrio configurar para quais Vlans o relay ser ativado.
Habilita o relay em todas as Vlans
ip dhcp relay vlan all
Habilita o relay por Vlan
ip dhcp relay vlan 333
ip dhcp relay vlan 555
3. Habilitar o encaminhamento dos pacotes DHCP para o servidor DHCP.
ip helper-address 192.168.200.2
Configurao do DHCP Relay com Option 82
O protocolo DHCP baseia a atribuio de IP pelo Gateway IP Address GIADDR que o IP da interface do
switch na qual se comunica diretamente com os clientes, com a utilizao do Option 82, a atribuio do IP
ser feita pelo Circuit ID que no caso do switch DATACOM a identificao da VLAN, exemplo:
VLAN555 e no pelo GIADDR como normalmente feito.
Configurao do Servidor DHCP para utilizar o Option 82
/etc/dhcp3/dhcpd.conf

ddns-updates off;

class "VLAN333" {
match if (option agent.circuit-id = "VLAN333");
}

class "VLAN444" {
match if (option agent.circuit-id = "VLAN444");
}

class "VLAN555" {
match if (option agent.circuit-id = "VLAN555");
}

shared-network DATACOM {
interface eth5;

subnet 192.168.201.0 netmask 255.255.255.0 {
pool {
allow members of "VLAN333";
Documento de Uso Pblico DATACOM 4
range 192.168.201.2 192.168.201.254;
}
}

subnet 192.168.200.0 netmask 255.255.255.128 {
pool {
allow members of "VLAN444";
range 192.168.200.3 192.168.200.126;
}
}

subnet 192.168.200.128 netmask 255.255.255.128 {
pool {
allow members of "VLAN555";
range 192.168.200.130 192.168.200.254;
}
}

}
1. Habilitar o Option 82
ip dhcp relay information option
2. Depois de habilitado o Option 82 necessrio adicionar quais as Vlans iro estar habilitadas a enviar
pacotes DHCP com esta opo.
Habilita o DHCP relay com option 82 em todas as Vlans
ip dhcp relay information trusted all
Habilita o DHCP relay com Option 82 por Vlan
Obs: com a utilizao do Option 82 necessrio incluir a VLAN que est o Servidor DHCP, no nosso
caso a VLAN 444.
ip dhcp relay information trusted 333
ip dhcp relay information trusted 444
ip dhcp relay information trusted 555
Aplicao
Documento de Uso Pblico DATACOM 5
Configurao dos Switches
DM4000
interface vlan 333
name Desktops
ip address 192.168.201.1/24
set-member tagged ethernet 3/1
!
interface vlan 444
name Servidores
ip address 192.168.200.1/25
set-member tagged ethernet 3/1
set-member untagged ethernet 3/2
!
interface vlan 555
name Voip
ip address 192.168.200.129/25
set-member tagged ethernet 3/1
!
interface ethernet 3/2
switchport native vlan 444
!
!
ip dhcp relay
ip helper-address 192.168.200.2
ip dhcp relay vlan 333
ip dhcp relay vlan 555
ip dhcp relay information option
ip dhcp relay information trusted all
DM3000
Documento de Uso Pblico DATACOM 6
interface vlan 333
set-member untagged ethernet range 1/1 1/2
set-member untagged ethernet 1/5
set-member tagged ethernet 1/25
!
interface vlan 444
set-member untagged ethernet 1/3
set-member tagged ethernet 1/25
!
interface vlan 555
set-member untagged ethernet 1/4
set-member tagged ethernet 1/25
!
interface ethernet range 1/1 1/2
switchport native vlan 333
!
interface ethernet 1/3
switchport native vlan 444
!
interface ethernet 1/4
switchport native vlan 555
!
interface ethernet 1/5
switchport native vlan 333
Configurao do servidor DHCP
/etc/dhcp3/dhcpd.conf

ddns-updates off;

subnet 192.168.200.0 netmask 255.255.255.128 {
range 192.168.200.3 192.168.200.126;
}

subnet 192.168.200.128 netmask 255.255.255.128 {
range 192.168.200.130 192.168.200.254;
}

subnet 192.168.201.0 netmask 255.255.255.0 {
range 192.168.201.2 192.168.201.254;
}
Documento de Uso Pblico DATACOM 7