Você está na página 1de 7

Leia um numero e calcule o seu fatorial.

Algoritmo Fatorial;
Declare
Var fat, n, i :inteiro;
Incio
escreva (Digite um nmero para calcular seu fatorial);
leia (n);
fat1;
para i1 at n faa
fatfat*i;
fimpara;
escreva (O fatorial de , n , , fat);
Fim.



Ler 80 nmeros e ao final informar quantos nmero(s) est()o no intervalo entre 10 (inclusive) e 150
(inclusive).
1. Algoritmo;
Declare
Var i, c :inteiro;
Incio
c0;
para i1 at 80 faa
escreva (Digite um nmero );
leia (n);
se n >=10 e n<=150
ento cc+1;
fimse;
fimpara;
escreva (Esto no intervalo de 10 a 150 , c , nmeros );
Fim.


Faa um algoritmo que receba a idade de 75 pessoas e mostre mensagem informando maior de
idade e menor de idade para cada pessoa. Considere a idade a partir de 18 anos como maior de
idade.
2. Algoritmo;
Declare
Var i, idade :inteiro;
Incio
para i1 at 75 faa
escreva (Digite a idade );
leia (idade);
se n >=18
ento escreva (Maior de idade )
seno escreva (Menor de idade );
fimse;
fimpara;
Fim.

Escrever um algoritmo que leia o nome e o sexo de 56 pessoas e informe o nome e se ela homem
ou mulher. No final informe total de homens e de mulheres.
3. Algoritmo;
Declare
Var i, ch, cm :inteiro;
nome, sexo :string;
Incio
ch0;
cm0;
para i1 at 56 faa
escreva (Digite o nome: );
leia (nome);
escreva (Digite o sexo: );
leia (sexo);
se sexo =M
ento chch+1
seno cmcm+1;
fimse;
fimpara;
escreva (Das 56 pessoas , ch , so homens);
escreva (Das 56 pessoas , cm , so mulheres);
Fim.
Faa um algoritmo que receba o preo de custo e o preo de venda de 40 produtos. Mostre como
resultado se houve lucro, prejuzo ou empate para cada produto. Informe media de preo de custo e
do preo de venda
4. Algoritmo;
Declare
Var pcusto, pvenda, lucro :real;
i :inteiro;
nomeproduto :string;
Incio
para i1 at 40 faa
escreva (Digite o nome do produto: );
leia (nomeproduto);
escreva (Digite o preo de custo: );
leia (pcusto);
escreva (Digite o preo de venda: );
leia (pvenda);
se pvenda >pcusto
ento escreva (deu lucro )
seno se pvenda =pcusto
ento escreva (empate, nem lucro, nem prejuzo )
seno escreva (prejuzo );
fimse;
fimse;
fimpara;
Fim.
Escreva um algoritmo para imprimir os nmeros de 1 (inclusive) a 10 (inclusive) em ordem crescente.
5. Algoritmo;
Declare
Var i :inteiro;
Incio
para i1 at 10 faa
escreva (i);
fimpara;
Fim.


Escreva um algoritmo para imprimir os nmeros de 1 (inclusive) a 10 (inclusive) em ordem
decrescente.

6. Algoritmo;
Declare
Var i,c :inteiro;
Incio
c10;
para i1 at 10 faa
escreva (c);
cc-1;
fimpara;
Fim.


Escreva um algoritmo para imprimir os 10 primeiros nmeros inteiros maiores que 100.
7. Algoritmo;
Declare
Var i :inteiro;
Incio
para i101 at 110 faa
escreva (i);
fimpara;
Fim.



Ler um valor N e imprimir todos os valores inteiros entre 1 (inclusive) e N (inclusive). Considere que o
N ser sempre maior que ZERO.
8. Algoritmo;
Declare
Var i, n :inteiro;
Incio
escreva (Digite um nmero maior que zero);
leia (n);
para i1 at n faa
escreva (i );
fimpara;
Fim.
Modifique o exerccio anterior para aceitar somente valores maiores que 0 para N. Caso o valor
informado (para N) no seja maior que 0, dever ser lido um novo valor para N.

9. Algoritmo;
Declare
Var i, n, parada :inteiro;
Incio
escreva (Digite um nmero maior que zero);
leia (n);
se n>0
ento
para i1 at n faa
escreva (i );
fimpara;
fimse;
Fim.
Escreva um algoritmo que calcule e imprima a tabuada do 8 (1 a 10).
10. Algoritmo;
Declare
Var i,res :inteiro;
Incio
para i1 at 10 faa
resi*8;
escreva (i , x , 8 , =, res );
fimpara;
Fim.
Ler um valor inteiro (aceitar somente valores entre 1 e 10) e escrever a tabuada de 1 a 10 do valor
lido.
11. Algoritmo;
Declare
Var i,res :inteiro;
Incio
escreva (Digite um nmero maior que zero);
leia (n);
se n>=1 e n<=10
ento incio
para i1 at 10 faa
resi*n;
escreva (i , x , n , =, res );
fimpara;
fim;
fimse;
Fim.



Seja o seguinte algoritmo:

12. Algoritmo ABC;
Declare
Var x, y, z : inteiro;
incio
ler (x) ;
ler (y);
z (x*y) +5 ;
se z <=0
ento escreva (A )
seno se z <=100
ento escreva (B )
seno escreva (C );
fim_se;
fim_se;
fim.


Faa uma simulao (ou teste de mesa) que complete o quadro a seguir para os seguintes
valores:
Variveis
X Y Z Resposta
3 2 11 B
150 3 455 C
7 -1 -2 A
-2 5 -5 A
50 3 155 C