Você está na página 1de 5

Algoritmo "soma, subtrao, multriplicao e diviso"

var
a, b, res1, res2, res3: inteiro
res4: real
funcao soma (x, y: inteiro):inteiro
inicio
retorne x+y
fimfuncao
funcao subtracao (x, y: inteiro):inteiro
inicio
retorne x-y
fimfuncao
funcao multriplicacao (x, y: inteiro):inteiro
inicio
retorne x*y
fimfuncao
funcao divisao (x, y: inteiro):real
inicio
retorne x/y
fimfuncao

inicio
// Seo de Comandos
escreval ("Digite dois numeros inteiros:")
leia (a,b)
res1:= soma (a, b)
res2:= subtracao (a, b)
res3:= multriplicacao (a, b)
res4:= divisao (a, b)
escreval (" O resultado soma, subtrao, multriplicao e diviso respectivamente:", res1,
res2, res3, res4)

fimalgoritmo

Algoritmo "Funo Equao 2 Grau"
var
a, b, c, x1, x2, delta : real
funcao equacao (a, b, c: real): caractere
inicio
se (a=0) entao
retorne ("no h soluo, digite por favor diferente de 0")
senao
delta:=(b^2)-4*a*c
se (delta<0) entao
retorne ("No h raizes reais")
senao
se (delta=0) entao
x1:= -b/2*a
retorne ("H Apenas uma Raiz X1:")
senao
se (delta>0) entao
x1:= (-b+(delta)^1/2)/2*a)
x2:= (-b-(delta)^1/2)/2*a)
retorne ("H duas Raizes:X1 e X2:")
fimse
fimse
fimse
fimse
fimfuncao
funcao res1 (a, b, c: real): real
inicio
x1:= (-b+(b^2-4*a*c)^1/2)/2*a)
retorne x1
fimfuncao
funcao res2 (a, b, c: real): real
inicio
x2:= (-b-(b^2-4*a*c)^1/2)/2*a)
retorne x2
fimfuncao
inicio
escreval ("Digite a, b, c")
leia (a, b, c)
escreval (" O Resultado da Equao :", equacao (a, b, c))
escreval (" O Resultado de X1 :", res1 (a, b, c))
escreval (" O Resultado de X2 :", res2 (a, b, c))


// Seo de Comandos
fimalgoritmo


Algoritmo "MDIA"
var
n1, n2, media: real
funcao media (n1, n2:real): caractere
//variaveis locais
var
x: real
inicio
x <- (n1 + n2)/2
se (x >=6) entao
retorne "aprovado"
fimse
se (x <=4) entao
retorne "reprovado"
fimse
se (x >=4) e (x <6) entao
retorne "final"
fimse
fimfuncao

inicio
// Seo de Comandos
escreval ("Digite as duas notas do aluno: ")
leia (n1, n2)
escreval ("Voc est: ", media(n1, n2))

fimalgoritmo

Algoritmo "Funo Peso Ideal-Masculino e Feminino"
var
m, f, h: real
Sexo:caractere
funcao peso (m, f, h: real):real
var
sexo:caractere
inicio
se (sexo=m) entao
m:=(72.7*h)-58
retorne (m)
senao
se (sexo=f) entao
f:=(61.1*h)-44.7
retorne (f)
fimse
fimse
fimfuncao
inicio
escreval ("Digite seu sexo (M) ou (F):", sexo)
leia (sexo)
escreval ("Digite Sua Altura (h):")
leia (h)
escreval ("Seu Peso Ideal :", peso (m, f ,h))

fimalgoritmo







Algoritmo "IMC"
var
p, h, imc: real
funcao imc (p, h: real): caractere
var
//variaveis locais
res: real
inicio
res <- p/(h^2)
se (res <18.5) entao
retorne " Voc est abaixo do seu peso ideal"
fimse
se (res >=18.5) e (res <24.9) entao
retorne "Parabns, voc est no seu peso ideal"
fimse
se (res >25) e (res < 29.9) entao
retorne "Voc est com sobrepeso"
fimse
se (res >30) e (res <34.9) entao
retorne "Voc est no nvel de obesidade I"
fimse
se (res >35) e (res <39.9) entao
retorne "Voc est no nvel de obesidade II"
fimse
se (res >40) entao
retorne "Voc est no nvel de obesidade III"
fimse
fimfuncao
inicio
// Seo de Comandos
escreval ("Digite a sua altura em metros: ")
leia ( h )
escreval ("Digite o seu peso em kg: ")
leia ( p )
escreval ("De acordo com o resultado do seu imc: ", imc(p, h))
fimalgoritmo

Você também pode gostar